Service Name and Transport Protocol Port Number Registry
- Last Updated
- 2026-10-09
- Expert(s)
-
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf SCTP: Michael Tuexen DCCP: Eddie Kohler and Yoshifumi Nishida
- Reference
- [RFC 6335]
- Note
-
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP. Service names are assigned on a first-come, first-served process, as documented in [RFC 6335]. Port numbers are assigned in various ways, based on three ranges: System Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private Ports (49152-65535); the different uses of these ranges are described in [RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are assigned by the "IETF Review" or "IESG Approval" procedures described in [RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, the "IESG Approval" process, or the "Expert Review" process, as per [RFC 6335]. Dynamic Ports are not assigned. The registration procedures for service names and port numbers are described in [RFC 6335]. Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration. ************************************************************************ * PLEASE NOTE THE FOLLOWING: * * * * ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN * * ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK * * TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT * * IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE * * ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD * * CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF * * THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER * * REGISTERED OR NOT. * ************************************************************************
- Request an Assignment
-
[https://www.iana.org/protocols/apply]
- Available Formats
-

CSV
XML
HTML
TXT
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| a26-fap-fgw | 4726 | udp | A26 (FAP-FGW) | [David_Ott] | [David_Ott] | 2010-10-15 | |||||
| fcis | 4727 | tcp | F-Link Client Information Service | ||||||||
| fcis-disc | 4727 | udp | F-Link Client Information Service Discovery | [Makoto_Zukawa] | [Makoto_Zukawa] | 2010-10-15 | |||||
| 4734-4736 | Unassigned | ||||||||||
| ipdr-sp | 4737 | tcp | IPDR/SP | [Ken_Sarno] | [Ken_Sarno] | 2005-08 | |||||
| ipdr-sp | 4737 | udp | IPDR/SP | [Ken_Sarno] | [Ken_Sarno] | 2005-08 | |||||
| solera-lpn | 4738 | tcp | SoleraTec Locator | [Mark_Armstrong] | [Mark_Armstrong] | 2005-12 | |||||
| solera-lpn | 4738 | udp | SoleraTec Locator | [Mark_Armstrong] | [Mark_Armstrong] | 2005-12 | |||||
| sicct-sdp | 4742 | udp | SICCT Service Discovery Protocol | [TeleTrusT_Deutschlan] | [TeleTrusT_Deutschlan] | 2006-04 | |||||
| intelliadm-disc | 4746 | udp | IntelliAdmin Discovery | [IntelliAdmin_LLC] | [Steve_Wiseman] | 2016-11-18 | |||||
| buschtrommel | 4747 | udp | peer-to-peer file exchange protocol | [Tobias_Sturm] | [Tobias_Sturm] | 2013-01-14 | |||||
| 4748-4748 | Unassigned | ||||||||||
| simon-disc | 4753 | udp | Simple Invocation of Methods Over Network (SIMON) Discovery | [Alexander_Christian] | [Alexander_Christian] | 2012-04-19 | |||||
| gre-in-udp | 4754 | udp | GRE-in-UDP Encapsulation | [IESG] | [IETF_Chair] | 2016-10-05 | [RFC 8086] | ||||
| gre-udp-dtls | 4755 | udp | GRE-in-UDP Encapsulation with DTLS | [IESG] | [IETF_Chair] | 2016-10-05 | [RFC 8086] | ||||
| 4757-4773 | Unassigned | ||||||||||
| 4775-4783 | Unassigned | ||||||||||
| bfd-multi-ctl | 4784 | tcp | BFD Multihop Control | [Dave_Katz][Dave_Ward] | [Dave_Katz][Dave_Ward] | 2006-02 | |||||
| bfd-multi-ctl | 4784 | udp | BFD Multihop Control | [Dave_Katz][Dave_Ward] | [Dave_Katz][Dave_Ward] | 2006-02 | |||||
| smart-install | 4786 | tcp | Smart Install Service | [Amit_Nigam] | [Amit_Nigam] | 2009-08-24 | |||||
| sia-ctrl-plane | 4787 | tcp | Service Insertion Architecture (SIA) Control-Plane | [Shree_Murthy] | [Shree_Murthy] | 2009-10-29 | |||||
| xmcp | 4788 | tcp | eXtensible Messaging Client Protocol | [Cisco] | [Glenn_Matthews] | 2011-05-23 | 2011-10-25 | Defined TXT keys: txtvers=1 (as described in the draft) protovers=<comma-separated list of major/minor versions supported> (examples: "protovers=1.0" "protovers=1.1,2.0" | |||
| vxlan-gpe | 4790 | udp | Generic Protocol Extension for Virtual eXtensible Local Area Network (VXLAN) | [Lawrence_Kreeger] | [Lawrence_Kreeger] | 2014-08-26 | |||||
| unified-bus | 4792 | tcp | IP Routable Unified Bus | [Huawei] | [Wei_Pan] | 2022-07-08 | 2023-04-10 | ||||
| unified-bus | 4792 | udp | IP Routable Unified Bus | [Huawei] | [Wei_Pan] | 2022-07-08 | 2023-04-10 | ||||
| 4795-4799 | Unassigned | ||||||||||
| notateit-disc | 4803 | udp | Notateit Messaging Discovery | [Ean_Black] | [Ean_Black] | 2009-04-08 | |||||
| aja-ntv4-disc | 4804 | udp | AJA ntv4 Video System Discovery | [Mike_Bernadett] | [Mike_Bernadett] | 2010-06-03 | |||||
| 4805-4826 | Unassigned | ||||||||||
| 4828-4836 | Unassigned | ||||||||||
| varadero-0 | 4837 | tcp | Varadero-0 | ||||||||
| varadero-0 | 4837 | udp | Varadero-0 | ||||||||
| varadero-1 | 4838 | tcp | Varadero-1 | ||||||||
| varadero-1 | 4838 | udp | Varadero-1 | ||||||||
| varadero-2 | 4839 | tcp | Varadero-2 | [Carlos_Arteaga] | [Carlos_Arteaga] | ||||||
| varadero-2 | 4839 | udp | Varadero-2 | [Carlos_Arteaga] | [Carlos_Arteaga] | ||||||
| opcua-tcp | 4840 | tcp | OPC UA Connection Protocol | [OPC_Foundation] | [Randy_Armstrong] | 2018-01-04 | |||||
| opcua-udp | 4840 | udp | OPC UA Multicast Datagram Protocol | [OPC_Foundation] | [Randy_Armstrong] | 2006-09 | 2018-01-04 | ||||
| gw-asv | 4842 | tcp | nCode ICE-flow Library AppServer | [Ross_Swithenbank] | [Ross_Swithenbank] | 2006-09 | |||||
| gw-asv | 4842 | udp | nCode ICE-flow Library AppServer | [Ross_Swithenbank] | [Ross_Swithenbank] | 2006-09 | 2017-05-23 | ||||
| opcua-tls | 4843 | tcp | OPC UA TCP Protocol over TLS/SSL | [OPC_Foundation] | [Randy_Armstrong] | 2006-09 | 2017-05-23 | ||||
| opcua-tls | 4843 | udp | OPC UA TCP Protocol over TLS/SSL | [OPC_Foundation] | [Randy_Armstrong] | 2006-09 | |||||
| gw-log | 4844 | tcp | nCode ICE-flow Library LogServer | [Ross_Swithenbank] | [Ross_Swithenbank] | 2006-09 | |||||
| gw-log | 4844 | udp | nCode ICE-flow Library LogServer | [Ross_Swithenbank] | [Ross_Swithenbank] | 2006-09 | |||||
| wcr-remlib | 4845 | tcp | WordCruncher Remote Library Service | [Jason_Dzubak] | [Jason_Dzubak] | 2008-03-17 | |||||
| wcr-remlib | 4845 | udp | WordCruncher Remote Library Service | [Jason_Dzubak] | [Jason_Dzubak] | 2008-03-17 | |||||
| contamac-icm | 4846 | tcp | Contamac ICM Service IANA assigned this well-formed service name as a replacement for "contamac_icm". |
[Abdullah_Obeid] | [Abdullah_Obeid] | 2008-03-20 | |||||
| contamac_icm | 4846 | tcp | Contamac ICM Service | [Abdullah_Obeid] | [Abdullah_Obeid] | 2008-03-20 | This entry is an alias to "contamac-icm". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| contamac-icm | 4846 | udp | Contamac ICM Service IANA assigned this well-formed service name as a replacement for "contamac_icm". |
[Abdullah_Obeid] | [Abdullah_Obeid] | 2008-03-20 | |||||
| contamac_icm | 4846 | udp | Contamac ICM Service | [Abdullah_Obeid] | [Abdullah_Obeid] | 2008-03-20 | This entry is an alias to "contamac-icm". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| appserv-http | 4848 | tcp | App Server - Admin HTTP | ||||||||
| appserv-http | 4848 | udp | App Server - Admin HTTP | ||||||||
| appserv-https | 4849 | tcp | App Server - Admin HTTPS | [Sreeram_Duvvuru] | [Sreeram_Duvvuru] | 2002-04 | |||||
| appserv-https | 4849 | udp | App Server - Admin HTTPS | [Sreeram_Duvvuru] | [Sreeram_Duvvuru] | 2002-04 | |||||
| sun-as-nodeagt | 4850 | tcp | Sun App Server - NA | [Kedar_Mhaswade] | [Kedar_Mhaswade] | 2004-11 | |||||
| sun-as-nodeagt | 4850 | udp | Sun App Server - NA | [Kedar_Mhaswade] | [Kedar_Mhaswade] | 2004-11 | |||||
| derby-repli | 4851 | tcp | Apache Derby Replication | [Jorgen_Loland] | [Jorgen_Loland] | 2008-02-27 | |||||
| derby-repli | 4851 | udp | Apache Derby Replication | [Jorgen_Loland] | [Jorgen_Loland] | 2008-02-27 | |||||
| 4852-4866 | Unassigned | ||||||||||
| unify-debug | 4867 | tcp | Unify Debugger | [Daegis_Inc] | [Chris_Anderson] | 2006-05 | 2012-07-31 | ||||
| unify-debug | 4867 | udp | Unify Debugger | [Daegis_Inc] | [Chris_Anderson] | 2006-05 | 2012-07-31 | ||||
| cc-tracking | 4870 | tcp | Citcom Tracking Service | [Wolfgang_Weidner] | [Wolfgang_Weidner] | 2005-12 | |||||
| cc-tracking | 4870 | udp | Citcom Tracking Service | [Wolfgang_Weidner] | [Wolfgang_Weidner] | 2005-12 | |||||
| 4872-4875 | Unassigned | ||||||||||
| tritium-can | 4876 | tcp | Tritium CAN Bus Bridge Service | [James_Kennedy] | [James_Kennedy] | 2011-02-15 | |||||
| tritium-can | 4876 | udp | Tritium CAN Bus Bridge Service | [James_Kennedy] | [James_Kennedy] | 2011-02-15 | |||||
| inst-discovery | 4878 | udp | Agilent Instrument Discovery | [Charles_F_Steele] | [Charles_F_Steele] | 2011-02-15 | |||||
| wsdl-event | 4879 | tcp | WSDL Event Receiver | [Charles_F_Steele] | [Charles_F_Steele] | 2011-02-15 | |||||
| hislip | 4880 | tcp | IVI High-Speed LAN Instrument Protocol | [IVI_Foundation] | [Larry_Ostheimer] | 2021-05-06 | |||||
| socp-t | 4881 | udp | SOCP Time Synchronization Protocol | [Joe_Haver] | [Joe_Haver] | 2010-05-28 | |||||
| socp-c | 4882 | udp | SOCP Control Protocol | [Joe_Haver] | [Joe_Haver] | 2010-05-28 | |||||
| wmlserver | 4883 | tcp | Meier-Phelps License Server | [William_Phelps] | [William_Phelps] | 2010-03-22 | |||||
| 4886-4887 | Unassigned | ||||||||||
| xcap-portal | 4888 | tcp | xcap code analysis portal public user access | [_88solutions_Corporation] | [Manfred_Koethe] | 2018-06-06 | |||||
| xcap-control | 4889 | tcp | xcap code analysis portal cluster control and administration | [_88solutions_Corporation] | [Manfred_Koethe] | 2018-06-06 | |||||
| 4890-4893 | Unassigned | ||||||||||
| 4895-4898 | Unassigned | ||||||||||
| radmin-port | 4899 | tcp | RAdmin Port | [Dmitri_Znosko] | [Dmitri_Znosko] | 2003-03 | |||||
| radmin-port | 4899 | udp | RAdmin Port | [Dmitri_Znosko] | [Dmitri_Znosko] | 2003-03 | |||||
| flr-agent | 4901 | tcp | FileLocator Remote Search Agent IANA assigned this well-formed service name as a replacement for "flr_agent". |
[David_Vest] | [David_Vest] | 2008-11-19 | |||||
| flr_agent | 4901 | tcp | FileLocator Remote Search Agent | [David_Vest] | [David_Vest] | 2008-11-19 | This entry is an alias to "flr-agent". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 4903-4911 | Unassigned | ||||||||||
| 4916-4935 | Unassigned | ||||||||||
| an-signaling | 4936 | udp | Signal protocol port for autonomic networking | [Cisco_Systems_3] | [Toerless_Eckert_2] | 2014-06-06 | |||||
| atsc-mh-ssc | 4937 | udp | ATSC-M/H Service Signaling Channel | [Jerry_Whitaker] | [Jerry_Whitaker] | 2008-10-27 | |||||
| 4938-4939 | Unassigned | ||||||||||
| eq-office-4940 | 4940 | tcp | Equitrac Office | ||||||||
| eq-office-4940 | 4940 | udp | Equitrac Office | ||||||||
| eq-office-4941 | 4941 | tcp | Equitrac Office | ||||||||
| eq-office-4941 | 4941 | udp | Equitrac Office | ||||||||
| eq-office-4942 | 4942 | tcp | Equitrac Office | [Tom_Haapanen_2] | [Tom_Haapanen_2] | 2007-07-11 | |||||
| eq-office-4942 | 4942 | udp | Equitrac Office | [Tom_Haapanen_2] | [Tom_Haapanen_2] | 2007-07-11 | |||||
| 4943-4948 | Unassigned | ||||||||||
| 4954-4968 | Unassigned | Known UNAUTHORIZED USE: port 4967 | |||||||||
| ccss-qmm | 4969 | tcp | CCSS QMessageMonitor | ||||||||
| ccss-qmm | 4969 | udp | CCSS QMessageMonitor | ||||||||
| ccss-qsm | 4970 | tcp | CCSS QSystemMonitor | [David_Young] | [David_Young] | 2006-01 | |||||
| ccss-qsm | 4970 | udp | CCSS QSystemMonitor | [David_Young] | [David_Young] | 2006-01 | |||||
| 4972-4979 | Unassigned | ||||||||||
| ctxs-vpp | 4980 | udp | Citrix Virtual Path | [Citrix_Systems] | [Rohith_Ramkumar] | 2015-04-17 | |||||
| 4981-4982 | Unassigned |