Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| piranha2 | 4601 | tcp | Piranha2 | Primark Corporation | Primark Corporation | ||||||
| piranha2 | 4601 | udp | Piranha2 | Primark Corporation | Primark Corporation | ||||||
| 4621 | tcp | Reserved | |||||||||
| ventoso | 4621 | udp | Bidirectional single port remote radio VOIP and Control stream | Ventoso Integrated Peripherals | John Lindsey | 2016-03-04 | |||||
| dots-signal | 4646 | tcp | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. | IESG | IETF Chair | 2020-01-16 | 2021-06-14 | RFC 8973; RFC 9132 | |||
| dots-signal | 4646 | udp | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. | IESG | IETF Chair | 2020-01-16 | 2021-06-14 | RFC 8973; RFC 9132 | |||
| kar2ouche | 4661 | tcp | Kar2ouche Peer location service | Andy Krouwel | Andy Krouwel | ||||||
| kar2ouche | 4661 | udp | Kar2ouche Peer location service | Andy Krouwel | Andy Krouwel | ||||||
| acter | 4671 | tcp | Bull RSF action server | Christian Caudrelier | Christian Caudrelier | 2006-02 | |||||
| acter | 4671 | udp | Bull RSF action server | Christian Caudrelier | Christian Caudrelier | 2006-02 | |||||
| parliant | 4681 | tcp | Parliant Telephony System | Colin Henein | Colin Henein | 2005-08 | |||||
| parliant | 4681 | udp | Parliant Telephony System | Colin Henein | Colin Henein | 2005-08 | |||||
| rfid-rp1 | 4684 | tcp | RFID Reader Protocol 1.0 | Michael Mealling | Michael Mealling | 2005-08 | |||||
| rfid-rp1 | 4684 | udp | RFID Reader Protocol 1.0 | Michael Mealling | Michael Mealling | 2005-08 | |||||
| mtn | 4691 | tcp | monotone Netsync Protocol | Thomas Keller | Thomas Keller | 2010-12-22 | |||||
| mtn | 4691 | udp | monotone Netsync Protocol | Thomas Keller | Thomas Keller | 2010-12-22 | |||||
| netxms-mgmt | 4701 | tcp | NetXMS Management | ||||||||
| netxms-mgmt | 4701 | udp | NetXMS Management | ||||||||
| 4705-4710 | Unassigned | ||||||||||
| trinity-dist | 4711 | tcp | Trinity Trust Network Node Communication | P3KI GmbH | Gregor Jehle | 2017-01-12 | |||||
| trinity-dist | 4711 | udp | Trinity Trust Network Node Communication | P3KI GmbH | Gregor Jehle | 2017-01-12 | |||||
| trinity-dist | 4711 | sctp | Trinity Trust Network Node Communication | P3KI GmbH | Gregor Jehle | 2017-01-12 | |||||
| 4712-4724 | Unassigned | ||||||||||
| remcap | 4731 | tcp | Remote Capture Protocol | Marc Donner | Marc Donner | 2009-01-16 | |||||
| 4731 | udp | Reserved | |||||||||
| lumimgrd | 4741 | tcp | Luminizer Manager | George Hwa | George Hwa | 2007-03 | |||||
| lumimgrd | 4741 | udp | Luminizer Manager | George Hwa | George Hwa | 2007-03 | |||||
| spocp | 4751 | tcp | Simple Policy Control Protocol | Roland Hedberg | Roland Hedberg | 2005-08 | |||||
| spocp | 4751 | udp | Simple Policy Control Protocol | Roland Hedberg | Roland Hedberg | 2005-08 | |||||
| xmcp | 4788 | tcp | eXtensible Messaging Client Protocol | Cisco | Glenn Matthews | 2011-05-23 | 2011-10-25 | Defined TXT keys: txtvers=1 (as described in the draft) protovers=<comma-separated list of major/minor versions supported> (examples: "protovers=1.0" "protovers=1.1,2.0" | |||
| roce | 4791 | udp | IP Routable RocE | InfiniBand Trade Association (IBTA) | Diego Crupnicoff (IBTA TWG Chair) | 2014-10-17 | |||||
| 4791 | tcp | Reserved | |||||||||
| iwec | 4801 | tcp | Icona Web Embedded Chat | ||||||||
| iwec | 4801 | udp | Icona Web Embedded Chat | ||||||||
| varadero-1 | 4838 | tcp | Varadero-1 | ||||||||
| varadero-1 | 4838 | udp | Varadero-1 | ||||||||
| quosa | 4841 | tcp | QUOSA Virtual Library Service | Uri Blank | Uri Blank | 2006-09 | |||||
| quosa | 4841 | udp | QUOSA Virtual Library Service | Uri Blank | Uri Blank | 2006-09 | |||||
| derby-repli | 4851 | tcp | Apache Derby Replication | Jorgen Loland | Jorgen Loland | 2008-02-27 | |||||
| derby-repli | 4851 | udp | Apache Derby Replication | Jorgen Loland | Jorgen Loland | 2008-02-27 | |||||
| wired | 4871 | tcp | Wired | Axel Andersson | Axel Andersson | 2006-02 | |||||
| wired | 4871 | udp | Wired | Axel Andersson | Axel Andersson | 2006-02 | |||||
| 4881 | tcp | Reserved | |||||||||
| socp-t | 4881 | udp | SOCP Time Synchronization Protocol | Joe Haver | Joe Haver | 2010-05-28 | |||||
| flr-agent | 4901 | tcp | FileLocator Remote Search Agent IANA assigned this well-formed service name as a replacement for "flr_agent". |
David Vest | David Vest | 2008-11-19 | |||||
| flr_agent | 4901 | tcp | FileLocator Remote Search Agent | David Vest | David Vest | 2008-11-19 | This entry is an alias to "flr-agent". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 4901 | udp | Reserved | |||||||||
| 4903-4911 | Unassigned | ||||||||||
| lutap | 4912 | tcp | Technicolor LUT Access Protocol | Markus Loeffler | Markus Loeffler | 2009-02-17 | |||||
| 4912 | udp | Reserved | |||||||||
| lutcp | 4913 | tcp | LUTher Control Protocol | Markus Loeffler | Markus Loeffler | 2007-07-03 | |||||
| bones | 4914 | tcp | Bones Remote Control | Andreas Foedrowitz | Andreas Foedrowitz | 2008-06-18 | |||||
| bones | 4914 | udp | Bones Remote Control | Andreas Foedrowitz | Andreas Foedrowitz | 2008-06-18 | |||||
| frcs | 4915 | tcp | Fibics Remote Control Service | Ken Lagarec | Ken Lagarec | 2009-04-17 | |||||
| 4915 | udp | Reserved | |||||||||
| 4916-4935 | Unassigned | ||||||||||
| eq-office-4941 | 4941 | tcp | Equitrac Office | ||||||||
| eq-office-4941 | 4941 | udp | Equitrac Office | ||||||||
| pwgwims | 4951 | tcp | PWG WIMS | Ira McDonald | Ira McDonald | 2005-12 | |||||
| pwgwims | 4951 | udp | PWG WIMS | Ira McDonald | Ira McDonald | 2005-12 | |||||
| burp | 4971 | tcp | BackUp and Restore Program | Marat Khalili | Marat Khalili | 2017-08-23 | |||||
| 4971 | udp | Reserved | |||||||||
| 4981-4982 | Unassigned | ||||||||||
| smar-se-port1 | 4987 | tcp | SMAR Ethernet Port 1 | ||||||||
| smar-se-port1 | 4987 | udp | SMAR Ethernet Port 1 | ||||||||
| vrt | 4991 | tcp | VITA Radio Transport | Sam Bretheim | Sam Bretheim | 2009-01-08 | |||||
| vrt | 4991 | udp | VITA Radio Transport | Sam Bretheim | Sam Bretheim | 2009-01-08 | |||||
| commplex-link | 5001 | tcp | |||||||||
| commplex-link | 5001 | udp | |||||||||
| avt-profile-1 | 5004 | tcp | RTP media data | RFC 3551; RFC 4571 | |||||||
| avt-profile-1 | 5004 | udp | RTP media data | RFC 3551 | |||||||
| avt-profile-1 | 5004 | dccp | RTP media data | RFC 3551; RFC 5762 | |||||||
| avt-profile-2 | 5005 | tcp | RTP control protocol | RFC 3551; RFC 4571 | |||||||
| avt-profile-2 | 5005 | udp | RTP control protocol | RFC 3551 | |||||||
| avt-profile-2 | 5005 | dccp | RTP control protocol | RFC 3551; RFC 5762 | |||||||
| telelpathstart | 5010 | tcp | TelepathStart | Helmuth Breitenfellner | Helmuth Breitenfellner | ||||||
| telelpathstart | 5010 | udp | TelepathStart | Helmuth Breitenfellner | Helmuth Breitenfellner | ||||||
| telelpathattack | 5011 | tcp | TelepathAttack | Helmuth Breitenfellner | Helmuth Breitenfellner | ||||||
| telelpathattack | 5011 | udp | TelepathAttack | Helmuth Breitenfellner | Helmuth Breitenfellner | ||||||
| nsp | 5012 | tcp | NetOnTap Service | Kim Hancock | Kim Hancock | 2007-10-24 | |||||
| nsp | 5012 | udp | NetOnTap Service | Kim Hancock | Kim Hancock | 2007-10-24 | |||||
| fmpro-v6 | 5013 | tcp | FileMaker, Inc. - Proprietary transport | Alex Chen | Alex Chen | 2007-08-01 | |||||
| fmpro-v6 | 5013 | udp | FileMaker, Inc. - Proprietary transport | Alex Chen | Alex Chen | 2007-08-01 | |||||
| 5014 | tcp | Reserved | |||||||||
| onpsocket | 5014 | udp | Overlay Network Protocol | Roger Matthias | Roger Matthias | 2009-08-24 | |||||
| fmwp | 5015 | tcp | FileMaker, Inc. - Web publishing | Alex Chen | Alex Chen | 2009-11-25 | |||||
| 5015 | udp | Reserved | |||||||||
| 5016-5019 | Unassigned | ||||||||||
| zenginkyo-1 | 5020 | tcp | zenginkyo-1 | Masashi Suzaki | Masashi Suzaki | ||||||
| zenginkyo-1 | 5020 | udp | zenginkyo-1 | Masashi Suzaki | Masashi Suzaki | ||||||
| zenginkyo-2 | 5021 | tcp | zenginkyo-2 | Masashi Suzaki | Masashi Suzaki | ||||||
| zenginkyo-2 | 5021 | udp | zenginkyo-2 | Masashi Suzaki | Masashi Suzaki | ||||||
| 5030 | tcp | Reserved | 2006-12 | 2022-01-10 | Historic usage was surfpass. De-Assigned on 2022-01-10 | ||||||
| 5030 | udp | Reserved | 2006-12 | 2022-01-10 | Historic usage was surfpass. De-Assigned on 2022-01-10 | ||||||
| 5031 | tcp | Reserved | |||||||||
| dmp | 5031 | udp | Direct Message Protocol | Gjermund Wallenius | Gjermund Wallenius | 2009-09-30 | |||||
| 5035-5041 | Unassigned | ||||||||||
| ita-agent | 5051 | tcp | ITA Agent | Don Merrell | Don Merrell | ||||||
| ita-agent | 5051 | udp | ITA Agent | Don Merrell | Don Merrell | ||||||
| intecom-ps1 | 5056 | tcp | Intecom Pointspan 1 | David Meermans | David Meermans | ||||||
| intecom-ps1 | 5056 | udp | Intecom Pointspan 1 | David Meermans | David Meermans |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alex Chen | alex_chen&filemaker.com | 2009-11-25 | |
| Andreas Foedrowitz | andreas.foedrowitz&thomson.net | 2008-06-18 | |
| Andy Krouwel | andy&kar2ouche.com | ||
| Axel Andersson | axel&zankasoftware.com | 2006-02 | |
| Christian Caudrelier | Christian.Caudrelier&bull.net | 2006-02 | |
| Cisco | glenn.matthews&cisco.com | 2011-10-25 | |
| Colin Henein | iana&cmh.parliant.com | 2005-08 | |
| David Meermans | david.meermans&aastra.com | ||
| David Vest | dave&mythicsoft.com | 2008-11-19 | |
| Diego Crupnicoff (IBTA TWG Chair) | diego&mellanox.com | 2014-10-17 | |
| Don Merrell | donmer&axent.com | ||
| George Hwa | george.hwa&kla-tencor.com | 2016-10-17 | |
| Gjermund Wallenius | gwallenius&ndlocis.mil.no | 2009-09-30 | |
| Glenn Matthews | glenn.matthews&cisco.com | 2011-05-23 | |
| Gregor Jehle | hadez&p3ki.com | 2017-01-12 | |
| Helmuth Breitenfellner | hbreitenf&vnet.imb.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| InfiniBand Trade Association (IBTA) | administration&infinibandta.org | 2014-10-17 | |
| Ira McDonald | imcdonald&sharplabs.com | 2005-12 | |
| Joe Haver | joe.haver&jdsu.com | 2010-05-28 | |
| John Lindsey | john.lindsey&nilesradio.com | 2016-03-04 | |
| Jorgen Loland | jorgen.loland&sun.com | 2008-02-27 | |
| Ken Lagarec | klagarec&fibics.com | 2009-04-17 | |
| Kim Hancock | registry&dragondex.com | 2007-10-24 | |
| Marat Khalili | qm2k&yandex.ru | 2017-08-23 | |
| Marc Donner | mail&poweraudio.de | 2009-01-16 | |
| Markus Loeffler | markus.loeffler&thomson.net | 2009-02-17 | |
| Masashi Suzaki | susakim&noa.nttdata.jp | ||
| Michael Mealling | michael&refactored-networks.com | 2005-08 | |
| P3KI GmbH | iana&p3ki.com | 2017-01-12 | |
| Primark Corporation | joe.boone&primark.com | ||
| Roger Matthias | rogermatthias&yahoo.co.uk | 2009-08-24 | |
| Roland Hedberg | roland&catalogix.se | 2005-08 | |
| Sam Bretheim | info&opensigint.org | 2009-01-08 | |
| Thomas Keller | me&thomaskeller.biz | 2010-12-22 | |
| Uri Blank | uri&quosa.com | 2006-09 | |
| Ventoso Integrated Peripherals | john.lindsey&nilesradio.com | 2016-03-04 |