Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
36462 tcp Reserved
36462 udp Reserved
xw-control 36462 sctp Xw-Control Plane (3GPP) Boubacar KIMNBA DIT ADAMOU Boubacar KIMNBA DIT ADAMOU 2015-11-13
36463-36523 Unassigned
febooti-aw 36524 tcp Febooti Automation Workshop Maris Bormanis Maris Bormanis 2011-06-10
36524 udp Reserved
36525-36601 Unassigned
observium-agent 36602 tcp Observium statistics collection agent Observium Adam Armstrong 2013-05-10
36602 udp Reserved
36603-36699 Unassigned
mapx 36700 tcp MapX communication MicroTechniX Yarochkin Michail 2014-10-13
36700 udp Reserved
36701-36864 Unassigned
kastenxpipe 36865 tcp KastenX Pipe Guy Cheng Guy Cheng
kastenxpipe 36865 udp KastenX Pipe Guy Cheng Guy Cheng
36866-37471 Unassigned
37476-37482 Unassigned
37484-37600 Unassigned
eftp 37601 tcp Epipole File Transfer Protocol Epipole Limited Colin Buchanan 2014-11-13
37601 udp Reserved
37602-37653 Unassigned
unisys-eportal 37654 tcp Unisys ClearPath ePortal Sung U. Ro Sung U. Ro 2006-01
unisys-eportal 37654 udp Unisys ClearPath ePortal Sung U. Ro Sung U. Ro 2006-01
37655-37999 Unassigned
38423-38461 Unassigned
38462 tcp Reserved
38462 udp Reserved
e1-interface 38462 sctp E1 signalling transport (3GPP) Huawei Technologies France Yang Xudong; Issam Toufik 2018-11-06 2018-11-15
38463-38471 Unassigned
38473-38637 Unassigned
psqlmws 38638 tcp Premier SQL Middleware Server Brain Patchwork DX, LLC. Ozz Nixon 2022-02-15
38638 udp Reserved
38639-38799 Unassigned
38801-38864 Unassigned
secrmmsafecopya 38865 tcp Security approval process for use of the secRMM SafeCopy program Squadra Technologies Anthony LaMark 2012-03-14
38865 udp Reserved
38866-39062 Unassigned
vroa 39063 tcp Children's hearing test/Telemedicine Hearing Australia Dan Zhou 2021-12-23
39063 udp Reserved
39064-39680 Unassigned
turbonote-1 39681 tcp TurboNote Default Port Peter Hyde Peter Hyde
turbonote-1 39681 udp TurboNote Default Port Peter Hyde Peter Hyde
39682-39999 Unassigned
crestron-cips 41796 tcp Crestron Secure Control Port Crestron Electronics, Inc. John Pavlik 2012-06-27 2019-10-17
41796 udp Reserved
44323 udp Unassigned "pcp" assignment withdrawn, moved to port 5351 per RFC 6887
44446-44543 Unassigned Known UNAUTHORIZED USE: Ports 44515 & 44516
44600 tcp Reserved
asihpi 44600 udp AudioScience HPI Eliot Blennerhassett Eliot Blennerhassett 2011-07-07
44601-44817 Unassigned
45046-45053 Unassigned
45186-45513 Unassigned
45515-45677 Unassigned
eba 45678 tcp EBA PRISE Patrick Kara Patrick Kara
eba 45678 udp EBA PRISE Patrick Kara Patrick Kara
45679-45823 Unassigned
45826-45965 Unassigned
ssr-servermgr 45966 tcp SSRServerMgr Jeremy Gilliat Jeremy Gilliat
ssr-servermgr 45966 udp SSRServerMgr Jeremy Gilliat Jeremy Gilliat
45967-46335 Unassigned
inedo 46336 tcp Listen port used for Inedo agent communication Inedo Steve Dennis 2016-01-12
46336 udp Reserved
46337-46997 Unassigned
spremotetablet 46998 tcp Connection between a desktop computer or server and a signature tablet to capture handwritten signatures SOFTPRO GmbH Christoph Hipp 2012-07-19 2013-08-02
46998 udp Reserved
mediabox 46999 tcp MediaBox Server Alexander Graef Alexander Graef 2004-11
mediabox 46999 udp MediaBox Server Alexander Graef Alexander Graef 2004-11
47101-47556 Unassigned
47558-47623 Unassigned
directplaysrvr 47624 tcp Direct Play Server Ajay Jindal Ajay Jindal
directplaysrvr 47624 udp Direct Play Server Ajay Jindal Ajay Jindal
47625-47805 Unassigned
ap 47806 tcp ALC Protocol Dave Robin Dave Robin
ap 47806 udp ALC Protocol Dave Robin Dave Robin
48006-48047 Unassigned
com-bardac-dw 48556 tcp com-bardac-dw Nicholas J Howes Nicholas J Howes
com-bardac-dw 48556 udp com-bardac-dw Nicholas J Howes Nicholas J Howes
48557-48618 Unassigned
iqobject 48619 tcp iqobject Bjorn de Bonnenfant Bjorn de Bonnenfant 2003-11
iqobject 48619 udp iqobject Bjorn de Bonnenfant Bjorn de Bonnenfant 2003-11
48620-48652 Unassigned
robotraconteur 48653 tcp Robot Raconteur transport Wason Technology, LLC John Wason 2014-01-27
robotraconteur 48653 udp Robot Raconteur transport Wason Technology, LLC John Wason 2014-01-27
48654-48999 Unassigned
49151 Reserved 2024-12-20 RFC 6335
mihcs MIH Command Services RFC 5679
mihes MIH Event Services RFC 5679
mihis MIH Information Services RFC 5679
autotunnel udp IPSEC VPN tunnel over UDP Stuart Cheshire Stuart Cheshire 2019-05-04 RFC 6281 Defined TXT Keys: None
caldav tcp Calendaring Extensions to WebDAV (CalDAV) - non-TLS IESG IETF Chair 2012-02-17 RFC 6764 This is an extension of the http service. Defined TXT keys: path=<context path>
caldavs tcp Calendaring Extensions to WebDAV (CalDAV) - over TLS IESG IETF Chair 2012-02-17 RFC 6764 This is an extension of the https service. Defined TXT keys: path=<context path>
carddav tcp vCard Extensions to WebDAV (CardDAV) - non-TLS IESG IETF Chair 2012-02-17 RFC 6352 This is an extension of the http service. Defined TXT keys: path=<context path>
carddavs tcp vCard Extensions to WebDAV (CardDAV) - over TLS IESG IETF Chair 2012-02-17 RFC 6352 This is an extension of the https service. Defined TXT keys: path=<context path>
core-rd tcp Resource Directory accessed using CoAP over TCP IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
core-rd udp Resource Directory accessed using CoAP IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
core-rd-tls tcp Resource Directory accessed using CoAP over TLS IESG IETF Chair 2021-03-16 2022-04-14 RFC 9176 Defined TXT keys: None
core-rd-dtls udp Resource Directory accessed using CoAP over DTLS IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
dns-llq-tls tcp DNS Long-Lived Queries over TLS Stuart Cheshire Stuart Cheshire 2019-05-04 RFC 6281 Defined TXT Keys: None
dns-push-tls tcp DNS Push Notification Service Type IESG IETF Chair 2019-11-25 RFC 8765, Section 6.1 Defined TXT Keys: None
dns-update-tls tcp DNS Dynamic Update Service over TLS Stuart Cheshire Stuart Cheshire 2019-05-04 RFC 6281 DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain.
dnssd-srp tcp DNS-Based Service Discovery IESG IETF Chair 2024-04-12 2024-09-05 RFC 9665 Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
Adam Armstrong Observium adama&observium.org 2013-05-10
Ajay Jindal ajayj&microsoft.com
Alexander Graef alex&graef.cc 2004-11
Anthony LaMark Squadra Technologies anthony&squadratechnologies.com 2012-03-14
Bjorn de Bonnenfant bdeb&iqobject.com 2003-11
Boubacar KIMNBA DIT ADAMOU jinba&chinamobile.com 2015-11-13
Brain Patchwork DX, LLC. specifications&brainpatchworkdx.com 2022-02-15
Christoph Hipp SOFTPRO GmbH christoph.hipp&softpro.de 2013-08-02
Colin Buchanan Epipole Limited colin&epipole.com 2014-11-13
Crestron Electronics, Inc. jpavlik&crestron.com 2019-10-17
Dan Zhou Hearing Australia dan.zhou&hearing.com.au 2021-12-23
Dave Robin iana_ports&daverobin.com
Eliot Blennerhassett eblennerhassett&audioscience.com 2011-07-07
Epipole Limited info&epipole.com 2014-11-13
Guy Cheng GCHE&kastenchase.com
Hearing Australia dan.zhou&hearing.com.au 2021-12-23
Huawei Technologies France yangxudong&huawei.com 2018-11-06
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Inedo support&inedo.com 2016-01-12
Issam Toufik Huawei Technologies France yangxudong&huawei.com 2018-11-06
Jeremy Gilliat jeremy.gilliat&geac.com
John Pavlik jpavlik&crestron.com 2019-10-17
John Wason Wason Technology, LLC wason&wasontech.com 2014-01-27
Maris Bormanis info&febooti.com 2011-06-10
MicroTechniX Info&microtechnix.com 2014-10-13
Nicholas J Howes nick&ghostwood.org
Observium adama&observium.org 2013-05-10
Ozz Nixon Brain Patchwork DX, LLC. specifications&bpdx.com 2022-02-15
Patrick Kara Patrick&eba.net
Peter Hyde peter&spis.co.nz
SOFTPRO GmbH christoph.hipp&softpro.de 2013-08-02
Squadra Technologies anthony&squadratechnologies.com 2012-03-14
Steve Dennis sdennis&inedo.com 2016-01-12
Stuart Cheshire cheshire&apple.com 2022-07-11
Sung U. Ro ePortalSupport&unisys.com 2006-01
Wason Technology, LLC wason&wasontech.com 2014-01-27
Yang Xudong Huawei Technologies France yangxudong&huawei.com 2018-11-06
Yarochkin Michail MicroTechniX Michail.Yarochkin&microtechnix.com 2014-10-13