Service Name and Transport Protocol Port Number Registry
- Last Updated
- 2026-10-09
- Expert(s)
-
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf SCTP: Michael Tuexen DCCP: Eddie Kohler and Yoshifumi Nishida
- Reference
- [RFC 6335]
- Note
-
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP. Service names are assigned on a first-come, first-served process, as documented in [RFC 6335]. Port numbers are assigned in various ways, based on three ranges: System Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private Ports (49152-65535); the different uses of these ranges are described in [RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are assigned by the "IETF Review" or "IESG Approval" procedures described in [RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, the "IESG Approval" process, or the "Expert Review" process, as per [RFC 6335]. Dynamic Ports are not assigned. The registration procedures for service names and port numbers are described in [RFC 6335]. Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration. ************************************************************************ * PLEASE NOTE THE FOLLOWING: * * * * ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN * * ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK * * TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT * * IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE * * ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD * * CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF * * THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER * * REGISTERED OR NOT. * ************************************************************************
- Request an Assignment
-
[https://www.iana.org/protocols/apply]
- Available Formats
-

CSV
XML
HTML
TXT
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| hughes-ap | 5105 | udp | Hughes Association Protocol | [Varun_Santosh] | [Varun_Santosh] | 2010-10-20 | |||||
| 5108-5110 | Unassigned | ||||||||||
| taep-as-svc | 5111 | tcp | TAEP AS service | [Liu_Changchun] | [Liu_Changchun] | 2008-11-05 | |||||
| taep-as-svc | 5111 | udp | TAEP AS service | [Liu_Changchun] | [Liu_Changchun] | 2008-11-05 | |||||
| pm-cmdsvr | 5112 | tcp | PeerMe Msg Cmd Service | [Marcos_Della] | [Marcos_Della] | 2005-08 | |||||
| pm-cmdsvr | 5112 | udp | PeerMe Msg Cmd Service | [Marcos_Della] | [Marcos_Della] | 2005-08 | |||||
| ev-services | 5114 | tcp | Enterprise Vault Services | [Richard_Jones_2] | [Richard_Jones_2] | 2009-05-26 | |||||
| emb-proj-cmd | 5116 | udp | EPSON Projecter Image Transfer | [SEIKO_EPSON_4] | [SEIKO_EPSON_4] | 2008-11-17 | |||||
| 5118-5119 | Unassigned | ||||||||||
| barracuda-bbs | 5120 | tcp | Barracuda Backup Protocol | [Barracuda_Networks] | [Andrew_Blyler] | 2013-04-05 | |||||
| barracuda-bbs | 5120 | udp | Barracuda Backup Protocol | [Barracuda_Networks] | [Andrew_Blyler] | 2013-04-05 | |||||
| 5121-5132 | Unassigned | ||||||||||
| nbt-pc | 5133 | tcp | Policy Commander | [Emily_Harris] | [Emily_Harris] | 2004-11 | |||||
| nbt-pc | 5133 | udp | Policy Commander | [Emily_Harris] | [Emily_Harris] | 2004-11 | |||||
| erp-scale | 5135 | tcp | ERP-Scale | [Ian_Bradley] | [Ian_Bradley] | 2009-10-14 | Defined TXT keys: RFC=<RFC destination and status> Device=<Scale device and status> |
||||
| minotaur-sa | 5136 | udp | Minotaur SA | [Kenneth_Flynn] | [Kenneth_Flynn] | 2009-10-14 | |||||
| 5138-5144 | Unassigned | ||||||||||
| rmonitor-secure | 5145 | tcp | RMONITOR SECURE IANA assigned this well-formed service name as a replacement for "rmonitor_secure". |
[Kory_Hamzeh] | [Kory_Hamzeh] | ||||||
| rmonitor_secure | 5145 | tcp | RMONITOR SECURE | [Kory_Hamzeh] | [Kory_Hamzeh] | This entry is an alias to "rmonitor-secure". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| rmonitor-secure | 5145 | udp | RMONITOR SECURE IANA assigned this well-formed service name as a replacement for "rmonitor_secure". |
[Kory_Hamzeh] | [Kory_Hamzeh] | ||||||
| rmonitor_secure | 5145 | udp | RMONITOR SECURE | [Kory_Hamzeh] | [Kory_Hamzeh] | This entry is an alias to "rmonitor-secure". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| social-alarm | 5146 | tcp | Social Alarm Service | [Shaun_Byrne] | [Shaun_Byrne] | 2009-08-18 | |||||
| 5147-5149 | Unassigned | ||||||||||
| esri-sde | 5151 | tcp | ESRI SDE Instance IANA assigned this well-formed service name as a replacement for "esri_sde". |
[Peter_Aronson] | [Peter_Aronson] | Unauthorized Use Known on ports 5151 and 5152 | |||||
| esri_sde | 5151 | tcp | ESRI SDE Instance | [Peter_Aronson] | [Peter_Aronson] | This entry is an alias to "esri-sde". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| esri-sde | 5151 | udp | ESRI SDE Remote Start IANA assigned this well-formed service name as a replacement for "esri_sde". |
[Peter_Aronson] | [Peter_Aronson] | Unauthorized Use Known on ports 5151 and 5152 | |||||
| esri_sde | 5151 | udp | ESRI SDE Remote Start | [Peter_Aronson] | [Peter_Aronson] | This entry is an alias to "esri-sde". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| sde-discovery | 5152 | tcp | ESRI SDE Instance Discovery | [Peter_Aronson] | [Peter_Aronson] | Unauthorized Use Known on ports 5151 and 5152 | |||||
| sde-discovery | 5152 | udp | ESRI SDE Instance Discovery | [Peter_Aronson] | [Peter_Aronson] | Unauthorized Use Known on ports 5151 and 5152 | |||||
| 5153 | tcp | Reserved | 2009-07-01 | 2018-04-19 | Historic usage was toruxserver. De-Assigned on 2018-04-19 | ||||||
| asctrl-agent | 5155 | tcp | Oracle asControl Agent | [Todd_Guay] | [Todd_Guay] | 2005-08 | |||||
| asctrl-agent | 5155 | udp | Oracle asControl Agent | [Todd_Guay] | [Todd_Guay] | 2005-08 | |||||
| 5158-5160 | Unassigned | ||||||||||
| snmpssh-trap | 5162 | tcp | SNMP Notification over SSH Transport Model | [RFC 5592] | Known Unauthorized Use on port 5162 | ||||||
| vpa-disc | 5164 | udp | Virtual Protocol Adapter Discovery | [Douglas_Goodall] | [Douglas_Goodall] | 2009-08-05 | |||||
| ife-icorp | 5165 | tcp | ife_1corp IANA assigned this well-formed service name as a replacement for "ife_icorp". |
[Paul_Annala] | [Paul_Annala] | ||||||
| ife_icorp | 5165 | tcp | ife_1corp | [Paul_Annala] | [Paul_Annala] | This entry is an alias to "ife-icorp". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| ife-icorp | 5165 | udp | ife_1corp IANA assigned this well-formed service name as a replacement for "ife_icorp". |
[Paul_Annala] | [Paul_Annala] | ||||||
| ife_icorp | 5165 | udp | ife_1corp | [Paul_Annala] | [Paul_Annala] | This entry is an alias to "ife-icorp". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 5169-5171 | Unassigned | ||||||||||
| pcoip-mgmt | 5172 | tcp | PC over IP Endpoint Management | [HP_Inc_2] | [Jeff_Jeansonne] | 2014-04-28 | 2026-03-10 | ||||
| 5173-5189 | Unassigned | ||||||||||
| aol | 5190 | tcp | America-Online | [Marty_Lyons] | [Marty_Lyons] | ||||||
| aol | 5190 | udp | America-Online | [Marty_Lyons] | [Marty_Lyons] | ||||||
| aol-1 | 5191 | tcp | AmericaOnline1 | [Bruce_Mackey] | [Bruce_Mackey] | ||||||
| aol-1 | 5191 | udp | AmericaOnline1 | [Bruce_Mackey] | [Bruce_Mackey] | ||||||
| aol-2 | 5192 | tcp | AmericaOnline2 | [Bruce_Mackey] | [Bruce_Mackey] | ||||||
| aol-2 | 5192 | udp | AmericaOnline2 | [Bruce_Mackey] | [Bruce_Mackey] | ||||||
| aol-3 | 5193 | tcp | AmericaOnline3 | [Bruce_Mackey] | [Bruce_Mackey] | ||||||
| aol-3 | 5193 | udp | AmericaOnline3 | [Bruce_Mackey] | [Bruce_Mackey] | ||||||
| ampl-lic | 5195 | tcp | The protocol is used by a license server and client programs to control use of program licenses that float to networked machines | [AMPL_Optimization] | [David_M_Gay] | 2012-05-25 | |||||
| ampl-tableproxy | 5196 | tcp | The protocol is used by two programs that exchange "table" data used in the AMPL modeling language | [AMPL_Optimization] | [David_M_Gay] | 2012-05-25 | |||||
| tunstall-lwp | 5197 | tcp | Tunstall Lone worker device interface | [Tunstall_Healthcare_UK_Ltd] | [Robert_Moore] | 2014-12-10 | |||||
| 5198-5199 | Unassigned | ||||||||||
| targus-getdata | 5200 | tcp | TARGUS GetData | [John_Keaveney] | [John_Keaveney] | ||||||
| targus-getdata | 5200 | udp | TARGUS GetData | [John_Keaveney] | [John_Keaveney] | ||||||
| targus-getdata1 | 5201 | tcp | TARGUS GetData 1 | [John_Keaveney] | [John_Keaveney] | ||||||
| targus-getdata1 | 5201 | udp | TARGUS GetData 1 | [John_Keaveney] | [John_Keaveney] | ||||||
| targus-getdata2 | 5202 | tcp | TARGUS GetData 2 | [John_Keaveney] | [John_Keaveney] | ||||||
| targus-getdata2 | 5202 | udp | TARGUS GetData 2 | [John_Keaveney] | [John_Keaveney] | ||||||
| targus-getdata3 | 5203 | tcp | TARGUS GetData 3 | [John_Keaveney] | [John_Keaveney] | ||||||
| targus-getdata3 | 5203 | udp | TARGUS GetData 3 | [John_Keaveney] | [John_Keaveney] | ||||||
| 5204-5208 | Unassigned | ||||||||||
| 5210-5214 | Unassigned | ||||||||||
| 5216-5220 | Unassigned | ||||||||||
| xmpp-client | 5222 | tcp | XMPP Client Connection | [RFC 6120] | |||||||
| hp-server | 5225 | tcp | HP Server | [Brett_Green_2] | [Brett_Green_2] | ||||||
| hp-server | 5225 | udp | HP Server | [Brett_Green_2] | [Brett_Green_2] | ||||||
| hp-status | 5226 | tcp | HP Status | [Brett_Green_2] | [Brett_Green_2] | ||||||
| hp-status | 5226 | udp | HP Status | [Brett_Green_2] | [Brett_Green_2] | ||||||
| jaxflow-data | 5230 | tcp | JaxMP RealFlow application and protocol data | [JaxMP] | [Stephen_Hull] | 2014-08-15 | |||||
| galaxy-network | 5235 | tcp | Galaxy Network Service | [Michael_Andre_2] | [Michael_Andre_2] | 2007-10-04 | |||||
| galaxy-network | 5235 | udp | Galaxy Network Service | [Michael_Andre_2] | [Michael_Andre_2] | 2007-10-04 | |||||
| mnet-discovery | 5237 | tcp | m-net discovery | [Andy_Crick] | [Andy_Crick] | 2007-11-13 | |||||
| mnet-discovery | 5237 | udp | m-net discovery | [Andy_Crick] | [Andy_Crick] | 2007-11-13 | |||||
| 5238-5241 | Unassigned | ||||||||||
| downtools-disc | 5245 | udp | DownTools Discovery Protocol | [Jarrod_Sayers] | [Jarrod_Sayers] | 2009-04-07 | |||||
| capwap-control | 5246 | udp | CAPWAP Control Protocol | [RFC 5415] | |||||||
| capwap-data | 5247 | udp | CAPWAP Data Protocol | [RFC 5415] | |||||||
| movaz-ssc | 5252 | tcp | Movaz SSC | [Lou_Berger] | [Lou_Berger] | 2004-11 | |||||
| movaz-ssc | 5252 | udp | Movaz SSC | [Lou_Berger] | [Lou_Berger] | 2004-11 | |||||
| 5255-5263 | Unassigned | ||||||||||
| 3com-njack-1 | 5264 | tcp | 3Com Network Jack Port 1 | [Abhay_Rajaram] | [Abhay_Rajaram] | 2003-03 | |||||
| 3com-njack-1 | 5264 | udp | 3Com Network Jack Port 1 | [Abhay_Rajaram] | [Abhay_Rajaram] | 2003-03 | |||||
| 3com-njack-2 | 5265 | tcp | 3Com Network Jack Port 2 | [Abhay_Rajaram] | [Abhay_Rajaram] | 2003-03 | |||||
| 3com-njack-2 | 5265 | udp | 3Com Network Jack Port 2 | [Abhay_Rajaram] | [Abhay_Rajaram] | 2003-03 | |||||
| 5266-5268 | Unassigned | ||||||||||
| xmpp-server | 5269 | tcp | XMPP Server Connection | [RFC 6120] | |||||||
| cuelink-disc | 5271 | udp | StageSoft CueLink discovery | [Todd_Pichler] | [Todd_Pichler] | 2010-03-26 | |||||
| 5273-5279 | Unassigned | ||||||||||
| xmpp-bosh | 5280 | tcp | Bidirectional-streams Over Synchronous HTTP (BOSH) | [Peter_Saint_Andre] | [Peter_Saint_Andre] | 2009-11-25 | |||||
| undo-lm | 5281 | tcp | Undo License Manager | [Undo_Ltd] | [Edward_Moffett] | 2010-04-19 | 2019-01-25 | ||||
| transmit-port | 5282 | tcp | Marimba Transmitter Port | [Johan_Eriksson] | [Johan_Eriksson] | 2002-04 | |||||
| transmit-port | 5282 | udp | Marimba Transmitter Port | [Johan_Eriksson] | [Johan_Eriksson] | 2002-04 | |||||
| 5283-5297 | Unassigned | ||||||||||
| presence | 5298 | tcp | XMPP Link-Local Messaging | [Eric_St_Onge] | [Eric_St_Onge] | 2008-01-14 | Defined TXT keys: See http://www.xmpp.org/registrar/linklocal.html | ||||
| presence | 5298 | udp | XMPP Link-Local Messaging | [Eric_St_Onge] | [Eric_St_Onge] | 2008-01-14 | Defined TXT keys: See http://www.xmpp.org/registrar/linklocal.html | ||||
| nlg-data | 5299 | tcp | NLG Data Service | [Andy_Shellam] | [Andy_Shellam] | 2008-02-19 | |||||
| nlg-data | 5299 | udp | NLG Data Service | [Andy_Shellam] | [Andy_Shellam] | 2008-02-19 | |||||
| hacl-hb | 5300 | tcp | HA cluster heartbeat | [Eric_Soderberg_2][Edward_Yim] | [Eric_Soderberg_2][Edward_Yim] | ||||||
| hacl-hb | 5300 | udp | HA cluster heartbeat | [Eric_Soderberg_2][Edward_Yim] | [Eric_Soderberg_2][Edward_Yim] |