Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
scte30 5168 udp SCTE30 Connection Thomas Russell Thomas Russell 2005-05
5169-5171 Unassigned
pcoip-mgmt 5172 tcp PC over IP Endpoint Management HP Inc. Jeff Jeansonne 2014-04-28 2026-03-10
5172 udp Reserved
5173-5189 Unassigned
aol 5190 tcp America-Online Marty Lyons Marty Lyons
aol 5190 udp America-Online Marty Lyons Marty Lyons
aol-1 5191 tcp AmericaOnline1 Bruce Mackey Bruce Mackey
aol-1 5191 udp AmericaOnline1 Bruce Mackey Bruce Mackey
aol-2 5192 tcp AmericaOnline2 Bruce Mackey Bruce Mackey
aol-2 5192 udp AmericaOnline2 Bruce Mackey Bruce Mackey
aol-3 5193 tcp AmericaOnline3 Bruce Mackey Bruce Mackey
aol-3 5193 udp AmericaOnline3 Bruce Mackey Bruce Mackey
cpscomm 5194 tcp CipherPoint Config Service CipherPoint Software, inc. CipherPoint Software, inc. 2010-03-03
5194 udp Reserved
ampl-lic 5195 tcp The protocol is used by a license server and client programs to control use of program licenses that float to networked machines AMPL Optimization, Inc. David M. Gay 2012-05-25
5195 udp Reserved
ampl-tableproxy 5196 tcp The protocol is used by two programs that exchange "table" data used in the AMPL modeling language AMPL Optimization, Inc. David M. Gay 2012-05-25
5196 udp Reserved
tunstall-lwp 5197 tcp Tunstall Lone worker device interface Tunstall Healthcare (UK) Ltd. Robert Moore 2014-12-10
5197 udp Reserved
5198-5199 Unassigned
targus-getdata1 5201 tcp TARGUS GetData 1 John Keaveney John Keaveney
targus-getdata1 5201 udp TARGUS GetData 1 John Keaveney John Keaveney
5210-5214 Unassigned
noteza 5215 tcp NOTEZA Data Safety Service CNS a.s. (IT company registered in Czech republic) Pavel Mendl 2014-06-12
5215 udp Reserved
noteza 5215 sctp NOTEZA Data Safety Service CNS a.s. (IT company registered in Czech republic) Pavel Mendl 2014-06-12
5216-5220 Unassigned
3exmp 5221 tcp 3eTI Extensible Management Protocol for OAMP Bill Rettig Bill Rettig 2010-05-19
5221 udp Reserved
xmpp-client 5222 tcp XMPP Client Connection RFC 6120
crusecontrol 5231 tcp Remote Control of Scan Software for Cruse Scanners Cruse Spezialmaschinen GmbH Christof J. Reetz 2014-08-15
5231 udp Reserved
5238-5241 Unassigned
capwap-control 5246 udp CAPWAP Control Protocol RFC 5415
capwap-data 5247 udp CAPWAP Data Protocol RFC 5415
caevms 5251 tcp CA eTrust VM Service Kevin Bond Kevin Bond 2004-11
caevms 5251 udp CA eTrust VM Service Kevin Bond Kevin Bond 2004-11
3com-njack-1 5264 tcp 3Com Network Jack Port 1 Abhay Rajaram Abhay Rajaram 2003-03
3com-njack-1 5264 udp 3Com Network Jack Port 1 Abhay Rajaram Abhay Rajaram 2003-03
xmpp-server 5269 tcp XMPP Server Connection RFC 6120
cuelink 5271 tcp StageSoft CueLink messaging Todd Pichler Todd Pichler 2010-03-26
cuelink-disc 5271 udp StageSoft CueLink discovery Todd Pichler Todd Pichler 2010-03-26
undo-lm 5281 tcp Undo License Manager Undo Ltd Edward Moffett 2010-04-19 2019-01-25
5281 udp Reserved
hacl-gs 5301 tcp HA cluster general services Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-gs 5301 udp HA cluster general services Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
outlaws 5310 tcp Outlaws Richard Fife Richard Fife
outlaws 5310 udp Outlaws Richard Fife Richard Fife
5311 Unassigned 2004-05-07
permabit-cs 5312 tcp Permabit Client-Server Jered Floyd Jered Floyd 2004-06
permabit-cs 5312 udp Permabit Client-Server Jered Floyd Jered Floyd 2004-06
rrdp 5313 tcp Real-time & Reliable Data Ted Hoshi Ted Hoshi 2004-06
rrdp 5313 udp Real-time & Reliable Data Ted Hoshi Ted Hoshi 2004-06
opalis-rbt-ipc 5314 tcp opalis-rbt-ipc Laurent Domenech Laurent Domenech
opalis-rbt-ipc 5314 udp opalis-rbt-ipc Laurent Domenech Laurent Domenech
hacl-poll 5315 tcp HA Cluster UDP Polling Hoa Nguyen Hoa Nguyen
hacl-poll 5315 udp HA Cluster UDP Polling Hoa Nguyen Hoa Nguyen
hpbladems 5316 tcp HPBladeSystem Monitor Service Alan Minchew Alan Minchew 2011-05-23 2011-05-16
5316 udp Unassigned 2011-05-16
hpdevms 5317 tcp HP Device Monitor Service Alan Minchew Alan Minchew 2011-05-16
5317 udp Reserved
pkix-cmc 5318 tcp PKIX Certificate Management using CMS (CMC) IESG IETF Chair 2026-02-13 RFC 10003
5318 udp Reserved
roughtime 5319 tcp Roughtime time synchronization IESG IETF Chair 2026-03-27 RFC 10049
roughtime 5319 udp Roughtime time synchronization IESG IETF Chair 2026-03-27 RFC 10049
bsfsvr-zn-ssl 5321 tcp Webservices-based Zn interface of BSF over SSL Bert Paul Bert Paul 2008-07-03
5321 udp Reserved
5351 tcp Reserved
pcp 5351 udp Port Control Protocol IESG IETF Chair RFC 6887
ms-s-sideshow 5361 tcp Secure Protocol for Windows SideShow Dan Polivy Dan Polivy 2008-03-12
ms-s-sideshow 5361 udp Secure Protocol for Windows SideShow Dan Polivy Dan Polivy 2008-03-12
excerpts 5401 tcp Excerpt Search Secure John Hinsdale John Hinsdale
excerpts 5401 udp Excerpt Search Secure John Hinsdale John Hinsdale
salient-usrmgr 5410 tcp Salient User Manager Richard Farnham Richard Farnham
salient-usrmgr 5410 udp Salient User Manager Richard Farnham Richard Farnham
actnet 5411 tcp ActNet Simon Robillard Simon Robillard
actnet 5411 udp ActNet Simon Robillard Simon Robillard
continuus 5412 tcp Continuus Steven Holtsberg Steven Holtsberg
continuus 5412 udp Continuus Steven Holtsberg Steven Holtsberg
wwiotalk 5413 tcp WWIOTALK Roger Knobbe Roger Knobbe
wwiotalk 5413 udp WWIOTALK Roger Knobbe Roger Knobbe
statusd 5414 tcp StatusD Stephen Misel Stephen Misel
statusd 5414 udp StatusD Stephen Misel Stephen Misel
ns-server 5415 tcp NS Server Jeffrey Chiao Jeffrey Chiao
ns-server 5415 udp NS Server Jeffrey Chiao Jeffrey Chiao
sns-gateway 5416 tcp SNS Gateway Mary Holstage Mary Holstage
sns-gateway 5416 udp SNS Gateway Mary Holstage Mary Holstage
sns-agent 5417 tcp SNS Agent Mary Holstage Mary Holstage
sns-agent 5417 udp SNS Agent Mary Holstage Mary Holstage
mcntp 5418 tcp MCNTP Heiko Rupp Heiko Rupp
mcntp 5418 udp MCNTP Heiko Rupp Heiko Rupp
dj-ice 5419 tcp DJ-ICE Don Tyson Don Tyson
dj-ice 5419 udp DJ-ICE Don Tyson Don Tyson
netsupport2 5421 tcp Net Support 2 Paul Sanders Paul Sanders
netsupport2 5421 udp Net Support 2 Paul Sanders Paul Sanders
park-agent 5431 tcp PARK AGENT John Clifford John Clifford
park-agent 5431 udp PARK AGENT John Clifford John Clifford
5451-5452 Unassigned
silkmeter 5461 tcp SILKMETER Klaus Fellner Klaus Fellner

Contact Information

Name Organization Contact URI Last Updated
Abhay Rajaram Abhay_Rajaram&3com.com 2003-03
Alan Minchew alan.minchew&hp.com 2011-05-23
AMPL Optimization, Inc. dmg&ampl.com 2012-05-25
Bert Paul bert.paul&apertio.com 2008-07-03
Bill Rettig WRettig&efji.com 2010-05-19
Bruce Mackey BAMackey&aol.com
Christof J. Reetz Cruse Spezialmaschinen GmbH cjr&crusescanner.com 2014-08-15
CipherPoint Software, inc. wshea&cipherpointsoftware.com 2010-03-03
CNS a.s. (IT company registered in Czech republic) HAJN.L&cns.cz 2014-06-12
Cruse Spezialmaschinen GmbH cjr&crusescanner.com 2014-08-15
Dan Polivy dpolivy&microsoft.com 2008-03-12
David M. Gay AMPL Optimization, Inc. dmg&ampl.com 2012-05-25
Don Tyson don.tyson&cor.dowjones.com
Edward Moffett Undo Ltd office.manager&undo.io 2019-01-25
Edward Yim eyim&hpmfas4.cup.hp.com
Eric Soderberg seric&hposl102.cup.hp
Heiko Rupp hwr&pilhuhn.de
Hoa Nguyen hoan&cup.hp.com
HP Inc. jeff.jeansonne&hp.com 2026-03-10
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jeff Jeansonne jeff.jeansonne&hp.com 2026-03-10
Jeffrey Chiao chiaoj&netsoft.com
Jered Floyd jered&permabit.com 2004-06
John Clifford John.Clifford&veritas.com
John Hinsdale hin&alma.com
John Keaveney johnkeaveney&targusinfo.com
Kevin Bond kevin.bond&ca.com 2004-11
Klaus Fellner webmaster&segue.com
kfellner&segue.com
Laurent Domenech Opalis ldomenech&opalis.com
Marty Lyons marty&aol.com
Mary Holstage holstege&firstfloor.com
Paul Sanders p.sanders&dial.pipex.com
Pavel Mendl CNS a.s. (IT company registered in Czech republic) Pavel.MENDL&cns.cz 2014-06-12
Richard Farnham rfarnham&salient.com
Richard Fife richardf&lucasarts.com
Robert Moore Tunstall Healthcare (UK) Ltd. robert.moore&tunstall.com 2014-12-10
Roger Knobbe RogerK&wonderware.com
Simon Robillard RobillardS&actresearch.com
Stephen Misel steve&satelnet.org
Steven Holtsberg steveh&continuus.com
Ted Hoshi tetsuo.hoshi&jp.yokogawa.com 2004-06
Thomas Russell trussell&scte.org 2005-05
Todd Pichler todd.pichler&stagesoft.com 2010-03-26
Tunstall Healthcare (UK) Ltd. robert.moore&tunstall.com 2014-12-10
Undo Ltd office.manager&undo.io 2019-01-25