Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| icl-twobase7 | 25006 | tcp | icl-twobase7 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase7 | 25006 | udp | icl-twobase7 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase8 | 25007 | tcp | icl-twobase8 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase8 | 25007 | udp | icl-twobase8 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase9 | 25008 | tcp | icl-twobase9 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase9 | 25008 | udp | icl-twobase9 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase10 | 25009 | tcp | icl-twobase10 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase10 | 25009 | udp | icl-twobase10 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| 25010-25099 | Unassigned | ||||||||||
| db2c-tls | 25100 | tcp | IBM Db2 Client Interface - Encrypted | IBM | Matthew Emmerton | 2024-03-05 | |||||
| 25100 | udp | Reserved | |||||||||
| 25101-25470 | Unassigned | ||||||||||
| rna | 25471 | sctp | RNSAP User Adaptation for Iurh | Dario S. Tonesi | Dario S. Tonesi | 2011-02-07 | |||||
| 25472-25575 | Unassigned | ||||||||||
| sauterdongle | 25576 | tcp | Sauter Dongle | Christian Brecht | Christian Brecht | 2010-12-15 | |||||
| 25576 | udp | Reserved | |||||||||
| 25577-25603 | Unassigned | ||||||||||
| idtp | 25604 | tcp | Identifier Tracing Protocol | Huang Neng-geng | Huang Neng-geng | 2011-08-09 | |||||
| 25604 | udp | Reserved | |||||||||
| 25605-25792 | Unassigned | ||||||||||
| vocaltec-hos | 25793 | tcp | Vocaltec Address Server | Scott Petrack | Scott Petrack | ||||||
| vocaltec-hos | 25793 | udp | Vocaltec Address Server | Scott Petrack | Scott Petrack | ||||||
| 25794-25899 | Unassigned | ||||||||||
| tasp-net | 25900 | tcp | TASP Network Comm | Martin Ellis | Martin Ellis | 2004-11 | |||||
| tasp-net | 25900 | udp | TASP Network Comm | Martin Ellis | Martin Ellis | 2004-11 | |||||
| niobserver | 25901 | tcp | NIObserver | Roman Oliynyk | Roman Oliynyk | ||||||
| niobserver | 25901 | udp | NIObserver | Roman Oliynyk | Roman Oliynyk | ||||||
| nilinkanalyst | 25902 | tcp | NILinkAnalyst | Roman Oliynyk | Roman Oliynyk | 2007-08-30 | |||||
| nilinkanalyst | 25902 | udp | NILinkAnalyst | Roman Oliynyk | Roman Oliynyk | 2007-08-30 | |||||
| niprobe | 25903 | tcp | NIProbe | Roman Oliynyk | Roman Oliynyk | ||||||
| niprobe | 25903 | udp | NIProbe | Roman Oliynyk | Roman Oliynyk | ||||||
| 25904-25953 | Unassigned | ||||||||||
| bf-game | 25954 | udp | Bitfighter game server | Christopher Eykamp | Christopher Eykamp | 2012-08-16 | |||||
| 25954 | tcp | Reserved | |||||||||
| bf-master | 25955 | udp | Bitfighter master server | Christopher Eykamp | Christopher Eykamp | 2012-08-16 | |||||
| 25955 | tcp | Reserved | |||||||||
| 25956-25999 | Unassigned | ||||||||||
| 26209-26256 | Unassigned | ||||||||||
| cockroach | 26257 | tcp | CockroachDB | Cockroach Labs, Inc. | Ben_Darnell | 2015-09-29 | |||||
| 26257 | udp | Reserved | |||||||||
| 26258-26259 | Unassigned | ||||||||||
| 26265-26485 | Unassigned | ||||||||||
| 27011-27015 | Unassigned | ||||||||||
| imagepump | 27345 | tcp | ImagePump | Richard Minner | Richard Minner | ||||||
| imagepump | 27345 | udp | ImagePump | Richard Minner | Richard Minner | ||||||
| 27443-27503 | Unassigned | ||||||||||
| kopek-httphead | 27504 | tcp | Kopek HTTP Head Port | Sten H. Danielsen | Sten H. Danielsen | 2002-07 | |||||
| kopek-httphead | 27504 | udp | Kopek HTTP Head Port | Sten H. Danielsen | Sten H. Danielsen | 2002-07 | |||||
| 27505-27781 | Unassigned | ||||||||||
| 27783-27875 | Unassigned | ||||||||||
| 28241-28588 | Unassigned | ||||||||||
| bosswave | 28589 | tcp | Building operating system services wide area verified exchange | University of California, Berkeley | Michael Andersen | 2016-06-13 | |||||
| 28589 | udp | Reserved | |||||||||
| 28590-28999 | Unassigned | ||||||||||
| bingbang | 29999 | tcp | data exchange protocol for IEC61850 in wind power plants | DEIF A/S | Armin Solies | 2012-10-15 | |||||
| 30005-30099 | Unassigned | ||||||||||
| 30101-30259 | Unassigned | ||||||||||
| 31000-31015 | Unassigned | ||||||||||
| autotrac-acp | 31020 | tcp | Autotrac ACP 245 | Roberto Jorge Dino | Roberto Jorge Dino | ||||||
| 31401-31415 | Unassigned | ||||||||||
| 31417-31456 | Unassigned | ||||||||||
| tetrinet | 31457 | tcp | TetriNET Protocol | Emmanuel Bourg | Emmanuel Bourg | 2004-11 | |||||
| tetrinet | 31457 | udp | TetriNET Protocol | Emmanuel Bourg | Emmanuel Bourg | 2004-11 | |||||
| 31458-31619 | Unassigned | ||||||||||
| dsx-monitor | 31685 | tcp | DS Expert Monitor IANA assigned this well-formed service name as a replacement for "dsx_monitor". |
John Lowery | John Lowery | 2008-08-21 | |||||
| dsx_monitor | 31685 | tcp | DS Expert Monitor | John Lowery | John Lowery | 2008-08-21 | This entry is an alias to "dsx-monitor". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 31685 | udp | Reserved | |||||||||
| gamesmith-port | 31765 | tcp | GameSmith Port | Randy Thompson | Randy Thompson | 2002-08 | |||||
| gamesmith-port | 31765 | udp | GameSmith Port | Randy Thompson | Randy Thompson | 2002-08 | |||||
| 31950-32033 | Unassigned | ||||||||||
| 32035-32248 | Unassigned | ||||||||||
| 32250-32399 | Unassigned | ||||||||||
| sec-ntb-clnt | 32635 | tcp | SecureNotebook-CLNT | Eric Cantineau | Eric Cantineau | 2004-11 | |||||
| sec-ntb-clnt | 32635 | udp | SecureNotebook-CLNT | Eric Cantineau | Eric Cantineau | 2004-11 | |||||
| filenet-pch | 32775 | tcp | Performance Clearinghouse | Tim Morgan | Tim Morgan | 2005-11 | |||||
| filenet-pch | 32775 | udp | Performance Clearinghouse | Tim Morgan | Tim Morgan | 2005-11 | |||||
| 32812-32895 | Unassigned | ||||||||||
| 33001-33059 | Unassigned | ||||||||||
| 33335-33433 | Unassigned | ||||||||||
| 33435 | tcp | Reserved | |||||||||
| mtrace | 33435 | udp | IP Multicast Traceroute | IESG | IETF Chair | 2017-12-13 | 2019-08-09 | RFC 8487 | Known Unauthorized Use on port 33435 | ||
| 33436-33655 | Unassigned | Known Unauthorized Use on ports 33436-33534 | |||||||||
| snip-slave | 33656 | tcp | SNIP Slave | Dr. Chris Tucker | Dr. Chris Tucker | 2005-08 | |||||
| snip-slave | 33656 | udp | SNIP Slave | Dr. Chris Tucker | Dr. Chris Tucker | 2005-08 | |||||
| 33657-33889 | Unassigned | ||||||||||
| 34250-34377 | Unassigned | ||||||||||
| 34380-34566 | Unassigned | ||||||||||
| dhanalakshmi | 34567 | tcp | dhanalakshmi.org EDI Service | Girish Gopalakrishnan | Girish Gopalakrishnan | 2010-04-20 | |||||
| edi_service | 34567 | udp | dhanalakshmi.org EDI Service | Girish Gopalakrishnan | Girish Gopalakrishnan | 2016-10-26 | |||||
| 34568-34961 | Unassigned | ||||||||||
| profinet-cm-sec | 34965 | tcp | PROFINET secure connection management and key provisioning | PNO – PROFIBUS Nutzerorganisation e.V. | Dietmar Bohn | 2026-03-10 | |||||
| profinet-cm-sec | 34965 | udp | PROFINET secure connection management and key provisioning | PNO – PROFIBUS Nutzerorganisation e.V. | Dietmar Bohn | 2026-03-10 | |||||
| heathview | 35000 | tcp | HeathView | Heathwest Systems Limited | Andrew Porrer | 2013-03-21 | |||||
| 35000 | udp | Reserved | |||||||||
| rt-viewer | 35001 | tcp | ReadyTech Viewer | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-viewer | 35001 | udp | ReadyTech Viewer | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-sound | 35002 | tcp | ReadyTech Sound Server | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35002 | udp | Reserved | |||||||||
| rt-devicemapper | 35003 | tcp | ReadyTech DeviceMapper Server | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35003 | udp | Reserved | |||||||||
| rt-classmanager | 35004 | tcp | ReadyTech ClassManager | ReadyTech Corporation | Kevin Woodward | 2013-09-13 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andrew Porrer | Heathwest Systems Limited | Andrew.Porrer&heathwest.com | 2013-03-21 |
| Armin Solies | DEIF A/S | aes&deif.com | 2012-10-15 |
| ben&cockroachlabs.com | 2015-09-29 | ||
| Christian Brecht | Christian.Brecht&sauter-gmbh.de | 2010-12-15 | |
| Christopher Eykamp | chris&eykamp.com | 2012-08-16 | |
| Cockroach Labs, Inc. | iana-contact&cockroachlabs.com | 2015-09-29 | |
| Dario S. Tonesi | dario.tonesi&nsn.com | 2011-02-07 | |
| DEIF A/S | aes&deif.com | 2012-10-15 | |
| Dietmar Bohn | standards.central-office&profibus.com | 2026-03-10 | |
| Dr. Chris Tucker | chris.tucker&ioltd.co.uk | 2005-08 | |
| Emmanuel Bourg | smanux&lfjr.net | 2004-11 | |
| Eric Cantineau | eric&securenotebook.com | 2004-11 | |
| Girish Gopalakrishnan | girish&shankar-software.org | 2016-10-26 | |
| Heathwest Systems Limited | info&heathwest.com | 2013-03-21 | |
| Huang Neng-geng | huangng&ngweb.org
nghuang&ieee.org |
2011-08-09 | |
| IBM | memmerto&ca.ibm.com | 2024-03-05 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| J. A. (Tony) Sever | J.A.Sever&bra0119.wins.icl.co.uk | ||
| John Lowery | NetPro Computing | jlowery&netpro.com | 2008-08-21 |
| Kevin Woodward | ReadyTech Corporation | kwoodward&readytech.com | 2013-09-13 |
| Martin Ellis | martin&clanleagues.net | 2004-11 | |
| Matthew Emmerton | IBM | memmerto&ca.ibm.com | 2024-03-05 |
| Michael Andersen | michael&steelcode.com | 2016-06-13 | |
| PNO – PROFIBUS Nutzerorganisation e.V. | standards.central-office&profibus.com | 2026-03-10 | |
| Randy Thompson | thompr&earthlink.net | 2002-08 | |
| ReadyTech Corporation | kwoodward&readytech.com | 2013-09-13 | |
| Richard Minner | http://xippix.com | ||
| Roberto Jorge Dino | roberto.dino&autotrac.com.br | ||
| Roman Oliynyk | romano&netinst.com | ||
| Roman Oliynyk | roman&netinst.com | 2007-08-30 | |
| Scott Petrack | Scott_Petrack&vocaltec.com | ||
| Sten H. Danielsen | shd&kopek.net | 2002-07 | |
| Tim Morgan | tmorgan&filenet.com | 2005-11 | |
| University of California, Berkeley | m.andersen&cs.berkeley.edu | 2016-06-13 |