Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| dnssd-srp | tcp | DNS-Based Service Discovery | IESG | IETF Chair | 2024-04-12 | 2024-09-05 | RFC 9665 | Defined TXT keys: None | |||
| dnssd-srp-tls | tcp | DNS-Based Service Discovery (TLS) | IESG | IETF Chair | 2024-04-12 | 2024-09-05 | RFC 9665 | Defined TXT keys: None | |||
| hyperstream | Atempo HyperStream deduplication server | Laurent Charmet | Laurent Charmet | Defined TXT keys: version=x.y.z.w uuid=<36 bytes UUID string> host=<real host name> | |||||||
| im | tcp | Instant Messaging | RFC 3861 | ||||||||
| im | udp | Instant Messaging | RFC 3861 | ||||||||
| jmap | tcp | JSON Meta Application Protocol | IESG | IETF Chair | 2016-01-22 | 2019-07-16 | RFC 8620 | This service name was previously assigned under the name "JSON Mail Access Protocol". This has been de-assigned and re-assigned with the approval of the previous assignee. | |||
| jnx-kcsync | tcp | jollys keychain cloud sync protocol | Patrick Stein | Patrick Stein | 2011-10-24 | Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa | |||||
| msrps | tcp | MSRP protocol over TLS | 2014-04-25 | RFC 4976 | Defined TXT keys: | ||||||
| nfs-domainroot | tcp | NFS service for the domain root, the root of an organization's published file namespace. | IESG | IETF Chair | 2012-04-24 | RFC 6641 | Defined TXT keys: None | ||||
| pkixrep | Public Key Infrastructure Repository Locator Service | RFC 4386 | |||||||||
| pres | tcp | Presence | RFC 3861 | ||||||||
| pres | udp | Presence | RFC 3861 | ||||||||
| split-dns64 | tcp | DNS64 in split configuration | Kasper Dupont | Kasper Dupont | 2021-10-19 | Defined TXT keys: None | |||||
| timezone | tcp | Time Zone Data Distribution Service - non-TLS | IESG | IETF Chair | 2015-08-03 | RFC 7808 | This is an extension of the http service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763). | ||||
| timezones | tcp | Time Zone Data Distribution Service - over TLS | IESG | IETF Chair | 2015-08-03 | RFC 7808 | This is an extension of the https service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763). |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Kasper Dupont | kasperd&xwhfx.16.oct.2021.kasperd.dk | 2021-10-19 | |
| Laurent Charmet | laurent.charmet&atempo.com | ||
| Patrick Stein | Patrick.Stein&jinx.eu | 2011-10-24 |