Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
hacl-hb 5300 udp HA cluster heartbeat [Eric_Soderberg_2][Edward_Yim] [Eric_Soderberg_2][Edward_Yim]
hacl-gs 5301 tcp HA cluster general services [Eric_Soderberg_2][Edward_Yim] [Eric_Soderberg_2][Edward_Yim]
hacl-gs 5301 udp HA cluster general services [Eric_Soderberg_2][Edward_Yim] [Eric_Soderberg_2][Edward_Yim]
hacl-cfg 5302 tcp HA cluster configuration [Eric_Soderberg_2][Edward_Yim] [Eric_Soderberg_2][Edward_Yim]
hacl-cfg 5302 udp HA cluster configuration [Eric_Soderberg_2][Edward_Yim] [Eric_Soderberg_2][Edward_Yim]
hacl-probe 5303 tcp HA cluster probing [Eric_Soderberg_2][Edward_Yim] [Eric_Soderberg_2][Edward_Yim]
hacl-probe 5303 udp HA cluster probing [Eric_Soderberg_2][Edward_Yim] [Eric_Soderberg_2][Edward_Yim]
hacl-local 5304 tcp HA Cluster Commands [Eric_Soderberg_2][Edward_Yim] [Eric_Soderberg_2][Edward_Yim]
hacl-local 5304 udp HA Cluster Commands [Eric_Soderberg_2][Edward_Yim] [Eric_Soderberg_2][Edward_Yim]
hacl-test 5305 tcp HA Cluster Test [Eric_Soderberg_2][Edward_Yim] [Eric_Soderberg_2][Edward_Yim]
hacl-test 5305 udp HA Cluster Test [Eric_Soderberg_2][Edward_Yim] [Eric_Soderberg_2][Edward_Yim]
sun-mc-grp 5306 tcp Sun MC Group [Michael_DeMoney] [Michael_DeMoney]
sun-mc-grp 5306 udp Sun MC Group [Michael_DeMoney] [Michael_DeMoney]
sco-aip 5307 tcp SCO AIP [Barrie_Cooper] [Barrie_Cooper]
sco-aip 5307 udp SCO AIP [Barrie_Cooper] [Barrie_Cooper]
permabit-cs 5312 tcp Permabit Client-Server [Jered_Floyd] [Jered_Floyd] 2004-06
permabit-cs 5312 udp Permabit Client-Server [Jered_Floyd] [Jered_Floyd] 2004-06
rrdp 5313 tcp Real-time & Reliable Data [Ted_Hoshi] [Ted_Hoshi] 2004-06
rrdp 5313 udp Real-time & Reliable Data [Ted_Hoshi] [Ted_Hoshi] 2004-06
opalis-rbt-ipc 5314 tcp opalis-rbt-ipc [Laurent_Domenech] [Laurent_Domenech]
opalis-rbt-ipc 5314 udp opalis-rbt-ipc [Laurent_Domenech] [Laurent_Domenech]
hacl-poll 5315 tcp HA Cluster UDP Polling [Hoa_Nguyen] [Hoa_Nguyen]
hacl-poll 5315 udp HA Cluster UDP Polling [Hoa_Nguyen] [Hoa_Nguyen]
pkix-cmc 5318 tcp PKIX Certificate Management using CMS (CMC) [IESG] [IETF_Chair] 2026-02-13 [RFC 10003]
bsfserver-zn 5320 tcp Webservices-based Zn interface of BSF [Bert_Paul] [Bert_Paul] 2008-05-01
bsfsvr-zn-ssl 5321 tcp Webservices-based Zn interface of BSF over SSL [Bert_Paul] [Bert_Paul] 2008-07-03
5322-5342 Unassigned
5345-5348 Unassigned
stun-behaviors 5349 tcp STUN Behavior Discovery over TLS [RFC 5780]
stun-behaviors 5349 udp Reserved for a future enhancement of STUN-BEHAVIOR [RFC 5780]
pcp-multicast 5350 udp Port Control Protocol Multicast [IESG] [IETF_Chair] [RFC 6887]
dns-llq 5352 tcp DNS Long-Lived Queries [Stuart_Cheshire] [Stuart_Cheshire] 2005-08 2019-08-26 [RFC 8764]
dns-llq 5352 udp DNS Long-Lived Queries [Stuart_Cheshire] [Stuart_Cheshire] 2005-08 2019-08-26 [RFC 8764]
ms-smlbiz 5356 tcp Microsoft Small Business [Gopikrishna_Sandra] [Gopikrishna_Sandra] 2005-02
ms-smlbiz 5356 udp Microsoft Small Business [Gopikrishna_Sandra] [Gopikrishna_Sandra] 2005-02
wsdapi-s 5358 tcp WS for Devices Secured [Henry_Rawas] [Henry_Rawas] 2005-08
wsdapi-s 5358 udp WS for Devices Secured [Henry_Rawas] [Henry_Rawas] 2005-08
ms-alerter 5359 tcp Microsoft Alerter [Marc_McClure] [Marc_McClure] 2007-08-07
ms-alerter 5359 udp Microsoft Alerter [Marc_McClure] [Marc_McClure] 2007-08-07
ms-sideshow 5360 tcp Protocol for Windows SideShow [Dan_Polivy] [Dan_Polivy] 2008-03-12
ms-sideshow 5360 udp Protocol for Windows SideShow [Dan_Polivy] [Dan_Polivy] 2008-03-12
ms-s-sideshow 5361 tcp Secure Protocol for Windows SideShow [Dan_Polivy] [Dan_Polivy] 2008-03-12
ms-s-sideshow 5361 udp Secure Protocol for Windows SideShow [Dan_Polivy] [Dan_Polivy] 2008-03-12
net-projection 5363 tcp Windows Network Projection [Rob_Williams] [Rob_Williams] 2009-02-17
net-projection 5363 udp Windows Network Projection [Rob_Williams] [Rob_Williams] 2009-02-17
5365-5396 Unassigned
elektron-admin 5398 tcp Elektron Administration [Chris_Hawk] [Chris_Hawk] 2005-08
elektron-admin 5398 udp Elektron Administration [Chris_Hawk] [Chris_Hawk] 2005-08
hpoms-ci-lstn 5403 tcp HPOMS-CI-LSTN [Harold_Froehling] [Harold_Froehling]
hpoms-ci-lstn 5403 udp HPOMS-CI-LSTN [Harold_Froehling] [Harold_Froehling]
hpoms-dps-lstn 5404 tcp HPOMS-DPS-LSTN [Harold_Froehling] [Harold_Froehling]
hpoms-dps-lstn 5404 udp HPOMS-DPS-LSTN [Harold_Froehling] [Harold_Froehling]
systemics-sox 5406 tcp Systemics Sox [Gary_Howland] [Gary_Howland]
systemics-sox 5406 udp Systemics Sox [Gary_Howland] [Gary_Howland]
foresyte-clear 5407 tcp Foresyte-Clear [Jorge_Aldana] [Jorge_Aldana]
foresyte-clear 5407 udp Foresyte-Clear [Jorge_Aldana] [Jorge_Aldana]
foresyte-sec 5408 tcp Foresyte-Sec [Jorge_Aldana] [Jorge_Aldana]
foresyte-sec 5408 udp Foresyte-Sec [Jorge_Aldana] [Jorge_Aldana]
salient-dtasrv 5409 tcp Salient Data Server [Richard_Farnham] [Richard_Farnham]
salient-dtasrv 5409 udp Salient Data Server [Richard_Farnham] [Richard_Farnham]
salient-usrmgr 5410 tcp Salient User Manager [Richard_Farnham] [Richard_Farnham]
salient-usrmgr 5410 udp Salient User Manager [Richard_Farnham] [Richard_Farnham]
ns-server 5415 tcp NS Server [Jeffrey_Chiao] [Jeffrey_Chiao]
ns-server 5415 udp NS Server [Jeffrey_Chiao] [Jeffrey_Chiao]
sns-gateway 5416 tcp SNS Gateway [Mary_Holstage] [Mary_Holstage]
sns-gateway 5416 udp SNS Gateway [Mary_Holstage] [Mary_Holstage]
sns-agent 5417 tcp SNS Agent [Mary_Holstage] [Mary_Holstage]
sns-agent 5417 udp SNS Agent [Mary_Holstage] [Mary_Holstage]
dj-ice 5419 tcp DJ-ICE [Don_Tyson_2] [Don_Tyson_2]
dj-ice 5419 udp DJ-ICE [Don_Tyson_2] [Don_Tyson_2]
cylink-c 5420 tcp Cylink-C [John_Jobe] [John_Jobe]
cylink-c 5420 udp Cylink-C [John_Jobe] [John_Jobe]
salient-mux 5422 tcp Salient MUX [Richard_Farnham] [Richard_Farnham]
salient-mux 5422 udp Salient MUX [Richard_Farnham] [Richard_Farnham]
beyond-remote 5424 tcp Beyond Remote [Michael_Berg] [Michael_Berg] 2004-11
beyond-remote 5424 udp Beyond Remote [Michael_Berg] [Michael_Berg] 2004-11
br-channel 5425 tcp Beyond Remote Command Channel [Michael_Berg] [Michael_Berg] 2005-08
br-channel 5425 udp Beyond Remote Command Channel [Michael_Berg] [Michael_Berg] 2005-08
sco-peer-tta 5427 tcp SCO-PEER-TTA [Andrew_Shire] [Andrew_Shire]
sco-peer-tta 5427 udp SCO-PEER-TTA [Andrew_Shire] [Andrew_Shire]
radec-corp 5430 tcp RADEC CORP [David_Chell] [David_Chell]
radec-corp 5430 udp RADEC CORP [David_Chell] [David_Chell]
park-agent 5431 tcp PARK AGENT [John_Clifford] [John_Clifford]
park-agent 5431 udp PARK AGENT [John_Clifford] [John_Clifford]
sgi-arrayd 5434 tcp SGI Array Services Daemon [Karl_Feind] [Karl_Feind] 2005-10
sgi-arrayd 5434 udp SGI Array Services Daemon [Karl_Feind] [Karl_Feind] 2005-10
pmip6-cntl 5436 udp pmip6-cntl [RFC 5844]
pmip6-data 5437 udp pmip6-data [RFC 5844]
5438-5442 Unassigned
5446-5449 Unassigned
tiepie-disc 5450 udp TiePie engineering data acquisition (discovery) [TiePie_engineering] [Reinder_Feenstra] 2016-04-01
5451-5452 Unassigned
apc-5454 5454 tcp APC 5454 [American_Power_Conve] [American_Power_Conve]
apc-5454 5454 udp APC 5454 [American_Power_Conve] [American_Power_Conve]
apc-5455 5455 tcp APC 5455 [American_Power_Conve] [American_Power_Conve]
apc-5455 5455 udp APC 5455 [American_Power_Conve] [American_Power_Conve]
apc-5456 5456 tcp APC 5456 [American_Power_Conve] [American_Power_Conve]
apc-5456 5456 udp APC 5456 [American_Power_Conve] [American_Power_Conve]
5457-5460 Unassigned
ttl-publisher 5462 tcp TTL Publisher [Peter_Jacobs] [Peter_Jacobs]
ttl-publisher 5462 udp TTL Publisher [Peter_Jacobs] [Peter_Jacobs]

Contact Information

ID Name Organization Contact URI Last Updated
[American_Power_Conve] American Power Conversion mailto:ports&apcc.com 2002-02
[Andrew_Shire] Andrew Shire mailto:sndrewsh&sco.com
[Barrie_Cooper] Barrie Cooper mailto:barrie&sco.com
[Bert_Paul] Bert Paul mailto:bert.paul&apertio.com 2008-07-03
[Chris_Hawk] Chris Hawk mailto:chris&corriente.net 2005-08
[Dan_Polivy] Dan Polivy mailto:dpolivy&microsoft.com 2008-03-12
[David_Chell] David Chell mailto:david&softlife.co.nz
[Don_Tyson_2] Don Tyson mailto:don.tyson&cor.dowjones.com
[Edward_Yim] Edward Yim mailto:eyim&hpmfas4.cup.hp.com
[Eric_Soderberg_2] Eric Soderberg mailto:seric&hposl102.cup.hp
[Gary_Howland] Gary Howland mailto:gary&systemics.com
[Gopikrishna_Sandra] Gopikrishna Sandra mailto:v-gosand&microsoft.com 2005-02
[Harold_Froehling] Harold Froehling mailto:hrf&cup.hp.com
[Henry_Rawas] Henry Rawas mailto:henryr&microsoft.com 2005-08
[Hoa_Nguyen] Hoa Nguyen mailto:hoan&cup.hp.com
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Jeffrey_Chiao] Jeffrey Chiao mailto:chiaoj&netsoft.com
[Jered_Floyd] Jered Floyd mailto:jered&permabit.com 2004-06
[John_Clifford] John Clifford mailto:John.Clifford&veritas.com
[John_Jobe] John Jobe mailto:jjobe&cylink.com
[Jorge_Aldana] Jorge Aldana mailto:operator&foresyte.com
[Karl_Feind] Karl Feind mailto:kaf&sgi.com 2005-10
[Laurent_Domenech] Laurent Domenech Opalis mailto:ldomenech&opalis.com
[Marc_McClure] Marc McClure mailto:marcmcc&microsoft.com 2007-08-07
[Mary_Holstage] Mary Holstage mailto:holstege&firstfloor.com
[Michael_Berg] Michael Berg mailto:mike&dataapples.com 2005-08
[Michael_DeMoney] Michael DeMoney mailto:demoney&eng.sun.com
[Peter_Jacobs] Peter Jacobs mailto:pjacobs&tullib.com
[Reinder_Feenstra] Reinder Feenstra mailto:r.feenstra&tiepie.nl 2016-04-01
[Richard_Farnham] Richard Farnham mailto:rfarnham&salient.com
[Rob_Williams] Rob Williams mailto:rob.williams&microsoft.com 2009-02-17
[Stuart_Cheshire] Stuart Cheshire mailto:cheshire&apple.com 2022-07-11
[Ted_Hoshi] Ted Hoshi mailto:tetsuo.hoshi&jp.yokogawa.com 2004-06
[TiePie_engineering] TiePie engineering mailto:tiepie&tiepie.nl 2016-04-01