Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| silkmeter | 5461 | tcp | SILKMETER | Klaus Fellner | Klaus Fellner | ||||||
| silkmeter | 5461 | udp | SILKMETER | Klaus Fellner | Klaus Fellner | ||||||
| apsolab-cols | 5471 | tcp | The Apsolab company's secure data collection protocol (native api) | Apsolab Inc. | Jean-Francois Gauthier | 2014-11-10 | |||||
| 5471 | udp | Reserved | |||||||||
| fcp-addr-srvr1 | 5500 | tcp | fcp-addr-srvr1 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-addr-srvr1 | 5500 | udp | fcp-addr-srvr1 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-addr-srvr2 | 5501 | tcp | fcp-addr-srvr2 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-addr-srvr2 | 5501 | udp | fcp-addr-srvr2 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-srvr-inst1 | 5502 | tcp | fcp-srvr-inst1 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-srvr-inst1 | 5502 | udp | fcp-srvr-inst1 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-cics-gw1 | 5504 | tcp | fcp-cics-gw1 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-cics-gw1 | 5504 | udp | fcp-cics-gw1 | Ken Wittmer | Ken Wittmer | ||||||
| 5541-5542 | Unassigned | ||||||||||
| 5551-5552 | Unassigned | ||||||||||
| rdmnet-ctrl | 5569 | tcp | PLASA E1.33, Remote Device Management (RDM) controller status notifications | PLASA | Simon Newton | 2012-06-01 | |||||
| rdmnet-device | 5569 | udp | PLASA E1.33, Remote Device Management (RDM) messages | PLASA | Simon Newton | 2012-06-01 | |||||
| tmosms1 | 5581 | tcp | T-Mobile SMS Protocol Message 1 | Ezinne Oji | Ezinne Oji | 2006-06 | |||||
| tmosms1 | 5581 | udp | T-Mobile SMS Protocol Message 1 | Ezinne Oji | Ezinne Oji | 2006-06 | |||||
| esmagent | 5601 | tcp | Enterprise Security Agent | Kimberly Gibbs | Kimberly Gibbs | ||||||
| esmagent | 5601 | udp | Enterprise Security Agent | Kimberly Gibbs | Kimberly Gibbs | ||||||
| a1-msc | 5602 | tcp | A1-MSC | Mike Dolan | Mike Dolan | ||||||
| a1-msc | 5602 | udp | A1-MSC | Mike Dolan | Mike Dolan | ||||||
| a1-bs | 5603 | tcp | A1-BS | Mike Dolan | Mike Dolan | ||||||
| a1-bs | 5603 | udp | A1-BS | Mike Dolan | Mike Dolan | ||||||
| 5606-5617 | Unassigned | ||||||||||
| efr | 5618 | tcp | Fiscal Registering Protocol | efsta IT Services GmbH | Ernst Bewersdorff | 2013-08-13 | 2022-02-02 | ||||
| 5618 | udp | Reserved | |||||||||
| 5619-5626 | Unassigned | ||||||||||
| pcanywheredata | 5631 | tcp | pcANYWHEREdata | Jon Rosarky | Jon Rosarky | ||||||
| pcanywheredata | 5631 | udp | pcANYWHEREdata | Jon Rosarky | Jon Rosarky | ||||||
| amqps | 5671 | tcp | amqp protocol over TLS/SSL | Ted Ross | Ted Ross | 2008-03-26 | |||||
| amqps | 5671 | udp | amqp protocol over TLS/SSL | Ted Ross | Ted Ross | 2008-03-26 | |||||
| ncxcp | 5681 | tcp | Net-coneX Control Protocol | Ryan Werber | Ryan Werber | 2006-06 | |||||
| ncxcp | 5681 | udp | Net-coneX Control Protocol | Ryan Werber | Ryan Werber | 2006-06 | |||||
| coaps | 5684 | tcp | Constrained Application Protocol (CoAP) | IESG | IETF Chair | 2017-12-22 | RFC 7301; RFC 8323 | ||||
| 5701-5704 | Unassigned | ||||||||||
| 5706-5712 | Unassigned | ||||||||||
| proshareaudio | 5713 | tcp | proshare conf audio | gunner | gunner | ||||||
| proshareaudio | 5713 | udp | proshare conf audio | gunner | gunner | ||||||
| prosharevideo | 5714 | tcp | proshare conf video | gunner | gunner | ||||||
| prosharevideo | 5714 | udp | proshare conf video | gunner | gunner | ||||||
| prosharedata | 5715 | tcp | proshare conf data | gunner | gunner | ||||||
| prosharedata | 5715 | udp | proshare conf data | gunner | gunner | ||||||
| prosharerequest | 5716 | tcp | proshare conf request | gunner | gunner | ||||||
| prosharerequest | 5716 | udp | proshare conf request | gunner | gunner | ||||||
| prosharenotify | 5717 | tcp | proshare conf notify | gunner | gunner | ||||||
| prosharenotify | 5717 | udp | proshare conf notify | ||||||||
| dpm | 5718 | tcp | DPM Communication Server | Sundar Srinivasan; Vinay Badami | Sundar Srinivasan; Vinay Badami | ||||||
| dpm | 5718 | udp | DPM Communication Server | Sundar Srinivasan; Vinay Badami | Sundar Srinivasan; Vinay Badami | ||||||
| dpm-agent | 5719 | tcp | DPM Agent Coordinator | Sundar Srinivasan; Vinay Badami | Sundar Srinivasan; Vinay Badami | 2006-05 | |||||
| dpm-agent | 5719 | udp | DPM Agent Coordinator | Sundar Srinivasan; Vinay Badami | Sundar Srinivasan; Vinay Badami | 2006-05 | |||||
| dtpt | 5721 | tcp | Desktop Passthru Service | Dan Leising | Dan Leising | 2005-01 | |||||
| dtpt | 5721 | udp | Desktop Passthru Service | Dan Leising | Dan Leising | 2005-01 | |||||
| 5731-5740 | Unassigned | ||||||||||
| ida-discover1 | 5741 | tcp | IDA Discover Port 1 | MPITech Support | MPITech Support | ||||||
| ida-discover1 | 5741 | udp | IDA Discover Port 1 | MPITech Support | MPITech Support | ||||||
| 5751-5754 | Unassigned | ||||||||||
| netagent | 5771 | tcp | NetAgent | Bradley Birnbaum | Bradley Birnbaum | ||||||
| netagent | 5771 | udp | NetAgent | Bradley Birnbaum | Bradley Birnbaum | ||||||
| 3par-evts | 5781 | tcp | 3PAR Event Reporting Service | Sushil Thomas | Sushil Thomas | 2008-03-10 | |||||
| 3par-evts | 5781 | udp | 3PAR Event Reporting Service | Sushil Thomas | Sushil Thomas | 2008-03-10 | |||||
| 5799-5812 | Unassigned | ||||||||||
| icmpd | 5813 | tcp | ICMPD | Shane O'Donnell | Shane O'Donnell | ||||||
| icmpd | 5813 | udp | ICMPD | Shane O'Donnell | Shane O'Donnell | ||||||
| spt-automation | 5814 | tcp | Support Automation | Joshua Hawkins | Joshua Hawkins | 2003-11 | |||||
| spt-automation | 5814 | udp | Support Automation | Joshua Hawkins | Joshua Hawkins | 2003-11 | |||||
| 5815-5819 | Unassigned | ||||||||||
| 5821-5840 | Unassigned | ||||||||||
| shiprush-d-ch | 5841 | tcp | Z-firm ShipRush interface for web access and bidirectional data | Z-Firm LLC | Rafael Zimberoff | 2014-08-22 | |||||
| 5841 | udp | Reserved | |||||||||
| rfb | 5900 | tcp | Remote Framebuffer | Tristan Richardson | Tristan Richardson | 2006-03 | RFC 6143 | ||||
| rfb | 5900 | udp | Remote Framebuffer | Tristan Richardson | Tristan Richardson | 2006-03 | RFC 6143 | ||||
| 5901-5902 | Unassigned | ||||||||||
| ats-atn | 5910 | tcp | Air Traffic Services applications using ATN | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ats-atn | 5910 | udp | Air Traffic Services applications using ATN | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| cm | 5910 | sctp | Context Management | Justin Yu | Justin Yu | 2011-05-19 | |||||
| ats-acars | 5911 | tcp | Air Traffic Services applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ats-acars | 5911 | udp | Air Traffic Services applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| cpdlc | 5911 | sctp | Controller Pilot Data Link Communication | Justin Yu | Justin Yu | 2011-05-18 | |||||
| ais-met | 5912 | tcp | Aeronautical Information Service/Meteorological applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ais-met | 5912 | udp | Aeronautical Information Service/Meteorological applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| fis | 5912 | sctp | Flight Information Services | Justin Yu | Justin Yu | 2011-05-25 | |||||
| aoc-acars | 5913 | tcp | Airline operational communications applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| aoc-acars | 5913 | udp | Airline operational communications applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ads-c | 5913 | sctp | Automatic Dependent Surveillance | Justin Yu | Justin Yu | 2011-05-25 | |||||
| ipsdtls | 5914 | tcp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| ipsdtls | 5914 | udp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| ipsdtls | 5914 | sctp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| 5915-5962 | Unassigned | ||||||||||
| nuxsl | 5991 | tcp | NUXSL | Kai Kretschmann | Kai Kretschmann | 2002-03 | |||||
| nuxsl | 5991 | udp | NUXSL | Kai Kretschmann | Kai Kretschmann | 2002-03 | |||||
| x11 | 6000-6063 | tcp | X Window System | Stephen Gildea | Stephen Gildea | Known Unauthorized Use on port 6003 | |||||
| x11 | 6000-6063 | udp | X Window System | Stephen Gildea | Stephen Gildea | Known Unauthorized Use on port 6003 | |||||
| ssdtp | 6071 | tcp | SSDTP | Michael Shearson | Michael Shearson | ||||||
| ssdtp | 6071 | udp | SSDTP | Michael Shearson | Michael Shearson | ||||||
| geneve | 6081 | udp | Generic Network Virtualization Encapsulation (Geneve) | IESG | IETF Chair | 2014-03-27 | 2020-05-04 | RFC 8926 | |||
| 6081 | tcp | Reserved | |||||||||
| synchronet-db | 6100 | tcp | SynchroNet-db | Arne Haugland | Arne Haugland | Known Unauthorized Use on port 6100 | |||||
| synchronet-db | 6100 | udp | SynchroNet-db | Arne Haugland | Arne Haugland | Known Unauthorized Use on port 6100 | |||||
| synchronet-rtc | 6101 | tcp | SynchroNet-rtc | Arne Haugland | Arne Haugland | ||||||
| synchronet-rtc | 6101 | udp | SynchroNet-rtc | Arne Haugland | Arne Haugland |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Apsolab Inc. | admin&apsolab.com | 2014-11-10 | |
| Arne Haugland | Arne.Haugland¶soldev.com | ||
| Bradley Birnbaum | bradley.birnbaum&eshare.com | ||
| Dan Leising | dleisingµsoft.com | 2005-01 | |
| efsta IT Services GmbH | admin&efsta.eu | 2022-02-02 | |
| Eivan Cerasi | eivan.cerasi&eurocontrol.int | 2022-08-08 | |
| Ernst Bewersdorff | efsta IT Services GmbH | e.bewersdorff&efsta.eu | 2022-02-02 |
| Ezinne Oji | ezinne.oji&t-mobile.com | 2006-06 | |
| Greg Saccone | gregory.t.saccone&boeing.com | 2022-08-08 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| International Civil Aviation Organisation (ICAO) | gisinbox&icao.int | 2024-11-19 | |
| Jean-Francois Gauthier | Apsolab Inc. | jfgauthier&apsolab.com | 2014-11-10 |
| Jon Rosarky | JRosarky&symantec.com | ||
| Joshua Hawkins | joshua.hawkins&hp.com | 2003-11 | |
| Justin Yu | yyu&mitre.org | 2011-05-25 | |
| Kai Kretschmann | K.Kretschmann&security-gui.de | 2002-03 | |
| Ken Wittmer | kenneth.m.wittmer&accenture.com | ||
| Kimberly Gibbs | kimgib&ccgate-ut.axent.com | ||
| Klaus Fellner | webmaster&segue.com
kfellner&segue.com |
||
| MPITech Support | morten.christensen&i-data.com | ||
| Michael Shearson | mikes&softsys-inc.com | ||
| Mike Dolan | MDolan&ihcmail.ih.lucent.com | ||
| Nathan Lackey | nathan.lackey&boeing.com | 2024-11-19 | |
| PLASA | standards.na&plasa.org | 2012-06-01 | |
| Rafael Zimberoff | rafael&zfirmllc.com | 2003-11 | |
| Ryan Werber | ryan&ncxti.com | 2006-06 | |
| Shane O'Donnell | shane&opennms.org | ||
| Simon Newton | simon&nomis52.net | 2012-06-01 | |
| Stephen Gildea | gildea&lcs.mit.edu | ||
| Sundar Srinivasan | sundarsµsoft.com | 2006-05 | |
| Sushil Thomas | iana-comm&3par.com | 2008-03-10 | |
| Ted Ross | tross&redhat.com | 2008-03-26 | |
| Tristan Richardson | iana&realvnc.com | 2006-03 | |
| Vinay Badami | VinayBµsoft.com | 2006-05 | |
| Z-Firm LLC | rafael&zfirmllc.com | 2014-08-22 | |
| gunner&ibeam.intel.com |