Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| rt-classmanager | 35004 | tcp | ReadyTech ClassManager | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-classmanager | 35004 | udp | ReadyTech ClassManager | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-labtracker | 35005 | tcp | ReadyTech LabTracker | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35005 | udp | Reserved | |||||||||
| rt-helper | 35006 | tcp | ReadyTech Helper Service | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35006 | udp | Reserved | |||||||||
| 35007-35099 | Unassigned | ||||||||||
| axio-disc | 35100 | tcp | Axiomatic discovery protocol | Axiomatic Technologies Corporation | Oleksandr_Bogush | 2016-12-09 | |||||
| axio-disc | 35100 | udp | Axiomatic discovery protocol | Axiomatic Technologies Corporation | Oleksandr_Bogush | 2016-12-09 | |||||
| 35101-35353 | Unassigned | ||||||||||
| kitim | 35354 | tcp | KIT Messenger | Rudi Visser | Rudi Visser | 2011-07-07 | |||||
| 35354 | udp | Reserved | |||||||||
| altova-lm | 35355 | tcp | Altova License Management | Alexander Falk | Alexander Falk | 2011-07-07 | |||||
| altova-lm-disc | 35355 | udp | Altova License Management Discovery | Alexander Falk | Alexander Falk | 2011-07-07 | |||||
| guttersnex | 35356 | tcp | Gutters Note Exchange | Squee! Application Development | Tristan Seifert | 2011-07-19 | |||||
| 35356 | udp | Reserved | |||||||||
| openstack-id | 35357 | tcp | OpenStack ID Service | Rackspace Hosting | Ziad Sawalha | 2011-08-15 | |||||
| 35357 | udp | Reserved | |||||||||
| 35358-36000 | Unassigned | ||||||||||
| 36425-36442 | Unassigned | ||||||||||
| 36445-36461 | Unassigned | ||||||||||
| 36463-36523 | Unassigned | ||||||||||
| febooti-aw | 36524 | tcp | Febooti Automation Workshop | Maris Bormanis | Maris Bormanis | 2011-06-10 | |||||
| 36524 | udp | Reserved | |||||||||
| 36525-36601 | Unassigned | ||||||||||
| kastenxpipe | 36865 | tcp | KastenX Pipe | Guy Cheng | Guy Cheng | ||||||
| kastenxpipe | 36865 | udp | KastenX Pipe | Guy Cheng | Guy Cheng | ||||||
| neckar | 37475 | tcp | science + computing's Venus Administration Port | Ralf Allrutz | Ralf Allrutz | 2002-02 | |||||
| neckar | 37475 | udp | science + computing's Venus Administration Port | Ralf Allrutz | Ralf Allrutz | 2002-02 | |||||
| 37602-37653 | Unassigned | ||||||||||
| unisys-eportal | 37654 | tcp | Unisys ClearPath ePortal | Sung U. Ro | Sung U. Ro | 2006-01 | |||||
| unisys-eportal | 37654 | udp | Unisys ClearPath ePortal | Sung U. Ro | Sung U. Ro | 2006-01 | |||||
| 37655-37999 | Unassigned | ||||||||||
| secrmmsafecopya | 38865 | tcp | Security approval process for use of the secRMM SafeCopy program | Squadra Technologies | Anthony LaMark | 2012-03-14 | |||||
| 38865 | udp | Reserved | |||||||||
| 40405-40840 | Unassigned | ||||||||||
| 40844-40852 | Unassigned | ||||||||||
| 40853 | tcp | Reserved | |||||||||
| ortec-disc | 40853 | udp | ORTEC Service Discovery | Jesse Ursery | Jesse Ursery | 2010-11-22 | |||||
| 40854-41110 | Unassigned | ||||||||||
| crestron-ctp | 41795 | tcp | Crestron Terminal Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| crestron-ctp | 41795 | udp | Crestron Terminal Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| 41798-42507 | Unassigned | Unauthorized Use Known on port 42000 | |||||||||
| candp | 42508 | tcp | Computer Associates network discovery protocol | Jon Press | Jon Press | 2005-09 | |||||
| candp | 42508 | udp | Computer Associates network discovery protocol | Jon Press | Jon Press | 2005-09 | |||||
| candrp | 42509 | tcp | CA discovery response | Jon Press | Jon Press | 2005-08 | |||||
| candrp | 42509 | udp | CA discovery response | Jon Press | Jon Press | 2005-08 | |||||
| caerpc | 42510 | tcp | CA eTrust RPC | Jon Press | Jon Press | 2005-08 | |||||
| caerpc | 42510 | udp | CA eTrust RPC | Jon Press | Jon Press | 2005-08 | |||||
| 42511-42998 | Unassigned | ||||||||||
| 44323 | udp | Unassigned | "pcp" assignment withdrawn, moved to port 5351 per RFC 6887 | ||||||||
| acronis-backup | 44445 | tcp | Acronis Backup Gateway service port | Acronis | Kevin Reed | 2019-11-25 | |||||
| 44445 | udp | Reserved | |||||||||
| 44446-44543 | Unassigned | Known UNAUTHORIZED USE: Ports 44515 & 44516 | |||||||||
| 44544 | tcp | Reserved | |||||||||
| domiq | 44544 | udp | DOMIQ Building Automation | DOMIQ Sp. z o.o. | Filip Zawadiak | 2011-08-29 | |||||
| 44545-44552 | Unassigned | ||||||||||
| rbr-debug | 44553 | tcp | REALbasic Remote Debug | Aaron Ballman | Aaron Ballman | 2004-11 | |||||
| rbr-debug | 44553 | udp | REALbasic Remote Debug | Aaron Ballman | Aaron Ballman | 2004-11 | |||||
| 44554-44599 | Unassigned | ||||||||||
| asmp | 45000 | tcp | Nuance AutoStore Status Monitoring Protocol (data transfer) | Nuance Communications, Inc. | Andrew Andrews | 2011-09-01 | 2017-04-26 | ||||
| asmp-mon | 45000 | udp | Nuance AutoStore Status Monitoring Protocol (device monitoring) | Nuance Communications, Inc. | Andrew Andrews | 2011-09-01 | 2017-04-26 | ||||
| asmps | 45001 | tcp | Nuance AutoStore Status Monitoring Protocol (secure data transfer) | Nuance Communications, Inc. | Andrew Andrews | 2011-09-01 | 2017-04-26 | ||||
| 45001 | udp | Reserved | |||||||||
| rs-status | 45002 | tcp | Redspeed Status Monitor | Redspeed International Ltd | Simon Griffiths | 2015-03-10 | |||||
| 45002 | udp | Reserved | |||||||||
| 45003-45044 | Unassigned | ||||||||||
| synctest | 45045 | tcp | Remote application control protocol | Eleks, Ltd. | Andriy Skop | 2013-04-08 | |||||
| 45045 | udp | Reserved | |||||||||
| 45046-45053 | Unassigned | ||||||||||
| invision-ag | 45054 | tcp | InVision AG | Matthias Schroer | Matthias Schroer | ||||||
| invision-ag | 45054 | udp | InVision AG | Matthias Schroer | Matthias Schroer | ||||||
| 45055-45184 | Unassigned | ||||||||||
| witsnet | 45185 | tcp | Wire and Wireless transfer on synchroniz | Shenzhen Inovance Technology Co., Ltd | Yan Yi | 2025-03-11 | |||||
| witsnet | 45185 | udp | Wire and Wireless transfer on synchroniz | Shenzhen Inovance Technology Co., Ltd | Yan Yi | 2025-03-11 | |||||
| 45186-45513 | Unassigned | ||||||||||
| cloudcheck | 45514 | tcp | ASSIA CloudCheck WiFi Management System | ASSIA Inc. | Leonardo Dagum | 2016-08-29 | |||||
| cloudcheck-ping | 45514 | udp | ASSIA CloudCheck WiFi Management keepalive | ASSIA Inc. | Leonardo Dagum | 2016-08-29 | |||||
| 45515-45677 | Unassigned | ||||||||||
| eba | 45678 | tcp | EBA PRISE | Patrick Kara | Patrick Kara | ||||||
| eba | 45678 | udp | EBA PRISE | Patrick Kara | Patrick Kara | ||||||
| 45679-45823 | Unassigned | ||||||||||
| dai-shell | 45824 | tcp | Server for the DAI family of client-server products | Data Access, Inc. | Adam Robinson | 2012-04-30 | |||||
| 45824 | udp | Reserved | |||||||||
| qdb2service | 45825 | tcp | Qpuncture Data Access Service | Michael Yun | Michael Yun | 2007-10-24 | |||||
| qdb2service | 45825 | udp | Qpuncture Data Access Service | Michael Yun | Michael Yun | 2007-10-24 | |||||
| 45826-45965 | Unassigned | ||||||||||
| ssr-servermgr | 45966 | tcp | SSRServerMgr | Jeremy Gilliat | Jeremy Gilliat | ||||||
| ssr-servermgr | 45966 | udp | SSRServerMgr | Jeremy Gilliat | Jeremy Gilliat | ||||||
| 45967-46335 | Unassigned | ||||||||||
| 47101-47556 | Unassigned | ||||||||||
| dbbrowse | 47557 | tcp | Databeam Corporation | Cindy Martin | Cindy Martin | ||||||
| dbbrowse | 47557 | udp | Databeam Corporation | Cindy Martin | Cindy Martin | ||||||
| 47558-47623 | Unassigned | ||||||||||
| 47625-47805 | Unassigned | ||||||||||
| nimbusdbctrl | 48005 | tcp | NimbusDB Control | Stephen Harrison | Stephen Harrison | 2011-01-24 | |||||
| 48005 | udp | Reserved | |||||||||
| weandsf | 48050 | tcp | WeFi Access Network Discovery and Selection Function | WeFi, Inc. | Eran Naveh | 2013-07-19 | |||||
| 48050 | udp | Reserved | |||||||||
| 48051-48127 | Unassigned | ||||||||||
| blp5 | 48129 | tcp | Bloomberg locator | Albert Hou | Albert Hou | 2006-05 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Aaron Ballman | aaron&realsoftware.com | 2004-11 | |
| Acronis | kr&acronis.com | 2019-11-25 | |
| Adam Robinson | Data Access, Inc. | adam&dataaccessinc.com | 2012-04-30 |
| Albert Hou | ahou1&bloomberg.com | 2006-05 | |
| Alexander Falk | Altova, Inc. | al&altova.com | 2011-07-07 |
| Andrew Andrews | Andrew.Andrews&Nuance.com | 2017-04-26 | |
| Andriy Skop | Eleks, Ltd. | andriy.skop&eleks.com | 2013-04-08 |
| Anthony LaMark | Squadra Technologies | anthony&squadratechnologies.com | 2012-03-14 |
| ASSIA Inc. | info&assia-inc.com | 2016-08-29 | |
| Axiomatic Technologies Corporation | obogush&axiomatic.com | 2016-12-09 | |
| Cindy Martin | cmartin&databeam.com | ||
| Crestron Electronics, Inc. | jpavlik&crestron.com | 2019-10-17 | |
| Data Access, Inc. | development&dataaccessinc.com | 2012-04-30 | |
| DOMIQ Sp. z o.o. | registries&domiq.pl | 2011-08-29 | |
| Eleks, Ltd. | eleksinfo&eleks.com | 2013-04-08 | |
| Eran Naveh | WeFi, Inc. | eranna&wefi.com | 2013-07-19 |
| Filip Zawadiak | DOMIQ Sp. z o.o. | fzawadiak&domiq.pl | 2011-08-29 |
| Guy Cheng | GCHE&kastenchase.com | ||
| Jeremy Gilliat | jeremy.gilliat&geac.com | ||
| Jesse Ursery | jesse.ursery&ametek.com | 2010-11-22 | |
| John Pavlik | jpavlik&crestron.com | 2019-10-17 | |
| Jon Press | IANA.Registions&ca.com | 2005-09 | |
| Kevin Reed | kr&acronis.com | 2019-11-25 | |
| Kevin Woodward | ReadyTech Corporation | kwoodward&readytech.com | 2013-09-13 |
| Leonardo Dagum | ldagum&assia-inc.com | 2016-08-29 | |
| Maris Bormanis | info&febooti.com | 2011-06-10 | |
| Matthias Schroer | matthias.schroer&invision.de | ||
| Michael Yun | cinnanda&gmail.com | 2007-10-24 | |
| Nuance Communications, Inc. | dev&nsius.com | 2017-04-26 | |
| Oleksandr_Bogush | obogush&axiomatic.com | 2016-12-09 | |
| Patrick Kara | Patrick&eba.net | ||
| Rackspace Hosting | ziad.sawalha&rackspace.com | 2011-08-15 | |
| Ralf Allrutz | R.Allrutz&science-computing.de | 2002-02 | |
| ReadyTech Corporation | kwoodward&readytech.com | 2013-09-13 | |
| Redspeed International Ltd | simon.griffiths&redspeed-int.com | 2015-03-10 | |
| Rudi Visser | rudi.visser&ljund.eu | 2011-07-07 | |
| Shenzhen Inovance Technology Co., Ltd | yanyi&inovance.com | 2025-03-11 | |
| Simon Griffiths | Redspeed International Ltd | simon.griffiths&redspeed-int.com | 2015-03-10 |
| Squadra Technologies | anthony&squadratechnologies.com | 2012-03-14 | |
| Squee! Application Development | tristan&squee.co | 2011-07-19 | |
| Stephen Harrison | sharrison&nimbusdb.com | 2011-01-24 | |
| Sung U. Ro | ePortalSupport&unisys.com | 2006-01 | |
| Tristan Seifert | Squee! Application Development | tristan&squee.co | 2011-07-19 |
| WeFi, Inc. | eranna&wefi.com | 2013-07-19 | |
| Yan Yi | yanyi&inovance.com | 2025-03-11 | |
| Ziad Sawalha | Rackspace Hosting | ziad.sawalha&rackspace.com | 2011-08-15 |