Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ttl-publisher 5462 udp TTL Publisher [Peter_Jacobs] [Peter_Jacobs]
netops-broker 5465 tcp NETOPS-BROKER [John_R_Deuel] [John_R_Deuel]
netops-broker 5465 udp NETOPS-BROKER [John_R_Deuel] [John_R_Deuel]
5466-5469 Unassigned
apsolab-col 5470 tcp The Apsolab company's data collection protocol (native api) [Apsolab_Inc] [Jean-Francois_Gauthier] 2014-11-10
apsolab-cols 5471 tcp The Apsolab company's secure data collection protocol (native api) [Apsolab_Inc] [Jean-Francois_Gauthier] 2014-11-10
apsolab-tag 5472 tcp The Apsolab company's dynamic tag protocol [Apsolab_Inc] [Jean-Francois_Gauthier] 2014-11-10
apsolab-tags 5473 tcp The Apsolab company's secure dynamic tag protocol [Apsolab_Inc] [Jean-Francois_Gauthier] 2014-11-10
apsolab-rpc 5474 udp The Apsolab company's status query protocol [Apsolab_Inc] [Jean-Francois_Gauthier] 2014-11-10
apsolab-data 5475 tcp The Apsolab company's data retrieval protocol [Apsolab_Inc] [Jean-Francois_Gauthier] 2014-11-10
5476-5499 Unassigned
fcp-addr-srvr1 5500 tcp fcp-addr-srvr1 [Ken_Wittmer] [Ken_Wittmer]
fcp-addr-srvr1 5500 udp fcp-addr-srvr1 [Ken_Wittmer] [Ken_Wittmer]
fcp-addr-srvr2 5501 tcp fcp-addr-srvr2 [Ken_Wittmer] [Ken_Wittmer]
fcp-addr-srvr2 5501 udp fcp-addr-srvr2 [Ken_Wittmer] [Ken_Wittmer]
fcp-srvr-inst1 5502 tcp fcp-srvr-inst1 [Ken_Wittmer] [Ken_Wittmer]
fcp-srvr-inst1 5502 udp fcp-srvr-inst1 [Ken_Wittmer] [Ken_Wittmer]
fcp-srvr-inst2 5503 tcp fcp-srvr-inst2 [Ken_Wittmer] [Ken_Wittmer]
fcp-srvr-inst2 5503 udp fcp-srvr-inst2 [Ken_Wittmer] [Ken_Wittmer]
fcp-cics-gw1 5504 tcp fcp-cics-gw1 [Ken_Wittmer] [Ken_Wittmer]
fcp-cics-gw1 5504 udp fcp-cics-gw1 [Ken_Wittmer] [Ken_Wittmer]
psl-management 5507 tcp PowerSysLab Electrical Management [PowerSysLab] [Lucas_Lorensi] 2015-07-20
5508-5539 Unassigned
5541-5542 Unassigned
qftest-lic-mcp 5543 tcp QF-Test License Server / QF-Test MCP Server [Quality_First_Software_GmbH] [Gregor_Schmid] 2024-01-05 2026-09-04
5544-5549 Unassigned
5551-5552 Unassigned
sgi-eventmond 5553 tcp SGI Eventmond Port [Andrei_Vilkotski] [Andrei_Vilkotski] 2003-06
sgi-eventmond 5553 udp SGI Eventmond Port [Andrei_Vilkotski] [Andrei_Vilkotski] 2003-06
sgi-esphttp 5554 tcp SGI ESP HTTP [Vladimir_Legalov] [Vladimir_Legalov]
sgi-esphttp 5554 udp SGI ESP HTTP [Vladimir_Legalov] [Vladimir_Legalov]
personal-agent 5555 tcp Personal Agent [Jackie_Wu] [Jackie_Wu] Known UNAUTHORIZED USEs on port 5555
personal-agent 5555 udp Personal Agent [Jackie_Wu] [Jackie_Wu] Known UNAUTHORIZED USEs on port 5555
5558-5564 Unassigned
dp-bura 5565 tcp Data Protector BURA [Micro_Focus] [Shishir_Misra] 2016-01-13 2019-10-04
westec-connect 5566 tcp Westec Connect [Jon_Bolen] [Jon_Bolen] 2009-03-18
dof-dps-mc-sec 5567 tcp DOF Protocol Stack Multicast/Secure Transport [OpenDOF] [Bryant_Eastham] 2004-11 2015-04-23
dof-dps-mc-sec 5567 udp DOF Protocol Stack Multicast/Secure Transport [OpenDOF] [Bryant_Eastham] 2004-11 2015-04-23
rdmnet-ctrl 5569 tcp PLASA E1.33, Remote Device Management (RDM) controller status notifications [PLASA] [Simon_Newton] 2012-06-01
rdmnet-device 5569 udp PLASA E1.33, Remote Device Management (RDM) messages [PLASA] [Simon_Newton] 2012-06-01
5570-5572 Unassigned Known UNAUTHORIZED USE on Port 5570
lsi-bobcat 5574 tcp SAS IO Forwarding [Mandar_Joshi] [Mandar_Joshi] 2009-02-09
ora-oap 5575 tcp Oracle Access Protocol [Peter_Povinec] [Peter_Povinec] 2010-04-13
5576-5578 Unassigned
tmosms0 5580 tcp T-Mobile SMS Protocol Message 0 [Ezinne_Oji] [Ezinne_Oji] 2006-06
tmosms0 5580 udp T-Mobile SMS Protocol Message 0 [Ezinne_Oji] [Ezinne_Oji] 2006-06
tmosms1 5581 tcp T-Mobile SMS Protocol Message 1 [Ezinne_Oji] [Ezinne_Oji] 2006-06
tmosms1 5581 udp T-Mobile SMS Protocol Message 1 [Ezinne_Oji] [Ezinne_Oji] 2006-06
fac-restore 5582 tcp T-Mobile SMS Protocol Message 3 [Jessica_Yan] [Jessica_Yan] 2008-02-19
fac-restore 5582 udp T-Mobile SMS Protocol Message 3 [Jessica_Yan] [Jessica_Yan] 2008-02-19
tmo-icon-sync 5583 tcp T-Mobile SMS Protocol Message 2 [Donghwan_Lim] [Donghwan_Lim] 2008-01-22
tmo-icon-sync 5583 udp T-Mobile SMS Protocol Message 2 [Donghwan_Lim] [Donghwan_Lim] 2008-01-22
bis-web 5584 tcp BeInSync-Web [Adi_Ruppin] [Adi_Ruppin] 2005-08
bis-web 5584 udp BeInSync-Web [Adi_Ruppin] [Adi_Ruppin] 2005-08
bis-sync 5585 tcp BeInSync-sync [Adi_Ruppin] [Adi_Ruppin] 2005-08
bis-sync 5585 udp BeInSync-sync [Adi_Ruppin] [Adi_Ruppin] 2005-08
att-mt-sms 5586 tcp Planning to send mobile terminated SMS to the specific port so that the SMS is not visible to the client [ATT] [Dhillesh_Sigilipelli] 2014-08-21
5587-5596 Unassigned
a1-msc 5602 tcp A1-MSC [Mike_Dolan] [Mike_Dolan]
a1-msc 5602 udp A1-MSC [Mike_Dolan] [Mike_Dolan]
a1-bs 5603 tcp A1-BS [Mike_Dolan] [Mike_Dolan]
a1-bs 5603 udp A1-BS [Mike_Dolan] [Mike_Dolan]
a3-sdunode 5604 tcp A3-SDUNode [Mike_Dolan] [Mike_Dolan]
a3-sdunode 5604 udp A3-SDUNode [Mike_Dolan] [Mike_Dolan]
a4-sdunode 5605 tcp A4-SDUNode [Mike_Dolan] [Mike_Dolan]
a4-sdunode 5605 udp A4-SDUNode [Mike_Dolan] [Mike_Dolan]
5606-5617 Unassigned
5619-5626 Unassigned
symantec-sfdb 5629 tcp Symantec Storage Foundation for Database [Quang_Thoi] [Quang_Thoi] 2006-11
symantec-sfdb 5629 udp Symantec Storage Foundation for Database [Quang_Thoi] [Quang_Thoi] 2006-11
precise-comm 5630 tcp PreciseCommunication [Alon_Tamir] [Alon_Tamir] 2006-04
precise-comm 5630 udp PreciseCommunication [Alon_Tamir] [Alon_Tamir] 2006-04
sfm-db-server 5636 tcp SFMdb - SFM DB server [De_Chih_Chien] [De_Chih_Chien] 2008-10-06
5640-5645 Unassigned
5647-5665 Unassigned
5667-5669 Unassigned
filemq 5670 tcp ZeroMQ file publish-subscribe protocol [Pieter_Hintjens2] [Pieter_Hintjens2] 2012-11-01 2013-02-25
zre-disc 5670 udp Local area discovery and messaging over ZeroMQ [Pieter_Hintjens_3] [Pieter_Hintjens_3] 2012-12-17
hyperscsi-port 5674 tcp HyperSCSI Port [Data_Storage_Institu] [Data_Storage_Institu] 2002-02
hyperscsi-port 5674 udp HyperSCSI Port [Data_Storage_Institu] [Data_Storage_Institu] 2002-02
questdb2-lnchr 5677 tcp Quest Central DB2 Launchr [Robert_M_Mackowiak] [Robert_M_Mackowiak] 2002-02
questdb2-lnchr 5677 udp Quest Central DB2 Launchr [Robert_M_Mackowiak] [Robert_M_Mackowiak] 2002-02
auriga-router 5680 tcp Auriga Router Service [Vincent_Gaudeul] [Vincent_Gaudeul] 2006-02
auriga-router 5680 udp Auriga Router Service [Vincent_Gaudeul] [Vincent_Gaudeul] 2006-02
ncxcp 5681 tcp Net-coneX Control Protocol [Ryan_Werber] [Ryan_Werber] 2006-06
ncxcp 5681 udp Net-coneX Control Protocol [Ryan_Werber] [Ryan_Werber] 2006-06
coaps 5684 udp DTLS-secured CoAP [IESG] [IETF_Chair] 2013-07-25 [RFC 7252]
5685-5686 Unassigned
gog-multiplayer 5687 udp GOG multiplayer game protocol [GOG.com] [Michal_Gruchala] 2014-07-31 2014-10-09
5690-5692 Unassigned
5694-5695 Unassigned
5697-5699 Unassigned
5701-5704 Unassigned
5706-5712 Unassigned
dpm-agent 5719 tcp DPM Agent Coordinator [Sundar_Srinivasan][Vinay_Badami] [Sundar_Srinivasan][Vinay_Badami] 2006-05
dpm-agent 5719 udp DPM Agent Coordinator [Sundar_Srinivasan][Vinay_Badami] [Sundar_Srinivasan][Vinay_Badami] 2006-05
ms-licensing 5720 tcp MS-Licensing [Thomas_Lindeman] [Thomas_Lindeman] 2002-11
ms-licensing 5720 udp MS-Licensing [Thomas_Lindeman] [Thomas_Lindeman] 2002-11
omhs 5723 tcp Operations Manager - Health Service [Gerardo_Dilillo] [Gerardo_Dilillo] 2006-08
omhs 5723 udp Operations Manager - Health Service [Gerardo_Dilillo] [Gerardo_Dilillo] 2006-08
omsdk 5724 tcp Operations Manager - SDK Service [Gerardo_Dilillo] [Gerardo_Dilillo] 2006-08

Contact Information

ID Name Organization Contact URI Last Updated
[Adi_Ruppin] Adi Ruppin mailto:adi.ruppin&data-pod.com 2005-08
[Alon_Tamir] Alon Tamir mailto:alon_tamir&symantec.com 2006-04
[Andrei_Vilkotski] Andrei Vilkotski mailto:andreiv&sgi.com 2003-06
[Apsolab_Inc] Apsolab Inc. mailto:admin&apsolab.com 2014-11-10
[ATT] AT&T mailto:ds978v&att.com 2014-08-21
[Bryant_Eastham] Bryant Eastham OenDOF mailto:protocol&opendof.org 2015-04-23
[Data_Storage_Institu] Data Storage Institute of Singapore mailto:Patrick&dsi.nus.edu.sg 2002-02
[De_Chih_Chien] De-Chih Chien mailto:de-chih_chien&symantec.com 2008-10-06
[Dhillesh_Sigilipelli] Dhillesh Sigilipelli AT&T mailto:ds978v&att.com 2014-08-21
[Donghwan_Lim] Donghwan Lim mailto:donghwan.lim&t-mobile.com 2008-01-22
[Ezinne_Oji] Ezinne Oji mailto:ezinne.oji&t-mobile.com 2006-06
[Gerardo_Dilillo] Gerardo Dilillo mailto:MOMIANA&microsoft.com 2006-08
[GOG.com] GOG.com mailto:admin&gog.com 2014-07-31
[Gregor_Schmid] Gregor Schmid mailto:gregor.schmid&qfs.de 2024-01-05
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Jackie_Wu] Jackie Wu mailto:jackiew&infoseek.com
[Jean-Francois_Gauthier] Jean-Francois Gauthier Apsolab Inc. mailto:jfgauthier&apsolab.com 2014-11-10
[Jessica_Yan] Jessica Yan mailto:jessica.yan2&t-mobile.com 2008-02-19
[John_R_Deuel] John R. Deuel mailto:kink&netops.com
[Jon_Bolen] Jon Bolen mailto:jon.bolen&westec.net 2009-03-18
[Ken_Wittmer] Ken Wittmer mailto:kenneth.m.wittmer&accenture.com
[Lucas_Lorensi] Lucas Lorensi mailto:lucas.lorensi&powersyslab.com 2015-07-20
[Mandar_Joshi] Mandar Joshi mailto:mandar.joshi&lsi.com 2009-02-09
[Michal_Gruchala] Michał Gruchała GOG.com mailto:admin&gog.com 2014-07-31
[Micro_Focus] Micro Focus mailto:swpdl.dp.rd&microfocus.com 2019-09-30
[Mike_Dolan] Mike Dolan mailto:MDolan&ihcmail.ih.lucent.com
[OpenDOF] OpenDOF mailto:protocol&opendof.org 2015-04-23
[Peter_Jacobs] Peter Jacobs mailto:pjacobs&tullib.com
[Peter_Povinec] Peter Povinec mailto:peter.povinec&oracle.com 2010-04-13
[Pieter_Hintjens2] Pieter Hintjens mailto:ph&imatix.com 2012-11-01
[Pieter_Hintjens_3] Pieter Hintjens mailto:ph&imatix.com 2012-12-17
[PLASA] PLASA mailto:standards.na&plasa.org 2012-06-01
[PowerSysLab] PowerSysLab mailto:info&powersyslab.com 2015-07-20
[Quality_First_Software_GmbH] Quality First Software GmbH mailto:qfs&qfs.de 2024-01-05
[Quang_Thoi] Quang Thoi mailto:quang_thoi&symantec.com 2006-11
[Robert_M_Mackowiak] Robert M. Mackowiak mailto:rmackowiak&quest.com 2002-02
[Ryan_Werber] Ryan Werber mailto:ryan&ncxti.com 2006-06
[Shishir_Misra] Shishir Misra mailto:shishir.misra&microfocus.com 2019-09-30
[Simon_Newton] Simon Newton mailto:simon&nomis52.net 2012-06-01
[Sundar_Srinivasan] Sundar Srinivasan mailto:sundars&microsoft.com 2006-05
[Thomas_Lindeman] Thomas Lindeman mailto:tlinde&microsoft.com 2002-11
[Vinay_Badami] Vinay Badami mailto:VinayB&microsoft.com 2006-05
[Vincent_Gaudeul] Vincent Gaudeul mailto:technique&auriga.fr 2006-02
[Vladimir_Legalov] Vladimir Legalov mailto:legalov&sgi.com