Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| blp5 | 48129 | tcp | Bloomberg locator | Albert Hou | Albert Hou | 2006-05 | |||||
| blp5 | 48129 | udp | Bloomberg locator | Albert Hou | Albert Hou | 2006-05 | |||||
| 48130-48555 | Unassigned | ||||||||||
| com-bardac-dw | 48556 | tcp | com-bardac-dw | Nicholas J Howes | Nicholas J Howes | ||||||
| com-bardac-dw | 48556 | udp | com-bardac-dw | Nicholas J Howes | Nicholas J Howes | ||||||
| 48557-48618 | Unassigned | ||||||||||
| 48620-48652 | Unassigned | ||||||||||
| robotraconteur | 48653 | tcp | Robot Raconteur transport | Wason Technology, LLC | John Wason | 2014-01-27 | |||||
| robotraconteur | 48653 | udp | Robot Raconteur transport | Wason Technology, LLC | John Wason | 2014-01-27 | |||||
| 48654-48999 | Unassigned | ||||||||||
| inspider | 49150 | tcp | InSpider System | AnRobot | Zhang Xinnan | 2017-11-06 | |||||
| 49150 | udp | Reserved | |||||||||
| 49151 | Reserved | 2024-12-20 | RFC 6335 | ||||||||
| ip-x25 | Internet Protocol on X.25 Networks | ||||||||||
| mihcs | MIH Command Services | RFC 5679 | |||||||||
| mihes | MIH Event Services | RFC 5679 | |||||||||
| mihis | MIH Information Services | RFC 5679 | |||||||||
| 7ksonar | tcp | Teledyne Marine 7k Sonar Protocol | Teledyne Marine | Anders Brandt | 2023-10-03 | Defined TXT keys: None | |||||
| 7ksonar | udp | Teledyne Marine 7k Sonar Protocol | Teledyne Marine | Anders Brandt | 2023-10-03 | Defined TXT keys: None | |||||
| accessone | Strix Systems 5S/AccessOne protocol | Scott Herscher | Scott Herscher | Defined TXT keys: None | |||||||
| boardplus | tcp | board plus application transfer protocol | CX5 SOFTWARE | Yohei Yoshihara | 2013-02-04 | Defined TXT keys: None | |||||
| brski-proxy | tcp | The Bootstrapping Remote Secure Key Infrastructure Proxy | IESG | IETF Chair | 2020-04-29 | RFC 8995 | Defined TXT keys: None | ||||
| brski-registrar | tcp | The Bootstrapping Remote Secure Key Infrastructure Registrar | IESG | IETF Chair | 2020-04-29 | RFC 8995 | Defined TXT keys: None | ||||
| carddav | tcp | vCard Extensions to WebDAV (CardDAV) - non-TLS | IESG | IETF Chair | 2012-02-17 | RFC 6352 | This is an extension of the http service. Defined TXT keys: path=<context path> | ||||
| carddavs | tcp | vCard Extensions to WebDAV (CardDAV) - over TLS | IESG | IETF Chair | 2012-02-17 | RFC 6352 | This is an extension of the https service. Defined TXT keys: path=<context path> | ||||
| certificates | tcp | Server for S/MIME and PGP certificates | IESG | John Levine | 2016-07-26 | draft-bhjl-x509-srv-01 | Defined TXT keys: None | ||||
| dccp-ping | dccp | ping/traceroute using DCCP | Samuel Jero | Samuel Jero | 2012-11-14 | 1885957735 | Defined TXT keys: None | ||||
| dns-push-tls | tcp | DNS Push Notification Service Type | IESG | IETF Chair | 2019-11-25 | RFC 8765, Section 6.1 | Defined TXT Keys: None | ||||
| dns-update | tcp | DNS Dynamic Update Service | Stuart Cheshire | Stuart Cheshire | 2019-05-04 | DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain. | |||||
| dns-update | udp | DNS Dynamic Update Service | Stuart Cheshire | Stuart Cheshire | 2019-05-04 | DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain. | |||||
| dns-update-tls | tcp | DNS Dynamic Update Service over TLS | Stuart Cheshire | Stuart Cheshire | 2019-05-04 | RFC 6281 | DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain. | ||||
| dnssd-srp | tcp | DNS-Based Service Discovery | IESG | IETF Chair | 2024-04-12 | 2024-09-05 | RFC 9665 | Defined TXT keys: None | |||
| dnssd-srp-tls | tcp | DNS-Based Service Discovery (TLS) | IESG | IETF Chair | 2024-04-12 | 2024-09-05 | RFC 9665 | Defined TXT keys: None | |||
| fix | Financial Information Exchange (FIX) Protocol | Joakim Johansson | Joakim Johansson | Defined TXT keys: Currently valid enumerated values: FIX Session Protocol Versions (SESSIONVERSION): 1.1 FIX Application Protocol Versions (APPLICATIONVERSION): 2.7, 3.0, 4.0, 4.1, 4.2, 4.3, 4.4, 5.0 Possible TXT records defined and their values (replace uppercase text with enumerations from the list above): txtvers=1 fix=APPLICATIONVERSION fix supported=APPLICATIONVERSION[,APPLICATIONVERSION, ... ,APPLICATIONVERSION] fixt=SESSIONVERSION | |||||||
| jnx-kcsync | tcp | jollys keychain cloud sync protocol | Patrick Stein | Patrick Stein | 2011-10-24 | Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa | |||||
| lobby | Gobby | 0x539 dev group | 0x539 dev group | Defined TXT keys: None | |||||||
| lontalk | LonTalk over IP (ANSI 852) | Michael Tennefoss | Michael Tennefoss | Defined TXT keys: None | |||||||
| lumiere | tcp | A protocol to remotely control DMX512 devices over the network | Gangsta Ltd. | Jean-Charles Boude | 2011-10-13 | Defined TXT keys: None | |||||
| radiusdtls | udp | Authentication, Accounting, and Dynamic Authorization via the RADIUS protocol. This service name is used to construct the SRV service label "_radiusdtls" for discovery of RADIUS/DTLS servers. | IESG | IETF Chair | 2015-03-23 | 2015-10-06 | RFC 7585 | Defined TXT keys: None | |||
| radiustls | tcp | Authentication, Accounting, and Dynamic Authorization via the RADIUS protocol. This service name is used to construct the SRV service label "_radiustls" for discovery of RADIUS/TLS servers. | IESG | IETF Chair | 2015-03-23 | 2015-10-06 | RFC 7585 | Defined TXT keys: None | |||
| robustirc | tcp | Like ircu (RFC 1459), but failure tolerant due to strong consistency among n>=3 servers | Michael Stapelberg | Michael Stapelberg | 2015-01-07 | Defined TXT keys: None | |||||
| smartenergy | Smart Energy Profile | Robby Simpson, PhD | Robby Simpson, PhD | 2026-09-01 | Defined TXT keys: See IEEE Std 2030.5 | ||||||
| smimeca | tcp | Domain signing certificate for S/MIME keys | IESG | John Levine | 2016-07-26 | draft-bhjl-x509-srv-01 | Defined TXT keys: None | ||||
| snif-cln | tcp | SNIF End-to-End TLS Relay Client Connection | VESvault Corp | Jim Zubov | 2021-12-15 | 2026-07-22 | draft-zubov-snif-05, Section 4.5 | Defined TXT keys: None | |||
| snif-fifo | tcp | SNIF End-to-End TLS Relay Cluster | VESvault Corp | Jim Zubov | 2021-12-15 | 2026-07-22 | draft-zubov-snif-05, Section 4.6 | Defined TXT keys: None | |||
| snif-srv | tcp | SNIF End-to-End TLS Relay Service Connection | VESvault Corp | Jim Zubov | 2021-12-29 | 2026-07-22 | draft-zubov-snif-05, Section 4.3 | Defined TXT keys: None | |||
| sztp | tcp | This service name is used to construct the SRV service label "_sztp" for discovering SZTP bootstrap servers. | IESG | IETF Chair | 2019-01-17 | RFC 8572 | This protocol uses HTTPS as a substrate. | ||||
| tmsensor | tcp | Teledyne Marine Sensor | Teledyne Marine | Anders Brandt | 2023-10-03 | Defined TXT keys: None | |||||
| tmsensor | udp | Teledyne Marine Sensor | Teledyne Marine | Anders Brandt | 2023-10-03 | Defined TXT keys: None | |||||
| wdp | tcp | Windows Device Portal | Microsoft Corporation | Hirsch Singhal | 2016-03-03 | Defined TXT keys: D (device type), S (https port), A (architecture), T (tags) | |||||
| wot | tcp | W3C WoT Thing Description or Directory | W3C Web of Things Working Group | Kazuyuki Ashimura | 2022-11-22 | 2022-12-15 | Defined TXT keys: td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory. type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing. scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations RFC 7595: http (HTTP over TCP),https (HTTP over TLS/TCP), coap+tcp (CoAP over TCP), or coaps+tcp (CoAP over TLS/TCP). If omitted, the scheme is assumed to be http. |
||||
| wot | udp | W3C WoT Thing Description or Directory | W3C Web of Things Working Group | Kazuyuki Ashimura | 2022-11-22 | 2022-12-15 | Defined TXT keys: td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory. type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing. scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations RFC 7595: coap (CoAP over UDP), coaps CoAP over DTLS/UDP. If omitted, the scheme is assumed to be coap. |
||||
| x510 | tcp | Security service to protocols | ITU-T Study Group 17 | Erik Andersen | 2019-08-13 | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Albert Hou | ahou1&bloomberg.com | 2006-05 | |
| Anders Brandt | Teledyne Marine | Anders.Brandt&Teledyne.com | 2023-10-03 |
| AnRobot | webmaster&anrobot.org | 2017-11-06 | |
| CX5 SOFTWARE | contact&cx5software.com | 2013-02-04 | |
| Erik Andersen | era&x500.eu | 2019-08-13 | |
| Gangsta Ltd. | jc&gangstamedia.com | 2011-10-13 | |
| 0x539 dev group | http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi | ||
| Hirsch Singhal | Microsoft Corporation | hirsinµsoft.com | 2016-03-03 |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| ITU-T Study Group 17 | era&x500.eu | 2019-08-13 | |
| Jean-Charles Boude | Gangsta Ltd. | jc&gangstamedia.com | 2011-10-17 |
| Jim Zubov | VESvault Corp | jz&vesvault.com | 2021-12-29 |
| Joakim Johansson | joakim.johansson&tbricks.com | ||
| John Levine | standards&taugh.com | 2016-07-26 | |
| John Wason | Wason Technology, LLC | wason&wasontech.com | 2014-01-27 |
| Kazuyuki Ashimura | ashimura&w3.org | 2022-11-22 | |
| Michael Stapelberg | michael+iana&stapelberg.ch | 2015-01-07 | |
| Michael Tennefoss | mtennefoss&echelon.com | ||
| Microsoft Corporation | hirsinµsoft.com | 2016-03-03 | |
| Nicholas J Howes | nick&ghostwood.org | ||
| Patrick Stein | Patrick.Stein&jinx.eu | 2011-10-24 | |
| Robby Simpson, PhD | rsimpson&gmail.com | ||
| Samuel Jero | sj323707&ohio.edu | 2012-11-14 | |
| Scott Herscher | scott&strixsystems.com | ||
| Stuart Cheshire | cheshire&apple.com | 2022-07-11 | |
| Teledyne Marine | info&teledynemarine.com | 2023-10-03 | |
| VESvault Corp | info&vesvault.com | 2021-12-29 | |
| W3C Web of Things Working Group | team-wot&w3.org | 2022-11-22 | |
| Wason Technology, LLC | wason&wasontech.com | 2014-01-27 | |
| Yohei Yoshihara | CX5 SOFTWARE | yohei_yoshihara&cx5software.com | 2013-02-04 |
| Zhang Xinnan | 70331471&qq.com | 2017-11-06 |