Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
omsdk 5724 tcp Operations Manager - SDK Service [Gerardo_Dilillo] [Gerardo_Dilillo] 2006-08
omsdk 5724 udp Operations Manager - SDK Service [Gerardo_Dilillo] [Gerardo_Dilillo] 2006-08
ms-ilm 5725 tcp Microsoft Identity Lifecycle Manager [Rob_Ward] [Rob_Ward]
ms-ilm-sts 5726 tcp Microsoft Lifecycle Manager Secure Token Service [Rob_Ward] [Rob_Ward]
io-dist-data 5728 tcp Dist. I/O Comm. Service Data and Control [Harish_Kuttan] [Harish_Kuttan] 2010-03-22
io-dist-group 5728 udp Dist. I/O Comm. Service Group Membership [Harish_Kuttan] [Harish_Kuttan] 2010-03-22
5731-5740 Unassigned
ida-discover1 5741 tcp IDA Discover Port 1 [MPITech_Support] [MPITech_Support]
ida-discover1 5741 udp IDA Discover Port 1 [MPITech_Support] [MPITech_Support]
ida-discover2 5742 tcp IDA Discover Port 2 [MPITech_Support] [MPITech_Support]
ida-discover2 5742 udp IDA Discover Port 2 [MPITech_Support] [MPITech_Support]
watchdoc-pod 5743 tcp Watchdoc NetPOD Protocol [Christophe_Chevalier] [Christophe_Chevalier] 2005-08
watchdoc-pod 5743 udp Watchdoc NetPOD Protocol [Christophe_Chevalier] [Christophe_Chevalier] 2005-08
fcopy-server 5745 tcp fcopy-server [Moshe_Leibovitch] [Moshe_Leibovitch]
fcopy-server 5745 udp fcopy-server [Moshe_Leibovitch] [Moshe_Leibovitch]
fcopys-server 5746 tcp fcopys-server [Moshe_Leibovitch] [Moshe_Leibovitch]
fcopys-server 5746 udp fcopys-server [Moshe_Leibovitch] [Moshe_Leibovitch]
5751-5754 Unassigned
5758-5765 Unassigned
s-openmail 5767 tcp OpenMail Suer Agent Layer (Secure) [OpenMail_Encyclopedi][Don_Loughry] [OpenMail_Encyclopedi][Don_Loughry]
s-openmail 5767 udp OpenMail Suer Agent Layer (Secure) [OpenMail_Encyclopedi][Don_Loughry] [OpenMail_Encyclopedi][Don_Loughry]
5772-5776 Unassigned
starfield-io 5777 tcp Control commands and responses [Wayne_Morrow] [Wayne_Morrow] 2003-10 2021-02-18
starfield-io 5777 udp Control commands and responses [Wayne_Morrow] [Wayne_Morrow] 2003-10 2021-02-18
5778-5779 Unassigned
vts-rpc 5780 tcp Visual Tag System RPC [Graham_Bloice] [Graham_Bloice] 2009-09-17
3par-evts 5781 tcp 3PAR Event Reporting Service [Sushil_Thomas] [Sushil_Thomas] 2008-03-10
3par-evts 5781 udp 3PAR Event Reporting Service [Sushil_Thomas] [Sushil_Thomas] 2008-03-10
3par-mgmt 5782 tcp 3PAR Management Service [Don_Marselle] [Don_Marselle] 2008-04-09
3par-mgmt 5782 udp 3PAR Management Service [Don_Marselle] [Don_Marselle] 2008-04-09
3par-mgmt-ssl 5783 tcp 3PAR Management Service with SSL [Don_Marselle] [Don_Marselle] 2008-03-19
3par-mgmt-ssl 5783 udp 3PAR Management Service with SSL [Don_Marselle] [Don_Marselle] 2008-03-19
3par-rcopy 5785 tcp 3PAR Inform Remote Copy [Don_Marselle] [Don_Marselle] 2010-02-03
3par-rcopy 5785 udp 3PAR Inform Remote Copy [Don_Marselle] [Don_Marselle] 2008-04-09
cisco-redu 5786 udp redundancy notification [Ming_Zhang] [Ming_Zhang] 2010-02-04
5788-5792 Unassigned
5795-5797 Unassigned
enlabel-dpl 5798 tcp Proprietary Website deployment service [enLabel_Global_Services] [Clay_S_Didier] 2021-10-12
5799-5812 Unassigned
spt-automation 5814 tcp Support Automation [Joshua_Hawkins] [Joshua_Hawkins] 2003-11
spt-automation 5814 udp Support Automation [Joshua_Hawkins] [Joshua_Hawkins] 2003-11
5815-5819 Unassigned
5821-5840 Unassigned
shiprush-d-ch 5841 tcp Z-firm ShipRush interface for web access and bidirectional data [Z-Firm_LLC] [Rafael_Zimberoff] 2014-08-22
5843-5858 Unassigned
5860-5862 Unassigned
5864-5867 Unassigned
5869-5882 Unassigned
5884-5899 Unassigned
5901-5902 Unassigned
ff-ice 5903 tcp Flight & Flow Info for Collaborative Env [International_Civil_Aviation_Organisation] [Greg_Saccone] 2022-06-03 Defined TXT keys: FF-ICE
ff-ice 5903 udp Flight & Flow Info for Collaborative Env [International_Civil_Aviation_Organisation] [Greg_Saccone] 2022-06-03 Defined TXT keys: FF-ICE
ff-ice 5903 sctp Flight & Flow Info for Collaborative Env [International_Civil_Aviation_Organisation] [Greg_Saccone] 2022-06-03 Defined TXT keys: FF-ICE
ag-swim 5904 tcp Air-Ground SWIM [International_Civil_Aviation_Organisation] [Greg_Saccone] 2022-06-03 Defined TXT keys: AG-SWIM
ag-swim 5904 udp Air-Ground SWIM [International_Civil_Aviation_Organisation] [Greg_Saccone] 2022-06-03 Defined TXT keys: AG-SWIM
ag-swim 5904 sctp Air-Ground SWIM [International_Civil_Aviation_Organisation] [Greg_Saccone] 2022-06-03 Defined TXT keys: AG-SWIM
rpas-c2 5906 tcp Remotely Piloted Vehicle C&C [International_Civil_Aviation_Organisation] [Greg_Saccone] 2022-06-03 Defined TXT keys: RPAS-C2
rpas-c2 5906 udp Remotely Piloted Vehicle C&C [International_Civil_Aviation_Organisation] [Greg_Saccone] 2022-06-03 Defined TXT keys: RPAS-C2
rpas-c2 5906 sctp Remotely Piloted Vehicle C&C [International_Civil_Aviation_Organisation] [Greg_Saccone] 2022-06-03 Defined TXT keys: RPAS-C2
agma 5909 tcp Air-ground media advisory [International_Civil_Aviation_Organisation] [Greg_Saccone] 2022-06-03 Defined TXT keys: AGMA
agma 5909 udp Air-ground media advisory [International_Civil_Aviation_Organisation] [Greg_Saccone] 2022-06-03 Defined TXT keys: AGMA
agma 5909 sctp Air-ground media advisory [International_Civil_Aviation_Organisation] [Greg_Saccone] 2022-06-03 Defined TXT keys: AGMA
ats-atn 5910 tcp Air Traffic Services applications using ATN [Eivan_Cerasi] [Greg_Saccone] 2008-10-10 2022-08-08
ats-atn 5910 udp Air Traffic Services applications using ATN [Eivan_Cerasi] [Greg_Saccone] 2008-10-10 2022-08-08
ats-acars 5911 tcp Air Traffic Services applications using ACARS [Eivan_Cerasi] [Greg_Saccone] 2008-10-10 2022-08-08
ats-acars 5911 udp Air Traffic Services applications using ACARS [Eivan_Cerasi] [Greg_Saccone] 2008-10-10 2022-08-08
ais-met 5912 tcp Aeronautical Information Service/Meteorological applications using ACARS [Eivan_Cerasi] [Greg_Saccone] 2008-10-10 2022-08-08
ais-met 5912 udp Aeronautical Information Service/Meteorological applications using ACARS [Eivan_Cerasi] [Greg_Saccone] 2008-10-10 2022-08-08
aoc-acars 5913 tcp Airline operational communications applications using ACARS [Eivan_Cerasi] [Greg_Saccone] 2008-10-10 2022-08-08
aoc-acars 5913 udp Airline operational communications applications using ACARS [Eivan_Cerasi] [Greg_Saccone] 2008-10-10 2022-08-08
ads-c 5913 sctp Automatic Dependent Surveillance [Justin_Yu] [Justin_Yu] 2011-05-25
5915-5962 Unassigned
5964-5967 Unassigned
mppolicy-v5 5968 tcp mppolicy-v5 [Yutaka_Ono] [Yutaka_Ono]
mppolicy-v5 5968 udp mppolicy-v5 [Yutaka_Ono] [Yutaka_Ono]
mppolicy-mgr 5969 tcp mppolicy-mgr [Yutaka_Ono] [Yutaka_Ono]
mppolicy-mgr 5969 udp mppolicy-mgr [Yutaka_Ono] [Yutaka_Ono]
5970-5983 Unassigned
wsman 5985 tcp WBEM WS-Management HTTP [Jim_Davis] [Jim_Davis] 2006-11
wsman 5985 udp WBEM WS-Management HTTP [Jim_Davis] [Jim_Davis] 2006-11
wsmans 5986 tcp WBEM WS-Management HTTP over TLS/SSL [Jim_Davis] [Jim_Davis] 2006-11
wsmans 5986 udp WBEM WS-Management HTTP over TLS/SSL [Jim_Davis] [Jim_Davis] 2006-11
wbem-rmi 5987 tcp WBEM RMI [Jim_Davis] [Jim_Davis]
wbem-rmi 5987 udp WBEM RMI [Jim_Davis] [Jim_Davis]
wbem-http 5988 tcp WBEM CIM-XML (HTTP) [Jim_Davis] [Jim_Davis]
wbem-http 5988 udp WBEM CIM-XML (HTTP) [Jim_Davis] [Jim_Davis]
wbem-https 5989 tcp WBEM CIM-XML (HTTPS) [Jim_Davis] [Jim_Davis]
wbem-https 5989 udp WBEM CIM-XML (HTTPS) [Jim_Davis] [Jim_Davis]
wbem-exp-https 5990 tcp WBEM Export HTTPS [Denise_Eckstein] [Denise_Eckstein] 2004-11
wbem-exp-https 5990 udp WBEM Export HTTPS [Denise_Eckstein] [Denise_Eckstein] 2004-11
consul-insight 5992 tcp Consul InSight Security [Arthur_Hillenaar] [Arthur_Hillenaar] 2006-01
consul-insight 5992 udp Consul InSight Security [Arthur_Hillenaar] [Arthur_Hillenaar] 2006-01
cim-rs 5993 tcp DMTF WBEM CIM REST [WS_Inc] [Jim_Davis_2] 2015-04-24
rms-agent 5994 tcp RMS Agent Listening Service [RiverMeadow_Software_Inc] [Greg_Dennis] 2021-03-24
5995-5998 Unassigned
x11 6000-6063 tcp X Window System [Stephen_Gildea] [Stephen_Gildea] Known Unauthorized Use on port 6003
x11 6000-6063 udp X Window System [Stephen_Gildea] [Stephen_Gildea] Known Unauthorized Use on port 6003
ndl-ahp-svc 6064 tcp NDL-AHP-SVC [John_Richmond_2] [John_Richmond_2]
ndl-ahp-svc 6064 udp NDL-AHP-SVC [John_Richmond_2] [John_Richmond_2]
gsmp-ancp 6068 tcp GSMP/ANCP [Avri_Doria] [Avri_Doria] [RFC 6320]
diagnose-proc 6072 tcp DIAGNOSE-PROC [Allan_Miller] [Allan_Miller]

Contact Information

ID Name Organization Contact URI Last Updated
[Allan_Miller] Allan Miller mailto:amiller&handsfreenetworks.com
[Arthur_Hillenaar] Arthur Hillenaar mailto:arthur.hillenaar&consul.com 2006-01
[Avri_Doria] Avri Doria mailto:avri.doria&nokia.com
[Christophe_Chevalier] Christophe Chevalier mailto:chevalier&archimed.fr 2005-08
[Clay_S_Didier] Clay S. Didier enLabel Global Services mailto:cdidier&enlabel.com 2021-10-12
[Denise_Eckstein] Denise Eckstein mailto:denise.eckstein&hp.com 2004-11
[Don_Loughry] Don Loughry mailto:DON_LOUGHRY&hp-cupertino-om4.om.hp.com
[Don_Marselle] Don Marselle mailto:don.marselle&3par.com 2008-04-09
[Eivan_Cerasi] Eivan Cerasi mailto:eivan.cerasi&eurocontrol.int 2022-08-08
[enLabel_Global_Services] enLabel Global Services mailto:support&enlabel.com 2021-10-12
[Gerardo_Dilillo] Gerardo Dilillo mailto:MOMIANA&microsoft.com 2006-08
[Graham_Bloice] Graham Bloice mailto:graham.bloice&trihedral.com 2009-09-17
[Greg_Dennis] Greg Dennis RiverMeadow Software Inc. mailto:gdennis&rivermeadow.com 2021-03-24
[Greg_Saccone] Greg Saccone mailto:gregory.t.saccone&boeing.com 2022-08-08
[Harish_Kuttan] Harish Kuttan mailto:harish.k&hp.com 2010-03-22
[International_Civil_Aviation_Organisation] International Civil Aviation Organisation (ICAO) mailto:gisinbox&icao.int 2024-11-19
[Jim_Davis] Jim Davis mailto:jim.davis&wbemsolutions.com 2007-06
[Jim_Davis_2] Jim Davis WS, Inc mailto:Jim.Davis&ws-inc.com 2015-04-24
[John_Richmond_2] John Richmond mailto:john&ndl.co.uk
[Joshua_Hawkins] Joshua Hawkins mailto:joshua.hawkins&hp.com 2003-11
[Justin_Yu] Justin Yu mailto:yyu&mitre.org 2011-05-25
[MPITech_Support] MPITech Support mailto:morten.christensen&i-data.com
[Ming_Zhang] Ming Zhang mailto:mzhang&cisco.com 2010-02-04
[Moshe_Leibovitch] Moshe Leibovitch mailto:moshe&softlinkusa.com
[OpenMail_Encyclopedi] OpenMail Encyclopedia mailto:opencyc&hpopd.pwd.hp.com
[Rafael_Zimberoff] Rafael Zimberoff mailto:rafael&zfirmllc.com 2003-11
[RiverMeadow_Software_Inc] RiverMeadow Software Inc. mailto:gdennis&rivermeadow.com 2021-03-24
[Rob_Ward] Rob Ward mailto:RobWard&microsoft.com 2008-05-02
[Stephen_Gildea] Stephen Gildea mailto:gildea&lcs.mit.edu
[Sushil_Thomas] Sushil Thomas mailto:iana-comm&3par.com 2008-03-10
[Wayne_Morrow] Wayne Morrow mailto:wmorrow&slaauto.com 2021-02-18
[WS_Inc] WS, Inc mailto:Jim.Davis&ws-inc.com 2015-04-24
[Yutaka_Ono] Yutaka Ono mailto:ono&saint.nm.fujitsu.co.jp
[Z-Firm_LLC] Z-Firm LLC mailto:rafael&zfirmllc.com 2014-08-22