Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
abb-escp 6316 udp Ethernet Sensor Communications Protocol Jaime Antolin Jaime Antolin 2008-09-25
nav-data-cmd 6317 tcp Navtech Radar Sensor Data Command Navtech Radar Guy Avery 2013-02-20
nav-data 6317 udp Navtech Radar Sensor Data Navtech Radar Guy Avery 2013-02-20
iona-data 6318 tcp IONA Measurement and control data Insphere Ltd Guy Avery 2024-07-01
6318 udp Reserved
6319 Unassigned
emp-server1 6321 tcp Empress Software Connectivity Server 1 Srdjan Holovac Srdjan Holovac
emp-server1 6321 udp Empress Software Connectivity Server 1 Srdjan Holovac Srdjan Holovac
6351-6354 Unassigned
6361-6362 Unassigned
6371-6378 Unassigned
6380-6381 Unassigned
clariion-evr01 6389 tcp clariion-evr01 Dave DesRoches Dave DesRoches
clariion-evr01 6389 udp clariion-evr01 Dave DesRoches Dave DesRoches
6391-6399 Unassigned
boe-was 6401 boe-was SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-resssvr1 6407 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-resssvr4 6410 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
6411-6416 Unassigned
faxcomservice 6417 tcp Faxcom Message Service Albert Leung Albert Leung 2006-04
faxcomservice 6417 udp Faxcom Message Service Albert Leung Albert Leung 2006-04
syserverremote 6418 tcp SYserver remote commands David Ashkenazi David Ashkenazi 2010-03-23
6418 udp Reserved
svdrp 6419 tcp Simple VDR Protocol Klaus Schmidinger Klaus Schmidinger 2010-03-31
svdrp-disc 6419 udp Simple VDR Protocol Discovery Klaus Schmidinger Klaus Schmidinger 2015-05-08
nim-wan 6421 tcp NIM_WAN Rik Ditter Rik Ditter 2006-02
nim-wan 6421 udp NIM_WAN Rik Ditter Rik Ditter 2006-02
6422-6431 Unassigned
6441 Unassigned
ieee11073-20701 6464 tcp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
ieee11073-20701 6464 udp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
lvision-lm 6471 tcp LVision License Manager Brian McKinnon Brian McKinnon
lvision-lm 6471 udp LVision License Manager Brian McKinnon Brian McKinnon
servicetags 6481 tcp Service Tags Peter Schow Peter Schow 2007-01
servicetags 6481 udp Service Tags Peter Schow Peter Schow 2007-01
boks-servc 6501 tcp BoKS Servc

IANA assigned this well-formed service name as a replacement for "boks_servc".
Magnus Nystrom Magnus Nystrom Known Unauthorized Use on port 6501
boks_servc 6501 tcp BoKS Servc Magnus Nystrom Magnus Nystrom Known Unauthorized Use on port 6501 This entry is an alias to "boks-servc". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-servc 6501 udp BoKS Servc

IANA assigned this well-formed service name as a replacement for "boks_servc".
Magnus Nystrom Magnus Nystrom
boks_servc 6501 udp BoKS Servc Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servc". This entry is now historic, not usable for use with many common service discovery mechanisms.
mcer-port 6510 tcp MCER Port Portnoy Boxman Portnoy Boxman
mcer-port 6510 udp MCER Port Portnoy Boxman Portnoy Boxman
6511 tcp Reserved
dccp-udp 6511 udp Datagram Congestion Control Protocol Encapsulation for NAT Traversal IESG IETF Chair RFC 6773
6512-6512 Unassigned
netconf-tls 6513 tcp NETCONF over TLS IESG IETF Chair 2024-01-24 RFC 7589; RFC 9918
6513 udp Reserved
syslog-tls 6514 tcp Syslog over TLS RFC 5425
syslog-tls 6514 udp syslog over DTLS RFC 6012
syslog-tls 6514 dccp syslog over DTLS RFC 6012
elipse-rec 6515 tcp Elipse RPC Protocol Fl√°vio Englert Fl√°vio Englert 2007-09-17
elipse-rec 6515 udp Elipse RPC Protocol Fl√°vio Englert Fl√°vio Englert 2007-09-17
6516-6542 Unassigned
sum 6551 tcp Software Update Manager Jan Dirven Jan Dirven 2007-12-13
sum 6551 udp Software Update Manager Jan Dirven Jan Dirven 2007-12-13
6567 Reserved 2007-01 2011-08-26 This entry has been removed on 2011-08-26.
parsec-peer 6581 tcp Parsec Peer-to-Peer Andreas Varga Andreas Varga
parsec-peer 6581 udp Parsec Peer-to-Peer Andreas Varga Andreas Varga
mstmg-sstp 6601 tcp Microsoft Threat Management Gateway SSTP Ori Yosefi Ori Yosefi 2009-05-04
6601 udp Reserved
bencher 6610 tcp Bencher API Bencher Everett Pompeii 2026-06-17
bencher 6610 udp Bencher API Bencher Everett Pompeii 2026-06-17
6611-6618 Unassigned
odette-ftps 6619 tcp ODETTE-FTP over TLS/SSL Ieuan Friend Ieuan Friend 2006-03 RFC 5024
odette-ftps 6619 udp ODETTE-FTP over TLS/SSL Ieuan Friend Ieuan Friend 2006-03 RFC 5024
kftp 6621 tcp Kerberos V5 FTP Control Robert J. Scott Robert J. Scott 2005-08
kftp 6621 udp Kerberos V5 FTP Control Robert J. Scott Robert J. Scott 2005-08
6631 Unassigned 2004-05-28
mpls-udp 6635 udp Encapsulate MPLS packets in UDP tunnels. IESG IETF Chair 2015-02-10 RFC 7510
mpls-udp-dtls 6636 udp Encapsulate MPLS packets in UDP tunnels with DTLS. IESG IETF Chair 2015-02-10 RFC 7510
6641-6652 Unassigned
p4p-portal 6671 tcp P4P Portal Service Chris Griffiths Chris Griffiths 2008-07-28
p4p-portal 6671 udp P4P Portal Service Chris Griffiths Chris Griffiths 2008-07-28
6691-6695 Unassigned
ircs-u 6697 tcp Internet Relay Chat via TLS/SSL 2014-02-11 RFC 7194
kti-icad-srvr 6701 tcp KTI/ICAD Nameserver Stanley Knutson Stanley Knutson
kti-icad-srvr 6701 udp KTI/ICAD Nameserver Stanley Knutson Stanley Knutson
6701 sctp Unassigned 2010-01-26
frc-hp 6704 sctp ForCES HP (High Priority) channel RFC 5811
frc-mp 6705 sctp ForCES MP (Medium Priority) channel RFC 5811
frc-lp 6706 sctp ForCES LP (Low priority) channel RFC 5811
6707-6713 Unassigned
ibprotocol 6714 tcp Internet Backplane Protocol Alessandro Bassi Alessandro Bassi
ibprotocol 6714 udp Internet Backplane Protocol Alessandro Bassi Alessandro Bassi
fibotrader-com 6715 tcp Fibotrader Communications Robert Wetzold Robert Wetzold 2006-01
fibotrader-com 6715 udp Fibotrader Communications Robert Wetzold Robert Wetzold 2006-01
princity-agent 6716 tcp Princity Agent ENSTEAM Sp. z o.o. Tomasz Krakowiak 2014-07-07 2015-07-08
6716 udp Reserved
6717-6766 Unassigned
plysrv-https 6771 tcp PolyServe https Mike Spitzer Mike Spitzer 2005-08
plysrv-https 6771 udp PolyServe https Mike Spitzer Mike Spitzer 2005-08
bfd-lag 6784 udp Bidirectional Forwarding Detection (BFD) on Link Aggregation Group (LAG) Interfaces IESG IETF BFD Working Group Chairs 2012-11-08 2014-01-09 RFC 7130
hnm 6791 tcp Halcyon Network Manager Fortra Henriët Wilkinson 2005-05 2023-05-24
hnm 6791 udp Halcyon Network Manager Fortra Henriët Wilkinson 2005-05 2023-05-24
acnet 6801 tcp ACNET Control System Protocol Fermilab Rich Neswold 2007-02 2017-07-13
acnet 6801 udp ACNET Control System Protocol Fermilab Rich Neswold 2007-02 2017-07-13
6802-6816 Unassigned
pentbox-sim 6817 tcp PenTBox Secure IM Protocol Alberto Ortega Llamas Alberto Ortega Llamas 2009-11-04
6817 udp Reserved
6818-6830 Unassigned
ambit-lm 6831 tcp ambit-lm Don Hejna Don Hejna
ambit-lm 6831 udp ambit-lm Don Hejna Don Hejna

Contact Information

Name Organization Contact URI Last Updated
Albert Leung aleung&biscom.com 2006-04
Alberto Ortega Llamas alberto.kun666&gmail.com 2009-11-04
Alessandro Bassi abassi&cs.utk.edu
Andreas Varga sid&parsec.org
Bencher info&bencher.dev 2026-06-17
IETF BFD Working Group Chairs bfd-chairs&tools.ietf.org 2014-01-09
Brian McKinnon bmk&lvision.com
Chris Griffiths chris_griffiths&cable.comcast.com 2008-07-28
Dave DesRoches ddesroches&clariion.com
David Ashkenazi david&synel.co.il 2010-03-23
David Gregorczyk david.gregorczyk&draeger.com 2017-03-02
Don Hejna djhejna&ambit.com
ENSTEAM Sp. z o.o. support&ensteam.com 2015-07-08
Everett Pompeii everett&bencher.dev 2026-06-17
Fl√°vio Englert flavio&elipse.com.br 2007-09-17
Fermilab neswold&fnal.gov 2017-07-13
Fortra info&fortra.com 2023-05-24
Giriraj Harapanahalli giriraj.harapanahalli&sap.com 2026-05-27
Guy Avery Navtech Radar guy.avery&navtechradar.com 2013-02-20
Guy Avery Insphere Ltd guy&insphereltd.com 2013-02-20
Henriët Wilkinson henriet.wilkinson&fortra.com 2023-05-24
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ieuan Friend ieuan.friend&dip.co.uk 2006-03
Insphere Ltd guy&insphereltd.com 2024-07-01
Jaime Antolin jaime.antolin&ie.abb.com 2008-09-25
Jan Dirven jan.dirven&agfa.com 2007-12-13
Klaus Schmidinger Klaus.Schmidinger&tvdr.de 2010-03-31
Magnus Nystrom magnus&dynas.se
Mike Spitzer mjs&polyserve.com 2005-08
Ori Yosefi Ori.Yosefi&microsoft.com 2009-05-04
Peter Schow Peter.Schow&sun.com 2007-01
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Rich Neswold neswold&fnal.gov 2007-02
Rik Ditter managers&generationtechnologies.com 2006-02
Robert J. Scott rob&hpcmo.hpc.mil 2005-08
Robert Wetzold robert.wetzold&fibotrader.com 2006-01
SAP Giriraj Harapanahalli 2026-05-27
Srdjan Holovac srdjan&empress.com
Stanley Knutson Stanley.Knutson&ktiworld.com
Tomasz Krakowiak ENSTEAM Sp. z o.o. tomasz.krakowiak&ensteam.com 2015-07-08