Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
diagnose-proc 6072 tcp DIAGNOSE-PROC [Allan_Miller] [Allan_Miller]
diagnose-proc 6072 udp DIAGNOSE-PROC [Allan_Miller] [Allan_Miller]
dpm-acm 6075 tcp Microsoft DPM Access Control Manager [Prabu_Ambravaneswara] [Prabu_Ambravaneswara] 2009-10-29
msft-dpm-cert 6076 tcp Microsoft DPM WCF Certificates [Microsoft_Corporation] [Prateek_Sharma] 2011-08-04
6078-6079 Unassigned
gue 6080 udp Generic UDP Encapsulation [Tom_Herbert] [Tom_Herbert] 2015-03-05 [draft-herbert-gue-02]
p25cai 6082 udp APCO Project 25 Common Air Interface - UDP encapsulation [APCO_Project] [APCO_Project] 2011-05-13
miami-bcast 6083 udp telecomsoftware miami broadcast [Peter_Steiner] [Peter_Steiner] 2011-02-22
reload-config 6084 tcp Peer to Peer Infrastructure Configuration [IESG] [IETF_Chair] 2009-01-29 2013-03-26 [RFC 6940]
doglms-notify 6088 udp SuperDog License Manager Notifier [SafeNet] [Rob_Tao] 2012-07-26
6089-6098 Unassigned
raxa-mgmt 6099 tcp RAXA Management [Sukanta_Ganguly] [Sukanta_Ganguly]
synchronet-db 6100 tcp SynchroNet-db [Arne_Haugland] [Arne_Haugland] Known Unauthorized Use on port 6100
synchronet-db 6100 udp SynchroNet-db [Arne_Haugland] [Arne_Haugland] Known Unauthorized Use on port 6100
synchronet-rtc 6101 tcp SynchroNet-rtc [Arne_Haugland] [Arne_Haugland]
synchronet-rtc 6101 udp SynchroNet-rtc [Arne_Haugland] [Arne_Haugland]
synchronet-upd 6102 tcp SynchroNet-upd [Arne_Haugland] [Arne_Haugland]
synchronet-upd 6102 udp SynchroNet-upd [Arne_Haugland] [Arne_Haugland]
etc-control 6107 tcp ETC Control [Electronic_Theatre_Controls_Inc] [ETC_IANA_Registration] 2021-09-24
etc-control 6107 udp ETC Control [Electronic_Theatre_Controls_Inc] [ETC_IANA_Registration] 2021-09-24
sercomm-scadmin 6108 tcp Sercomm-SCAdmin [Melinda_Tsao_2] [Melinda_Tsao_2]
sercomm-scadmin 6108 udp Sercomm-SCAdmin [Melinda_Tsao_2] [Melinda_Tsao_2]
globecast-id 6109 tcp GLOBECAST-ID [Piers_Scannell_2] [Piers_Scannell_2]
globecast-id 6109 udp GLOBECAST-ID [Piers_Scannell_2] [Piers_Scannell_2]
spc 6111 tcp HP SoftBench Sub-Process Control [Scott_A_Kramer] [Scott_A_Kramer]
spc 6111 udp HP SoftBench Sub-Process Control [Scott_A_Kramer] [Scott_A_Kramer]
dtspcd 6112 tcp Desk-Top Sub-Process Control Daemon [Doug_Royer] [Doug_Royer] 2010-12-08
dtspcd 6112 udp Desk-Top Sub-Process Control Daemon [Doug_Royer] [Doug_Royer] 2010-12-08
6119-6120 Unassigned
bex-webadmin 6122 tcp Backup Express Web Server [Catalogic_Software_Inc] [Chi_Shih_Chang] 2008-03-19 2015-02-04
bex-webadmin 6122 udp Backup Express Web Server [Catalogic_Software_Inc] [Chi_Shih_Chang] 2008-03-19 2015-02-04
backup-express 6123 tcp Backup Express [Catalogic_Software_Inc] [Chi_Shih_Chang] 2008-03-19 2015-02-04
backup-express 6123 udp Backup Express [Catalogic_Software_Inc] [Chi_Shih_Chang] 2008-03-19 2015-02-04
6125-6129 Unassigned
6131-6132 Unassigned
nbt-wol 6133 tcp New Boundary Tech WOL [Elizabeth_Zilen] [Elizabeth_Zilen] 2004-11
nbt-wol 6133 udp New Boundary Tech WOL [Elizabeth_Zilen] [Elizabeth_Zilen] 2004-11
6134-6139 Unassigned
meta-corp 6141 tcp Meta Corporation License Manager [Osamu_Masuda] [Osamu_Masuda]
meta-corp 6141 udp Meta Corporation License Manager [Osamu_Masuda] [Osamu_Masuda]
aspentec-lm 6142 tcp Aspen Technology License Manager [Kevin_Massey] [Kevin_Massey]
aspentec-lm 6142 udp Aspen Technology License Manager [Kevin_Massey] [Kevin_Massey]
watershed-lm 6143 tcp Watershed License Manager [David_Ferrero] [David_Ferrero]
watershed-lm 6143 udp Watershed License Manager [David_Ferrero] [David_Ferrero]
statsci1-lm 6144 tcp StatSci License Manager - 1 [Scott_Blachowicz] [Scott_Blachowicz]
statsci1-lm 6144 udp StatSci License Manager - 1 [Scott_Blachowicz] [Scott_Blachowicz]
statsci2-lm 6145 tcp StatSci License Manager - 2 [Scott_Blachowicz] [Scott_Blachowicz]
statsci2-lm 6145 udp StatSci License Manager - 2 [Scott_Blachowicz] [Scott_Blachowicz]
lonewolf-lm 6146 tcp Lone Wolf Systems License Manager [Dan_Klein] [Dan_Klein]
lonewolf-lm 6146 udp Lone Wolf Systems License Manager [Dan_Klein] [Dan_Klein]
montage-lm 6147 tcp Montage License Manager [Michael_Ubell] [Michael_Ubell]
montage-lm 6147 udp Montage License Manager [Michael_Ubell] [Michael_Ubell]
ricardo-lm 6148 tcp Ricardo North America License Manager [M_Flemming] [M_Flemming]
ricardo-lm 6148 udp Ricardo North America License Manager [M_Flemming] [M_Flemming]
tal-pod 6149 tcp tal-pod [Steven_Loomis] [Steven_Loomis]
tal-pod 6149 udp tal-pod [Steven_Loomis] [Steven_Loomis]
6150-6158 Unassigned
efb-aci 6159 tcp EFB Application Control Interface [Jonathan_Schaaf] [Jonathan_Schaaf] 2010-02-10
ecmp-data 6160 udp Emerson Extensible Control and Management Protocol Data [Bryce_Beeston] [Bryce_Beeston] 2011-06-23
patrol-ism 6161 tcp PATROL Internet Srv Mgr [Portnoy_Boxman] [Portnoy_Boxman] 2005-01
patrol-ism 6161 udp PATROL Internet Srv Mgr [Portnoy_Boxman] [Portnoy_Boxman] 2005-01
patrol-coll 6162 tcp PATROL Collector [Portnoy_Boxman] [Portnoy_Boxman] 2005-01
patrol-coll 6162 udp PATROL Collector [Portnoy_Boxman] [Portnoy_Boxman] 2005-01
6164-6199 Unassigned
lm-x 6200 tcp LM-X License Manager by X-Formation [Henrik_Goldman] [Henrik_Goldman] 2006-10 Known Unauthorized Use on port 6200
lm-x 6200 udp LM-X License Manager by X-Formation [Henrik_Goldman] [Henrik_Goldman] 2006-10 Known Unauthorized Use on port 6200
thermo-calc 6201 udp Management of service nodes in a processing grid for thermodynamic calculations [Thermo-Calc_Software] [Thomas_Revesz] 2012-06-28
6202-6208 Unassigned
6210-6221 Unassigned
6223-6240 Unassigned
jeol-nsdtp-1 6241 tcp JEOL Network Services Data Transport Protocol 1 [Kevin_Wellwood] [Kevin_Wellwood] 2008-04-17
jeol-nsddp-1 6241 udp JEOL Network Services Dynamic Discovery Protocol 1 [Kevin_Wellwood] [Kevin_Wellwood] 2008-04-17
jeol-nsdtp-2 6242 tcp JEOL Network Services Data Transport Protocol 2 [Kevin_Wellwood] [Kevin_Wellwood] 2008-04-17
jeol-nsddp-2 6242 udp JEOL Network Services Dynamic Discovery Protocol 2 [Kevin_Wellwood] [Kevin_Wellwood] 2008-04-17
jeol-nsdtp-3 6243 tcp JEOL Network Services Data Transport Protocol 3 [Kevin_Wellwood] [Kevin_Wellwood] 2008-04-17
jeol-nsddp-3 6243 udp JEOL Network Services Dynamic Discovery Protocol 3 [Kevin_Wellwood] [Kevin_Wellwood] 2008-04-17
jeol-nsdtp-4 6244 tcp JEOL Network Services Data Transport Protocol 4 [Kevin_Wellwood] [Kevin_Wellwood] 2008-04-17
jeol-nsddp-4 6244 udp JEOL Network Services Dynamic Discovery Protocol 4 [Kevin_Wellwood] [Kevin_Wellwood] 2008-04-17
6245-6250 Unassigned
tl1-raw-ssl 6251 tcp TL1 Raw Over SSL/TLS [Jim_Humphreys] [Jim_Humphreys] 2008-01-29
tl1-raw-ssl 6251 udp TL1 Raw Over SSL/TLS [Jim_Humphreys] [Jim_Humphreys] 2008-01-29
tl1-ssh 6252 tcp TL1 over SSH [Jim_Humphreys] [Jim_Humphreys] 2008-01-25
tl1-ssh 6252 udp TL1 over SSH [Jim_Humphreys] [Jim_Humphreys] 2008-01-25
6254-6266 Unassigned
gld 6267 tcp GridLAB-D User Interface [David_Chassin] [David_Chassin] 2010-12-10
grid-alt 6269 tcp Grid Authentication Alt [Jason_Hamilton] [Jason_Hamilton] 2006-06
grid-alt 6269 udp Grid Authentication Alt [Jason_Hamilton] [Jason_Hamilton] 2006-06
6270-6299 Unassigned
bmc-grx 6300 tcp BMC GRX [Portnoy_Boxman] [Portnoy_Boxman]
bmc-grx 6300 udp BMC GRX [Portnoy_Boxman] [Portnoy_Boxman]
bmc-ctd-ldap 6301 tcp BMC CONTROL-D LDAP SERVER

IANA assigned this well-formed service name as a replacement for "bmc_ctd_ldap".
[Portnoy_Boxman_2] [Portnoy_Boxman_2] 2006-09
bmc_ctd_ldap 6301 tcp BMC CONTROL-D LDAP SERVER [Portnoy_Boxman_2] [Portnoy_Boxman_2] 2006-09 This entry is an alias to "bmc-ctd-ldap". This entry is now historic, not usable for use with many common service discovery mechanisms.
bmc-ctd-ldap 6301 udp BMC CONTROL-D LDAP SERVER

IANA assigned this well-formed service name as a replacement for "bmc_ctd_ldap".
[Portnoy_Boxman_2] [Portnoy_Boxman_2] 2006-09
bmc_ctd_ldap 6301 udp BMC CONTROL-D LDAP SERVER [Portnoy_Boxman_2] [Portnoy_Boxman_2] 2006-09 This entry is an alias to "bmc-ctd-ldap". This entry is now historic, not usable for use with many common service discovery mechanisms.
6302-6305 Unassigned
6307-6314 Unassigned
scup-disc 6315 udp Sensor Control Unit Protocol Discovery Protocol [Sven_Kopacz] [Sven_Kopacz] 2010-09-01
abb-escp 6316 tcp Ethernet Sensor Communications Protocol [Jaime_Antolin] [Jaime_Antolin] 2008-09-25
abb-escp 6316 udp Ethernet Sensor Communications Protocol [Jaime_Antolin] [Jaime_Antolin] 2008-09-25
nav-data-cmd 6317 tcp Navtech Radar Sensor Data Command [Navtech_Radar_Ltd] [Guy_Avery] 2013-02-20
nav-data 6317 udp Navtech Radar Sensor Data [Navtech_Radar_Ltd] [Guy_Avery] 2013-02-20

Contact Information

ID Name Organization Contact URI Last Updated
[APCO_Project] Steve Glass APCO Project 25 mailto:admin&sedition.org.au 2011-05-13
[Allan_Miller] Allan Miller mailto:amiller&handsfreenetworks.com
[Arne_Haugland] Arne Haugland mailto:Arne.Haugland&parasoldev.com
[Bryce_Beeston] Bryce Beeston mailto:bryce.beeston&emerson.com 2011-06-23
[Catalogic_Software_Inc] Catalogic Software, Inc. mailto:cchang&catalogicsoftware.com 2015-02-04
[Chi_Shih_Chang] Chi Shih Chang Catalogic Software, Inc. mailto:cchang&catalogicsoftware.com 2015-02-04
[Dan_Klein] Dan Klein mailto:daniel.v.klein&gmail.com 2018-08-21
[David_Chassin] David Chassin mailto:david.chassin&pnl.gov 2010-12-10
[David_Ferrero] David Ferrero mailto:david&zion.com
[Doug_Royer] Doug Royer mailto:DouglasRoyer&gmail.com 2010-12-09
[Electronic_Theatre_Controls_Inc] Electronic Theatre Controls, Inc. mailto:ianaregistration&etcconnect.com 2021-09-24
[Elizabeth_Zilen] Elizabeth Zilen mailto:ezilen&newboundary.com 2004-11
[ETC_IANA_Registration] ETC IANA Registration Electronic Theatre Controls, Inc. mailto:ianaregistration&etcconnect.com 2021-09-24
[Guy_Avery] Guy Avery Navtech Radar mailto:guy.avery&navtechradar.com 2013-02-20
[Henrik_Goldman] Henrik Goldman mailto:hg&x-formation.com 2006-10
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Jaime_Antolin] Jaime Antolin mailto:jaime.antolin&ie.abb.com 2008-09-25
[Jason_Hamilton] Jason Hamilton mailto:JHamilton&griddatasecurity.com 2006-06
[Jim_Humphreys] Jim Humphreys mailto:jhumphre&ciena.com 2008-01-29
[Jonathan_Schaaf] Jonathan Schaaf mailto:j.schaaf&astronautics.com 2010-02-10
[Kevin_Massey] Kevin Massey mailto:massey&aspentec.com
[Kevin_Wellwood] Kevin Wellwood mailto:wellwood&jeol.com 2008-04-17
[M_Flemming] M Flemming mailto:mflemming&aol.com
[Melinda_Tsao_2] Melinda Tsao mailto:melinda_tsao&mail.sercomm.com.tw
[Michael_Ubell] Michael Ubell mailto:michael&montage.com
[Microsoft_Corporation] Microsoft Corporation mailto:pratshar&microsoft.com 2011-08-04
[Navtech_Radar_Ltd] Navtech Radar mailto:network.admin&navtechradar.com 2013-02-20
[Osamu_Masuda] Osamu Masuda
[Peter_Steiner] Peter Steiner mailto:steiner&telecomsoftware.com 2011-02-22
[Piers_Scannell_2] Piers Scannell mailto:piers&globecastne.com
[Portnoy_Boxman] Portnoy Boxman mailto:portnoy_boxman&bmc.com 2005-01
[Portnoy_Boxman_2] Portnoy Boxman mailto:Portnoy_Boxman&bmc.com 2006-09
[Prabu_Ambravaneswara] Prabu Ambravaneswaran mailto:prambrav&microsoft.com 2009-10-29
[Prateek_Sharma] Prateek Sharma mailto:pratshar&microsoft.com 2011-08-04
[Rob_Tao] Rob Tao SafeNet mailto:rtao&safenet-inc.com 2012-07-26
[SafeNet] SafeNet mailto:rtao&safenet-inc.com 2012-07-26
[Scott_A_Kramer] Scott A. Kramer mailto:sk&tleilaxu.sde.hp.com
[Scott_Blachowicz] Scott Blachowicz mailto:scott&statsci.com
[Steven_Loomis] Steven Loomis mailto:srl&taligent.com
[Sukanta_Ganguly] Sukanta Ganguly mailto:sganguly&kineticnetworks.com
[Sven_Kopacz] Sven Kopacz mailto:s.kopacz&controllerware.com 2010-09-01
[Thermo-Calc_Software] Thermo-Calc Software AB mailto:thomasr&thermocalc.se 2012-06-28
[Thomas_Revesz] Thomas Revesz Thermo-Calc Software AB mailto:thomasr&thermocalc.se 2012-06-28
[Tom_Herbert] Tom Herbert mailto:tom&herbertland.com 2017-05-19