Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ambit-lm 6831 udp ambit-lm Don Hejna Don Hejna
netmo-default 6841 tcp Netmo Default Urs Bertschinger Urs Bertschinger
netmo-default 6841 udp Netmo Default Urs Bertschinger Urs Bertschinger
6851-6867 Unassigned
jetstream 6901 tcp Novell Jetstream messaging protocol Anil Tyagi Anil Tyagi 2010-06-11
6901 udp Reserved
otlp 6951 tcp OTLP Brent Foster Brent Foster 2006-04
otlp 6951 udp OTLP Brent Foster Brent Foster 2006-04
jmact3 6961 tcp JMACT3 Yutaka Ono Yutaka Ono
jmact3 6961 udp JMACT3 Yutaka Ono Yutaka Ono
swismgr1 6963 tcp swismgr1 Yutaka Ono Yutaka Ono
swismgr1 6963 udp swismgr1 Yutaka Ono Yutaka Ono
6971-6979 Unassigned
6981-6996 Unassigned
afs3-callback 7001 tcp callbacks to cache managers Known Unauthorized Use on port 7001
afs3-callback 7001 udp callbacks to cache managers Known Unauthorized Use on port 7001
ups-onlinet 7010 tcp onlinet uninterruptable power supplies Jim Thompson Jim Thompson
ups-onlinet 7010 udp onlinet uninterruptable power supplies Jim Thompson Jim Thompson
talon-disc 7011 tcp Talon Discovery Port Jim Thompson Jim Thompson Known Unauthorized Use on 7011
talon-disc 7011 udp Talon Discovery Port Jim Thompson Jim Thompson Known Unauthorized Use on 7011
talon-engine 7012 tcp Talon Engine Jim Thompson Jim Thompson Known Unauthorized Use on 7011
talon-engine 7012 udp Talon Engine Jim Thompson Jim Thompson Known Unauthorized Use on 7011
microtalon-dis 7013 tcp Microtalon Discovery Jim Thompson Jim Thompson
microtalon-dis 7013 udp Microtalon Discovery Jim Thompson Jim Thompson
microtalon-com 7014 tcp Microtalon Communications Jim Thompson Jim Thompson
microtalon-com 7014 udp Microtalon Communications Jim Thompson Jim Thompson
talon-webserver 7015 tcp Talon Webserver Jim Thompson Jim Thompson
talon-webserver 7015 udp Talon Webserver Jim Thompson Jim Thompson
spg 7016 tcp SPG Controls Carrier SPG Controls Ltd Steve Barton 2017-03-27
spg 7016 udp SPG Controls Carrier SPG Controls Ltd Steve Barton 2017-03-27
grasp 7017 tcp GeneRic Autonomic Signaling Protocol IESG IETF Chair 2017-04-28 2017-07-20 RFC 8990
grasp 7017 udp GeneRic Autonomic Signaling Protocol IESG IETF Chair 2017-04-28 2017-07-20 RFC 8990
fisa-svc 7018 tcp FISA Service FAUCONNET Ingénierie SA FAUCONNET Ingénierie SA 2011-05-19
7018 udp Reserved
doceri-ctl 7019 tcp doceri drawing service control Paul Brown Paul Brown 2011-04-27
doceri-view 7019 udp doceri drawing service screen view Paul Brown Paul Brown 2011-04-27
dpserveadmin 7021 tcp DP Serve Admin Allan Stanley Allan Stanley
dpserveadmin 7021 udp DP Serve Admin Allan Stanley Allan Stanley
iposplanet 7031 tcp IPOSPLANET retailing multi devices protocol Fabrice Paget Fabrice Paget 2012-10-23
7031 udp Reserved
7041-7069 Unassigned
iwg1 7071 tcp IWGADTS Aircraft Housekeeping Message Don Sullivan Don Sullivan 2010-02-16
iwg1 7071 udp IWGADTS Aircraft Housekeeping Message Don Sullivan Don Sullivan 2010-02-16
7081-7087 Unassigned
font-service 7100 tcp X Font Service Stephen Gildea Stephen Gildea
font-service 7100 udp X Font Service Stephen Gildea Stephen Gildea
elcn 7101 tcp Embedded Light Control Network Michael Scarito Michael Scarito 2007-02
elcn 7101 udp Embedded Light Control Network Michael Scarito Michael Scarito 2007-02
7102-7106 Unassigned
7107 tcp Reserved
aes-x170 7107 udp AES-X170 Richard Foss Richard Foss 2011-02-10
7108-7116 Unassigned
rothaga 7117 tcp Encrypted chat and file transfer service Arcadian Computers Jonathan Pollock 2016-05-10
7117 udp Reserved
7118-7120 Unassigned
virprot-lm 7121 tcp Virtual Prototypes License Manager Victor Galis Victor Galis
virprot-lm 7121 udp Virtual Prototypes License Manager Victor Galis Victor Galis
7122 Unassigned
snif 7123 tcp SNIF End-to-End TLS Relay Control Connection VESvault Corp Jim Zubov 2021-12-24 2026-07-22 draft-zubov-snif-05, Section 4.3
snif 7123 udp SNIF End-to-End TLS Relay over QUIC VESvault Corp Jim Zubov 2026-07-22 2026-07-22 draft-zubov-snif-05, Section 4.4
7124-7127 Unassigned
scenidm 7128 tcp intelligent data manager Paul Ignatius Paul Ignatius 2006-03
scenidm 7128 udp intelligent data manager Paul Ignatius Paul Ignatius 2006-03
scenccs 7129 tcp Catalog Content Search Anil Sharma Anil Sharma 2006-04
scenccs 7129 udp Catalog Content Search Anil Sharma Anil Sharma 2006-04
7130-7160 Unassigned
cabsm-comm 7161 tcp CA BSM Comm Chun-Ho Chang Chun-Ho Chang 2004-11
cabsm-comm 7161 udp CA BSM Comm Chun-Ho Chang Chun-Ho Chang 2004-11
caistoragemgr 7162 tcp CA Storage Manager Emre Tunar Emre Tunar 2004-11
caistoragemgr 7162 udp CA Storage Manager Emre Tunar Emre Tunar 2004-11
cacsambroker 7163 tcp CA Connection Broker David Roberts David Roberts 2005-05
cacsambroker 7163 udp CA Connection Broker David Roberts David Roberts 2005-05
fsr 7164 tcp File System Repository Agent Micha Ben-Efraim Micha Ben-Efraim 2007-07-19
fsr 7164 udp File System Repository Agent Micha Ben-Efraim Micha Ben-Efraim 2007-07-19
doc-server 7165 tcp Document WCF Server Micha Ben-Efraim Micha Ben-Efraim 2008-01-07
doc-server 7165 udp Document WCF Server Micha Ben-Efraim Micha Ben-Efraim 2008-01-07
aruba-server 7166 tcp Aruba eDiscovery Server Micha Ben-Efraim Micha Ben-Efraim 2008-01-07
aruba-server 7166 udp Aruba eDiscovery Server Micha Ben-Efraim Micha Ben-Efraim 2008-01-07
casrmagent 7167 tcp CA SRM Agent Venkata Krishna Venkata Krishna 2010-02-24
7167 udp Reserved
cnckadserver 7168 tcp cncKadServer DB & Inventory Services Micha Ben-Efraim Micha Ben-Efraim 2011-01-31
7168 udp Reserved
ccag-pib 7169 tcp Consequor Consulting Process Integration Bridge Frank Goenninger Frank Goenninger 2010-02-22
ccag-pib 7169 udp Consequor Consulting Process Integration Bridge Frank Goenninger Frank Goenninger 2010-02-22
nsrp 7170 tcp Adaptive Name/Service Resolution Geoff Back Geoff Back 2010-02-01
nsrp 7170 udp Adaptive Name/Service Resolution Geoff Back Geoff Back 2010-02-01
drm-production 7171 tcp Discovery and Retention Mgt Production Micha Ben-Efraim Micha Ben-Efraim 2010-02-18
drm-production 7171 udp Discovery and Retention Mgt Production Micha Ben-Efraim Micha Ben-Efraim 2010-02-18
metalbend 7172 tcp Port used for MetalBend programmable interface Micha Ben-Efraim Micha Ben-Efraim 2012-11-27
7172 udp Reserved
zsecure 7173 tcp zSecure Server Hans Schoone Hans Schoone 2010-10-01
7173 udp Reserved
clutild 7174 tcp Clutild Cheryl Stoutenburg Cheryl Stoutenburg
clutild 7174 udp Clutild Cheryl Stoutenburg Cheryl Stoutenburg
7175-7180 Unassigned
janus-disc 7181 udp Janus Guidewire Enterprise Discovery Service Bus Guidewire Software, Inc Luca Debiasi 2014-02-06
7181 tcp Reserved
7182-7199 Unassigned
dlip 7201 tcp DLIP Albert Manfredi Albert Manfredi
dlip 7201 udp DLIP Albert Manfredi Albert Manfredi
7203-7214 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Albert Manfredi manfredi&engr05.comsys.rockwell.com
Allan Stanley allan&hummingbird.com
Anil Sharma anil.sharma&scentric.com 2006-04
Anil Tyagi tanil&novell.com 2010-06-11
Arcadian Computers support&arcadiancomputers.com 2016-05-10
Brent Foster brent.foster&onstreamsystems.com 2006-04
Cheryl Stoutenburg cstoutenburg&vnet.ibm.com
Chun-Ho Chang chun-ho.chang&ca.com 2004-11
David Roberts David.Roberts&ca.com 2005-05
Don Hejna djhejna&ambit.com
Don Sullivan donald.v.sullivan&nasa.gov 2010-02-16
Emre Tunar emre.tunar&ca.com 2004-11
Fabrice Paget onefrench&me.com 2012-10-23
FAUCONNET Ingénierie SA dev&fisa.fr 2011-05-19
Frank Goenninger frank.goenninger&consequor.de 2010-02-22
Geoff Back geoff&demonlair.co.uk 2010-02-01
Guidewire Software, Inc info&guidewire.com 2014-02-06
Hans Schoone Hans.Schoone&nl.ibm.com 2010-10-01
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jim Thompson jim.thompson&powerware.com
Jim Zubov VESvault Corp jz&vesvault.com 2021-12-29
Jonathan Pollock jon&arcadiancomputers.com 2016-05-10
Luca Debiasi Guidewire Software, Inc ldebiasi&guidewire.com 2014-02-06
Micha Ben-Efraim benmi07&ca.com 2008-01-07
Micha Ben-Efraim micha&metalix.net 2011-01-31
Micha Ben-Efraim micha.ben-efraim&ca.com 2010-02-18
Micha Ben-Efraim micha&metalix.net 2012-11-27
Michael Scarito ms&mit.edu 2007-02
Paul Brown pbrown&spcontrols.com 2011-04-27
Paul Ignatius paul.ignatius&scentric.com 2006-03
Richard Foss r.foss&ru.ac.za 2011-02-10
SPG Controls Ltd steveb&spgcontrols.com 2017-03-27
Stephen Gildea gildea&lcs.mit.edu
Steve Barton SPG Controls Ltd steveb&spgcontrols.com 2017-03-27
Urs Bertschinger urs&netmosphere.com
Venkata Krishna VenkataKrishna.Bezawada&ca.com 2010-02-24
VESvault Corp info&vesvault.com 2021-12-29
Victor Galis galis&satchmo.virtualprototypes.ca
Yutaka Ono ono&saint.nm.fujitsu.co.jp