Service Name and Transport Protocol Port Number Registry
- Last Updated
- 2026-10-09
- Expert(s)
-
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf SCTP: Michael Tuexen DCCP: Eddie Kohler and Yoshifumi Nishida
- Reference
- [RFC 6335]
- Note
-
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP. Service names are assigned on a first-come, first-served process, as documented in [RFC 6335]. Port numbers are assigned in various ways, based on three ranges: System Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private Ports (49152-65535); the different uses of these ranges are described in [RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are assigned by the "IETF Review" or "IESG Approval" procedures described in [RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, the "IESG Approval" process, or the "Expert Review" process, as per [RFC 6335]. Dynamic Ports are not assigned. The registration procedures for service names and port numbers are described in [RFC 6335]. Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration. ************************************************************************ * PLEASE NOTE THE FOLLOWING: * * * * ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN * * ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK * * TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT * * IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE * * ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD * * CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF * * THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER * * REGISTERED OR NOT. * ************************************************************************
- Request an Assignment
-
[https://www.iana.org/protocols/apply]
- Available Formats
-

CSV
XML
HTML
TXT
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ftp-agent | 574 | udp | FTP Software Agent System | [Michael_S_Greenberg] | [Michael_S_Greenberg] | ||||||
| sntp-heartbeat | 580 | tcp | SNTP HEARTBEAT | [Louis_Mamakos_2] | [Louis_Mamakos_2] | ||||||
| sntp-heartbeat | 580 | udp | SNTP HEARTBEAT | [Louis_Mamakos_2] | [Louis_Mamakos_2] | ||||||
| scc-security | 582 | tcp | SCC Security | [Prashant_Dholakia] | [Prashant_Dholakia] | ||||||
| scc-security | 582 | udp | SCC Security | [Prashant_Dholakia] | [Prashant_Dholakia] | ||||||
| philips-vc | 583 | tcp | Philips Video-Conferencing | [Janna_Chang] | [Janna_Chang] | ||||||
| philips-vc | 583 | udp | Philips Video-Conferencing | [Janna_Chang] | [Janna_Chang] | ||||||
| 585 | De-registered | 2006-04-25 | Use of 585 is not recommended, use 993 instead | ||||||||
| password-chg | 586 | tcp | Password Change | ||||||||
| password-chg | 586 | udp | Password Change | ||||||||
| tns-cml | 590 | tcp | TNS CML | [Jerome_Albin] | [Jerome_Albin] | ||||||
| tns-cml | 590 | udp | TNS CML | [Jerome_Albin] | [Jerome_Albin] | ||||||
| http-alt | 591 | tcp | FileMaker, Inc. - HTTP Alternate (see Port 80) | [Clay_Maeckel] | [Clay_Maeckel] | ||||||
| http-alt | 591 | udp | FileMaker, Inc. - HTTP Alternate (see Port 80) | [Clay_Maeckel] | [Clay_Maeckel] | ||||||
| eudora-set | 592 | tcp | Eudora Set | [Randall_Gellens] | [Randall_Gellens] | ||||||
| eudora-set | 592 | udp | Eudora Set | [Randall_Gellens] | [Randall_Gellens] | ||||||
| http-rpc-epmap | 593 | tcp | HTTP RPC Ep Map | [Edward_Reus] | [Edward_Reus] | ||||||
| http-rpc-epmap | 593 | udp | HTTP RPC Ep Map | [Edward_Reus] | [Edward_Reus] | ||||||
| cab-protocol | 595 | tcp | CAB Protocol | [Winston_Hetherington] | [Winston_Hetherington] | ||||||
| cab-protocol | 595 | udp | CAB Protocol | [Winston_Hetherington] | [Winston_Hetherington] | ||||||
| sco-websrvrmg3 | 598 | tcp | SCO Web Server Manager 3 | [Simon_Baldwin] | [Simon_Baldwin] | ||||||
| sco-websrvrmg3 | 598 | udp | SCO Web Server Manager 3 | [Simon_Baldwin] | [Simon_Baldwin] | ||||||
| syslog-conn | 601 | tcp | Reliable Syslog Service | [RFC 3195] | |||||||
| syslog-conn | 601 | udp | Reliable Syslog Service | [RFC 3195] | |||||||
| xmlrpc-beep | 602 | tcp | XML-RPC over BEEP | [RFC 3529] | |||||||
| xmlrpc-beep | 602 | udp | XML-RPC over BEEP | [RFC 3529] | |||||||
| soap-beep | 605 | tcp | SOAP over BEEP | [RFC 4227] | |||||||
| soap-beep | 605 | udp | SOAP over BEEP | [RFC 4227] | |||||||
| sift-uft | 608 | tcp | Sender-Initiated/Unsolicited File Transfer | [Rick_Troth] | [Rick_Troth] | ||||||
| sift-uft | 608 | udp | Sender-Initiated/Unsolicited File Transfer | [Rick_Troth] | [Rick_Troth] | ||||||
| npmp-trap | 609 | tcp | npmp-trap | ||||||||
| npmp-trap | 609 | udp | npmp-trap | ||||||||
| npmp-local | 610 | tcp | npmp-local | ||||||||
| npmp-local | 610 | udp | npmp-local | ||||||||
| npmp-gui | 611 | tcp | npmp-gui | [John_Barnes] | [John_Barnes] | ||||||
| npmp-gui | 611 | udp | npmp-gui | [John_Barnes] | [John_Barnes] | ||||||
| hmmp-ind | 612 | tcp | HMMP Indication | ||||||||
| hmmp-ind | 612 | udp | HMMP Indication | ||||||||
| hmmp-op | 613 | tcp | HMMP Operation | [Andrew_Sinclair] | [Andrew_Sinclair] | ||||||
| hmmp-op | 613 | udp | HMMP Operation | [Andrew_Sinclair] | [Andrew_Sinclair] | ||||||
| sco-inetmgr | 615 | tcp | Internet Configuration Manager | ||||||||
| sco-inetmgr | 615 | udp | Internet Configuration Manager | ||||||||
| sco-sysmgr | 616 | tcp | SCO System Administration Server | ||||||||
| sco-sysmgr | 616 | udp | SCO System Administration Server | ||||||||
| sco-dtmgr | 617 | tcp | SCO Desktop Administration Server | [Christopher_Durham] | [Christopher_Durham] | ||||||
| sco-dtmgr | 617 | udp | SCO Desktop Administration Server | [Christopher_Durham] | [Christopher_Durham] | ||||||
| dei-icda | 618 | tcp | DEI-ICDA | [David_Turner] | [David_Turner] | ||||||
| dei-icda | 618 | udp | DEI-ICDA | [David_Turner] | [David_Turner] | ||||||
| compaq-evm | 619 | tcp | Compaq EVM | [Jem_Treadwell] | [Jem_Treadwell] | ||||||
| compaq-evm | 619 | udp | Compaq EVM | [Jem_Treadwell] | [Jem_Treadwell] | ||||||
| sco-websrvrmgr | 620 | tcp | SCO WebServer Manager | [Christopher_Durham] | [Christopher_Durham] | ||||||
| sco-websrvrmgr | 620 | udp | SCO WebServer Manager | [Christopher_Durham] | [Christopher_Durham] | ||||||
| escp-ip | 621 | tcp | ESCP | [Lai_Zit_Seng] | [Lai_Zit_Seng] | ||||||
| escp-ip | 621 | udp | ESCP | [Lai_Zit_Seng] | [Lai_Zit_Seng] | ||||||
| oob-ws-http | 623 | tcp | DMTF out-of-band web services management protocol | [Jim_Davis] | [Jim_Davis] | 2007-06 | |||||
| asf-rmcp | 623 | udp | ASF Remote Management and Control Protocol | [Carl_First] | [Carl_First] | ||||||
| dec-dlm | 625 | tcp | DEC DLM IANA assigned this well-formed service name as a replacement for "dec_dlm". |
[Rudi_Martin_2] | [Rudi_Martin_2] | ||||||
| dec_dlm | 625 | tcp | DEC DLM | [Rudi_Martin_2] | [Rudi_Martin_2] | This entry is an alias to "dec-dlm". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| dec-dlm | 625 | udp | DEC DLM IANA assigned this well-formed service name as a replacement for "dec_dlm". |
[Rudi_Martin_2] | [Rudi_Martin_2] | ||||||
| dec_dlm | 625 | udp | DEC DLM | [Rudi_Martin_2] | [Rudi_Martin_2] | This entry is an alias to "dec-dlm". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| passgo-tivoli | 627 | tcp | PassGo Tivoli | [John_Rainford_2] | [John_Rainford_2] | ||||||
| passgo-tivoli | 627 | udp | PassGo Tivoli | [John_Rainford_2] | [John_Rainford_2] | ||||||
| 3com-amp3 | 629 | tcp | 3Com AMP3 | [Prakash_Banthia] | [Prakash_Banthia] | ||||||
| 3com-amp3 | 629 | udp | 3Com AMP3 | [Prakash_Banthia] | [Prakash_Banthia] | ||||||
| mcns-sec | 638 | tcp | mcns-sec | [Kaz_Ozawa] | [Kaz_Ozawa] | ||||||
| mcns-sec | 638 | udp | mcns-sec | [Kaz_Ozawa] | [Kaz_Ozawa] | ||||||
| entrust-sps | 640 | tcp | entrust-sps | [Marek_Buchler] | [Marek_Buchler] | ||||||
| entrust-sps | 640 | udp | entrust-sps | [Marek_Buchler] | [Marek_Buchler] | ||||||
| esro-emsdp | 642 | tcp | ESRO-EMSDP V1.3 | [Mohsen_Banan_2] | [Mohsen_Banan_2] | ||||||
| esro-emsdp | 642 | udp | ESRO-EMSDP V1.3 | [Mohsen_Banan_2] | [Mohsen_Banan_2] | ||||||
| dhcp-failover | 647 | tcp | DHCP Failover | [IESG] | [IETF_Chair] | 2018-05-21 | [RFC 8156] | ||||
| dhcp-failover | 647 | udp | DHCP Failover | [Bernard_Volz] | [Bernard_Volz] | ||||||
| cadview-3d | 649 | tcp | Cadview-3d - streaming 3d models over the internet | [David_Cooper] | [David_Cooper] | ||||||
| cadview-3d | 649 | udp | Cadview-3d - streaming 3d models over the internet | [David_Cooper] | [David_Cooper] | ||||||
| ieee-mms | 651 | tcp | IEEE MMS | [Curtis_Anderson] | [Curtis_Anderson] | ||||||
| ieee-mms | 651 | udp | IEEE MMS | [Curtis_Anderson] | [Curtis_Anderson] | ||||||
| hello-port | 652 | tcp | HELLO_PORT | [Patrick_Cipiere] | [Patrick_Cipiere] | ||||||
| hello-port | 652 | udp | HELLO_PORT | [Patrick_Cipiere] | [Patrick_Cipiere] | ||||||
| mac-srvr-admin | 660 | tcp | MacOS Server Admin | [Forest_Hill] | [Forest_Hill] | ||||||
| mac-srvr-admin | 660 | udp | MacOS Server Admin | [Forest_Hill] | [Forest_Hill] | ||||||
| oob-ws-https | 664 | tcp | DMTF out-of-band secure web services management protocol | [Jim_Davis] | [Jim_Davis] | 2007-06 | |||||
| asf-secure-rmcp | 664 | udp | ASF Secure Remote Management and Control Protocol | [Carl_First] | [Carl_First] | ||||||
| sun-dr | 665 | tcp | Sun DR | [Harinder_Bhasin] | [Harinder_Bhasin] | ||||||
| sun-dr | 665 | udp | Sun DR | [Harinder_Bhasin] | [Harinder_Bhasin] | ||||||
| disclose | 667 | tcp | campaign contribution disclosures - SDR Technologies | [Jim_Dixon] | [Jim_Dixon] | ||||||
| disclose | 667 | udp | campaign contribution disclosures - SDR Technologies | [Jim_Dixon] | [Jim_Dixon] | ||||||
| vacdsm-sws | 670 | tcp | VACDSM-SWS | ||||||||
| vacdsm-sws | 670 | udp | VACDSM-SWS | ||||||||
| vacdsm-app | 671 | tcp | VACDSM-APP | ||||||||
| vacdsm-app | 671 | udp | VACDSM-APP | ||||||||
| vpps-qua | 672 | tcp | VPPS-QUA | ||||||||
| vpps-qua | 672 | udp | VPPS-QUA | ||||||||
| vpps-via | 676 | tcp | VPPS Via | [Ulysses_G_Smith_Jr] | [Ulysses_G_Smith_Jr] | ||||||
| vpps-via | 676 | udp | VPPS Via | [Ulysses_G_Smith_Jr] | [Ulysses_G_Smith_Jr] | ||||||
| ggf-ncp | 678 | tcp | GNU Generation Foundation NCP | [Noah_Paul] | [Noah_Paul] | ||||||
| ggf-ncp | 678 | udp | GNU Generation Foundation NCP | [Noah_Paul] | [Noah_Paul] | ||||||
| entrust-aaas | 680 | tcp | entrust-aaas | ||||||||
| entrust-aaas | 680 | udp | entrust-aaas | ||||||||
| entrust-aams | 681 | tcp | entrust-aams | [Adrian_Mancini] | [Adrian_Mancini] | ||||||
| entrust-aams | 681 | udp | entrust-aams | [Adrian_Mancini] | [Adrian_Mancini] | ||||||
| corba-iiop | 683 | tcp | CORBA IIOP |