Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
passgo 511 tcp PassGo John Rainford John Rainford
passgo 511 udp PassGo John Rainford John Rainford
exec 512 tcp remote process execution; authentication performed using passwords and UNIX login names
comsat 512 udp
biff 512 udp used by mail system to notify users of new mail received; currently receives messages only from processes on the same machine
login 513 tcp remote login a la telnet; automatic authentication performed based on priviledged port numbers and distributed data bases which identify "authentication domains"
who 513 udp maintains data bases showing who's logged in to machines on a local net and the load average of the machine
shell 514 tcp cmd like exec, but automatic authentication is performed as for login server
syslog 514 udp 2020-06-01 RFC 5426
printer 515 tcp spooler
printer 515 udp spooler
videotex 516 tcp videotex Daniel Mavrakis Daniel Mavrakis
videotex 516 udp videotex Daniel Mavrakis Daniel Mavrakis
talk 517 tcp like tenex link, but across machine - unfortunately, doesn't use link protocol (this is actually just a rendezvous port from which a tcp connection is established)
talk 517 udp like tenex link, but across machine - unfortunately, doesn't use link protocol (this is actually just a rendezvous port from which a tcp connection is established)
ntalk 518 tcp
ntalk 518 udp
utime 519 tcp unixtime
utime 519 udp unixtime
ripng 521 tcp ripng Robert E. Minnear Robert E. Minnear
ripng 521 udp ripng Robert E. Minnear Robert E. Minnear
conference 531 tcp chat
conference 531 udp chat
uucp-rlogin 541 tcp uucp-rlogin Stuart Lynne Stuart Lynne
uucp-rlogin 541 udp uucp-rlogin Stuart Lynne Stuart Lynne
dhcpv6-client 546 udp DHCPv6 Client IESG IETF Chair 2018-05-21 RFC 9915
dhcpv6-server 547 udp DHCPv6 Server IESG IETF Chair 2018-05-21 RFC 9915
cybercash 551 tcp cybercash Donald E. Eastlake 3rd Donald E. Eastlake 3rd RFC 1898
cybercash 551 udp cybercash Donald E. Eastlake 3rd Donald E. Eastlake 3rd RFC 1898
monitor 561 tcp
monitor 561 udp
meter 571 tcp udemon
meter 571 udp udemon
bdp 581 tcp Bundle Discovery Protocol Gary Malkin Gary Malkin
bdp 581 udp Bundle Discovery Protocol Gary Malkin Gary Malkin
http-alt 591 tcp FileMaker, Inc. - HTTP Alternate (see Port 80) Clay Maeckel Clay Maeckel
http-alt 591 udp FileMaker, Inc. - HTTP Alternate (see Port 80) Clay Maeckel Clay Maeckel
syslog-conn 601 tcp Reliable Syslog Service RFC 3195
syslog-conn 601 udp Reliable Syslog Service RFC 3195
npmp-local 610 tcp npmp-local
npmp-local 610 udp npmp-local
npmp-gui 611 tcp npmp-gui John Barnes John Barnes
npmp-gui 611 udp npmp-gui John Barnes John Barnes
hmmp-ind 612 tcp HMMP Indication
hmmp-ind 612 udp HMMP Indication
hmmp-op 613 tcp HMMP Operation Andrew Sinclair Andrew Sinclair
hmmp-op 613 udp HMMP Operation Andrew Sinclair Andrew Sinclair
sshell 614 tcp SSLshell Simon J. Gerraty Simon J. Gerraty
sshell 614 udp SSLshell Simon J. Gerraty Simon J. Gerraty
sco-inetmgr 615 tcp Internet Configuration Manager
sco-inetmgr 615 udp Internet Configuration Manager
sco-sysmgr 616 tcp SCO System Administration Server
sco-sysmgr 616 udp SCO System Administration Server
sco-dtmgr 617 tcp SCO Desktop Administration Server Christopher Durham Christopher Durham
sco-dtmgr 617 udp SCO Desktop Administration Server Christopher Durham Christopher Durham
dei-icda 618 tcp DEI-ICDA David Turner David Turner
dei-icda 618 udp DEI-ICDA David Turner David Turner
compaq-evm 619 tcp Compaq EVM Jem Treadwell Jem Treadwell
compaq-evm 619 udp Compaq EVM Jem Treadwell Jem Treadwell
escp-ip 621 tcp ESCP Lai Zit Seng Lai Zit Seng
escp-ip 621 udp ESCP Lai Zit Seng Lai Zit Seng
ipp 631 tcp IPP (Internet Printing Protocol) IESG IETF Chair 2018-07-06 RFC 8011 Defined TXT keys: See BonjourPrinting.pdf.
ipp 631 udp IPP (Internet Printing Protocol) IESG IETF Chair 2018-07-06 RFC 8011 Defined TXT keys: See BonjourPrinting.pdf.
ipps 631 tcp Internet Printing Protocol over HTTPS IESG IETF Chair 2018-07-06 RFC 8011
repcmd 641 tcp repcmd Scott Dale Scott Dale
repcmd 641 udp repcmd Scott Dale Scott Dale
esro-emsdp 642 tcp ESRO-EMSDP V1.3 Mohsen Banan Mohsen Banan
esro-emsdp 642 udp ESRO-EMSDP V1.3 Mohsen Banan Mohsen Banan
dhcp-failover 647 tcp DHCP Failover IESG IETF Chair 2018-05-21 RFC 8156
ieee-mms 651 tcp IEEE MMS Curtis Anderson Curtis Anderson
ieee-mms 651 udp IEEE MMS Curtis Anderson Curtis Anderson
hap 661 tcp HAP Igor Plotnikov Igor Plotnikov
hap 661 udp HAP Igor Plotnikov Igor Plotnikov
vacdsm-app 671 tcp VACDSM-APP
vacdsm-app 671 udp VACDSM-APP
entrust-aams 681 tcp entrust-aams Adrian Mancini Adrian Mancini
entrust-aams 681 udp entrust-aams Adrian Mancini Adrian Mancini
msexch-routing 691 tcp MS Exchange Routing David Lemson David Lemson
msexch-routing 691 udp MS Exchange Routing David Lemson David Lemson
epp 700 udp EPP running over QUIC IESG IETF Chair 2026-07-23 RFC 5734; RFC-ietf-regext-epp-quic-12
lmp 701 tcp Link Management Protocol (LMP) RFC 4204
lmp 701 udp Link Management Protocol (LMP) RFC 4204
entrust-ash 710 tcp Entrust Administration Service Handler Peter Whittaker Peter Whittaker
entrust-ash 710 udp Entrust Administration Service Handler Peter Whittaker Peter Whittaker
cisco-tdp 711 tcp Cisco TDP Bruce Davie Bruce Davie
cisco-tdp 711 udp Cisco TDP Bruce Davie Bruce Davie
tbrpf 712 tcp TBRPF RFC 3684
tbrpf 712 udp TBRPF RFC 3684
iris-xpc 713 tcp IRIS over XPC
iris-xpc 713 udp IRIS over XPC
iris-xpcs 714 tcp IRIS over XPCS RFC 4992
iris-xpcs 714 udp IRIS over XPCS RFC 4992
iris-lwz 715 tcp IRIS-LWZ RFC 4993
iris-lwz 715 udp IRIS-LWZ RFC 4993
pana 716 udp PANA Messages RFC 5191
717-728 Unassigned
netviewdm1 729 tcp IBM NetView DM/6000 Server/Client
netviewdm1 729 udp IBM NetView DM/6000 Server/Client
netviewdm3 731 tcp IBM NetView DM/6000 receive/tcp Philippe Binet Philippe Binet
netviewdm3 731 udp IBM NetView DM/6000 receive/tcp Philippe Binet Philippe Binet
netgw 741 tcp netGW Oliver Korfmacher Oliver Korfmacher

Contact Information

Name Organization Contact URI Last Updated
Adrian Mancini adrian.mancini&entrust.com
Andrew Sinclair andrsin&microsoft.com
Bruce Davie bsd&cisco.com
Christopher Durham chrisdu&sco.com
Clay Maeckel clay&claris.com 2023-09-12
Curtis Anderson canderson&turbolinux.com
Daniel Mavrakis system&venus.mctel.fr
David Lemson dlemson&microsoft.com
David Turner digital&quetico.tbaytel.net
Donald E. Eastlake 3rd d3e3e3&gmail.com
Gary Malkin gmalkin&xylogics.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Igor Plotnikov igor&uroam.com
Jem Treadwell Jem.Treadwell&compaq.com
John Barnes jbarnes&crl.com
John Rainford jrainford&passgo.com
Lai Zit Seng lzs&pobox.com
Mohsen Banan mohsen&neda.com
Oliver Korfmacher okorf&netcs.com
Peter Whittaker pww&entrust.com
Philippe Binet phbinet&vnet.ibm.com
Robert E. Minnear minnear&ipsilon.com
Scott Dale scott&replicase.com
Simon J. Gerraty sjg&quick.com.au
Stuart Lynne sl&wimsey.com