Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
talarian-tcp 5101 tcp Talarian_TCP Leo Martins Leo Martins
talarian-udp 5101 udp Talarian_UDP Leo Martins Leo Martins
oms-nonsecure 5102 tcp Oracle OMS non-secure Todd Guay Todd Guay 2005-08
oms-nonsecure 5102 udp Oracle OMS non-secure Todd Guay Todd Guay 2005-08
actifio-c2c 5103 tcp Actifio C2C Ravi Kollipara Ravi Kollipara 2010-06-18
5103 udp Reserved
5104 tcp Reserved
tinymessage 5104 udp TinyMessage Josip Medved Josip Medved 2010-10-20
5105 tcp Reserved
hughes-ap 5105 udp Hughes Association Protocol Varun Santosh Varun Santosh 2010-10-20
actifioudsagent 5106 tcp Actifio UDS Agent Actifio Madhav Mutalik 2014-06-05
5106 udp Reserved
actifioreplic 5107 tcp Disk to Disk replication between Actifio Clusters Actifio Madhav Mutalik 2015-10-23
5107 udp Reserved
5108-5110 Unassigned
scte104 5167 tcp SCTE104 Connection Thomas Russell Thomas Russell 2005-05
scte104 5167 udp SCTE104 Connection Thomas Russell Thomas Russell 2005-05
5210-5214 Unassigned
outlaws 5310 tcp Outlaws Richard Fife Richard Fife
outlaws 5310 udp Outlaws Richard Fife Richard Fife
pkix-cmc 5318 tcp PKIX Certificate Management using CMS (CMC) IESG IETF Chair 2026-02-13 RFC 10003
roughtime 5319 tcp Roughtime time synchronization IESG IETF Chair 2026-03-27 RFC 10049
roughtime 5319 udp Roughtime time synchronization IESG IETF Chair 2026-03-27 RFC 10049
salient-usrmgr 5410 tcp Salient User Manager Richard Farnham Richard Farnham
salient-usrmgr 5410 udp Salient User Manager Richard Farnham Richard Farnham
ats-atn 5910 tcp Air Traffic Services applications using ATN Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
ats-atn 5910 udp Air Traffic Services applications using ATN Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
cm 5910 sctp Context Management Justin Yu Justin Yu 2011-05-19
synchronet-db 6100 tcp SynchroNet-db Arne Haugland Arne Haugland Known Unauthorized Use on port 6100
synchronet-db 6100 udp SynchroNet-db Arne Haugland Arne Haugland Known Unauthorized Use on port 6100
synchronet-rtc 6101 tcp SynchroNet-rtc Arne Haugland Arne Haugland
synchronet-rtc 6101 udp SynchroNet-rtc Arne Haugland Arne Haugland
synchronet-upd 6102 tcp SynchroNet-upd Arne Haugland Arne Haugland
synchronet-upd 6102 udp SynchroNet-upd Arne Haugland Arne Haugland
rets 6103 tcp RETS Jeremy Crawford Jeremy Crawford
rets 6103 udp RETS Jeremy Crawford Jeremy Crawford
dbdb 6104 tcp DBDB Aaron Brick Aaron Brick
dbdb 6104 udp DBDB Aaron Brick Aaron Brick
primaserver 6105 tcp Prima Server Prima Designs Systems Ltd. Prima Designs Systems Ltd.
primaserver 6105 udp Prima Server Prima Designs Systems Ltd. Prima Designs Systems Ltd.
mpsserver 6106 tcp MPS Server Prima Designs Systems Ltd. Prima Designs Systems Ltd.
mpsserver 6106 udp MPS Server Prima Designs Systems Ltd. Prima Designs Systems Ltd.
etc-control 6107 tcp ETC Control Electronic Theatre Controls, Inc. ETC IANA Registration 2021-09-24
etc-control 6107 udp ETC Control Electronic Theatre Controls, Inc. ETC IANA Registration 2021-09-24
sercomm-scadmin 6108 tcp Sercomm-SCAdmin Melinda Tsao Melinda Tsao
sercomm-scadmin 6108 udp Sercomm-SCAdmin Melinda Tsao Melinda Tsao
globecast-id 6109 tcp GLOBECAST-ID Piers Scannell Piers Scannell
globecast-id 6109 udp GLOBECAST-ID Piers Scannell Piers Scannell
softcm 6110 tcp HP SoftBench CM Scott A. Kramer Scott A. Kramer
softcm 6110 udp HP SoftBench CM Scott A. Kramer Scott A. Kramer
6210-6221 Unassigned
boe-resssvr4 6410 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
ieee11073-20701 6464 tcp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
ieee11073-20701 6464 udp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
mcer-port 6510 tcp MCER Port Portnoy Boxman Portnoy Boxman
mcer-port 6510 udp MCER Port Portnoy Boxman Portnoy Boxman
bencher 6610 tcp Bencher API Bencher Everett Pompeii 2026-06-17
bencher 6610 udp Bencher API Bencher Everett Pompeii 2026-06-17
mpls-udp 6635 udp Encapsulate MPLS packets in UDP tunnels. IESG IETF Chair 2015-02-10 RFC 7510
mpls-udp-dtls 6636 udp Encapsulate MPLS packets in UDP tunnels with DTLS. IESG IETF Chair 2015-02-10 RFC 7510
ups-onlinet 7010 tcp onlinet uninterruptable power supplies Jim Thompson Jim Thompson
ups-onlinet 7010 udp onlinet uninterruptable power supplies Jim Thompson Jim Thompson
font-service 7100 tcp X Font Service Stephen Gildea Stephen Gildea
font-service 7100 udp X Font Service Stephen Gildea Stephen Gildea
elcn 7101 tcp Embedded Light Control Network Michael Scarito Michael Scarito 2007-02
elcn 7101 udp Embedded Light Control Network Michael Scarito Michael Scarito 2007-02
7102-7106 Unassigned
7107 tcp Reserved
aes-x170 7107 udp AES-X170 Richard Foss Richard Foss 2011-02-10
7108-7116 Unassigned
ionixnetmon 7410 tcp Ionix Network Monitor Maxime Renaud Maxime Renaud 2006-04
ionixnetmon 7410 udp Ionix Network Monitor Maxime Renaud Maxime Renaud 2006-04
ovhpas 7510 tcp HP OpenView Application Server Jeff Conrad Jeff Conrad
ovhpas 7510 udp HP OpenView Application Server Jeff Conrad Jeff Conrad
rbt-wanopt 7810 tcp Riverbed WAN Optimization Protocol Vladimir Legalov Vladimir Legalov 2007-09-04
rbt-wanopt 7810 udp Riverbed WAN Optimization Protocol Vladimir Legalov Vladimir Legalov 2007-09-04
8010 Reserved 2018-01-09 yes
xprint-server 8100 tcp Xprint Server John McKernan John McKernan
xprint-server 8100 udp Xprint Server John McKernan John McKernan
ldoms-migr 8101 tcp Logical Domains Migration Liam Merwick Liam Merwick 2009-01-16
8101 udp Reserved
kz-migr 8102 tcp Oracle Kernel zones migration server Oracle John Levon 2013-12-24
8102 udp Reserved
8103-8110 Unassigned
8209-8210 Unassigned
canon-mfnp 8610 tcp Canon MFNP Service Ritsuto Sako Ritsuto Sako 2009-05-04
canon-mfnp 8610 udp Canon MFNP Service Ritsuto Sako Ritsuto Sako 2009-05-04
semi-grpc 8710 tcp gRPC for SEMI Standards implementations SEMI Albert Fuchigami 2020-01-10
8710 udp Reserved
8810-8872 Unassigned
manyone-http 8910 tcp manyone-http Matt King Matt King 2002-04
manyone-http 8910 udp manyone-http Matt King Matt King 2002-04
sdr 9010 tcp Secure Data Replicator Protocol Sufyan Almajali Sufyan Almajali 2008-06-27
9010 udp Reserved
hp-pdl-datastr 9100 tcp PDL Data Streaming Port Shivaun Albright Shivaun Albright 2002-04
hp-pdl-datastr 9100 udp PDL Data Streaming Port Shivaun Albright Shivaun Albright 2002-04
pdl-datastream 9100 tcp Printer PDL Data Stream Stuart Cheshire Stuart Cheshire 2002-09 The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100.
pdl-datastream 9100 udp Printer PDL Data Stream Stuart Cheshire Stuart Cheshire 2002-09 The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100.
bacula-dir 9101 tcp Bacula Director Kern Sibbald Kern Sibbald 2002-01
bacula-dir 9101 udp Bacula Director Kern Sibbald Kern Sibbald 2002-01
bacula-fd 9102 tcp Bacula File Daemon Kern Sibbald Kern Sibbald 2002-01

Contact Information

Name Organization Contact URI Last Updated
Actifio madhav.mutalik&actifio.com 2015-10-23
Aaron Brick aa&lithic.org
Albert Fuchigami albert.fuchigami&peergroup.com 2020-01-10
Arne Haugland Arne.Haugland&parasoldev.com
Bencher info&bencher.dev 2026-06-17
David Gregorczyk david.gregorczyk&draeger.com 2017-03-02
Eivan Cerasi eivan.cerasi&eurocontrol.int 2022-08-08
Electronic Theatre Controls, Inc. ianaregistration&etcconnect.com 2021-09-24
ETC IANA Registration Electronic Theatre Controls, Inc. ianaregistration&etcconnect.com 2021-09-24
Everett Pompeii everett&bencher.dev 2026-06-17
Giriraj Harapanahalli giriraj.harapanahalli&sap.com 2026-05-27
Greg Saccone gregory.t.saccone&boeing.com 2022-08-08
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jeff Conrad jeff_conrad&hp.com
Jeremy Crawford jeremy&reso.org 2015-09-07
Jim Thompson jim.thompson&powerware.com
John Levon Oracle john.levon&oracle.com 2013-12-24
John McKernan John.McKernan&sun.com
Josip Medved jmedved&jmedved.com 2010-10-20
Justin Yu yyu&mitre.org 2011-05-25
Kern Sibbald kern&sibbald.com 2002-01
Leo Martins leo&talarian.com
Liam Merwick ldoms-iana-ports&sun.com 2009-01-16
Madhav Mutalik Actifio madhav.mutalik&actifio.com 2015-10-23
Matt King m&manyone.net 2002-04
Maxime Renaud maxdrenaud&gmail.com 2015-12-07
Melinda Tsao melinda_tsao&mail.sercomm.com.tw
Michael Scarito ms&mit.edu 2007-02
Oracle john.levon&oracle.com 2013-12-24
Piers Scannell piers&globecastne.com
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Prima Designs Systems Ltd. info&prima.com.hk
Ravi Kollipara ravi.kollipara&actifio.com 2010-06-18
Richard Farnham rfarnham&salient.com
Richard Fife richardf&lucasarts.com
Richard Foss r.foss&ru.ac.za 2011-02-10
Ritsuto Sako sakou.ritsuto&canon.co.jp 2009-05-04
SAP Giriraj Harapanahalli 2026-05-27
Scott A. Kramer sk&tleilaxu.sde.hp.com
SEMI jamano&semi.org 2020-01-10
Shivaun Albright shivaun_albright&hp.com 2002-04
Stephen Gildea gildea&lcs.mit.edu
Stuart Cheshire pdl-datastream&apple.com 2002-09
Sufyan Almajali sufyan.almajali&sdrlive.com 2008-06-27
Thomas Russell trussell&scte.org 2005-05
Todd Guay todd.guay&oracle.com 2005-08
Varun Santosh varun.santosh&hughes.com 2010-10-20
Vladimir Legalov vlegalov&riverbed.com 2007-09-04