Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 5118-5119 | Unassigned | ||||||||||
| 5311 | Unassigned | 2004-05-07 | |||||||||
| actnet | 5411 | tcp | ActNet | Simon Robillard | Simon Robillard | ||||||
| actnet | 5411 | udp | ActNet | Simon Robillard | Simon Robillard | ||||||
| ats-acars | 5911 | tcp | Air Traffic Services applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ats-acars | 5911 | udp | Air Traffic Services applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| cpdlc | 5911 | sctp | Controller Pilot Data Link Communication | Justin Yu | Justin Yu | 2011-05-18 | |||||
| x11 | 6000-6063 | tcp | X Window System | Stephen Gildea | Stephen Gildea | Known Unauthorized Use on port 6003 | |||||
| x11 | 6000-6063 | udp | X Window System | Stephen Gildea | Stephen Gildea | Known Unauthorized Use on port 6003 | |||||
| softcm | 6110 | tcp | HP SoftBench CM | Scott A. Kramer | Scott A. Kramer | ||||||
| softcm | 6110 | udp | HP SoftBench CM | Scott A. Kramer | Scott A. Kramer | ||||||
| spc | 6111 | tcp | HP SoftBench Sub-Process Control | Scott A. Kramer | Scott A. Kramer | ||||||
| spc | 6111 | udp | HP SoftBench Sub-Process Control | Scott A. Kramer | Scott A. Kramer | ||||||
| dtspcd | 6112 | tcp | Desk-Top Sub-Process Control Daemon | Doug Royer | Doug Royer | 2010-12-08 | |||||
| dtspcd | 6112 | udp | Desk-Top Sub-Process Control Daemon | Doug Royer | Doug Royer | 2010-12-08 | |||||
| dayliteserver | 6113 | tcp | Daylite Server | Brent Gulanowski | Brent Gulanowski | 2009-08-26 | |||||
| 6113 | udp | Reserved | |||||||||
| wrspice | 6114 | tcp | WRspice IPC Service | Stephen R. Whiteley | Stephen R. Whiteley | 2010-10-07 | |||||
| 6114 | udp | Reserved | |||||||||
| xic | 6115 | tcp | Xic IPC Service | Stephen R. Whiteley | Stephen R. Whiteley | 2010-10-07 | |||||
| 6115 | udp | Reserved | |||||||||
| xtlserv | 6116 | tcp | XicTools License Manager Service | Stephen R. Whiteley | Stephen R. Whiteley | 2010-10-07 | |||||
| 6116 | udp | Reserved | |||||||||
| daylitetouch | 6117 | tcp | Daylite Touch Sync | Brent Gulanowski | Brent Gulanowski | 2009-08-26 | |||||
| 6117 | udp | Reserved | |||||||||
| tipc | 6118 | udp | Transparent Inter Process Communication | Ericsson | Erik Hugne | 2012-09-05 | |||||
| 6118 | tcp | Reserved | |||||||||
| 6119-6120 | Unassigned | ||||||||||
| 6411-6416 | Unassigned | ||||||||||
| ieee11073-20701 | 6464 | tcp | Port assignment for medical device communication in accordance to IEEE 11073-20701 | David Gregorczyk | David Gregorczyk | 2017-03-02 | |||||
| ieee11073-20701 | 6464 | udp | Port assignment for medical device communication in accordance to IEEE 11073-20701 | David Gregorczyk | David Gregorczyk | 2017-03-02 | |||||
| 6511 | tcp | Reserved | |||||||||
| dccp-udp | 6511 | udp | Datagram Congestion Control Protocol Encapsulation for NAT Traversal | IESG | IETF Chair | RFC 6773 | |||||
| 6567 | Reserved | 2007-01 | 2011-08-26 | This entry has been removed on 2011-08-26. | |||||||
| 6611-6618 | Unassigned | ||||||||||
| frc-hp | 6704 | sctp | ForCES HP (High Priority) channel | RFC 5811 | |||||||
| frc-mp | 6705 | sctp | ForCES MP (Medium Priority) channel | RFC 5811 | |||||||
| frc-lp | 6706 | sctp | ForCES LP (Low priority) channel | RFC 5811 | |||||||
| talon-disc | 7011 | tcp | Talon Discovery Port | Jim Thompson | Jim Thompson | Known Unauthorized Use on 7011 | |||||
| talon-disc | 7011 | udp | Talon Discovery Port | Jim Thompson | Jim Thompson | Known Unauthorized Use on 7011 | |||||
| talon-engine | 7012 | tcp | Talon Engine | Jim Thompson | Jim Thompson | Known Unauthorized Use on 7011 | |||||
| talon-engine | 7012 | udp | Talon Engine | Jim Thompson | Jim Thompson | Known Unauthorized Use on 7011 | |||||
| 7108-7116 | Unassigned | ||||||||||
| rothaga | 7117 | tcp | Encrypted chat and file transfer service | Arcadian Computers | Jonathan Pollock | 2016-05-10 | |||||
| 7117 | udp | Reserved | |||||||||
| 7118-7120 | Unassigned | ||||||||||
| daqstream | 7411 | tcp | Streaming of measurement data | Hottinger Baldwin Messtechnik GmbH | Stephan Gatzka | 2013-03-15 | |||||
| daqstream | 7411 | udp | Streaming of measurement data | Hottinger Baldwin Messtechnik GmbH | Stephan Gatzka | 2013-03-15 | |||||
| pafec-lm | 7511 | tcp | pafec-lm | Billy Dhillon | Billy Dhillon | ||||||
| pafec-lm | 7511 | udp | pafec-lm | Billy Dhillon | Billy Dhillon | ||||||
| 7811-7844 | Unassigned | ||||||||||
| 8011-8014 | Unassigned | ||||||||||
| 8103-8110 | Unassigned | ||||||||||
| 8111 | tcp | Reserved | |||||||||
| skynetflow | 8111 | udp | Skynetflow network services | skynetflow.com | Dmitrii Ogarkov | 2019-05-28 | |||||
| 8112-8114 | Unassigned | ||||||||||
| mtl8000-matrix | 8115 | tcp | MTL8000 Matrix | David Pinch | David Pinch | 2002-04 | |||||
| mtl8000-matrix | 8115 | udp | MTL8000 Matrix | David Pinch | David Pinch | 2002-04 | |||||
| cp-cluster | 8116 | tcp | Check Point Clustering | Roni Moshitzky | Roni Moshitzky | ||||||
| cp-cluster | 8116 | udp | Check Point Clustering | Roni Moshitzky | Roni Moshitzky | ||||||
| purityrpc | 8117 | tcp | Purity replication clustering and remote management | Pure Storage | Steve Hodgson | 2013-08-13 | |||||
| 8117 | udp | Reserved | |||||||||
| privoxy | 8118 | tcp | Privoxy HTTP proxy | Andreas Oesterhelt | Andreas Oesterhelt | 2002-06 | |||||
| privoxy | 8118 | udp | Privoxy HTTP proxy | Andreas Oesterhelt | Andreas Oesterhelt | 2002-06 | |||||
| 8119-8120 | Unassigned | ||||||||||
| 8211 | tcp | Reserved | |||||||||
| aruba-papi | 8211 | udp | Aruba Networks AP management | Aruba Networks | Jon Green | 2018-10-04 | |||||
| canon-bjnp1 | 8611 | tcp | Canon BJNP Port 1 | Atsushi Nakamura | Atsushi Nakamura | 2003-11 | |||||
| canon-bjnp1 | 8611 | udp | Canon BJNP Port 1 | Atsushi Nakamura | Atsushi Nakamura | 2003-11 | |||||
| nvc | 8711 | tcp | Nuance Voice Control | Nuance Communications | Diego Negre | 2012-10-05 | |||||
| 8711 | udp | Reserved | |||||||||
| manyone-xml | 8911 | tcp | manyone-xml | Matt King | Matt King | 2002-04 | |||||
| manyone-xml | 8911 | udp | manyone-xml | Matt King | Matt King | 2002-04 | |||||
| 9011 | tcp | Reserved | |||||||||
| d-star | 9011 | udp | D-Star Routing digital voice+data for amateur radio | QuadNet2 USA IRC Network | Thomas A Early | 2018-03-16 | |||||
| 9108-9110 | Unassigned | ||||||||||
| hexxorecore | 9111 | tcp | Multiple Purpose, Distributed Message Bus | Hexxore | Patrick Roozeboom | 2018-07-31 | |||||
| hexxorecore | 9111 | udp | Multiple Purpose, Distributed Message Bus | Hexxore | Patrick Roozeboom | 2018-07-31 | |||||
| 9112-9118 | Unassigned | ||||||||||
| mxit | 9119 | tcp | MXit Instant Messaging | Marnus Freeman | Marnus Freeman | 2006-02 | |||||
| mxit | 9119 | udp | MXit Instant Messaging | Marnus Freeman | Marnus Freeman | 2006-02 | |||||
| oma-mlp-s | 9211 | tcp | OMA Mobile Location Protocol Secure | Hans Rohnert | Hans Rohnert | 2002-04 | |||||
| oma-mlp-s | 9211 | udp | OMA Mobile Location Protocol Secure | Hans Rohnert | Hans Rohnert | 2002-04 | |||||
| 9311 | Unassigned | ||||||||||
| 9601-9611 | Unassigned | ||||||||||
| x510 | 9877 | tcp | The X.510 wrapper protocol | ITU/TSB (ITU-T Study Group 17) | Erik Andersen | 2019-09-30 | ITU-T X.510 / ISO/IEC 9584-11 | ||||
| sype-transport | 9911 | tcp | SYPECom Transport Protocol | Sylvain Pedneault | Sylvain Pedneault | 2003-03 | |||||
| sype-transport | 9911 | udp | SYPECom Transport Protocol | Sylvain Pedneault | Sylvain Pedneault | 2003-03 | |||||
| 10011-10019 | Unassigned | ||||||||||
| nmea-0183 | 10110 | tcp | NMEA-0183 Navigational Data | Meindert Sprang | Meindert Sprang | 2009-02-18 | |||||
| nmea-0183 | 10110 | udp | NMEA-0183 Navigational Data | Meindert Sprang | Meindert Sprang | 2009-02-18 | |||||
| 10111 | tcp | Reserved | |||||||||
| nmea-onenet | 10111 | udp | NMEA OneNet multicast messaging | National Marine Electronics Association | Mark Oslund | 2011-09-15 | 2023-12-27 | ||||
| 10112 | Unassigned | ||||||||||
| netiq-endpoint | 10113 | tcp | NetIQ Endpoint | John Wood | John Wood | ||||||
| netiq-endpoint | 10113 | udp | NetIQ Endpoint | John Wood | John Wood | ||||||
| netiq-qcheck | 10114 | tcp | NetIQ Qcheck | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| netiq-qcheck | 10114 | udp | NetIQ Qcheck | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| netiq-endpt | 10115 | tcp | NetIQ Endpoint | Gary Weichinger | Gary Weichinger | ||||||
| netiq-endpt | 10115 | udp | NetIQ Endpoint | Gary Weichinger | Gary Weichinger | ||||||
| netiq-voipa | 10116 | tcp | NetIQ VoIP Assessor | Gary Weichinger | Gary Weichinger |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andreas Oesterhelt | oes&privoxy.org | 2002-06 | |
| Arcadian Computers | support&arcadiancomputers.com | 2016-05-10 | |
| Aruba Networks | jon.green&hpe.com | 2018-10-04 | |
| Atsushi Nakamura | nakamura.atsushi318&canon.co.jp | 2003-11 | |
| Billy Dhillon | bdsos&pafec.co.uk | ||
| Brent Gulanowski | bgulanowski&marketcircle.com | 2009-08-26 | |
| David Gregorczyk | david.gregorczyk&draeger.com | 2017-03-02 | |
| David Pinch | dpinch&mtl-inst.com | 2002-04 | |
| Diego Negre | Nuance Communications | Diego.Negre&nuance.com | 2012-10-05 |
| Dmitrii Ogarkov | df&skynetflow.com | 2019-05-28 | |
| Doug Royer | DouglasRoyer&gmail.com | 2010-12-09 | |
| Eivan Cerasi | eivan.cerasi&eurocontrol.int | 2022-08-08 | |
| Ericsson | erik.hugne&ericsson.com | 2012-09-05 | |
| Erik Andersen | era&x500.eu | 2019-08-13 | |
| Erik Hugne | Ericsson | erik.hugne&ericsson.com | 2012-09-05 |
| Gary Weichinger | gary.weichinger&netiq.com | ||
| Greg Saccone | gregory.t.saccone&boeing.com | 2022-08-08 | |
| Hans Rohnert | hans.rohnert&siemens.com | 2002-04 | |
| Hexxore | info&hexxore.nl | 2018-07-31 | |
| Hottinger Baldwin Messtechnik GmbH | stephan.gatzka&hbm.com | 2013-03-15 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| ITU/TSB (ITU-T Study Group 17) | tsbsg17&itu.int | 2019-09-30 | |
| Jim Thompson | jim.thompson&powerware.com | ||
| John Wood | John.Wood&netiq.com | ||
| Jon Green | Aruba Networks | jon.green&hpe.com | 2018-10-04 |
| Jonathan Pollock | jon&arcadiancomputers.com | 2016-05-10 | |
| Justin Yu | yyu&mitre.org | 2011-05-25 | |
| Mark Oslund | National Marine Electronics Association | info&nmea.org | 2023-12-27 |
| Marnus Freeman | marnus&swistgroup.com | 2006-02 | |
| Matt King | m&manyone.net | 2002-04 | |
| Meindert Sprang | ms&customware.nl | 2009-02-18 | |
| Michael Sharpe | iana-ports&netiq.com | 2010-09-14 | |
| National Marine Electronics Association | standards&nmea.org | 2023-12-27 | |
| Nuance Communications | NOD_SolutionsArchitecture&nuance.com | 2012-10-05 | |
| Patrick Roozeboom | info&hexxore.nl | 2018-07-31 | |
| Pure Storage | iana&purestorage.com | 2016-04-04 | |
| QuadNet2 USA IRC Network | admins&openquad.net | 2018-03-16 | |
| Roni Moshitzky | rmosh&checkpoint.com | ||
| Scott A. Kramer | sk&tleilaxu.sde.hp.com | ||
| Simon Robillard | RobillardS&actresearch.com | ||
| skynetflow.com | info&skynetflow.com | 2019-05-28 | |
| Stephan Gatzka | Hottinger Baldwin Messtechnik GmbH | stephan.gatzka&hbm.com | 2013-03-15 |
| Stephen Gildea | gildea&lcs.mit.edu | ||
| Stephen R. Whiteley | stevew&wrcad.com | 2010-10-07 | |
| Steve Hodgson | Pure Storage | steve&purestorage.com | 2013-08-13 |
| Sylvain Pedneault | sylvain&sypecom.qc.ca | 2003-03 | |
| Thomas A Early | tom.n7tae&tearly.net | 2018-03-16 |