Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| dtn-bundle | 4556 | udp | DTN Bundle UDP CL Protocol | 2006-11 | 2014-02-21 | RFC 7122 | |||||
| dtn-bundle | 4556 | dccp | DTN Bundle DCCP CL Protocol | 2013-11-12 | 2014-02-21 | RFC 7122 | 1685351985 | ||||
| 4712-4724 | Unassigned | ||||||||||
| lutap | 4912 | tcp | Technicolor LUT Access Protocol | Markus Loeffler | Markus Loeffler | 2009-02-17 | |||||
| 4912 | udp | Reserved | |||||||||
| nsp | 5012 | tcp | NetOnTap Service | Kim Hancock | Kim Hancock | 2007-10-24 | |||||
| nsp | 5012 | udp | NetOnTap Service | Kim Hancock | Kim Hancock | 2007-10-24 | |||||
| pm-cmdsvr | 5112 | tcp | PeerMe Msg Cmd Service | Marcos Della | Marcos Della | 2005-08 | |||||
| pm-cmdsvr | 5112 | udp | PeerMe Msg Cmd Service | Marcos Della | Marcos Della | 2005-08 | |||||
| barracuda-bbs | 5120 | tcp | Barracuda Backup Protocol | Barracuda Networks | Andrew Blyler | 2013-04-05 | |||||
| barracuda-bbs | 5120 | udp | Barracuda Backup Protocol | Barracuda Networks | Andrew Blyler | 2013-04-05 | |||||
| 5121-5132 | Unassigned | ||||||||||
| xmpp-client | 5222 | tcp | XMPP Client Connection | RFC 6120 | |||||||
| xmpp-server | 5269 | tcp | XMPP Server Connection | RFC 6120 | |||||||
| permabit-cs | 5312 | tcp | Permabit Client-Server | Jered Floyd | Jered Floyd | 2004-06 | |||||
| permabit-cs | 5312 | udp | Permabit Client-Server | Jered Floyd | Jered Floyd | 2004-06 | |||||
| continuus | 5412 | tcp | Continuus | Steven Holtsberg | Steven Holtsberg | ||||||
| continuus | 5412 | udp | Continuus | Steven Holtsberg | Steven Holtsberg | ||||||
| 5706-5712 | Unassigned | ||||||||||
| 5799-5812 | Unassigned | ||||||||||
| ais-met | 5912 | tcp | Aeronautical Information Service/Meteorological applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ais-met | 5912 | udp | Aeronautical Information Service/Meteorological applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| fis | 5912 | sctp | Flight Information Services | Justin Yu | Justin Yu | 2011-05-25 | |||||
| dtspcd | 6112 | tcp | Desk-Top Sub-Process Control Daemon | Doug Royer | Doug Royer | 2010-12-08 | |||||
| dtspcd | 6112 | udp | Desk-Top Sub-Process Control Daemon | Doug Royer | Doug Royer | 2010-12-08 | |||||
| 6119-6120 | Unassigned | ||||||||||
| spdy | 6121 | tcp | SPDY for a faster web | Matthew Lloyd | Matthew Lloyd | 2010-04-26 | |||||
| 6121 | udp | Reserved | |||||||||
| bex-webadmin | 6122 | tcp | Backup Express Web Server | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| bex-webadmin | 6122 | udp | Backup Express Web Server | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| backup-express | 6123 | tcp | Backup Express | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| backup-express | 6123 | udp | Backup Express | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| pnbs | 6124 | tcp | Phlexible Network Backup Service | William R. Lear | William R. Lear | 2008-10-23 | |||||
| pnbs | 6124 | udp | Phlexible Network Backup Service | William R. Lear | William R. Lear | 2008-10-23 | |||||
| 6125-6129 | Unassigned | ||||||||||
| 6512-6512 | Unassigned | ||||||||||
| syslog-tls | 6514 | udp | syslog over DTLS | RFC 6012 | |||||||
| syslog-tls | 6514 | dccp | syslog over DTLS | RFC 6012 | |||||||
| talon-engine | 7012 | tcp | Talon Engine | Jim Thompson | Jim Thompson | Known Unauthorized Use on 7011 | |||||
| talon-engine | 7012 | udp | Talon Engine | Jim Thompson | Jim Thompson | Known Unauthorized Use on 7011 | |||||
| 7118-7120 | Unassigned | ||||||||||
| virprot-lm | 7121 | tcp | Virtual Prototypes License Manager | Victor Galis | Victor Galis | ||||||
| virprot-lm | 7121 | udp | Virtual Prototypes License Manager | Victor Galis | Victor Galis | ||||||
| 7122 | Unassigned | ||||||||||
| snif | 7123 | tcp | SNIF End-to-End TLS Relay Control Connection | VESvault Corp | Jim Zubov | 2021-12-24 | 2026-07-22 | draft-zubov-snif-05, Section 4.3 | |||
| snif | 7123 | udp | SNIF End-to-End TLS Relay over QUIC | VESvault Corp | Jim Zubov | 2026-07-22 | 2026-07-22 | draft-zubov-snif-05, Section 4.4 | |||
| 7124-7127 | Unassigned | ||||||||||
| scenidm | 7128 | tcp | intelligent data manager | Paul Ignatius | Paul Ignatius | 2006-03 | |||||
| scenidm | 7128 | udp | intelligent data manager | Paul Ignatius | Paul Ignatius | 2006-03 | |||||
| scenccs | 7129 | tcp | Catalog Content Search | Anil Sharma | Anil Sharma | 2006-04 | |||||
| scenccs | 7129 | udp | Catalog Content Search | Anil Sharma | Anil Sharma | 2006-04 | |||||
| 7412-7419 | Unassigned | ||||||||||
| 7512-7541 | Unassigned | ||||||||||
| raqmon-pdu | 7744 | tcp | RAQMON PDU | RFC 4712 | |||||||
| raqmon-pdu | 7744 | udp | RAQMON PDU | RFC 4712 | |||||||
| 7904-7912 | Unassigned | ||||||||||
| 8012-8014 | Unassigned | ||||||||||
| 8112-8114 | Unassigned | ||||||||||
| 8119-8120 | Unassigned | ||||||||||
| apollo-data | 8121 | tcp | Apollo Data Port | Anthony Carrabino | Anthony Carrabino | 2003-08 | |||||
| apollo-data | 8121 | udp | Apollo Data Port | Anthony Carrabino | Anthony Carrabino | 2003-08 | |||||
| apollo-admin | 8122 | tcp | Apollo Admin Port | Anthony Carrabino | Anthony Carrabino | 2003-08 | |||||
| apollo-admin | 8122 | udp | Apollo Admin Port | Anthony Carrabino | Anthony Carrabino | 2003-08 | |||||
| 8123-8127 | Unassigned | ||||||||||
| paycash-online | 8128 | tcp | PayCash Online Protocol | MegaZone | MegaZone | 2005-08 | |||||
| paycash-online | 8128 | udp | PayCash Online Protocol | MegaZone | MegaZone | 2005-08 | |||||
| paycash-wbp | 8129 | tcp | PayCash Wallet-Browser | MegaZone | MegaZone | 2005-08 | |||||
| paycash-wbp | 8129 | udp | PayCash Wallet-Browser | MegaZone | MegaZone | 2005-08 | |||||
| 8212-8229 | Unassigned | ||||||||||
| 8302-8312 | Unassigned | ||||||||||
| canon-bjnp2 | 8612 | tcp | Canon BJNP Port 2 | Atsushi Nakamura | Atsushi Nakamura | 2003-11 | |||||
| canon-bjnp2 | 8612 | udp | Canon BJNP Port 2 | Atsushi Nakamura | Atsushi Nakamura | 2003-11 | |||||
| 8712-8731 | Unassigned | ||||||||||
| wcbackup | 8912 | tcp | Windows Client Backup | Jim Lyon | Jim Lyon | 2005-11 | |||||
| wcbackup | 8912 | udp | Windows Client Backup | Jim Lyon | Jim Lyon | 2005-11 | |||||
| 9012-9019 | Unassigned | ||||||||||
| 9112-9118 | Unassigned | ||||||||||
| 9120-9121 | Unassigned | ||||||||||
| grcmp | 9122 | tcp | Global Relay compliant mobile instant messaging protocol | Global Relay Communications Inc | Lu Vo | 2012-11-28 | 2025-06-12 | ||||
| 9122 | udp | Reserved | |||||||||
| grcp | 9123 | tcp | Global Relay compliant instant messaging protocol | Global Relay Communications Inc | Lu Vo | 2012-11-28 | 2025-06-12 | ||||
| 9123 | udp | Reserved | |||||||||
| 9124-9130 | Unassigned | ||||||||||
| serverviewdbms | 9212 | tcp | Server View dbms access | Detlef Rothe | Detlef Rothe | 2009-05-15 | |||||
| serverviewdbms | 9212 | udp | Server View dbms access | Detlef Rothe | Detlef Rothe | 2009-05-15 | |||||
| sphinxapi | 9312 | tcp | Sphinx search server | Andrew Aksyonoff | Andrew Aksyonoff | 2009-10-20 | |||||
| 9312 | udp | Reserved | |||||||||
| streamcomm-ds | 9612 | tcp | StreamComm User Directory | Brian C. Wiles | Brian C. Wiles | ||||||
| streamcomm-ds | 9612 | udp | StreamComm User Directory | Brian C. Wiles | Brian C. Wiles | ||||||
| kca-service | 9878 | udp | The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 | IESG | IETF Chair | 2012-07-12 | RFC 6717 | Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements. | |||
| 9912-9924 | Unassigned | ||||||||||
| 10112 | Unassigned | ||||||||||
| 10118-10124 | Unassigned | ||||||||||
| cimple | 10125 | tcp | HotLink CIMple REST API | HotLink Corporation | Richard Offer | 2014-12-18 | |||||
| 10125 | udp | Reserved | |||||||||
| 10126-10127 | Unassigned | ||||||||||
| bmc-perf-sd | 10128 | tcp | BMC-PERFORM-SERVICE DAEMON | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-perf-sd | 10128 | udp | BMC-PERFORM-SERVICE DAEMON | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-gms | 10129 | tcp | BMC General Manager Server | Dima Seliverstov | Dima Seliverstov | 2009-07-28 | |||||
| 10129 | udp | Reserved | |||||||||
| 10321 | tcp | Reserved | 2023-12-05 | De-Assigned on 2023-12-05. |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andrew Aksyonoff | shodan&sphinxsearch.com | 2009-10-20 | |
| Andrew Blyler | Barracuda Networks | ablyler&barracuda.com | 2013-04-05 |
| Anil Sharma | anil.sharma&scentric.com | 2006-04 | |
| Anthony Carrabino | anthonyc&vistasoftware.com | 2003-08 | |
| Atsushi Nakamura | nakamura.atsushi318&canon.co.jp | 2003-11 | |
| Barracuda Networks | BackupEngineering_Team&barracuda.com | 2013-04-05 | |
| Brian C. Wiles | brian&streamcomm.com | ||
| Catalogic Software, Inc. | cchang&catalogicsoftware.com | 2015-02-04 | |
| Chi Shih Chang | Catalogic Software, Inc. | cchang&catalogicsoftware.com | 2015-02-04 |
| Detlef Rothe | detlef.rothe&ts.fujitsu.com | 2009-05-15 | |
| Dima Seliverstov | Dima_Seliverstov&bmc.com | 2009-07-28 | |
| Doug Royer | DouglasRoyer&gmail.com | 2010-12-09 | |
| Eivan Cerasi | eivan.cerasi&eurocontrol.int | 2022-08-08 | |
| Global Relay Communications Inc | info&globalrelay.net | 2025-06-12 | |
| Greg Saccone | gregory.t.saccone&boeing.com | 2022-08-08 | |
| HotLink Corporation | roffer&hotlink.com | 2014-12-18 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jered Floyd | jered&permabit.com | 2004-06 | |
| Jim Lyon | JimLyonµsoft.com | 2005-11 | |
| Jim Thompson | jim.thompson&powerware.com | ||
| Jim Zubov | VESvault Corp | jz&vesvault.com | 2021-12-29 |
| Justin Yu | yyu&mitre.org | 2011-05-25 | |
| Kim Hancock | registry&dragondex.com | 2007-10-24 | |
| Lu Vo | Global Relay Communications Inc | lu.vo&globalrelay.net | 2025-06-12 |
| Marcos Della | mdella&peerme.com | 2005-08 | |
| Markus Loeffler | markus.loeffler&thomson.net | 2009-02-17 | |
| Matthew Lloyd | mlloyd&google.com | 2010-04-26 | |
| MegaZone | megazone&paycash.us | 2005-08 | |
| Paul Ignatius | paul.ignatius&scentric.com | 2006-03 | |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Richard Offer | HotLink Corporation | roffer&hotlink.com | 2014-12-18 |
| Steven Holtsberg | steveh&continuus.com | ||
| VESvault Corp | info&vesvault.com | 2021-12-29 | |
| Victor Galis | galis&satchmo.virtualprototypes.ca | ||
| William R. Lear | wlear&phlexible.com | 2008-10-23 |