Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-09
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER REGISTERED OR NOT.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| oidocsvc | 4142 | udp | Document Server | ||||||||
| oidsr | 4143 | tcp | Document Replication | Norman Brie | Norman Brie | ||||||
| oidsr | 4143 | udp | Document Replication | Norman Brie | Norman Brie | ||||||
| 4144 | Unassigned | Compuserve (unoffically) is using port 4144 | |||||||||
| vvr-control | 4145 | tcp | VVR Control | Ming Xu | Ming Xu | ||||||
| vvr-control | 4145 | udp | VVR Control | Ming Xu | Ming Xu | ||||||
| tgcconnect | 4146 | tcp | TGCConnect Beacon | Brian Becker | Brian Becker | 2006-10 | |||||
| tgcconnect | 4146 | udp | TGCConnect Beacon | Brian Becker | Brian Becker | 2006-10 | |||||
| vrxpservman | 4147 | tcp | Multum Service Manager | Scott Mager | Scott Mager | 2006-10 | |||||
| vrxpservman | 4147 | udp | Multum Service Manager | Scott Mager | Scott Mager | 2006-10 | |||||
| hhb-handheld | 4148 | tcp | HHB Handheld Client | Steven G. Loughner | Steven G. Loughner | 2007-03 | |||||
| hhb-handheld | 4148 | udp | HHB Handheld Client | Steven G. Loughner | Steven G. Loughner | 2007-03 | |||||
| agslb | 4149 | tcp | A10 GSLB Service | John Chiong | John Chiong | 2007-07-02 | |||||
| agslb | 4149 | udp | A10 GSLB Service | John Chiong | John Chiong | 2007-07-02 | |||||
| choiceview-agt | 4314 | tcp | ChoiceView Agent | Radish Systems | Richard A. Davis | 2013-03-28 | |||||
| 4314 | udp | Reserved | |||||||||
| updog | 4414 | tcp | Updog Monitoring and Status Framework | Egon Technologies, LLC | James Downs | 2015-10-05 | |||||
| 4414 | udp | Reserved | |||||||||
| bones | 4914 | tcp | Bones Remote Control | Andreas Foedrowitz | Andreas Foedrowitz | 2008-06-18 | |||||
| bones | 4914 | udp | Bones Remote Control | Andreas Foedrowitz | Andreas Foedrowitz | 2008-06-18 | |||||
| 5014 | tcp | Reserved | |||||||||
| onpsocket | 5014 | udp | Overlay Network Protocol | Roger Matthias | Roger Matthias | 2009-08-24 | |||||
| ev-services | 5114 | tcp | Enterprise Vault Services | Richard Jones | Richard Jones | 2009-05-26 | |||||
| 5114 | udp | Reserved | |||||||||
| 5138-5144 | Unassigned | ||||||||||
| rmonitor-secure | 5145 | tcp | RMONITOR SECURE IANA assigned this well-formed service name as a replacement for "rmonitor_secure". |
Kory Hamzeh | Kory Hamzeh | ||||||
| rmonitor_secure | 5145 | tcp | RMONITOR SECURE | Kory Hamzeh | Kory Hamzeh | This entry is an alias to "rmonitor-secure". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| rmonitor-secure | 5145 | udp | RMONITOR SECURE IANA assigned this well-formed service name as a replacement for "rmonitor_secure". |
Kory Hamzeh | Kory Hamzeh | ||||||
| rmonitor_secure | 5145 | udp | RMONITOR SECURE | Kory Hamzeh | Kory Hamzeh | This entry is an alias to "rmonitor-secure". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| social-alarm | 5146 | tcp | Social Alarm Service | Shaun Byrne | Shaun Byrne | 2009-08-18 | |||||
| 5146 | udp | Reserved | |||||||||
| 5147-5149 | Unassigned | ||||||||||
| 5210-5214 | Unassigned | ||||||||||
| opalis-rbt-ipc | 5314 | tcp | opalis-rbt-ipc | Laurent Domenech | Laurent Domenech | ||||||
| opalis-rbt-ipc | 5314 | udp | opalis-rbt-ipc | Laurent Domenech | Laurent Domenech | ||||||
| statusd | 5414 | tcp | StatusD | Stephen Misel | Stephen Misel | ||||||
| statusd | 5414 | udp | StatusD | Stephen Misel | Stephen Misel | ||||||
| prosharevideo | 5714 | tcp | proshare conf video | gunner | gunner | ||||||
| prosharevideo | 5714 | udp | proshare conf video | gunner | gunner | ||||||
| spt-automation | 5814 | tcp | Support Automation | Joshua Hawkins | Joshua Hawkins | 2003-11 | |||||
| spt-automation | 5814 | udp | Support Automation | Joshua Hawkins | Joshua Hawkins | 2003-11 | |||||
| rfb | 5900 | tcp | Remote Framebuffer | Tristan Richardson | Tristan Richardson | 2006-03 | RFC 6143 | ||||
| rfb | 5900 | udp | Remote Framebuffer | Tristan Richardson | Tristan Richardson | 2006-03 | RFC 6143 | ||||
| ipsdtls | 5914 | tcp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| ipsdtls | 5914 | udp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| ipsdtls | 5914 | sctp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| wrspice | 6114 | tcp | WRspice IPC Service | Stephen R. Whiteley | Stephen R. Whiteley | 2010-10-07 | |||||
| 6114 | udp | Reserved | |||||||||
| pulsonixnls | 6140 | tcp | Pulsonix Network License Service | David Manns | David Manns | 2008-02-28 | |||||
| pulsonixnls | 6140 | udp | Pulsonix Network License Service | David Manns | David Manns | 2008-02-28 | |||||
| meta-corp | 6141 | tcp | Meta Corporation License Manager | Osamu Masuda | Osamu Masuda | ||||||
| meta-corp | 6141 | udp | Meta Corporation License Manager | Osamu Masuda | Osamu Masuda | ||||||
| aspentec-lm | 6142 | tcp | Aspen Technology License Manager | Kevin Massey | Kevin Massey | ||||||
| aspentec-lm | 6142 | udp | Aspen Technology License Manager | Kevin Massey | Kevin Massey | ||||||
| watershed-lm | 6143 | tcp | Watershed License Manager | David Ferrero | David Ferrero | ||||||
| watershed-lm | 6143 | udp | Watershed License Manager | David Ferrero | David Ferrero | ||||||
| statsci1-lm | 6144 | tcp | StatSci License Manager - 1 | Scott Blachowicz | Scott Blachowicz | ||||||
| statsci1-lm | 6144 | udp | StatSci License Manager - 1 | Scott Blachowicz | Scott Blachowicz | ||||||
| statsci2-lm | 6145 | tcp | StatSci License Manager - 2 | Scott Blachowicz | Scott Blachowicz | ||||||
| statsci2-lm | 6145 | udp | StatSci License Manager - 2 | Scott Blachowicz | Scott Blachowicz | ||||||
| lonewolf-lm | 6146 | tcp | Lone Wolf Systems License Manager | Dan Klein | Dan Klein | ||||||
| lonewolf-lm | 6146 | udp | Lone Wolf Systems License Manager | Dan Klein | Dan Klein | ||||||
| montage-lm | 6147 | tcp | Montage License Manager | Michael Ubell | Michael Ubell | ||||||
| montage-lm | 6147 | udp | Montage License Manager | Michael Ubell | Michael Ubell | ||||||
| ricardo-lm | 6148 | tcp | Ricardo North America License Manager | M Flemming | M Flemming | ||||||
| ricardo-lm | 6148 | udp | Ricardo North America License Manager | M Flemming | M Flemming | ||||||
| tal-pod | 6149 | tcp | tal-pod | Steven Loomis | Steven Loomis | ||||||
| tal-pod | 6149 | udp | tal-pod | Steven Loomis | Steven Loomis | ||||||
| 6307-6314 | Unassigned | ||||||||||
| syslog-tls | 6514 | tcp | Syslog over TLS | RFC 5425 | |||||||
| syslog-tls | 6514 | udp | syslog over DTLS | RFC 6012 | |||||||
| syslog-tls | 6514 | dccp | syslog over DTLS | RFC 6012 | |||||||
| ibprotocol | 6714 | tcp | Internet Backplane Protocol | Alessandro Bassi | Alessandro Bassi | ||||||
| ibprotocol | 6714 | udp | Internet Backplane Protocol | Alessandro Bassi | Alessandro Bassi | ||||||
| microtalon-com | 7014 | tcp | Microtalon Communications | Jim Thompson | Jim Thompson | ||||||
| microtalon-com | 7014 | udp | Microtalon Communications | Jim Thompson | Jim Thompson | ||||||
| 7203-7214 | Unassigned | ||||||||||
| 7914-7931 | Unassigned | ||||||||||
| 8011-8014 | Unassigned | ||||||||||
| 8112-8114 | Unassigned | ||||||||||
| puppet | 8140 | tcp | The Puppet master service | Puppet | Charles Dunbar | 2014-09-18 | |||||
| 8140 | udp | Reserved | |||||||||
| 8141-8147 | Unassigned | ||||||||||
| isdd | 8148 | tcp | i-SDD file transfer | Frank Waarsenburg | Frank Waarsenburg | 2004-11 | |||||
| isdd | 8148 | udp | i-SDD file transfer | Frank Waarsenburg | Frank Waarsenburg | 2004-11 | |||||
| 8149 | tcp | Reserved | |||||||||
| eor-game | 8149 | udp | Edge of Reality game data | Sky Schulz | Sky Schulz | 2011-05-09 | |||||
| 8314-8319 | Unassigned | ||||||||||
| 8406-8414 | Unassigned | ||||||||||
| canon-bjnp4 | 8614 | tcp | Canon BJNP Port 4 | Atsushi Nakamura | Atsushi Nakamura | 2003-11 | |||||
| canon-bjnp4 | 8614 | udp | Canon BJNP Port 4 | Atsushi Nakamura | Atsushi Nakamura | 2003-11 | |||||
| 8914-8936 | Unassigned | ||||||||||
| ipdcesgbs | 9214 | tcp | IPDC ESG BootstrapService | Joerg Heuer | Joerg Heuer | 2006-02 | |||||
| ipdcesgbs | 9214 | udp | IPDC ESG BootstrapService | Joerg Heuer | Joerg Heuer | 2006-02 | |||||
| iadt-tls | 9614 | tcp | iADT Protocol over TLS | Paul A. Suhler | Paul A. Suhler | 2009-02-05 | |||||
| 9614 | udp | Reserved | |||||||||
| netiq-qcheck | 10114 | tcp | NetIQ Qcheck | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| netiq-qcheck | 10114 | udp | NetIQ Qcheck | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| 11372-11429 | Unassigned | ||||||||||
| lsdp | 11430 | udp | Lenbrook Service Discovery Protocol | Lenbrook Industries Limited | Kevin Groeneveld | 2014-03-27 | |||||
| 11430 | tcp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alessandro Bassi | abassi&cs.utk.edu | ||
| Andreas Foedrowitz | andreas.foedrowitz&thomson.net | 2008-06-18 | |
| Atsushi Nakamura | nakamura.atsushi318&canon.co.jp | 2003-11 | |
| Brian Becker | bbecker&tgc-usa.com | 2006-10 | |
| Charles Dunbar | Puppet | charles&puppet.com | 2016-04-12 |
| Dan Klein | daniel.v.klein&gmail.com | 2018-08-21 | |
| David Ferrero | david&zion.com | ||
| David Manns | davidm&pulsonix.com | 2008-02-28 | |
| Egon Technologies, LLC | james.downs&egontech.com | 2015-10-05 | |
| Frank Waarsenburg | frank&eye-display.nl | 2004-11 | |
| International Civil Aviation Organisation (ICAO) | gisinbox&icao.int | 2024-11-19 | |
| James Downs | james.downs&egontech.com | 2015-10-05 | |
| Jim Thompson | jim.thompson&powerware.com | ||
| Joerg Heuer | Joerg.Heuer&siemens.com | 2006-02 | |
| John Chiong | jchiong&a10networks.com | 2007-07-02 | |
| Joshua Hawkins | joshua.hawkins&hp.com | 2003-11 | |
| Kevin Groeneveld | Lenbrook Industries Limited | kgroeneveld&lenbrook.com | 2014-03-27 |
| Kevin Massey | massey&aspentec.com | ||
| Kory Hamzeh | kory&ascend.com | ||
| Laurent Domenech | Opalis | ldomenech&opalis.com | |
| Lenbrook Industries Limited | tsonderskov&lenbrook.com | 2014-03-27 | |
| M Flemming | mflemming&aol.com | ||
| Michael Sharpe | iana-ports&netiq.com | 2010-09-14 | |
| Michael Ubell | michael&montage.com | ||
| Ming Xu | ming&veritas.com | ||
| Nathan Lackey | nathan.lackey&boeing.com | 2024-11-19 | |
| Norman Brie | norm_brie&sns.ca | ||
| Osamu Masuda | |||
| Paul A. Suhler | paul.suhler&quantum.com | 2009-02-06 | |
| Puppet | sysops-dept&puppetlabs.com | 2016-04-12 | |
| Radish Systems | rad&radishsystems.com | 2013-03-28 | |
| Richard A. Davis | Radish Systems | rad&radishsystems.com | 2013-03-28 |
| Richard Jones | richard_jones1&symantec.com | 2009-05-26 | |
| Roger Matthias | rogermatthias&yahoo.co.uk | 2009-08-24 | |
| Scott Blachowicz | scott&statsci.com | ||
| Scott Mager | Scott.Mager&cerner.com | 2006-10 | |
| Shaun Byrne | s_byrne&tunstall.co.uk | 2009-08-18 | |
| Sky Schulz | sky&edgeofreality.com | 2011-05-09 | |
| Stephen Misel | steve&satelnet.org | ||
| Stephen R. Whiteley | stevew&wrcad.com | 2010-10-07 | |
| Steven G. Loughner | stevengloughner&eaton.com | 2007-03 | |
| Steven Loomis | srl&taligent.com | ||
| Tristan Richardson | iana&realvnc.com | 2006-03 | |
| gunner&ibeam.intel.com |