Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 4315 | Unassigned | Unauthorized Use Known on port 4315 | |||||||||
| 4324 | Reserved | 2015-05-12 | This entry is being removed on 2015-05-12. | ||||||||
| brcd-vr-req | 4415 | tcp | Brocade Virtual Router Request | Brocade Communications Systems | Nick Carter | 2015-11-17 | |||||
| 4415 | udp | Reserved | |||||||||
| ntske | 4460 | tcp | Network Time Security Key Establishment | IESG | IETF Chair | 2020-04-07 | RFC 8915 | ||||
| frcs | 4915 | tcp | Fibics Remote Control Service | Ken Lagarec | Ken Lagarec | 2009-04-17 | |||||
| 4915 | udp | Reserved | |||||||||
| fmwp | 5015 | tcp | FileMaker, Inc. - Web publishing | Alex Chen | Alex Chen | 2009-11-25 | |||||
| 5015 | udp | Reserved | |||||||||
| autobuild | 5115 | tcp | Symantec Autobuild Service | David Warden | David Warden | 2008-11-17 | |||||
| 5115 | udp | Reserved | |||||||||
| atmp | 5150 | tcp | Ascend Tunnel Management Protocol | Kory Hamzeh | Kory Hamzeh | ||||||
| atmp | 5150 | udp | Ascend Tunnel Management Protocol | Kory Hamzeh | Kory Hamzeh | ||||||
| esri-sde | 5151 | tcp | ESRI SDE Instance IANA assigned this well-formed service name as a replacement for "esri_sde". |
Peter Aronson | Peter Aronson | Unauthorized Use Known on ports 5151 and 5152 | |||||
| esri_sde | 5151 | tcp | ESRI SDE Instance | Peter Aronson | Peter Aronson | This entry is an alias to "esri-sde". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| esri-sde | 5151 | udp | ESRI SDE Remote Start IANA assigned this well-formed service name as a replacement for "esri_sde". |
Peter Aronson | Peter Aronson | Unauthorized Use Known on ports 5151 and 5152 | |||||
| esri_sde | 5151 | udp | ESRI SDE Remote Start | Peter Aronson | Peter Aronson | This entry is an alias to "esri-sde". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| sde-discovery | 5152 | tcp | ESRI SDE Instance Discovery | Peter Aronson | Peter Aronson | Unauthorized Use Known on ports 5151 and 5152 | |||||
| sde-discovery | 5152 | udp | ESRI SDE Instance Discovery | Peter Aronson | Peter Aronson | Unauthorized Use Known on ports 5151 and 5152 | |||||
| 5153 | tcp | Reserved | 2009-07-01 | 2018-04-19 | Historic usage was toruxserver. De-Assigned on 2018-04-19 | ||||||
| 5153 | udp | Reserved | |||||||||
| bzflag | 5154 | tcp | BZFlag game server | Tim Riker | Tim Riker | 2003-07 | |||||
| bzflag | 5154 | udp | BZFlag game server | Tim Riker | Tim Riker | 2003-07 | |||||
| asctrl-agent | 5155 | tcp | Oracle asControl Agent | Todd Guay | Todd Guay | 2005-08 | |||||
| asctrl-agent | 5155 | udp | Oracle asControl Agent | Todd Guay | Todd Guay | 2005-08 | |||||
| rugameonline | 5156 | tcp | Russian Online Game | Andrey Mohov | Andrey Mohov | 2010-08-17 | |||||
| 5156 | udp | Reserved | |||||||||
| mediat | 5157 | tcp | Mediat Remote Object Exchange | Oliver Anan | Oliver Anan | 2010-09-02 | |||||
| 5157 | udp | Reserved | |||||||||
| 5158-5160 | Unassigned | ||||||||||
| noteza | 5215 | tcp | NOTEZA Data Safety Service | CNS a.s. (IT company registered in Czech republic) | Pavel Mendl | 2014-06-12 | |||||
| 5215 | udp | Reserved | |||||||||
| noteza | 5215 | sctp | NOTEZA Data Safety Service | CNS a.s. (IT company registered in Czech republic) | Pavel Mendl | 2014-06-12 | |||||
| capwap-control | 5246 | udp | CAPWAP Control Protocol | RFC 5415 | |||||||
| capwap-data | 5247 | udp | CAPWAP Data Protocol | RFC 5415 | |||||||
| hacl-poll | 5315 | tcp | HA Cluster UDP Polling | Hoa Nguyen | Hoa Nguyen | ||||||
| hacl-poll | 5315 | udp | HA Cluster UDP Polling | Hoa Nguyen | Hoa Nguyen | ||||||
| ns-server | 5415 | tcp | NS Server | Jeffrey Chiao | Jeffrey Chiao | ||||||
| ns-server | 5415 | udp | NS Server | Jeffrey Chiao | Jeffrey Chiao | ||||||
| prosharedata | 5715 | tcp | proshare conf data | gunner | gunner | ||||||
| prosharedata | 5715 | udp | proshare conf data | gunner | gunner | ||||||
| 5815-5819 | Unassigned | ||||||||||
| 5915-5962 | Unassigned | ||||||||||
| xic | 6115 | tcp | Xic IPC Service | Stephen R. Whiteley | Stephen R. Whiteley | 2010-10-07 | |||||
| 6115 | udp | Reserved | |||||||||
| 6150-6158 | Unassigned | ||||||||||
| efb-aci | 6159 | tcp | EFB Application Control Interface | Jonathan Schaaf | Jonathan Schaaf | 2010-02-10 | |||||
| 6159 | udp | Reserved | |||||||||
| scup | 6315 | tcp | Sensor Control Unit Protocol | Sven Kopacz | Sven Kopacz | 2010-09-01 | |||||
| scup-disc | 6315 | udp | Sensor Control Unit Protocol Discovery Protocol | Sven Kopacz | Sven Kopacz | 2010-09-01 | |||||
| elipse-rec | 6515 | tcp | Elipse RPC Protocol | Fl√°vio Englert | Fl√°vio Englert | 2007-09-17 | |||||
| elipse-rec | 6515 | udp | Elipse RPC Protocol | Fl√°vio Englert | Fl√°vio Englert | 2007-09-17 | |||||
| fibotrader-com | 6715 | tcp | Fibotrader Communications | Robert Wetzold | Robert Wetzold | 2006-01 | |||||
| fibotrader-com | 6715 | udp | Fibotrader Communications | Robert Wetzold | Robert Wetzold | 2006-01 | |||||
| talon-webserver | 7015 | tcp | Talon Webserver | Jim Thompson | Jim Thompson | ||||||
| talon-webserver | 7015 | udp | Talon Webserver | Jim Thompson | Jim Thompson | ||||||
| PS-Server | 7215 | tcp | Communication ports for PaperStream Server services | PFU Systems Inc. | Hari Asuri | 2016-02-26 | |||||
| 7215 | udp | Reserved | |||||||||
| cfg-cloud | 8015 | tcp | Configuration Cloud Service | admin_at_cfg_cloud | Goksel Darcan | 2019-01-09 | |||||
| 8015 | udp | Reserved | |||||||||
| mtl8000-matrix | 8115 | tcp | MTL8000 Matrix | David Pinch | David Pinch | 2002-04 | |||||
| mtl8000-matrix | 8115 | udp | MTL8000 Matrix | David Pinch | David Pinch | 2002-04 | |||||
| 8150-8152 | Unassigned | ||||||||||
| quantastor | 8153 | tcp | QuantaStor Management Interface | OS NEXUS, Inc. | Steven Umbehocker | 2012-09-21 | |||||
| 8153 | udp | Reserved | |||||||||
| 8154-8159 | Unassigned | ||||||||||
| dlpx-sp | 8415 | tcp | Delphix Session Protocol | Delphix Corp | Peng Dai | 2012-11-01 | |||||
| 8415 | udp | Reserved | |||||||||
| imink | 8615 | tcp | Imink Service Control | Canon Inc. | Ken'ichi FUJII | 2011-10-10 | |||||
| 8615 | udp | Reserved | |||||||||
| xadmin | 9105 | tcp | Xadmin Control Service | Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009 | |||||||
| xadmin | 9105 | udp | Xadmin Control Service | Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009 | |||||||
| 9132-9159 | Unassigned | ||||||||||
| insis | 9215 | tcp | Integrated Setup and Install Service | Markus Treinen | Markus Treinen | 2006-02 | |||||
| insis | 9215 | udp | Integrated Setup and Install Service | Markus Treinen | Markus Treinen | 2006-02 | |||||
| 9615 | Unassigned | ||||||||||
| netiq-endpt | 10115 | tcp | NetIQ Endpoint | Gary Weichinger | Gary Weichinger | ||||||
| netiq-endpt | 10115 | udp | NetIQ Endpoint | Gary Weichinger | Gary Weichinger | ||||||
| 10130-10159 | Unassigned | ||||||||||
| 11490-11599 | Unassigned | ||||||||||
| 12866-13159 | Unassigned | ||||||||||
| 13161-13215 | Unassigned | ||||||||||
| vcscmd | 14150 | tcp | Veritas Cluster Server Command Server | Anand Bhalerao | Anand Bhalerao | 2008-10-02 | |||||
| 14150 | udp | Reserved | |||||||||
| 14151-14153 | Unassigned | ||||||||||
| vad | 14154 | tcp | Veritas Application Director | Rajeev Verma | Rajeev Verma | 2006-02 | |||||
| vad | 14154 | udp | Veritas Application Director | Rajeev Verma | Rajeev Verma | 2006-02 | |||||
| 14155-14249 | Unassigned | ||||||||||
| 14415-14499 | Unassigned | ||||||||||
| hydap | 15000 | tcp | Hypack Data Aquisition | HYPACK Inc. | Mircea Neacsu | 2011-10-27 | |||||
| hydap | 15000 | udp | Hypack Data Aquisition | HYPACK Inc. | Mircea Neacsu | 2011-10-27 | |||||
| 15001 | Unassigned | ||||||||||
| onep-tls | 15002 | tcp | Open Network Environment TLS | Cisco | Andrew Thurber | 2014-01-21 | |||||
| 15002 | udp | Reserved | |||||||||
| 15003-15117 | Unassigned | ||||||||||
| 15118 | tcp | Reserved | |||||||||
| v2g-secc | 15118 | udp | v2g Supply Equipment Communication Controller Discovery Protocol | Holger Lochner | Holger Lochner | 2011-04-06 | |||||
| 15119-15344 | Unassigned | ||||||||||
| xpilot | 15345 | tcp | XPilot Contact Port | Bert Gijsbers | Bert Gijsbers | ||||||
| xpilot | 15345 | udp | XPilot Contact Port | Bert Gijsbers | Bert Gijsbers | ||||||
| 15346-15362 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| admin_at_cfg_cloud | gdarcan&gmail.com | 2019-01-09 | |
| Alex Chen | alex_chen&filemaker.com | 2009-11-25 | |
| Anand Bhalerao | anand_bhalerao&symantec.com | 2008-10-02 | |
| Andrew Thurber | Cisco | anthurbe@cisco.com> | 2014-01-21 |
| Andrey Mohov | mohov_andrey&mail.ru | 2010-08-17 | |
| Bert Gijsbers | bert&xpilot.org | ||
| Brocade Communications Systems | ncarter&brocade.com | 2015-11-17 | |
| Canon Inc. | fujii.ken-ichi149&canon.co.jp | 2011-10-10 | |
| Cisco | anthurbe@cisco.com> | 2014-01-21 | |
| CNS a.s. (IT company registered in Czech republic) | HAJN.L&cns.cz | 2014-06-12 | |
| David Pinch | dpinch&mtl-inst.com | 2002-04 | |
| David Warden | david_warden&symantec.com | 2008-11-17 | |
| Delphix Corp | peng.dai&delphix.com | 2012-11-01 | |
| Fl√°vio Englert | flavio&elipse.com.br | 2007-09-17 | |
| Gary Weichinger | gary.weichinger&netiq.com | ||
| Goksel Darcan | gdarcan&gmail.com | 2019-01-09 | |
| Hari Asuri | hasuri.pfu&us.fujitsu.com | 2016-02-26 | |
| Hoa Nguyen | hoan&cup.hp.com | ||
| Holger Lochner | holger.lochner&daimler.com | 2011-04-06 | |
| HYPACK Inc. | mircea&hypack.com | 2011-10-27 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jeffrey Chiao | chiaoj&netsoft.com | ||
| Jim Thompson | jim.thompson&powerware.com | ||
| Jonathan Schaaf | j.schaaf&astronautics.com | 2010-02-10 | |
| Ken'ichi FUJII | Canon Inc. | fujii.ken-ichi149&canon.co.jp | 2011-10-10 |
| Ken Lagarec | klagarec&fibics.com | 2009-04-17 | |
| Kory Hamzeh | kory&ascend.com | ||
| Markus Treinen | markus.treinen&siemens.com | 2006-02 | |
| Mircea Neacsu | mircea&hypack.com | 2011-10-27 | |
| Nick Carter | ncarter&brocade.com | 2015-11-17 | |
| Oliver Anan | oliver&ananit.de | 2010-09-02 | |
| OS NEXUS, Inc. | info&osnexus.com | 2012-09-21 | |
| Pavel Mendl | CNS a.s. (IT company registered in Czech republic) | Pavel.MENDL&cns.cz | 2014-06-12 |
| Peng Dai | Delphix Corp | peng.dai&delphix.com | 2012-11-01 |
| Peter Aronson | paronson&esri.com | ||
| PFU Systems Inc. | hasuri.pfu&us.fujitsu.com | 2016-02-26 | |
| Rajeev Verma | rajeev_verma&symantec.com | 2006-02 | |
| Robert Wetzold | robert.wetzold&fibotrader.com | 2006-01 | |
| Stephen R. Whiteley | stevew&wrcad.com | 2010-10-07 | |
| Steven Umbehocker | OS NEXUS, Inc. | steven.umbehocker&osnexus.com | 2012-09-21 |
| Sven Kopacz | s.kopacz&controllerware.com | 2010-09-01 | |
| Tim Riker | tim&rikers.org | 2003-07 | |
| Todd Guay | todd.guay&oracle.com | 2005-08 | |
| gunner&ibeam.intel.com |