Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| dtn-bundle | 4556 | dccp | DTN Bundle DCCP CL Protocol | 2013-11-12 | 2014-02-21 | RFC 7122 | 1685351985 | ||||
| a16-an-an | 4598 | tcp | A16 (AN-AN) | David Ott | David Ott | 2005-12 | |||||
| a16-an-an | 4598 | udp | A16 (AN-AN) | David Ott | David Ott | 2005-12 | |||||
| 4916-4929 | Unassigned | ||||||||||
| 5016-5019 | Unassigned | ||||||||||
| sip | 5060 | sctp | SIP | RFC 4168 | |||||||
| sips | 5061 | sctp | SIP-TLS | RFC 4168 | |||||||
| 5116 | tcp | Reserved | |||||||||
| emb-proj-cmd | 5116 | udp | EPSON Projecter Image Transfer | SEIKO EPSON | SEIKO EPSON | 2008-11-17 | |||||
| 5158-5160 | Unassigned | ||||||||||
| snmpssh | 5161 | tcp | SNMP over SSH Transport Model | RFC 5592 | |||||||
| 5161 | udp | Reserved | |||||||||
| snmpssh-trap | 5162 | tcp | SNMP Notification over SSH Transport Model | RFC 5592 | Known Unauthorized Use on port 5162 | ||||||
| 5162 | udp | Reserved | Known Unauthorized Use on port 5162 | ||||||||
| sbackup | 5163 | tcp | Shadow Backup | Glenn Allen | Glenn Allen | 2009-08-05 | |||||
| 5163 | udp | Reserved | |||||||||
| vpa | 5164 | tcp | Virtual Protocol Adapter | Douglas Goodall | Douglas Goodall | 2009-08-05 | |||||
| vpa-disc | 5164 | udp | Virtual Protocol Adapter Discovery | Douglas Goodall | Douglas Goodall | 2009-08-05 | |||||
| ife-icorp | 5165 | tcp | ife_1corp IANA assigned this well-formed service name as a replacement for "ife_icorp". |
Paul Annala | Paul Annala | ||||||
| ife_icorp | 5165 | tcp | ife_1corp | Paul Annala | Paul Annala | This entry is an alias to "ife-icorp". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| ife-icorp | 5165 | udp | ife_1corp IANA assigned this well-formed service name as a replacement for "ife_icorp". |
Paul Annala | Paul Annala | ||||||
| ife_icorp | 5165 | udp | ife_1corp | Paul Annala | Paul Annala | This entry is an alias to "ife-icorp". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| winpcs | 5166 | tcp | WinPCS Service Connection | Complan Network AS | Complan Network AS | 2006-02 | |||||
| winpcs | 5166 | udp | WinPCS Service Connection | Complan Network AS | Complan Network AS | 2006-02 | |||||
| scte104 | 5167 | tcp | SCTE104 Connection | Thomas Russell | Thomas Russell | 2005-05 | |||||
| scte104 | 5167 | udp | SCTE104 Connection | Thomas Russell | Thomas Russell | 2005-05 | |||||
| scte30 | 5168 | tcp | SCTE30 Connection | Thomas Russell | Thomas Russell | 2005-05 | |||||
| scte30 | 5168 | udp | SCTE30 Connection | Thomas Russell | Thomas Russell | 2005-05 | |||||
| 5169-5171 | Unassigned | ||||||||||
| 5216-5220 | Unassigned | ||||||||||
| hpbladems | 5316 | tcp | HPBladeSystem Monitor Service | Alan Minchew | Alan Minchew | 2011-05-23 | 2011-05-16 | ||||
| 5316 | udp | Unassigned | 2011-05-16 | ||||||||
| sns-gateway | 5416 | tcp | SNS Gateway | Mary Holstage | Mary Holstage | ||||||
| sns-gateway | 5416 | udp | SNS Gateway | Mary Holstage | Mary Holstage | ||||||
| prosharerequest | 5716 | tcp | proshare conf request | gunner | gunner | ||||||
| prosharerequest | 5716 | udp | proshare conf request | gunner | gunner | ||||||
| xtlserv | 6116 | tcp | XicTools License Manager Service | Stephen R. Whiteley | Stephen R. Whiteley | 2010-10-07 | |||||
| 6116 | udp | Reserved | |||||||||
| ecmp | 6160 | tcp | Emerson Extensible Control and Management Protocol | Bryce Beeston | Bryce Beeston | 2011-06-23 | |||||
| ecmp-data | 6160 | udp | Emerson Extensible Control and Management Protocol Data | Bryce Beeston | Bryce Beeston | 2011-06-23 | |||||
| patrol-ism | 6161 | tcp | PATROL Internet Srv Mgr | Portnoy Boxman | Portnoy Boxman | 2005-01 | |||||
| patrol-ism | 6161 | udp | PATROL Internet Srv Mgr | Portnoy Boxman | Portnoy Boxman | 2005-01 | |||||
| patrol-coll | 6162 | tcp | PATROL Collector | Portnoy Boxman | Portnoy Boxman | 2005-01 | |||||
| patrol-coll | 6162 | udp | PATROL Collector | Portnoy Boxman | Portnoy Boxman | 2005-01 | |||||
| pscribe | 6163 | tcp | Precision Scribe Cnx Port | Robert W Hodges | Robert W Hodges | 2005-01 | |||||
| pscribe | 6163 | udp | Precision Scribe Cnx Port | Robert W Hodges | Robert W Hodges | 2005-01 | |||||
| 6164-6199 | Unassigned | ||||||||||
| abb-escp | 6316 | tcp | Ethernet Sensor Communications Protocol | Jaime Antolin | Jaime Antolin | 2008-09-25 | |||||
| abb-escp | 6316 | udp | Ethernet Sensor Communications Protocol | Jaime Antolin | Jaime Antolin | 2008-09-25 | |||||
| 6411-6416 | Unassigned | ||||||||||
| 6516-6542 | Unassigned | ||||||||||
| princity-agent | 6716 | tcp | Princity Agent | ENSTEAM Sp. z o.o. | Tomasz Krakowiak | 2014-07-07 | 2015-07-08 | ||||
| 6716 | udp | Reserved | |||||||||
| 6802-6816 | Unassigned | ||||||||||
| spg | 7016 | tcp | SPG Controls Carrier | SPG Controls Ltd | Steve Barton | 2017-03-27 | |||||
| spg | 7016 | udp | SPG Controls Carrier | SPG Controls Ltd | Steve Barton | 2017-03-27 | |||||
| 7108-7116 | Unassigned | ||||||||||
| 7130-7160 | Unassigned | ||||||||||
| cabsm-comm | 7161 | tcp | CA BSM Comm | Chun-Ho Chang | Chun-Ho Chang | 2004-11 | |||||
| cabsm-comm | 7161 | udp | CA BSM Comm | Chun-Ho Chang | Chun-Ho Chang | 2004-11 | |||||
| caistoragemgr | 7162 | tcp | CA Storage Manager | Emre Tunar | Emre Tunar | 2004-11 | |||||
| caistoragemgr | 7162 | udp | CA Storage Manager | Emre Tunar | Emre Tunar | 2004-11 | |||||
| cacsambroker | 7163 | tcp | CA Connection Broker | David Roberts | David Roberts | 2005-05 | |||||
| cacsambroker | 7163 | udp | CA Connection Broker | David Roberts | David Roberts | 2005-05 | |||||
| fsr | 7164 | tcp | File System Repository Agent | Micha Ben-Efraim | Micha Ben-Efraim | 2007-07-19 | |||||
| fsr | 7164 | udp | File System Repository Agent | Micha Ben-Efraim | Micha Ben-Efraim | 2007-07-19 | |||||
| doc-server | 7165 | tcp | Document WCF Server | Micha Ben-Efraim | Micha Ben-Efraim | 2008-01-07 | |||||
| doc-server | 7165 | udp | Document WCF Server | Micha Ben-Efraim | Micha Ben-Efraim | 2008-01-07 | |||||
| aruba-server | 7166 | tcp | Aruba eDiscovery Server | Micha Ben-Efraim | Micha Ben-Efraim | 2008-01-07 | |||||
| aruba-server | 7166 | udp | Aruba eDiscovery Server | Micha Ben-Efraim | Micha Ben-Efraim | 2008-01-07 | |||||
| casrmagent | 7167 | tcp | CA SRM Agent | Venkata Krishna | Venkata Krishna | 2010-02-24 | |||||
| 7167 | udp | Reserved | |||||||||
| cnckadserver | 7168 | tcp | cncKadServer DB & Inventory Services | Micha Ben-Efraim | Micha Ben-Efraim | 2011-01-31 | |||||
| 7168 | udp | Reserved | |||||||||
| ccag-pib | 7169 | tcp | Consequor Consulting Process Integration Bridge | Frank Goenninger | Frank Goenninger | 2010-02-22 | |||||
| ccag-pib | 7169 | udp | Consequor Consulting Process Integration Bridge | Frank Goenninger | Frank Goenninger | 2010-02-22 | |||||
| PS-Capture-Pro | 7216 | tcp | PaperStream Capture Professional | PFU Systems Inc. | Hari Asuri | 2016-02-26 | |||||
| 7216 | udp | Reserved | |||||||||
| ads-s | 8016 | tcp | Beckhoff Automation Device Specification | Beckhoff Automation GmbH & Co. KG | Henning Mersch | 2019-02-28 | |||||
| 8016 | udp | Reserved | |||||||||
| cp-cluster | 8116 | tcp | Check Point Clustering | Roni Moshitzky | Roni Moshitzky | ||||||
| cp-cluster | 8116 | udp | Check Point Clustering | Roni Moshitzky | Roni Moshitzky | ||||||
| patrol | 8160 | tcp | Patrol | Portnoy Boxman | Portnoy Boxman | ||||||
| patrol | 8160 | udp | Patrol | Portnoy Boxman | Portnoy Boxman | ||||||
| patrol-snmp | 8161 | tcp | Patrol SNMP | Portnoy Boxman | Portnoy Boxman | ||||||
| patrol-snmp | 8161 | udp | Patrol SNMP | Portnoy Boxman | Portnoy Boxman | ||||||
| lpar2rrd | 8162 | tcp | LPAR2RRD client server communication | LPAR2RRD project | Pavel Hampl | 2013-08-14 | |||||
| 8162 | udp | Reserved | |||||||||
| 8163-8180 | Unassigned | ||||||||||
| espeech | 8416 | tcp | eSpeech Session Protocol | Scott Tarone | Scott Tarone | 2002-11 | |||||
| espeech | 8416 | udp | eSpeech Session Protocol | Scott Tarone | Scott Tarone | 2002-11 | |||||
| 8616-8664 | Unassigned | Unauthorized Use Known on ports 8616 and 8617 | |||||||||
| apani1 | 9160 | tcp | apani1 | Neal Taylor | Neal Taylor | ||||||
| apani1 | 9160 | udp | apani1 | Neal Taylor | Neal Taylor | ||||||
| apani2 | 9161 | tcp | apani2 | Neal Taylor | Neal Taylor | ||||||
| apani2 | 9161 | udp | apani2 | Neal Taylor | Neal Taylor | ||||||
| apani3 | 9162 | tcp | apani3 | Neal Taylor | Neal Taylor | ||||||
| apani3 | 9162 | udp | apani3 | Neal Taylor | Neal Taylor | ||||||
| apani4 | 9163 | tcp | apani4 | Neal Taylor | Neal Taylor | ||||||
| apani4 | 9163 | udp | apani4 | Neal Taylor | Neal Taylor | ||||||
| apani5 | 9164 | tcp | apani5 | Neal Taylor | Neal Taylor |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alan Minchew | alan.minchew&hp.com | 2011-05-23 | |
| Beckhoff Automation GmbH & Co. KG | legal&beckhoff.com | 2019-02-28 | |
| Bryce Beeston | bryce.beeston&emerson.com | 2011-06-23 | |
| Chun-Ho Chang | chun-ho.chang&ca.com | 2004-11 | |
| Complan Network AS | knut&winpcs.com | 2006-02 | |
| David Ott | dott&qualcomm.com | 2010-10-15 | |
| David Roberts | David.Roberts&ca.com | 2005-05 | |
| Douglas Goodall | douglas_goodall&mac.com | 2009-08-05 | |
| Emre Tunar | emre.tunar&ca.com | 2004-11 | |
| ENSTEAM Sp. z o.o. | support&ensteam.com | 2015-07-08 | |
| Frank Goenninger | frank.goenninger&consequor.de | 2010-02-22 | |
| Glenn Allen | gallen&goorooinc.com | 2009-08-05 | |
| Hari Asuri | hasuri.pfu&us.fujitsu.com | 2016-02-26 | |
| Henning Mersch | support&beckhoff.com | 2019-02-28 | |
| Jaime Antolin | jaime.antolin&ie.abb.com | 2008-09-25 | |
| LPAR2RRD project | pavel.hampl&lpar2rrd.com | 2013-08-14 | |
| Mary Holstage | holstege&firstfloor.com | ||
| Micha Ben-Efraim | benmi07&ca.com | 2008-01-07 | |
| Micha Ben-Efraim | micha&metalix.net | 2011-01-31 | |
| Neal Taylor | ianareg&apani.com | ||
| Paul Annala | paa&bull.se | ||
| Pavel Hampl | LPAR2RRD project | pavel.hampl&lpar2rrd.com | 2013-08-14 |
| PFU Systems Inc. | hasuri.pfu&us.fujitsu.com | 2016-02-26 | |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Robert W Hodges | iana&precdata.com | 2005-01 | |
| Roni Moshitzky | rmosh&checkpoint.com | ||
| SEIKO EPSON | ProjectorSoft&exc.epson.co.jp | 2008-11-17 | |
| Scott Tarone | starone&proactivethought.com | 2003-04 | |
| SPG Controls Ltd | steveb&spgcontrols.com | 2017-03-27 | |
| Stephen R. Whiteley | stevew&wrcad.com | 2010-10-07 | |
| Steve Barton | SPG Controls Ltd | steveb&spgcontrols.com | 2017-03-27 |
| Thomas Russell | trussell&scte.org | 2005-05 | |
| Tomasz Krakowiak | ENSTEAM Sp. z o.o. | tomasz.krakowiak&ensteam.com | 2015-07-08 |
| Venkata Krishna | VenkataKrishna.Bezawada&ca.com | 2010-02-24 | |
| gunner&ibeam.intel.com |