Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 4417 | udp | Reserved | |||||||||
| dtn-bundle | 4556 | tcp | DTN Bundle TCP CL Protocol | IESG | IETF Chair | 2021-02-22 | RFC 9174 | ||||
| a17-an-an | 4599 | tcp | A17 (AN-AN) | David Ott | David Ott | 2006-02 | |||||
| a17-an-an | 4599 | udp | A17 (AN-AN) | David Ott | David Ott | 2006-02 | |||||
| gradecam | 5117 | tcp | GradeCam Image Processing | Robert Porter | Robert Porter | 2009-09-24 | |||||
| 5117 | udp | Reserved | |||||||||
| 5169-5171 | Unassigned | ||||||||||
| pcoip-mgmt | 5172 | tcp | PC over IP Endpoint Management | HP Inc. | Jeff Jeansonne | 2014-04-28 | 2026-03-10 | ||||
| 5172 | udp | Reserved | |||||||||
| 5173-5189 | Unassigned | ||||||||||
| hpdevms | 5317 | tcp | HP Device Monitor Service | Alan Minchew | Alan Minchew | 2011-05-16 | |||||
| 5317 | udp | Reserved | |||||||||
| sns-agent | 5417 | tcp | SNS Agent | Mary Holstage | Mary Holstage | ||||||
| sns-agent | 5417 | udp | SNS Agent | Mary Holstage | Mary Holstage | ||||||
| 5606-5617 | Unassigned | ||||||||||
| prosharenotify | 5717 | tcp | proshare conf notify | gunner | gunner | ||||||
| prosharenotify | 5717 | udp | proshare conf notify | ||||||||
| daylitetouch | 6117 | tcp | Daylite Touch Sync | Brent Gulanowski | Brent Gulanowski | 2009-08-26 | |||||
| 6117 | udp | Reserved | |||||||||
| nav-data-cmd | 6317 | tcp | Navtech Radar Sensor Data Command | Navtech Radar | Guy Avery | 2013-02-20 | |||||
| nav-data | 6317 | udp | Navtech Radar Sensor Data | Navtech Radar | Guy Avery | 2013-02-20 | |||||
| faxcomservice | 6417 | tcp | Faxcom Message Service | Albert Leung | Albert Leung | 2006-04 | |||||
| faxcomservice | 6417 | udp | Faxcom Message Service | Albert Leung | Albert Leung | 2006-04 | |||||
| 6717-6766 | Unassigned | ||||||||||
| pentbox-sim | 6817 | tcp | PenTBox Secure IM Protocol | Alberto Ortega Llamas | Alberto Ortega Llamas | 2009-11-04 | |||||
| 6817 | udp | Reserved | |||||||||
| grasp | 7017 | tcp | GeneRic Autonomic Signaling Protocol | IESG | IETF Chair | 2017-04-28 | 2017-07-20 | RFC 8990 | |||
| grasp | 7017 | udp | GeneRic Autonomic Signaling Protocol | IESG | IETF Chair | 2017-04-28 | 2017-07-20 | RFC 8990 | |||
| aes-x170 | 7107 | udp | AES-X170 | Richard Foss | Richard Foss | 2011-02-10 | |||||
| rothaga | 7117 | tcp | Encrypted chat and file transfer service | Arcadian Computers | Jonathan Pollock | 2016-05-10 | |||||
| 7117 | udp | Reserved | |||||||||
| nsrp | 7170 | tcp | Adaptive Name/Service Resolution | Geoff Back | Geoff Back | 2010-02-01 | |||||
| nsrp | 7170 | udp | Adaptive Name/Service Resolution | Geoff Back | Geoff Back | 2010-02-01 | |||||
| drm-production | 7171 | tcp | Discovery and Retention Mgt Production | Micha Ben-Efraim | Micha Ben-Efraim | 2010-02-18 | |||||
| drm-production | 7171 | udp | Discovery and Retention Mgt Production | Micha Ben-Efraim | Micha Ben-Efraim | 2010-02-18 | |||||
| metalbend | 7172 | tcp | Port used for MetalBend programmable interface | Micha Ben-Efraim | Micha Ben-Efraim | 2012-11-27 | |||||
| 7172 | udp | Reserved | |||||||||
| zsecure | 7173 | tcp | zSecure Server | Hans Schoone | Hans Schoone | 2010-10-01 | |||||
| 7173 | udp | Reserved | |||||||||
| clutild | 7174 | tcp | Clutild | Cheryl Stoutenburg | Cheryl Stoutenburg | ||||||
| clutild | 7174 | udp | Clutild | Cheryl Stoutenburg | Cheryl Stoutenburg | ||||||
| 7175-7180 | Unassigned | ||||||||||
| 7217-7226 | Unassigned | ||||||||||
| 8017 | tcp | Reserved | |||||||||
| cisco-cloudsec | 8017 | udp | Cisco Cloudsec Dataplane Port Number | Cisco Systems, Inc. | Govind Sharma | 2021-03-18 | |||||
| purityrpc | 8117 | tcp | Purity replication clustering and remote management | Pure Storage | Steve Hodgson | 2013-08-13 | |||||
| 8117 | udp | Reserved | |||||||||
| espeech-rtp | 8417 | tcp | eSpeech RTP Protocol | Scott Tarone | Scott Tarone | 2003-04 | |||||
| espeech-rtp | 8417 | udp | eSpeech RTP Protocol | Scott Tarone | Scott Tarone | 2003-04 | |||||
| 8616-8664 | Unassigned | Unauthorized Use Known on ports 8616 and 8617 | |||||||||
| fsc-port | 9217 | tcp | FSC Communication Port | Teijo Mustonen | Teijo Mustonen | 2002-03 | |||||
| fsc-port | 9217 | udp | FSC Communication Port | Teijo Mustonen | Teijo Mustonen | 2002-03 | |||||
| 9313-9317 | Unassigned | ||||||||||
| 9403-9417 | Unassigned | ||||||||||
| erunbook-server | 9617 | tcp | eRunbook Server IANA assigned this well-formed service name as a replacement for "erunbook_server". |
Gerhard Wagner | Gerhard Wagner | 2009-03-10 | |||||
| erunbook_server | 9617 | tcp | eRunbook Server | Gerhard Wagner | Gerhard Wagner | 2009-03-10 | This entry is an alias to "erunbook-server". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 9617 | udp | Reserved | |||||||||
| x510 | 9877 | tcp | The X.510 wrapper protocol | ITU/TSB (ITU-T Study Group 17) | Erik Andersen | 2019-09-30 | ITU-T X.510 / ISO/IEC 9584-11 | ||||
| kca-service | 9878 | udp | The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 | IESG | IETF Chair | 2012-07-12 | RFC 6717 | Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements. | |||
| iqrm | 10117 | tcp | NetIQ IQCResource Managament Svc | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| iqrm | 10117 | udp | NetIQ IQCResource Managament Svc | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| 11166-11170 | Unassigned | ||||||||||
| 11171 | tcp | Reserved | |||||||||
| snss | 11171 | udp | Surgical Notes Security Service Discovery (SNSS) | David Lethe | David Lethe | 2010-12-24 | |||||
| oemcacao-jmxmp | 11172 | tcp | OEM cacao JMX-remoting access point | David Sechrest | David Sechrest | 2010-09-22 | |||||
| 11172 | udp | Reserved | |||||||||
| t5-straton | 11173 | tcp | Straton Runtime Programing | COPALP | Jerome FOLLUT | 2012-03-01 | |||||
| 11173 | udp | Reserved | |||||||||
| oemcacao-rmi | 11174 | tcp | OEM cacao rmi registry access point | David Sechrest | David Sechrest | 2010-09-22 | |||||
| 11174 | udp | Reserved | |||||||||
| oemcacao-websvc | 11175 | tcp | OEM cacao web service access point | David Sechrest | David Sechrest | 2010-09-22 | |||||
| 11175 | udp | Reserved | |||||||||
| 11176-11200 | Unassigned | ||||||||||
| 11624-11719 | Unassigned | Unauthorized Use Known on port 11711 | |||||||||
| h323callsigalt | 11720 | tcp | H.323 Call Control Signalling Alternate | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| h323callsigalt | 11720 | udp | H.323 Call Control Signalling Alternate | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| 11721-11722 | Unassigned | ||||||||||
| emc-xsw-dcache | 11723 | tcp | EMC XtremSW distributed cache | EMC | David Erel | 2013-09-18 | |||||
| emc-xsw-dcache | 11723 | udp | EMC XtremSW distributed cache | EMC | David Erel | 2013-09-18 | |||||
| 11724-11750 | Unassigned | ||||||||||
| intrepid-ssl | 11751 | tcp | Intrepid SSL | Robert Eden | Robert Eden | 2003-03 | |||||
| intrepid-ssl | 11751 | udp | Intrepid SSL | Robert Eden | Robert Eden | 2003-03 | |||||
| 11752-11795 | Unassigned | ||||||||||
| lanschool | 11796 | tcp | LanSchool | Stoneware Inc. | Dana Doggett | 2012-05-18 | |||||
| lanschool-mpt | 11796 | udp | Lanschool Multipoint | Stoneware Inc. | Dana Doggett | 2012-05-18 | |||||
| 11797-11875 | Unassigned | ||||||||||
| 12169-12171 | Unassigned | ||||||||||
| hivep | 12172 | tcp | HiveP | Dick Augustsson | Dick Augustsson | ||||||
| hivep | 12172 | udp | HiveP | Dick Augustsson | Dick Augustsson | ||||||
| 12173-12299 | Unassigned | ||||||||||
| rs-pias | 13217 | tcp | R&S Proxy Installation Assistant Service | Guido Kiener | Guido Kiener | 2008-12-04 | |||||
| rs-pias | 13217 | udp | R&S Proxy Installation Assistant Service | Guido Kiener | Guido Kiener | 2008-12-04 | |||||
| 13787-13817 | Unassigned | ||||||||||
| 15003-15117 | Unassigned | ||||||||||
| 16996-17006 | Unassigned | ||||||||||
| isode-dua | 17007 | tcp | |||||||||
| isode-dua | 17007 | udp | |||||||||
| 17008-17009 | Unassigned | ||||||||||
| ncpu | 17010 | tcp | Plan 9 cpu port | Ronald G. Minnich | Ronald G. Minnich | 2022-05-13 | Defined TXT keys: u=username; k=keypattern; f=fstabFILE; n=namespace; h=hostkey; r=root | ||||
| 17010 | udp | Reserved | |||||||||
| 17011-17183 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alan Minchew | alan.minchew&hp.com | 2011-05-23 | |
| Albert Leung | aleung&biscom.com | 2006-04 | |
| Alberto Ortega Llamas | alberto.kun666&gmail.com | 2009-11-04 | |
| Arcadian Computers | support&arcadiancomputers.com | 2016-05-10 | |
| Brent Gulanowski | bgulanowski&marketcircle.com | 2009-08-26 | |
| Cheryl Stoutenburg | cstoutenburg&vnet.ibm.com | ||
| Cisco Systems, Inc. | gosharma&cisco.com | 2021-03-18 | |
| COPALP | jf&copalp.com | 2012-03-01 | |
| Dana Doggett | Stoneware Inc. | dana.doggett&stone-ware.com | 2012-05-18 |
| David Erel | EMC | david.erel&emc.com | 2013-09-18 |
| David Lethe | david&santools.com | 2010-12-24 | |
| David Ott | dott&qualcomm.com | 2010-10-15 | |
| David Sechrest | david.sechrest&oracle.com | 2010-09-22 | |
| Dick Augustsson | dick&skenbe.net | ||
| EMC | david.erel&emc.com | 2013-09-18 | |
| Erik Andersen | era&x500.eu | 2019-08-13 | |
| Geoff Back | geoff&demonlair.co.uk | 2010-02-01 | |
| Gerhard Wagner | gw&nova-ratio.de | 2009-03-10 | |
| Govind Sharma | Cisco Systems, Inc. | gosharma&cisco.com | 2021-03-18 |
| Guido Kiener | Guido.Kiener&rohde-schwarz.com | 2008-12-04 | |
| Guy Avery | Navtech Radar | guy.avery&navtechradar.com | 2013-02-20 |
| Hans Schoone | Hans.Schoone&nl.ibm.com | 2010-10-01 | |
| HP Inc. | jeff.jeansonne&hp.com | 2026-03-10 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| ITU-T | tsbsg16&itu.int | 2013-01-31 | |
| ITU-T TSB | ITU-T | tsbsg16&itu.int | 2013-01-31 |
| ITU/TSB (ITU-T Study Group 17) | tsbsg17&itu.int | 2019-09-30 | |
| Jeff Jeansonne | jeff.jeansonne&hp.com | 2026-03-10 | |
| Jerome FOLLUT | COPALP | jf&copalp.com | 2012-03-01 |
| Jonathan Pollock | jon&arcadiancomputers.com | 2016-05-10 | |
| Mary Holstage | holstege&firstfloor.com | ||
| Micha Ben-Efraim | micha.ben-efraim&ca.com | 2010-02-18 | |
| Micha Ben-Efraim | micha&metalix.net | 2012-11-27 | |
| Michael Sharpe | iana-ports&netiq.com | 2010-09-14 | |
| Navtech Radar | network.admin&navtechradar.com | 2013-02-20 | |
| Pure Storage | iana&purestorage.com | 2016-04-04 | |
| Richard Foss | r.foss&ru.ac.za | 2011-02-10 | |
| Robert Eden | reden&sieglertech.com | 2003-03 | |
| Robert Porter | rob&gradecam.com | 2009-09-24 | |
| Ronald G. Minnich | rminnich&gmail.com | 2022-05-13 | |
| Scott Tarone | starone&proactivethought.com | 2003-04 | |
| Steve Hodgson | Pure Storage | steve&purestorage.com | 2013-08-13 |
| Stoneware Inc. | coby.gurr&stone-ware.com | 2012-05-18 | |
| Teijo Mustonen | Teijo.Mustonen&f-secure.com | 2002-03 | |
| gunner&ibeam.intel.com |