Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| tipc | 6118 | udp | Transparent Inter Process Communication | Ericsson | Erik Hugne | 2012-09-05 | |||||
| 6118 | tcp | Reserved | |||||||||
| iona-data | 6318 | tcp | IONA Measurement and control data | Insphere Ltd | Guy Avery | 2024-07-01 | |||||
| 6318 | udp | Reserved | |||||||||
| syserverremote | 6418 | tcp | SYserver remote commands | David Ashkenazi | David Ashkenazi | 2010-03-23 | |||||
| 6418 | udp | Reserved | |||||||||
| netconf-tls | 6513 | tcp | NETCONF over TLS | IESG | IETF Chair | 2024-01-24 | RFC 7589; RFC 9918 | ||||
| 6611-6618 | Unassigned | ||||||||||
| 6818-6830 | Unassigned | ||||||||||
| fisa-svc | 7018 | tcp | FISA Service | FAUCONNET Ingénierie SA | FAUCONNET Ingénierie SA | 2011-05-19 | |||||
| 7018 | udp | Reserved | |||||||||
| 7118-7120 | Unassigned | ||||||||||
| 7175-7180 | Unassigned | ||||||||||
| janus-disc | 7181 | udp | Janus Guidewire Enterprise Discovery Service Bus | Guidewire Software, Inc | Luca Debiasi | 2014-02-06 | |||||
| 7181 | tcp | Reserved | |||||||||
| 7182-7199 | Unassigned | ||||||||||
| mipv6tls | 7872 | udp | TLS-based Mobile IPv6 Security | IESG | IETF Chair | 2012-04-12 | RFC 6618 | ||||
| 8018 | Unassigned | ||||||||||
| privoxy | 8118 | tcp | Privoxy HTTP proxy | Andreas Oesterhelt | Andreas Oesterhelt | 2002-06 | |||||
| privoxy | 8118 | udp | Privoxy HTTP proxy | Andreas Oesterhelt | Andreas Oesterhelt | 2002-06 | |||||
| 8163-8180 | Unassigned | ||||||||||
| intermapper | 8181 | tcp | Intermapper network management system | William Fisher | William Fisher | 2011-05-09 | |||||
| 8181 | udp | Reserved | |||||||||
| vmware-fdm | 8182 | tcp | VMware Fault Domain Manager | Ron Passerini | Ron Passerini | 2010-04-27 | |||||
| vmware-fdm | 8182 | udp | VMware Fault Domain Manager | Ron Passerini | Ron Passerini | 2010-04-27 | |||||
| proremote | 8183 | tcp | ProRemote | Alex Lelievre | Alex Lelievre | 2009-08-18 | |||||
| 8183 | udp | Reserved | |||||||||
| itach | 8184 | tcp | Remote iTach Connection | Barend Jacobus van der Merwe | Barend Jacobus van der Merwe | 2010-04-27 | |||||
| itach | 8184 | udp | Remote iTach Connection | Barend Jacobus van der Merwe | Barend Jacobus van der Merwe | 2010-04-27 | |||||
| 8185-8189 | Unassigned | ||||||||||
| 8418-8422 | Unassigned | ||||||||||
| 9112-9118 | Unassigned | ||||||||||
| 9165-9182 | Unassigned | ||||||||||
| sirius-agent | 9183 | tcp | Sirius Configuration Agent | Sirius Computer, Inc | Jason Van der Schyff | 2026-03-09 | |||||
| sirius-agent | 9183 | udp | Sirius Configuration Agent | Sirius Computer, Inc | Jason Van der Schyff | 2026-03-09 | |||||
| 9184-9190 | Unassigned | ||||||||||
| 9218-9221 | Unassigned | ||||||||||
| secure-ts | 9318 | tcp | PKIX TimeStamp over TLS | Niklas Weiss | Niklas Weiss | 2004-11 | |||||
| secure-ts | 9318 | udp | PKIX TimeStamp over TLS | Niklas Weiss | Niklas Weiss | 2004-11 | |||||
| git | 9418 | tcp | git pack transfer service | Linus Torvalds | Linus Torvalds | 2005-09 | |||||
| git | 9418 | udp | git pack transfer service | Linus Torvalds | Linus Torvalds | 2005-09 | |||||
| condor | 9618 | tcp | Condor Collector Service | Todd Tannenbaum | Todd Tannenbaum | 2008-04-03 | |||||
| condor | 9618 | udp | Condor Collector Service | Todd Tannenbaum | Todd Tannenbaum | 2008-04-03 | |||||
| nmea-0183 | 10110 | tcp | NMEA-0183 Navigational Data | Meindert Sprang | Meindert Sprang | 2009-02-18 | |||||
| nmea-0183 | 10110 | udp | NMEA-0183 Navigational Data | Meindert Sprang | Meindert Sprang | 2009-02-18 | |||||
| 10118-10124 | Unassigned | ||||||||||
| 11236-11318 | Unassigned | ||||||||||
| 11797-11875 | Unassigned | ||||||||||
| xoraya | 11876 | tcp | X2E Xoraya Multichannel protocol | Hannes K√§lber | Hannes K√§lber | 2010-09-13 | |||||
| xoraya | 11876 | udp | X2E Xoraya Multichannel protocol | Hannes K√§lber | Hannes K√§lber | 2010-09-13 | |||||
| 11877 | tcp | Reserved | |||||||||
| x2e-disc | 11877 | udp | X2E service discovery protocol | Hannes K√§lber | Hannes K√§lber | 2010-09-13 | |||||
| 11878-11966 | Unassigned | ||||||||||
| emc-vcas-tcp | 13218 | tcp | EMC Virtual CAS Service | ||||||||
| emc-vcas-udp | 13218 | udp | EMV Virtual CAS Service Discovery | Mark O'Connell | Mark O'Connell | 2008-12-04 | |||||
| dsmcc-config | 13818 | tcp | DSMCC Config | Tim Addington | Tim Addington | ISO/IEC 13818-6 MPEG-2 DSM-CC | |||||
| dsmcc-config | 13818 | udp | DSMCC Config | Tim Addington | Tim Addington | ISO/IEC 13818-6 MPEG-2 DSM-CC | |||||
| dsmcc-session | 13819 | tcp | DSMCC Session Messages | Tim Addington | Tim Addington | ISO/IEC 13818-6 MPEG-2 DSM-CC | |||||
| dsmcc-session | 13819 | udp | DSMCC Session Messages | Tim Addington | Tim Addington | ISO/IEC 13818-6 MPEG-2 DSM-CC | |||||
| dsmcc-passthru | 13820 | tcp | DSMCC Pass-Thru Messages | Tim Addington | Tim Addington | ISO/IEC 13818-6 MPEG-2 DSM-CC | |||||
| dsmcc-passthru | 13820 | udp | DSMCC Pass-Thru Messages | Tim Addington | Tim Addington | ISO/IEC 13818-6 MPEG-2 DSM-CC | |||||
| dsmcc-download | 13821 | tcp | DSMCC Download Protocol | Tim Addington | Tim Addington | ISO/IEC 13818-6 MPEG-2 DSM-CC | |||||
| dsmcc-download | 13821 | udp | DSMCC Download Protocol | Tim Addington | Tim Addington | ISO/IEC 13818-6 MPEG-2 DSM-CC | |||||
| dsmcc-ccp | 13822 | tcp | DSMCC Channel Change Protocol | Tim Addington | Tim Addington | ISO/IEC 13818-6 MPEG-2 DSM-CC | |||||
| dsmcc-ccp | 13822 | udp | DSMCC Channel Change Protocol | Tim Addington | Tim Addington | ISO/IEC 13818-6 MPEG-2 DSM-CC | |||||
| 15118 | tcp | Reserved | |||||||||
| v2g-secc | 15118 | udp | v2g Supply Equipment Communication Controller Discovery Protocol | Holger Lochner | Holger Lochner | 2011-04-06 | |||||
| 16386-16618 | Unassigned | ||||||||||
| 17011-17183 | Unassigned | ||||||||||
| vestasdlp | 17184 | tcp | Vestas Data Layer Protocol | Vestas Wind Systems | Teunis de Wit | 2013-10-30 | |||||
| 17184 | udp | Reserved | |||||||||
| soundsvirtual | 17185 | tcp | Sounds Virtual | Richard Snider | Richard Snider | ||||||
| soundsvirtual | 17185 | udp | Sounds Virtual | Richard Snider | Richard Snider | ||||||
| 17186-17218 | Unassigned | ||||||||||
| biimenu | 18000 | tcp | Beckman Instruments, Inc. | R. L. Meyering | R. L. Meyering | ||||||
| biimenu | 18000 | udp | Beckman Instruments, Inc. | R. L. Meyering | R. L. Meyering | ||||||
| 18001-18103 | Unassigned | ||||||||||
| radpdf | 18104 | tcp | RAD PDF Service | Christopher Truxaw | Christopher Truxaw | 2010-10-15 | |||||
| 18104 | udp | Reserved | |||||||||
| 18105-18135 | Unassigned | ||||||||||
| racf | 18136 | tcp | z/OS Resource Access Control Facility | Bruce Wells | Bruce Wells | 2010-10-04 | |||||
| 18136 | udp | Reserved | |||||||||
| 18137-18180 | Unassigned | ||||||||||
| opsec-cvp | 18181 | tcp | OPSEC CVP | Alon Kantor | Alon Kantor | ||||||
| opsec-cvp | 18181 | udp | OPSEC CVP | Alon Kantor | Alon Kantor | ||||||
| opsec-ufp | 18182 | tcp | OPSEC UFP | Alon Kantor | Alon Kantor | ||||||
| opsec-ufp | 18182 | udp | OPSEC UFP | Alon Kantor | Alon Kantor | ||||||
| opsec-sam | 18183 | tcp | OPSEC SAM | Alon Kantor | Alon Kantor | ||||||
| opsec-sam | 18183 | udp | OPSEC SAM | Alon Kantor | Alon Kantor | ||||||
| opsec-lea | 18184 | tcp | OPSEC LEA | Alon Kantor | Alon Kantor | ||||||
| opsec-lea | 18184 | udp | OPSEC LEA | Alon Kantor | Alon Kantor | ||||||
| opsec-omi | 18185 | tcp | OPSEC OMI | Alon Kantor | Alon Kantor | ||||||
| opsec-omi | 18185 | udp | OPSEC OMI | Alon Kantor | Alon Kantor | ||||||
| ohsc | 18186 | tcp | Occupational Health SC | David Fudge | David Fudge | 2003-08 | |||||
| ohsc | 18186 | udp | Occupational Health Sc | David Fudge | David Fudge | 2003-08 | |||||
| opsec-ela | 18187 | tcp | OPSEC ELA | Alon Kantor | Alon Kantor | ||||||
| opsec-ela | 18187 | udp | OPSEC ELA | Alon Kantor | Alon Kantor | ||||||
| 18188-18240 | Unassigned | ||||||||||
| checkpoint-rtm | 18241 | tcp | Check Point RTM | Dudi Hazan | Dudi Hazan | ||||||
| checkpoint-rtm | 18241 | udp | Check Point RTM | Dudi Hazan | Dudi Hazan | ||||||
| iclid | 18242 | tcp | Checkpoint router monitoring | Check Point Software Technologies Ltd. | Rahul Bahadur | 2012-06-28 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alex Lelievre | alex&folabs.com | 2009-08-18 | |
| Alon Kantor | alonk&checkpoint.com | ||
| Andreas Oesterhelt | oes&privoxy.org | 2002-06 | |
| Barend Jacobus van der Merwe | berneau.v&gmail.com | 2010-04-27 | |
| Bruce Wells | brwells&us.ibm.com | 2010-10-04 | |
| Check Point Software Technologies Ltd. | rbahadur&checkpoint.com | 2012-06-28 | |
| Christopher Truxaw | ctruxaw&redsoftware.com | 2010-10-15 | |
| David Ashkenazi | david&synel.co.il | 2010-03-23 | |
| David Fudge | david.fudge&tssi.co.uk | 2003-08 | |
| Dudi Hazan | dudi&checkpoint.com | ||
| Ericsson | erik.hugne&ericsson.com | 2012-09-05 | |
| Erik Hugne | Ericsson | erik.hugne&ericsson.com | 2012-09-05 |
| FAUCONNET Ingénierie SA | dev&fisa.fr | 2011-05-19 | |
| Guidewire Software, Inc | info&guidewire.com | 2014-02-06 | |
| Guy Avery | Insphere Ltd | guy&insphereltd.com | 2013-02-20 |
| Hannes K√§lber | hannes.kaelber&x2e.de | 2010-09-13 | |
| Holger Lochner | holger.lochner&daimler.com | 2011-04-06 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Insphere Ltd | guy&insphereltd.com | 2024-07-01 | |
| Jason Van der Schyff | jason&sirius.computer | 2026-03-09 | |
| Linus Torvalds | torvalds&osdl.org | 2005-09 | |
| Luca Debiasi | Guidewire Software, Inc | ldebiasi&guidewire.com | 2014-02-06 |
| Mark O'Connell | oconnell_marka&emc.com | 2008-12-04 | |
| Meindert Sprang | ms&customware.nl | 2009-02-18 | |
| Niklas Weiss | n.weiss&d-trust.net | 2004-11 | |
| R. L. Meyering | RLMEYERING&biivax.dp.beckman.com | ||
| Rahul Bahadur | Check Point Software Technologies Ltd. | rbahadur&checkpoint.com | 2012-06-28 |
| Richard Snider | rsnider&sounds.com | ||
| Ron Passerini | rpasserini&vmware.com | 2010-04-27 | |
| Sirius Computer, Inc | jason&sirius.computer | 2026-03-09 | |
| Teunis de Wit | Vestas Wind Systems | tdwi&vestas.com | 2013-10-30 |
| Tim Addington | Tim.Addington&sciatl.com | ||
| Todd Tannenbaum | tannenba&cs.wisc.edu | 2008-04-03 | |
| Vestas Wind Systems | tdwi&vestas.com | 2013-10-30 | |
| William Fisher | william.w.fisher&intermapper.com | 2011-05-09 |