Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-27
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| beyond-remote | 5424 | tcp | Beyond Remote | Michael Berg | Michael Berg | 2004-11 | |||||
| beyond-remote | 5424 | udp | Beyond Remote | Michael Berg | Michael Berg | 2004-11 | |||||
| omsdk | 5724 | tcp | Operations Manager - SDK Service | Gerardo Dilillo | Gerardo Dilillo | 2006-08 | |||||
| omsdk | 5724 | udp | Operations Manager - SDK Service | Gerardo Dilillo | Gerardo Dilillo | 2006-08 | |||||
| pnbs | 6124 | tcp | Phlexible Network Backup Service | William R. Lear | William R. Lear | 2008-10-23 | |||||
| pnbs | 6124 | udp | Phlexible Network Backup Service | William R. Lear | William R. Lear | 2008-10-23 | |||||
| 6223-6240 | Unassigned | ||||||||||
| jeol-nsdtp-1 | 6241 | tcp | JEOL Network Services Data Transport Protocol 1 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsddp-1 | 6241 | udp | JEOL Network Services Dynamic Discovery Protocol 1 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsdtp-2 | 6242 | tcp | JEOL Network Services Data Transport Protocol 2 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsddp-2 | 6242 | udp | JEOL Network Services Dynamic Discovery Protocol 2 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsdtp-3 | 6243 | tcp | JEOL Network Services Data Transport Protocol 3 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsddp-3 | 6243 | udp | JEOL Network Services Dynamic Discovery Protocol 3 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsdtp-4 | 6244 | tcp | JEOL Network Services Data Transport Protocol 4 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsddp-4 | 6244 | udp | JEOL Network Services Dynamic Discovery Protocol 4 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| 6245-6250 | Unassigned | ||||||||||
| hrd-ncs | 6324 | tcp | HR Device Network Configuration Service | Hall Research | Vishal Dharmadhikari | 2011-11-29 | |||||
| hrd-ns-disc | 6324 | udp | HR Device Network service | Hall Research | Vishal Dharmadhikari | 2011-11-29 | |||||
| odette-ftps | 6619 | tcp | ODETTE-FTP over TLS/SSL | Ieuan Friend | Ieuan Friend | 2006-03 | RFC 5024 | ||||
| odette-ftps | 6619 | udp | ODETTE-FTP over TLS/SSL | Ieuan Friend | Ieuan Friend | 2006-03 | RFC 5024 | ||||
| datascaler-db | 6624 | tcp | DataScaler database | Vasu Murthy | Vasu Murthy | 2010-02-08 | |||||
| 6624 | udp | Reserved | |||||||||
| split-ping | 6924 | tcp | Ping with RX/TX latency/loss split | Ben Cartwright-Cox | Ben Cartwright-Cox | 2020-02-12 | |||||
| split-ping | 6924 | udp | Ping with RX/TX latency/loss split | Ben Cartwright-Cox | Ben Cartwright-Cox | 2020-02-12 | |||||
| vmsvc | 7024 | tcp | Vormetric service | Tom Boyle | Tom Boyle | 2005-06 | |||||
| vmsvc | 7024 | udp | Vormetric service | Tom Boyle | Tom Boyle | 2005-06 | |||||
| 7124-7127 | Unassigned | ||||||||||
| 7238-7243 | Unassigned | ||||||||||
| frc-hicp | 7244 | tcp | FrontRow Calypso Human Interface Control Protocol | Frontrow Calypso, LLC | Scott Halberg | 2016-04-19 | |||||
| frc-hicp-disc | 7244 | udp | FrontRow Calypso Human Interface Control Protocol | Frontrow Calypso, LLC | Scott Halberg | 2016-04-19 | |||||
| 7245-7261 | Unassigned | ||||||||||
| indi | 7624 | tcp | Instrument Neutral Distributed Interface | Elwood Downey | Elwood Downey | 2002-04 | |||||
| indi | 7624 | udp | Instrument Neutral Distributed Interface | Elwood Downey | Elwood Downey | 2002-04 | |||||
| nsdeepfreezectl | 7724 | tcp | Novell Snap-in Deep Freeze Control | David Crowe | David Crowe | 2008-01-07 | |||||
| nsdeepfreezectl | 7724 | udp | Novell Snap-in Deep Freeze Control | David Crowe | David Crowe | 2008-01-07 | |||||
| 8024 | Unassigned | ||||||||||
| 8077 | tcp | Reserved | 2024-01-05 | De-Assigned on 2024-01-05. | |||||||
| 8233-8242 | Unassigned | ||||||||||
| synapse-nhttps | 8243 | tcp | Synapse Non Blocking HTTPS | Ruwan Linton | Ruwan Linton | 2008-07-10 | |||||
| synapse-nhttps | 8243 | udp | Synapse Non Blocking HTTPS | Ruwan Linton | Ruwan Linton | 2008-07-10 | |||||
| 8244-8265 | Unassigned | ||||||||||
| 8424-8431 | Unassigned | ||||||||||
| 8699 | udp | Reserved | 2004-11 | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||
| 3gpp-monp | 8809 | udp | MCPTT Off-Network Protocol (MONP) | 3GPP | Dongwook Kim | 2019-04-15 | 2026-01-23 | 3GPP TS 24.379 v13.5.0s | |||
| swa-2 | 9024 | tcp | Secure Web Access - 2 | Tim McGranaghan | Tim McGranaghan | ||||||
| swa-2 | 9024 | udp | Secure Web Access - 2 | Tim McGranaghan | Tim McGranaghan | ||||||
| 9124-9130 | Unassigned | ||||||||||
| 9912-9924 | Unassigned | ||||||||||
| 10024-10049 | Unassigned | ||||||||||
| 10118-10124 | Unassigned | ||||||||||
| 11624-11719 | Unassigned | Unauthorized Use Known on port 11711 | |||||||||
| 11724-11750 | Unassigned | ||||||||||
| powwow-server | 13224 | tcp | PowWow Server | Paul K. Peterson | Paul K. Peterson | ||||||
| powwow-server | 13224 | udp | PowWow Server | Paul K. Peterson | Paul K. Peterson | ||||||
| vnetd | 13724 | tcp | Veritas Network Utility | Jeff Holmbeck | Jeff Holmbeck | ||||||
| vnetd | 13724 | udp | Veritas Network Utility | Jeff Holmbeck | Jeff Holmbeck | ||||||
| 13824-13831 | Unassigned | ||||||||||
| 14155-14249 | Unassigned | ||||||||||
| trdp-pd | 17224 | udp | Train Realtime Data Protocol (TRDP) Process Data | IEC Central Office | Gianosvaldo Fadin | 2015-07-24 | |||||
| 17224 | tcp | Reserved | |||||||||
| 18188-18240 | Unassigned | ||||||||||
| checkpoint-rtm | 18241 | tcp | Check Point RTM | Dudi Hazan | Dudi Hazan | ||||||
| checkpoint-rtm | 18241 | udp | Check Point RTM | Dudi Hazan | Dudi Hazan | ||||||
| iclid | 18242 | tcp | Checkpoint router monitoring | Check Point Software Technologies Ltd. | Rahul Bahadur | 2012-06-28 | |||||
| 18242 | udp | Reserved | |||||||||
| clusterxl | 18243 | tcp | Checkpoint router state backup | Check Point Software Technologies Ltd. | Rahul Bahadur | 2012-06-28 | |||||
| 18243 | udp | Reserved | |||||||||
| 18244-18258 | Unassigned | ||||||||||
| 22006-22124 | Unassigned | ||||||||||
| med-ltp | 24000 | tcp | med-ltp | Juergen Fischbach | Juergen Fischbach | ||||||
| med-ltp | 24000 | udp | med-ltp | Juergen Fischbach | Juergen Fischbach | ||||||
| med-fsp-rx | 24001 | tcp | med-fsp-rx | Juergen Fischbach | Juergen Fischbach | ||||||
| med-fsp-rx | 24001 | udp | med-fsp-rx | Juergen Fischbach | Juergen Fischbach | ||||||
| med-fsp-tx | 24002 | tcp | med-fsp-tx | Juergen Fischbach | Juergen Fischbach | ||||||
| med-fsp-tx | 24002 | udp | med-fsp-tx | Juergen Fischbach | Juergen Fischbach | ||||||
| med-supp | 24003 | tcp | med-supp | Juergen Fischbach | Juergen Fischbach | ||||||
| med-supp | 24003 | udp | med-supp | Juergen Fischbach | Juergen Fischbach | ||||||
| med-ovw | 24004 | tcp | med-ovw | Juergen Fischbach | Juergen Fischbach | ||||||
| med-ovw | 24004 | udp | med-ovw | Juergen Fischbach | Juergen Fischbach | ||||||
| med-ci | 24005 | tcp | med-ci | Juergen Fischbach | Juergen Fischbach | ||||||
| med-ci | 24005 | udp | med-ci | Juergen Fischbach | Juergen Fischbach | ||||||
| med-net-svc | 24006 | tcp | med-net-svc | Juergen Fischbach | Juergen Fischbach | ||||||
| med-net-svc | 24006 | udp | med-net-svc | Juergen Fischbach | Juergen Fischbach | ||||||
| 24007-24241 | Unassigned | ||||||||||
| filesphere | 24242 | tcp | fileSphere | Carl Cedergren | Carl Cedergren | ||||||
| filesphere | 24242 | udp | fileSphere | Carl Cedergren | Carl Cedergren | ||||||
| 24243-24248 | Unassigned | ||||||||||
| vista-4gl | 24249 | tcp | Vista 4GL | Ingenta plc | Mark Itzcovitz | 2020-01-06 | |||||
| vista-4gl | 24249 | udp | Vista 4GL | Ingenta plc | Mark Itzcovitz | 2020-01-06 | |||||
| 24250-24320 | Unassigned | ||||||||||
| ild | 24321 | tcp | Isolv Local Directory | Mitchell Bass | Mitchell Bass | 2005-08 | |||||
| ild | 24321 | udp | Isolv Local Directory | Mitchell Bass | Mitchell Bass | 2005-08 | |||||
| hid | 24322 | udp | Transport of Human Interface Device data streams | Freebox SAS | Nicolas Pouillon | 2012-12-14 | |||||
| 24322 | tcp | Reserved | |||||||||
| vrmg-ip | 24323 | tcp | Verimag mobile class protocol over TCP | Verimag, OOO | Denis Ionov | 2018-08-15 | |||||
| 24323 | udp | Reserved | |||||||||
| 24324-24385 | Unassigned | ||||||||||
| intel-rci | 24386 | tcp | Intel RCI IANA assigned this well-formed service name as a replacement for "intel_rci". |
Mark Lewis | Mark Lewis | ||||||
| intel_rci | 24386 | tcp | Intel RCI | Mark Lewis | Mark Lewis | This entry is an alias to "intel-rci". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| intel-rci | 24386 | udp | Intel RCI IANA assigned this well-formed service name as a replacement for "intel_rci". |
Mark Lewis | Mark Lewis | ||||||
| intel_rci | 24386 | udp | Intel RCI | Mark Lewis | Mark Lewis | This entry is an alias to "intel-rci". This entry is now historic, not usable for use with many common service discovery mechanisms. |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP | info&3gpp.org | 2026-10-20 | |
| Ben Cartwright-Cox | ben&benjojo.co.uk | 2020-02-12 | |
| Carl Cedergren | asperon&home.se | ||
| Check Point Software Technologies Ltd. | rbahadur&checkpoint.com | 2012-06-28 | |
| David Crowe | dcrowe&faronics.com | 2008-01-07 | |
| Denis Ionov | Verimag, OOO | iddi&verimag.ru | 2018-07-20 |
| Dongwook Kim | 3GPP | info&3gpp.org | 2026-10-20 |
| Dudi Hazan | dudi&checkpoint.com | ||
| Elwood Downey | ecdowney&clearskyinstitute.com | 2002-04 | |
| Freebox SAS | npouillon&freebox.fr | 2012-12-14 | |
| Frontrow Calypso, LLC | eng&gofrontrow.com | 2016-04-13 | |
| Gerardo Dilillo | MOMIANAµsoft.com | 2006-08 | |
| Gianosvaldo Fadin | IEC Central Office | gianosvaldo.fadin&anie.it | 2015-07-24 |
| Hall Research | vishal&hallresearch.com | 2011-11-29 | |
| IEC Central Office | cj&iec.ch | 2015-07-24 | |
| Ieuan Friend | ieuan.friend&dip.co.uk | 2006-03 | |
| Ingenta plc | mark.itzcovitz&ingenta.com | 2020-01-06 | |
| Jeff Holmbeck | Jeff.Holmbeck&veritas.com | ||
| Juergen Fischbach | juergen.fischbach&philips.com | ||
| Kevin Wellwood | wellwood&jeol.com | 2008-04-17 | |
| Mark Itzcovitz | mark.itzcovitz&ingenta.com | 2020-01-06 | |
| Mark Lewis | mark.h.lewis&intel.com | ||
| Michael Berg | mike&dataapples.com | 2005-08 | |
| Mitchell Bass | mitch&integrasolv.com | 2005-08 | |
| Nicolas Pouillon | Freebox SAS | npouillon&freebox.fr | 2012-12-14 |
| Paul K. Peterson | paul&tribal.com | ||
| Rahul Bahadur | Check Point Software Technologies Ltd. | rbahadur&checkpoint.com | 2012-06-28 |
| Ruwan Linton | ruwan&wso2.com | 2008-08-20 | |
| Scott Halberg | slh&gofrontrow.com | 2016-04-13 | |
| Tim McGranaghan | tim_mcgranaghan&mech.disa.mil | ||
| Tom Boyle | tboyle&vormetric.com | 2005-06 | |
| Vasu Murthy | vmurthy&datascaler.com | 2010-02-08 | |
| Verimag, OOO | support&verimag.ru | 2018-07-20 | |
| Vishal Dharmadhikari | Hall Research | vishal&hallresearch.com | 2011-11-29 |
| William R. Lear | wlear&phlexible.com | 2008-10-23 |