Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dt-mgmtsvc 6325 tcp Double-Take Management Service Carbonite, Inc. James Wilkinson 2012-06-06 2019-08-23
6325 udp Reserved
syslog-tls 6514 tcp Syslog over TLS RFC 5425
datascaler-ctl 6625 tcp DataScaler control Vasu Murthy Vasu Murthy 2010-02-08
6625 udp Reserved
6925-6934 Unassigned
vmsvc-2 7025 tcp Vormetric Service II Tom Boyle Tom Boyle 2005-06
vmsvc-2 7025 udp Vormetric Service II Tom Boyle Tom Boyle 2005-06
7422-7425 Unassigned
7625 Unassigned
nitrogen 7725 tcp Nitrogen Service Randy Lomnes Randy Lomnes 2004-11
nitrogen 7725 udp Nitrogen Service Randy Lomnes Randy Lomnes 2004-11
ca-audit-da 8025 tcp CA Audit Distribution Agent Henning Smith Henning Smith 2006-07
ca-audit-da 8025 udp CA Audit Distribution Agent Henning Smith Henning Smith 2006-07
swa-3 9025 tcp Secure Web Access - 3 Tim McGranaghan Tim McGranaghan
swa-3 9025 udp Secure Web Access - 3 Tim McGranaghan Tim McGranaghan
9223-9254 Unassigned
mon 9255 tcp Manager On Network David Rouchet David Rouchet 2007-05
mon 9255 udp Manager On Network David Rouchet David Rouchet 2007-05
9256-9276 Unassigned
xybrid-cloud 9925 tcp XYBRID Cloud Rx Networks Inc. Drew Davies 2013-04-25
9925 udp Reserved
cimple 10125 tcp HotLink CIMple REST API HotLink Corporation Richard Offer 2014-12-18
10125 udp Reserved
10202-10251 Unassigned
apollo-relay 10252 tcp Apollo Relay Port Anthony Carrabino Anthony Carrabino 2003-08
apollo-relay 10252 udp Apollo Relay Port Anthony Carrabino Anthony Carrabino 2003-08
eapol-relay 10253 udp Relay of EAPOL frames Wi-SUN Alliance Phil Beecher 2015-06-26
10253 tcp Reserved
10254-10259 Unassigned
12346-12545 Unassigned
carb-repl-ctrl 12546 tcp Carbonite Server Replication Control Open Text Corporation Tony Ponzo 2022-10-07
12546 udp Reserved
12547-12752 Unassigned
13225-13399 Unassigned
13725-13781 Unassigned
cps 14250 tcp Fencing Server Mayank Vasa Mayank Vasa 2008-04-03
cps 14250 udp Fencing Server Mayank Vasa Mayank Vasa 2008-04-03
14251-14413 Unassigned
trdp-md 17225 tcp Train Realtime Data Protocol (TRDP) Message Data IEC Central Office Gianosvaldo Fadin 2015-07-24
trdp-md 17225 udp Train Realtime Data Protocol (TRDP) Message Data IEC Central Office Gianosvaldo Fadin 2015-07-24
18244-18258 Unassigned
18259 Unassigned Known Unauthorized Use on port 18259
dcap 22125 tcp dCache Access Protocol Christoph Anton Mitterer Christoph Anton Mitterer 2009-03-10
22125 udp Reserved
22352-22536 Unassigned
caldsoft-backup 22537 tcp CaldSoft Backup server file transfer CaldSoft Mark Caldwell 2011-08-12
22537 udp Reserved
22538-22554 Unassigned
vocaltec-wconf 22555 tcp Vocaltec Web Conference Scott Petrack Scott Petrack
vocaltec-phone 22555 udp Vocaltec Internet Phone Scott Petrack Scott Petrack
22556-22762 Unassigned
24250-24320 Unassigned
icl-twobase1 25000 tcp icl-twobase1 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase1 25000 udp icl-twobase1 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase2 25001 tcp icl-twobase2 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase2 25001 udp icl-twobase2 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase3 25002 tcp icl-twobase3 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase3 25002 udp icl-twobase3 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase4 25003 tcp icl-twobase4 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase4 25003 udp icl-twobase4 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase5 25004 tcp icl-twobase5 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase5 25004 udp icl-twobase5 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase6 25005 tcp icl-twobase6 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase6 25005 udp icl-twobase6 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase7 25006 tcp icl-twobase7 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase7 25006 udp icl-twobase7 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase8 25007 tcp icl-twobase8 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase8 25007 udp icl-twobase8 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase9 25008 tcp icl-twobase9 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase9 25008 udp icl-twobase9 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase10 25009 tcp icl-twobase10 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase10 25009 udp icl-twobase10 J. A. (Tony) Sever J. A. (Tony) Sever
25010-25099 Unassigned
db2c-tls 25100 tcp IBM Db2 Client Interface - Encrypted IBM Matthew Emmerton 2024-03-05
25100 udp Reserved
25101-25470 Unassigned
rna 25471 sctp RNSAP User Adaptation for Iurh Dario S. Tonesi Dario S. Tonesi 2011-02-07
25472-25575 Unassigned
sauterdongle 25576 tcp Sauter Dongle Christian Brecht Christian Brecht 2010-12-15
25576 udp Reserved
25577-25603 Unassigned
idtp 25604 tcp Identifier Tracing Protocol Huang Neng-geng Huang Neng-geng 2011-08-09
25604 udp Reserved
25605-25792 Unassigned
vocaltec-hos 25793 tcp Vocaltec Address Server Scott Petrack Scott Petrack
vocaltec-hos 25793 udp Vocaltec Address Server Scott Petrack Scott Petrack
25794-25899 Unassigned
tasp-net 25900 tcp TASP Network Comm Martin Ellis Martin Ellis 2004-11
tasp-net 25900 udp TASP Network Comm Martin Ellis Martin Ellis 2004-11
niobserver 25901 tcp NIObserver Roman Oliynyk Roman Oliynyk
niobserver 25901 udp NIObserver Roman Oliynyk Roman Oliynyk
nilinkanalyst 25902 tcp NILinkAnalyst Roman Oliynyk Roman Oliynyk 2007-08-30
nilinkanalyst 25902 udp NILinkAnalyst Roman Oliynyk Roman Oliynyk 2007-08-30
niprobe 25903 tcp NIProbe Roman Oliynyk Roman Oliynyk
niprobe 25903 udp NIProbe Roman Oliynyk Roman Oliynyk
25904-25953 Unassigned
bf-game 25954 udp Bitfighter game server Christopher Eykamp Christopher Eykamp 2012-08-16
25954 tcp Reserved
bf-master 25955 udp Bitfighter master server Christopher Eykamp Christopher Eykamp 2012-08-16
25955 tcp Reserved

Contact Information

Name Organization Contact URI Last Updated
Anthony Carrabino anthonyc&vistasoftware.com 2003-08
CaldSoft development&caldsoft.co.uk 2011-08-12
Carbonite, Inc. jwilkinson&carbonite.com 2019-08-23
Christian Brecht Christian.Brecht&sauter-gmbh.de 2010-12-15
Christoph Anton Mitterer calestyo&scientia.net 2009-03-10
Christopher Eykamp chris&eykamp.com 2012-08-16
Dario S. Tonesi dario.tonesi&nsn.com 2011-02-07
David Rouchet david.rouchet&medialon.com 2007-05
Drew Davies Rx Networks Inc. ddavies&rxnetworks.com 2013-04-25
Gianosvaldo Fadin IEC Central Office gianosvaldo.fadin&anie.it 2015-07-24
Henning Smith henning.smith&ca.com 2006-07
Huang Neng-geng huangng&ngweb.org
nghuang&ieee.org
2011-08-09
IBM memmerto&ca.ibm.com 2024-03-05
IEC Central Office cj&iec.ch 2015-07-24
J. A. (Tony) Sever J.A.Sever&bra0119.wins.icl.co.uk
James Wilkinson jwilkinson&carbonite.com 2019-08-23
Mark Caldwell development&caldsoft.co.uk 2011-08-12
Martin Ellis martin&clanleagues.net 2004-11
Matthew Emmerton IBM memmerto&ca.ibm.com 2024-03-05
Mayank Vasa mayank_vasa&symantec.com 2008-04-03
Open Text Corporation tponzo&opentext.com 2022-10-07
Phil Beecher Wi-SUN Alliance pbeecher&wi-sun.org 2015-06-26
Randy Lomnes rlomnes&faronics.com 2004-11
Richard Offer HotLink Corporation roffer&hotlink.com 2014-12-18
Roman Oliynyk romano&netinst.com
Roman Oliynyk roman&netinst.com 2007-08-30
Rx Networks Inc. ddavies&rxnetworks.com 2013-04-25
Scott Petrack Scott_Petrack&vocaltec.com
Tim McGranaghan tim_mcgranaghan&mech.disa.mil
Tom Boyle tboyle&vormetric.com 2005-06
Tony Ponzo Open Text Corporation tponzo&opentext.com 2022-10-07
Vasu Murthy vmurthy&datascaler.com 2010-02-08
Wi-SUN Alliance admin&wi-sun.org 2015-06-26