Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| xkotodrcp | 5344 | tcp | xkoto DRCP | Jeff Heisz | Jeff Heisz | 2006-02 | |||||
| xkotodrcp | 5344 | udp | xkoto DRCP | Jeff Heisz | Jeff Heisz | 2006-02 | |||||
| 5345-5348 | Unassigned | ||||||||||
| stuns | 5349 | tcp | Session Traversal Utilities for NAT (STUN) port | IESG | IETF Chair | 2019-03-28 | RFC 8489 | ||||
| stuns | 5349 | udp | STUN over DTLS | IESG | IETF Chair | 2014-07-03 | RFC 7350 | This service name was initially created by RFC 5389. | |||
| turns | 5349 | tcp | TURN over TLS | 2019-08-02 | RFC 8656 | ||||||
| turns | 5349 | udp | TURN over DTLS | IESG | IETF Chair | 2019-08-02 | RFC 7350 | This service name was initially created by RFC 8656. | |||
| stun-behaviors | 5349 | tcp | STUN Behavior Discovery over TLS | RFC 5780 | |||||||
| stun-behaviors | 5349 | udp | Reserved for a future enhancement of STUN-BEHAVIOR | RFC 5780 | |||||||
| sgi-arrayd | 5434 | tcp | SGI Array Services Daemon | Karl Feind | Karl Feind | 2005-10 | |||||
| sgi-arrayd | 5434 | udp | SGI Array Services Daemon | Karl Feind | Karl Feind | 2005-10 | |||||
| xprtld | 5634 | tcp | SF Message Service | VR Satish | VR Satish | 2007-08-16 | |||||
| xprtld | 5634 | udp | SF Message Service | VR Satish | VR Satish | 2007-08-16 | |||||
| 6134-6139 | Unassigned | ||||||||||
| 6327-6342 | Unassigned | ||||||||||
| sflow | 6343 | tcp | sFlow traffic monitoring | Peter Phaal | Peter Phaal | 2003-06 | |||||
| sflow | 6343 | udp | sFlow traffic monitoring | Peter Phaal | Peter Phaal | 2003-06 | |||||
| streletz | 6344 | tcp | Argus-Spectr security and fire-prevention systems service | Argus-Spectr | Kirill Marinushkin | 2013-10-25 | |||||
| 6344 | udp | Reserved | |||||||||
| 6345-6345 | Unassigned | ||||||||||
| gnutella-svc | 6346 | tcp | gnutella-svc | Serguei Osokine | Serguei Osokine | ||||||
| gnutella-svc | 6346 | udp | gnutella-svc | Serguei Osokine | Serguei Osokine | ||||||
| gnutella-rtr | 6347 | tcp | gnutella-rtr | Serguei Osokine | Serguei Osokine | ||||||
| gnutella-rtr | 6347 | udp | gnutella-rtr | Serguei Osokine | Serguei Osokine | ||||||
| 6348-6349 | Unassigned | ||||||||||
| mpls-pm | 6634 | udp | MPLS Performance Measurement out-of-band response | Cisco Systems | Sagar Soni | 2014-02-20 | |||||
| 6634 | tcp | Reserved | |||||||||
| 6925-6934 | Unassigned | ||||||||||
| asa-gateways | 7234 | tcp | Traffic forwarding for Okta cloud infra | Okta Inc | Sam Hu | 2020-07-07 | |||||
| 7234 | udp | Reserved | |||||||||
| 7634-7647 | Unassigned | ||||||||||
| smip | 7734 | tcp | Smith Protocol over IP | Guidant Measurement | Jim Pettinato | 2007-04 | 2024-10-08 | ||||
| smip | 7734 | udp | Smith Protocol over IP | Guidant Measurement | Jim Pettinato | 2007-04 | 2024-10-08 | ||||
| 7934-7961 | Unassigned | ||||||||||
| vantronix-mgmt | 8034 | tcp | .vantronix Management | Reyk Floeter | Reyk Floeter | 2008-02-27 | |||||
| vantronix-mgmt | 8034 | udp | .vantronix Management | Reyk Floeter | Reyk Floeter | 2008-02-27 | |||||
| 8434-8441 | Unassigned | ||||||||||
| 8734-8749 | Unassigned | ||||||||||
| gribi | 9340 | tcp | gRPC Routing Information Base Interface | Google Networking | Rob Shakir | 2022-03-29 | |||||
| 9340 | udp | Reserved | |||||||||
| 9341-9342 | Unassigned | ||||||||||
| mpidcmgr | 9343 | tcp | MpIdcMgr | Yutaka Ono | Yutaka Ono | ||||||
| mpidcmgr | 9343 | udp | MpIdcMgr | Yutaka Ono | Yutaka Ono | ||||||
| mphlpdmc | 9344 | tcp | Mphlpdmc | Yutaka Ono | Yutaka Ono | ||||||
| mphlpdmc | 9344 | udp | Mphlpdmc | Yutaka Ono | Yutaka Ono | ||||||
| rancher | 9345 | tcp | Rancher Agent | Rancher Labs, Inc. | Vincent Fiduccia | 2015-04-14 | |||||
| 9345 | udp | Reserved | |||||||||
| ctechlicensing | 9346 | tcp | C Tech Licensing | Reed Copsey Jr. | Reed Copsey Jr. | ||||||
| ctechlicensing | 9346 | udp | C Tech Licensing | Reed Copsey Jr. | Reed Copsey Jr. | ||||||
| 9347-9373 | Unassigned | ||||||||||
| 9523-9534 | Unassigned | ||||||||||
| 10934-10989 | Unassigned | ||||||||||
| 11212-11234 | Unassigned | ||||||||||
| ollama | 11434 | tcp | Ollama | Jesse Gross | Jesse Gross | 2025-09-26 | |||||
| 11434 | udp | Reserved | |||||||||
| 12323-12344 | Unassigned | ||||||||||
| italk | 12345 | tcp | Italk Chat System | Takayuki Ito | Takayuki Ito | ||||||
| italk | 12345 | udp | Italk Chat System | Takayuki Ito | Takayuki Ito | ||||||
| 12346-12545 | Unassigned | ||||||||||
| doip-data | 13400 | tcp | DoIP Data | Joerg Schneider | Joerg Schneider | 2011-01-26 | |||||
| doip-disc | 13400 | udp | DoIP Discovery | Joerg Schneider | Joerg Schneider | 2011-01-26 | |||||
| 13401-13719 | Unassigned | ||||||||||
| sage-best-com2 | 14034 | tcp | sage Best! Config Server 2 | Christian Rubach | Christian Rubach | ||||||
| sage-best-com2 | 14034 | udp | sage Best! Config Server 2 | Christian Rubach | Christian Rubach | ||||||
| 15119-15344 | Unassigned | ||||||||||
| xpilot | 15345 | tcp | XPilot Contact Port | Bert Gijsbers | Bert Gijsbers | ||||||
| xpilot | 15345 | udp | XPilot Contact Port | Bert Gijsbers | Bert Gijsbers | ||||||
| 15346-15362 | Unassigned | ||||||||||
| integrius-stp | 17234 | tcp | Integrius Secure Tunnel Protocol | Christian Klemetsson | Christian Klemetsson | 2010-03-04 | |||||
| integrius-stp | 17234 | udp | Integrius Secure Tunnel Protocol | Christian Klemetsson | Christian Klemetsson | 2010-03-04 | |||||
| rds-ib | 18634 | tcp | Reliable Datagram Service | Andy Grover | Andy Grover | 2009-02-27 | |||||
| rds-ib | 18634 | udp | Reliable Datagram Service | Andy Grover | Andy Grover | 2009-02-27 | |||||
| nburn-id | 20034 | tcp | NetBurner ID Port IANA assigned this well-formed service name as a replacement for "nburn_id". |
Paul Breed | Paul Breed | 2003-11 | |||||
| nburn_id | 20034 | tcp | NetBurner ID Port | Paul Breed | Paul Breed | 2003-11 | This entry is an alias to "nburn-id". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| nburn-id | 20034 | udp | NetBurner ID Port IANA assigned this well-formed service name as a replacement for "nburn_id". |
Paul Breed | Paul Breed | 2003-11 | |||||
| nburn_id | 20034 | udp | NetBurner ID Port | Paul Breed | Paul Breed | 2003-11 | This entry is an alias to "nburn-id". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 22334 | Unassigned | ||||||||||
| 22336-22342 | Unassigned | ||||||||||
| cis-secure | 22343 | tcp | CompactIS Secure Tunnel | Justin Paupore | Justin Paupore | 2007-08-16 | |||||
| cis-secure | 22343 | udp | CompactIS Secure Tunnel | Justin Paupore | Justin Paupore | 2007-08-16 | |||||
| 22344-22346 | Unassigned | ||||||||||
| wibukey | 22347 | tcp | WibuKey Standard WkLan | Wolfgang Voelker | Wolfgang Voelker | 2007-06 | |||||
| wibukey | 22347 | udp | WibuKey Standard WkLan | Wolfgang Voelker | Wolfgang Voelker | 2007-06 | |||||
| 22348-22349 | Unassigned | ||||||||||
| 23334-23399 | Unassigned | ||||||||||
| novar-dbase | 23400 | tcp | Novar Data | Keith Kilroy | Keith Kilroy | 2006-02 | |||||
| novar-dbase | 23400 | udp | Novar Data | Keith Kilroy | Keith Kilroy | 2006-02 | |||||
| novar-alarm | 23401 | tcp | Novar Alarm | Keith Kilroy | Keith Kilroy | 2006-02 | |||||
| novar-alarm | 23401 | udp | Novar Alarm | Keith Kilroy | Keith Kilroy | 2006-02 | |||||
| novar-global | 23402 | tcp | Novar Global | Keith Kilroy | Keith Kilroy | 2006-02 | |||||
| novar-global | 23402 | udp | Novar Global | Keith Kilroy | Keith Kilroy | 2006-02 | |||||
| 23403-23455 | Unassigned | ||||||||||
| aequus | 23456 | tcp | Aequus Service | James Anson | James Anson | 2009-02-12 | |||||
| 23456 | udp | Reserved | |||||||||
| aequus-alt | 23457 | tcp | Aequus Service Mgmt | James Anson | James Anson | 2009-02-12 | |||||
| 23457 | udp | Reserved | |||||||||
| 23458-23545 | Unassigned | ||||||||||
| 26134-26207 | Unassigned | ||||||||||
| 27018-27344 | Unassigned | Unauthorized Use Known on ports 27018 and 27019 | |||||||||
| imagepump | 27345 | tcp | ImagePump | Richard Minner | Richard Minner | ||||||
| imagepump | 27345 | udp | ImagePump | Richard Minner | Richard Minner |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andy Grover | andy.grover&oracle.com | 2009-05-20 | |
| Argus-Spectr | mail&argus-spectr.ru | 2013-10-25 | |
| Bert Gijsbers | bert&xpilot.org | ||
| Christian Klemetsson | Integrius AB | christian.klemetsson&integrius.se | 2010-03-04 |
| Christian Rubach | Christian_Rubach&bestsoftware.com | ||
| Cisco Systems | sagsoni&cisco.com | 2014-02-20 | |
| Google Networking | gribi-maintainers&google.com | 2022-03-29 | |
| Guidant Measurement | james.pettinato&guidantmeasurement.com | 2024-10-08 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| James Anson | janson&bigpond.com | 2009-02-12 | |
| Jeff Heisz | jeff.heisz&xkoto.com | 2006-02 | |
| Jesse Gross | jesse&ollama.com | 2026-02-02 | |
| Jim Pettinato | james.pettinato&guidantmeasurement.com | 2024-10-08 | |
| Joerg Schneider | joerg.s.schneider&daimler.com | 2011-01-26 | |
| Justin Paupore | jpaupore&blueshiftlabs.net | 2007-08-16 | |
| Karl Feind | kaf&sgi.com | 2005-10 | |
| Keith Kilroy | Keith.Kilroy&novarcontrols.com | 2006-02 | |
| Kirill Marinushkin | Argus-Spectr | k.marinushkin&argus-spectr.ru | 2013-10-25 |
| Okta Inc | asa-tech&okta.com | 2020-07-07 | |
| Paul Breed | paul&netburner.com | 2003-11 | |
| Peter Phaal | peter.phaal&inmon.com | 2003-06 | |
| Rancher Labs, Inc. | engineering&rancher.com | 2015-04-14 | |
| Reed Copsey Jr. | reedc&ctech.com | ||
| Reyk Floeter | reyk&vantronix.net | 2008-02-27 | |
| Richard Minner | http://xippix.com | ||
| Rob Shakir | Google Networking | robjs&google.com | 2022-03-29 |
| Sam Hu | Okta Inc | sam.hu&okta.com | 2020-07-07 |
| Sagar Soni | Cisco Systems | sagsoni&cisco.com | 2014-02-20 |
| Serguei Osokine | osokin¶graph.com | ||
| Takayuki Ito | yuki&euc.jp | ||
| VR Satish | vr_satish&symantec.com | 2007-08-16 | |
| Vincent Fiduccia | Rancher Labs, Inc. | vincent&rancher.com | 2015-04-14 |
| Wolfgang Voelker | wolfgang.voelker&wibu.com | 2007-06 | |
| Yutaka Ono | ono&saint.nm.fujitsu.co.jp |