Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-27
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| qsnet-workst | 4355 | udp | QSNet Workstation | ||||||||
| qsnet-assist | 4356 | tcp | QSNet Assistant | ||||||||
| qsnet-assist | 4356 | udp | QSNet Assistant | ||||||||
| qsnet-cond | 4357 | tcp | QSNet Conductor | ||||||||
| qsnet-cond | 4357 | udp | QSNet Conductor | ||||||||
| qsnet-nucl | 4358 | tcp | QSNet Nucleus | Neer Kleinman | Neer Kleinman | ||||||
| qsnet-nucl | 4358 | udp | QSNet Nucleus | Neer Kleinman | Neer Kleinman | ||||||
| omabcastltkm | 4359 | tcp | OMA BCAST Long-Term Key Messages | Frank Hartung | Frank Hartung | 2007-09-07 | |||||
| omabcastltkm | 4359 | udp | OMA BCAST Long-Term Key Messages | Frank Hartung | Frank Hartung | 2007-09-07 | |||||
| ehs | 4535 | tcp | Event Heap Server | ||||||||
| ehs | 4535 | udp | Event Heap Server | ||||||||
| dtn-bundle | 4556 | dccp | DTN Bundle DCCP CL Protocol | 2013-11-12 | 2014-02-21 | RFC 7122 | 1685351985 | ||||
| 4931-4935 | Unassigned | ||||||||||
| avt-profile-1 | 5004 | tcp | RTP media data | RFC 3551; RFC 4571 | |||||||
| avt-profile-1 | 5004 | udp | RTP media data | RFC 3551 | |||||||
| avt-profile-1 | 5004 | dccp | RTP media data | RFC 3551; RFC 5762 | |||||||
| avt-profile-2 | 5005 | tcp | RTP control protocol | RFC 3551; RFC 4571 | |||||||
| avt-profile-2 | 5005 | udp | RTP control protocol | RFC 3551 | |||||||
| avt-profile-2 | 5005 | dccp | RTP control protocol | RFC 3551; RFC 5762 | |||||||
| 5035-5041 | Unassigned | ||||||||||
| erp-scale | 5135 | tcp | ERP-Scale | Ian Bradley | Ian Bradley | 2009-10-14 | Defined TXT keys: RFC=<RFC destination and status> Device=<Scale device and status> |
||||
| 5135 | udp | Reserved | |||||||||
| galaxy-network | 5235 | tcp | Galaxy Network Service | Michael Andre | Michael Andre | 2007-10-04 | |||||
| galaxy-network | 5235 | udp | Galaxy Network Service | Michael Andre | Michael Andre | 2007-10-04 | |||||
| stuns | 5349 | udp | STUN over DTLS | IESG | IETF Chair | 2014-07-03 | RFC 7350 | This service name was initially created by RFC 5389. | |||
| turns | 5349 | udp | TURN over DTLS | IESG | IETF Chair | 2019-08-02 | RFC 7350 | This service name was initially created by RFC 8656. | |||
| 5350 | tcp | Reserved | |||||||||
| pcp-multicast | 5350 | udp | Port Control Protocol Multicast | IESG | IETF Chair | RFC 6887 | |||||
| 5351 | tcp | Reserved | |||||||||
| pcp | 5351 | udp | Port Control Protocol | IESG | IETF Chair | RFC 6887 | |||||
| dns-llq | 5352 | tcp | DNS Long-Lived Queries | Stuart Cheshire | Stuart Cheshire | 2005-08 | 2019-08-26 | RFC 8764 | |||
| dns-llq | 5352 | udp | DNS Long-Lived Queries | Stuart Cheshire | Stuart Cheshire | 2005-08 | 2019-08-26 | RFC 8764 | |||
| mdns | 5353 | tcp | Multicast DNS | IESG | IETF Chair | RFC 6762 | |||||
| mdns | 5353 | udp | Multicast DNS | IESG | IETF Chair | RFC 6762 | |||||
| mdnsresponder | 5354 | tcp | Multicast DNS Responder IPC | Stuart Cheshire | Stuart Cheshire | 2004-06 | |||||
| mdnsresponder | 5354 | udp | Multicast DNS Responder IPC | Stuart Cheshire | Stuart Cheshire | 2004-06 | |||||
| llmnr | 5355 | tcp | LLMNR | Bernard Aboba | Bernard Aboba | 2004-06 | |||||
| llmnr | 5355 | udp | LLMNR | Bernard Aboba | Bernard Aboba | 2004-06 | |||||
| ms-smlbiz | 5356 | tcp | Microsoft Small Business | Gopikrishna Sandra | Gopikrishna Sandra | 2005-02 | |||||
| ms-smlbiz | 5356 | udp | Microsoft Small Business | Gopikrishna Sandra | Gopikrishna Sandra | 2005-02 | |||||
| wsdapi | 5357 | tcp | Web Services for Devices | Henry Rawas | Henry Rawas | 2005-08 | |||||
| wsdapi | 5357 | udp | Web Services for Devices | Henry Rawas | Henry Rawas | 2005-08 | |||||
| wsdapi-s | 5358 | tcp | WS for Devices Secured | Henry Rawas | Henry Rawas | 2005-08 | |||||
| wsdapi-s | 5358 | udp | WS for Devices Secured | Henry Rawas | Henry Rawas | 2005-08 | |||||
| ms-alerter | 5359 | tcp | Microsoft Alerter | Marc McClure | Marc McClure | 2007-08-07 | |||||
| ms-alerter | 5359 | udp | Microsoft Alerter | Marc McClure | Marc McClure | 2007-08-07 | |||||
| sceanics | 5435 | tcp | SCEANICS situation and action notification | Richard Olsen | Richard Olsen | ||||||
| sceanics | 5435 | udp | SCEANICS situation and action notification | Richard Olsen | Richard Olsen | ||||||
| sfmsso | 5635 | tcp | SFM Authentication Subsystem | De-Chih Chien | De-Chih Chien | 2008-09-15 | |||||
| 5635 | udp | Reserved | |||||||||
| adap | 6350 | tcp | App Discovery and Access Protocol | Thomas Kjoernes | Thomas Kjoernes | 2010-06-22 | |||||
| adap | 6350 | udp | App Discovery and Access Protocol | Thomas Kjoernes | Thomas Kjoernes | 2010-06-22 | |||||
| 6351-6354 | Unassigned | ||||||||||
| pmcs | 6355 | tcp | PMCS applications | Pavel Mendl | Pavel Mendl | 2007-03 | |||||
| pmcs | 6355 | udp | PMCS applications | Pavel Mendl | Pavel Mendl | 2007-03 | |||||
| 6356-6359 | Unassigned | ||||||||||
| 6635 | tcp | Reserved | |||||||||
| mpls-udp | 6635 | udp | Encapsulate MPLS packets in UDP tunnels. | IESG | IETF Chair | 2015-02-10 | RFC 7510 | ||||
| ethoscan | 6935 | tcp | EthoScan Service | Marty Campbell | Marty Campbell | 2011-06-10 | |||||
| ethoscan | 6935 | udp | EthoScan Service | Marty Campbell | Marty Campbell | 2011-06-10 | |||||
| pon-ictp | 7202 | tcp | Inter-Channel Termination Protocol (ICTP) for multi-wavelength PON (Passive Optical Network) systems | Broadband Forum | Broadband Forum | 2017-02-22 | 2019-12-16 | TR-352; Inter-Channel-Termination protocol (ICTP) is a peer-to-peer protocol with a binary message format that is used by a set of optical line terminal (OLT) channel terminations (CT) comprising a 40-Gigabit-capable next-generation passive optical network (NG-PON2) system to exchange channel profile configuration and status information and to coordinate the operation of tunable optical network units (ONUs) in a multi-wavelength channel environment. | |||
| aspcoordination | 7235 | udp | ASP Coordination Protocol | Wi-Fi Alliance | Mick Conley | 2013-12-31 | |||||
| 7235 | tcp | Reserved | |||||||||
| swx | 7300-7359 | The Swiss Exchange | Edgar Blum | Edgar Blum | |||||||
| 7735-7737 | Unassigned | ||||||||||
| 8035-8039 | Unassigned | ||||||||||
| 8323-8350 | Unassigned | ||||||||||
| server-find | 8351 | tcp | Server Find | Chris Brown | Chris Brown | ||||||
| server-find | 8351 | udp | Server Find | Chris Brown | Chris Brown | ||||||
| 8352-8375 | Unassigned | ||||||||||
| mngsuite | 9535 | tcp | Management Suite Remote Control | Trevor Perkes | Trevor Perkes | 2010-02-01 | |||||
| mngsuite | 9535 | udp | Management Suite Remote Control | Trevor Perkes | Trevor Perkes | 2010-02-01 | |||||
| enrp-sctp | 9901 | sctp | enrp server channel | RFC 5353 | |||||||
| enrp-sctp-tls | 9902 | sctp | enrp/tls server channel | RFC 5353 | |||||||
| snmptls | 10161 | tcp | SNMP-TLS | RFC 6353 | |||||||
| snmpdtls | 10161 | udp | SNMP-DTLS | RFC 6353 | |||||||
| snmptls-trap | 10162 | tcp | SNMP-Trap-TLS | RFC 6353 | |||||||
| snmpdtls-trap | 10162 | udp | SNMP-Trap-DTLS | RFC 6353 | |||||||
| xcompute | 11235 | tcp | numerical systems messaging | Xplicit Computing Inc | Graham J. Orr | 2020-10-16 | |||||
| 11235 | udp | Reserved | |||||||||
| xcompute | 11235 | sctp | numerical systems messaging | Xplicit Computing Inc | Graham J. Orr | 2020-10-16 | |||||
| 11435-11488 | Unassigned | Known UNAUTHORIZED USE: port 11488 | |||||||||
| 14035-14140 | Unassigned | ||||||||||
| 14501-14935 | Unassigned | ||||||||||
| 16312-16359 | Unassigned | ||||||||||
| ssh-mgmt | 17235 | tcp | SSH Tectia Manager | Ville Laurikari | Ville Laurikari | 2005-08 | |||||
| ssh-mgmt | 17235 | udp | SSH Tectia Manager | Ville Laurikari | Ville Laurikari | 2005-08 | |||||
| 18105-18135 | Unassigned | ||||||||||
| rds-ip | 18635 | tcp | Reliable Datagram Service over IP | Andy Grover | Andy Grover | 2009-05-20 | |||||
| rds-ip | 18635 | udp | Reliable Datagram Service over IP | Andy Grover | Andy Grover | 2009-05-20 | |||||
| 20035-20045 | Unassigned | ||||||||||
| shrewd-control | 22335 | tcp | Initium Labs Security and Automation Control | Initium Labs LLC | Manbir Sahni | 2015-03-06 | |||||
| shrewd-stream | 22335 | udp | Initium Labs Security and Automation Streaming | Initium Labs LLC | Manbir Sahni | 2015-03-06 | |||||
| codemeter | 22350 | tcp | CodeMeter Standard | Wolfgang Voelker | Wolfgang Voelker | 2007-06 | |||||
| codemeter | 22350 | udp | CodeMeter Standard | Wolfgang Voelker | Wolfgang Voelker | 2007-06 | |||||
| codemeter-cmwan | 22351 | tcp | TPC/IP requests of copy protection software to a server | WIBU-SYSTEMS AG | Wolfgang Völker | 2013-06-25 | |||||
| 22351 | udp | Reserved | |||||||||
| 22352-22536 | Unassigned | ||||||||||
| 23458-23545 | Unassigned | ||||||||||
| areaguard-neo | 23546 | tcp | AreaGuard Neo - WebServer | SODATSW spol. s r.o. | Roman Štěpánek | 2012-05-31 | |||||
| 23546 | udp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andy Grover | andy.grover&oracle.com | 2009-05-20 | |
| Bernard Aboba | bernardaµsoft.com | 2004-06 | |
| Broadband Forum | help&broadband-forum.org | 2020-03-17 | |
| Chris Brown | chrisb&chancery.com | ||
| De-Chih Chien | de-chih_chien&symantec.com | 2008-10-06 | |
| Edgar Blum | edgar.blum&swx.ch | ||
| Frank Hartung | Frank.Hartung&ericsson.com | 2007-09-07 | |
| Gopikrishna Sandra | v-gosandµsoft.com | 2005-02 | |
| Graham J. Orr | graham&xplicitcomputing.com | 2020-10-16 | |
| Henry Rawas | henryrµsoft.com | 2005-08 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ian Bradley | ian.bradley&pocketprograms.com
development&pocketprograms.com |
2009-10-14 | |
| Initium Labs LLC | manbir&initiumlabs.com | 2015-03-06 | |
| Manbir Sahni | Initium Labs LLC | manbir&initiumlabs.com | 2015-03-06 |
| Marc McClure | marcmccµsoft.com | 2007-08-07 | |
| Marty Campbell | martycðosinfo.com | 2011-06-10 | |
| Michael Andre | mandre&gatewayticketing.com | 2007-10-04 | |
| Mick Conley | Wi-Fi Alliance | mconley&wi-fi.org | 2013-12-31 |
| Neer Kleinman | neer&qsr.co.il | ||
| Pavel Mendl | pavel_mendl¢rum.cz | 2007-03 | |
| Richard Olsen | olsen.richard&yahoo.com | ||
| Roman Štěpánek | SODATSW spol. s r.o. | roman.stepanek&sodatsw.cz | 2012-05-31 |
| SODATSW spol. s r.o. | info&sodatsw.cz | 2012-05-31 | |
| Stuart Cheshire | cheshire&apple.com | 2022-07-11 | |
| Stuart Cheshire | mdnsresponder-ipc&multicastdns.org | 2004-06 | |
| Thomas Kjoernes | thomas&ipv.no | 2010-06-22 | |
| Trevor Perkes | trevor.perkes&landesk.com | 2010-02-01 | |
| Ville Laurikari | vlaurika&ssh.com | 2005-08 | |
| Wi-Fi Alliance | mconley&wi-fi.org | 2013-12-31 | |
| WIBU-SYSTEMS AG | oliver.winzenried&wibu.com | 2013-06-25 | |
| Wolfgang Voelker | wolfgang.voelker&wibu.com | 2007-06 | |
| Wolfgang Völker | WIBU-SYSTEMS AG | wolfgang.voelker&wibu.com | 2013-06-25 |
| Xplicit Computing Inc | info&xplicitcomputing.com | 2020-10-16 |