Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
cbp 4419 tcp Colnod Binary Protocol Colsys s.r.o. Jiri Merth 2016-03-23
4419 udp Reserved
4441 tcp Reserved
netblox 4441 udp Netblox Protocol Brian S. Locke Brian S. Locke 2008-07-10
lumimgrd 4741 tcp Luminizer Manager George Hwa George Hwa 2007-03
lumimgrd 4741 udp Luminizer Manager George Hwa George Hwa 2007-03
quosa 4841 tcp QUOSA Virtual Library Service Uri Blank Uri Blank 2006-09
quosa 4841 udp QUOSA Virtual Library Service Uri Blank Uri Blank 2006-09
eq-office-4941 4941 tcp Equitrac Office
eq-office-4941 4941 udp Equitrac Office
5035-5041 Unassigned
sip 5060 sctp SIP RFC 4168
sips 5061 sctp SIP-TLS RFC 4168
5238-5241 Unassigned
capwap-control 5246 udp CAPWAP Control Protocol RFC 5415
capwap-data 5247 udp CAPWAP Data Protocol RFC 5415
salient-usrmgr 5410 tcp Salient User Manager Richard Farnham Richard Farnham
salient-usrmgr 5410 udp Salient User Manager Richard Farnham Richard Farnham
actnet 5411 tcp ActNet Simon Robillard Simon Robillard
actnet 5411 udp ActNet Simon Robillard Simon Robillard
continuus 5412 tcp Continuus Steven Holtsberg Steven Holtsberg
continuus 5412 udp Continuus Steven Holtsberg Steven Holtsberg
wwiotalk 5413 tcp WWIOTALK Roger Knobbe Roger Knobbe
wwiotalk 5413 udp WWIOTALK Roger Knobbe Roger Knobbe
statusd 5414 tcp StatusD Stephen Misel Stephen Misel
statusd 5414 udp StatusD Stephen Misel Stephen Misel
ns-server 5415 tcp NS Server Jeffrey Chiao Jeffrey Chiao
ns-server 5415 udp NS Server Jeffrey Chiao Jeffrey Chiao
sns-gateway 5416 tcp SNS Gateway Mary Holstage Mary Holstage
sns-gateway 5416 udp SNS Gateway Mary Holstage Mary Holstage
sns-agent 5417 tcp SNS Agent Mary Holstage Mary Holstage
sns-agent 5417 udp SNS Agent Mary Holstage Mary Holstage
mcntp 5418 tcp MCNTP Heiko Rupp Heiko Rupp
mcntp 5418 udp MCNTP Heiko Rupp Heiko Rupp
dj-ice 5419 tcp DJ-ICE Don Tyson Don Tyson
dj-ice 5419 udp DJ-ICE Don Tyson Don Tyson
5541-5542 Unassigned
ida-discover1 5741 tcp IDA Discover Port 1 MPITech Support MPITech Support
ida-discover1 5741 udp IDA Discover Port 1 MPITech Support MPITech Support
shiprush-d-ch 5841 tcp Z-firm ShipRush interface for web access and bidirectional data Z-Firm LLC Rafael Zimberoff 2014-08-22
5841 udp Reserved
meta-corp 6141 tcp Meta Corporation License Manager Osamu Masuda Osamu Masuda
meta-corp 6141 udp Meta Corporation License Manager Osamu Masuda Osamu Masuda
jeol-nsdtp-1 6241 tcp JEOL Network Services Data Transport Protocol 1 Kevin Wellwood Kevin Wellwood 2008-04-17
jeol-nsddp-1 6241 udp JEOL Network Services Dynamic Discovery Protocol 1 Kevin Wellwood Kevin Wellwood 2008-04-17
boe-resssvr4 6410 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
6411-6416 Unassigned
faxcomservice 6417 tcp Faxcom Message Service Albert Leung Albert Leung 2006-04
faxcomservice 6417 udp Faxcom Message Service Albert Leung Albert Leung 2006-04
syserverremote 6418 tcp SYserver remote commands David Ashkenazi David Ashkenazi 2010-03-23
6418 udp Reserved
svdrp 6419 tcp Simple VDR Protocol Klaus Schmidinger Klaus Schmidinger 2010-03-31
svdrp-disc 6419 udp Simple VDR Protocol Discovery Klaus Schmidinger Klaus Schmidinger 2015-05-08
6441 Unassigned
6641-6652 Unassigned
netmo-default 6841 tcp Netmo Default Urs Bertschinger Urs Bertschinger
netmo-default 6841 udp Netmo Default Urs Bertschinger Urs Bertschinger
7041-7069 Unassigned
ionixnetmon 7410 tcp Ionix Network Monitor Maxime Renaud Maxime Renaud 2006-04
ionixnetmon 7410 udp Ionix Network Monitor Maxime Renaud Maxime Renaud 2006-04
daqstream 7411 tcp Streaming of measurement data Hottinger Baldwin Messtechnik GmbH Stephan Gatzka 2013-03-15
daqstream 7411 udp Streaming of measurement data Hottinger Baldwin Messtechnik GmbH Stephan Gatzka 2013-03-15
7412-7419 Unassigned
7512-7541 Unassigned
scriptview 7741 tcp ScriptView Network Reinhard Wolf Reinhard Wolf 2010-08-19
scriptview 7741 udp ScriptView Network Reinhard Wolf Reinhard Wolf 2010-08-19
enguity-xccetp 8041 tcp Xcorpeon ASIC Carrier Ethernet Transport Enguity Technology Corp. Kraig Beahn Jr. 2017-06-28
enguity-xccetp 8041 udp Xcorpeon ASIC Carrier Ethernet Transport Enguity Technology Corp. Kraig Beahn Jr. 2017-06-28
8141-8147 Unassigned
8406-8414 Unassigned
dlpx-sp 8415 tcp Delphix Session Protocol Delphix Corp Peng Dai 2012-11-01
8415 udp Reserved
espeech 8416 tcp eSpeech Session Protocol Scott Tarone Scott Tarone 2002-11
espeech 8416 udp eSpeech Session Protocol Scott Tarone Scott Tarone 2002-11
espeech-rtp 8417 tcp eSpeech RTP Protocol Scott Tarone Scott Tarone 2003-04
espeech-rtp 8417 udp eSpeech RTP Protocol Scott Tarone Scott Tarone 2003-04
8418-8422 Unassigned
8434-8441 Unassigned
9341-9342 Unassigned
9403-9417 Unassigned
git 9418 tcp git pack transfer service Linus Torvalds Linus Torvalds 2005-09
git 9418 udp git pack transfer service Linus Torvalds Linus Torvalds 2005-09
9419-9442 Unassigned
9641-9665 Unassigned
MOS-upper 10541 tcp MOS Running Order Port Eric Thorniley Eric Thorniley 2007-09-17
MOS-upper 10541 udp MOS Running Order Port Eric Thorniley Eric Thorniley 2007-09-17
14035-14140 Unassigned
vcs-app 14141 tcp VCS Application Ming Xu Ming Xu
vcs-app 14141 udp VCS Application Ming Xu Ming Xu
icpp 14142 tcp IceWall Cert Protocol Tsutomu Fujinami Tsutomu Fujinami 2005-08
icpp 14142 udp IceWall Cert Protocol Tsutomu Fujinami Tsutomu Fujinami 2005-08
icpps 14143 tcp IceWall Cert Protocol over TLS Kenta Kambara Kenta Kambara 2016-05-24
14143 udp Reserved
14144 Unassigned
gcm-app 14145 tcp GCM Application Ming Xu Ming Xu
gcm-app 14145 udp GCM Application Ming Xu Ming Xu
14146-14148 Unassigned
vrts-tdd 14149 tcp Veritas Traffic Director Sameer Deokule Sameer Deokule 2002-03
vrts-tdd 14149 udp Veritas Traffic Director Sameer Deokule Sameer Deokule 2002-03
vcscmd 14150 tcp Veritas Cluster Server Command Server Anand Bhalerao Anand Bhalerao 2008-10-02
14150 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Albert Leung aleung&biscom.com 2006-04
Anand Bhalerao anand_bhalerao&symantec.com 2008-10-02
Brian S. Locke blocke&zortlabs.com 2008-07-10
Colsys s.r.o. jiri.merth&colsys.cz 2016-03-23
David Ashkenazi david&synel.co.il 2010-03-23
Delphix Corp peng.dai&delphix.com 2012-11-01
Don Tyson don.tyson&cor.dowjones.com
Enguity Technology Corp. kraig.beahn&enguity.com 2017-06-28
Eric Thorniley eric&etcomms.co.uk 2007-09-17
George Hwa george.hwa&kla-tencor.com 2016-10-17
Giriraj Harapanahalli giriraj.harapanahalli&sap.com 2026-05-27
Heiko Rupp hwr&pilhuhn.de
Hottinger Baldwin Messtechnik GmbH stephan.gatzka&hbm.com 2013-03-15
Jeffrey Chiao chiaoj&netsoft.com
Jiri Merth jiri.merth&colsys.cz 2016-03-23
Kenta Kambara kenta.kambara&hpe.com 2016-05-24
Kevin Wellwood wellwood&jeol.com 2008-04-17
Klaus Schmidinger Klaus.Schmidinger&tvdr.de 2010-03-31
Kraig Beahn Jr. kraig&enguity.com 2017-06-28
Linus Torvalds torvalds&osdl.org 2005-09
MPITech Support morten.christensen&i-data.com
Mary Holstage holstege&firstfloor.com
Maxime Renaud maxdrenaud&gmail.com 2015-12-07
Ming Xu ming&veritas.com
Osamu Masuda
Peng Dai Delphix Corp peng.dai&delphix.com 2012-11-01
Rafael Zimberoff rafael&zfirmllc.com 2003-11
Reinhard Wolf Adsoft AG adsoft&vtxmail.ch 2010-08-19
Richard Farnham rfarnham&salient.com
Roger Knobbe RogerK&wonderware.com
Sameer Deokule sameer.deokule&veritas.com 2002-03
SAP Giriraj Harapanahalli 2026-05-27
Scott Tarone starone&proactivethought.com 2003-04
Simon Robillard RobillardS&actresearch.com
Stephan Gatzka Hottinger Baldwin Messtechnik GmbH stephan.gatzka&hbm.com 2013-03-15
Stephen Misel steve&satelnet.org
Steven Holtsberg steveh&continuus.com
Tsutomu Fujinami tsutomu.fujinami&hp.com 2005-08
Uri Blank uri&quosa.com 2006-09
Urs Bertschinger urs&netmosphere.com
Z-Firm LLC rafael&zfirmllc.com 2014-08-22