Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-27
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 38472 | udp | Reserved | |||||||||
| f1-control | 38472 | sctp | F1 Control Plane (3GPP) | Luis Lopes | Luis Lopes | 2017-06-23 | |||||
| 38473-38637 | Unassigned | ||||||||||
| mbus | 47000 | tcp | Message Bus | Dirk Kutscher | Dirk Kutscher | ||||||
| mbus | 47000 | udp | Message Bus | Dirk Kutscher | Dirk Kutscher | ||||||
| winrm | 47001 | tcp | Windows Remote Management Service | Ryan Mack | Ryan Mack | 2009-04-29 | |||||
| 47001 | udp | Reserved | |||||||||
| 47002-47099 | Unassigned | ||||||||||
| jvl-mactalk | 47100 | udp | Configuration of motors connected to Industrial Ethernet | JVL Industri Elektronik | Kim Berthelsen | 2012-12-21 | |||||
| 47100 | tcp | Reserved | |||||||||
| 47101-47556 | Unassigned | ||||||||||
| dbbrowse | 47557 | tcp | Databeam Corporation | Cindy Martin | Cindy Martin | ||||||
| dbbrowse | 47557 | udp | Databeam Corporation | Cindy Martin | Cindy Martin | ||||||
| 47558-47623 | Unassigned | ||||||||||
| directplaysrvr | 47624 | tcp | Direct Play Server | Ajay Jindal | Ajay Jindal | ||||||
| directplaysrvr | 47624 | udp | Direct Play Server | Ajay Jindal | Ajay Jindal | ||||||
| 47625-47805 | Unassigned | ||||||||||
| ap | 47806 | tcp | ALC Protocol | Dave Robin | Dave Robin | ||||||
| ap | 47806 | udp | ALC Protocol | Dave Robin | Dave Robin | ||||||
| 47807 | Unassigned | ||||||||||
| bacnet | 47808 | tcp | Building Automation and Control Networks | Coleman Brumley | Coleman Brumley | 2011-02-10 | |||||
| bacnet | 47808 | udp | Building Automation and Control Networks | Coleman Brumley | Coleman Brumley | 2011-02-10 | |||||
| presonus-ucnet | 47809 | udp | PreSonus Universal Control Network Protocol | PreSonus Audio Electronics, Inc | Matthias Juwan | 2013-07-12 | |||||
| 47809 | tcp | Reserved | |||||||||
| 47810-47999 | Unassigned | ||||||||||
| 48006-48047 | Unassigned | ||||||||||
| netconf-beep | NETCONF over BEEP | RFC 4744; RFC 9900 | |||||||||
| netconfsoapbeep | NETCONF for SOAP over BEEP | RFC 4743; RFC 9900 | |||||||||
| netconfsoaphttp | NETCONF for SOAP over HTTPS | RFC 4743; RFC 9900 | |||||||||
| jnx-kcsync | tcp | jollys keychain cloud sync protocol | Patrick Stein | Patrick Stein | 2011-10-24 | Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Ajay Jindal | ajayjµsoft.com | ||
| Cindy Martin | cmartin&databeam.com | ||
| Coleman Brumley | cbrumley&polarsoft.biz | 2011-02-10 | |
| Dave Robin | iana_ports&daverobin.com | ||
| Dirk Kutscher | dku&informatik.uni-bremen.de | ||
| JVL Industri Elektronik | jvl&jvl.dk | 2012-12-21 | |
| Kim Berthelsen | JVL Industri Elektronik | kb&jvl.dk | 2012-12-21 |
| Luis Lopes | llopes&qti.qualcomm.com | 2017-06-23 | |
| Matthias Juwan | PreSonus Audio Electronics, Inc | mjuwan&presonus.com | 2013-07-12 |
| Patrick Stein | Patrick.Stein&jinx.eu | 2011-10-24 | |
| PreSonus Audio Electronics, Inc | mjuwan&presonus.com | 2013-07-12 | |
| Ryan Mack | rmackµsoft.com | 2009-04-29 |