Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| smsd | 596 | udp | SMSD | Wayne Barlow | Wayne Barlow | ||||||
| ptcnameservice | 597 | tcp | PTC Name Service | Yuri Machkasov | Yuri Machkasov | ||||||
| ptcnameservice | 597 | udp | PTC Name Service | Yuri Machkasov | Yuri Machkasov | ||||||
| sco-websrvrmg3 | 598 | tcp | SCO Web Server Manager 3 | Simon Baldwin | Simon Baldwin | ||||||
| sco-websrvrmg3 | 598 | udp | SCO Web Server Manager 3 | Simon Baldwin | Simon Baldwin | ||||||
| acp | 599 | tcp | Aeolon Core Protocol | Michael Alyn Miller | Michael Alyn Miller | ||||||
| acp | 599 | udp | Aeolon Core Protocol | Michael Alyn Miller | Michael Alyn Miller | ||||||
| syslog-conn | 601 | tcp | Reliable Syslog Service | RFC 3195 | |||||||
| syslog-conn | 601 | udp | Reliable Syslog Service | RFC 3195 | |||||||
| xmlrpc-beep | 602 | tcp | XML-RPC over BEEP | RFC 3529 | |||||||
| xmlrpc-beep | 602 | udp | XML-RPC over BEEP | RFC 3529 | |||||||
| soap-beep | 605 | tcp | SOAP over BEEP | RFC 4227 | |||||||
| soap-beep | 605 | udp | SOAP over BEEP | RFC 4227 | |||||||
| sco-inetmgr | 615 | tcp | Internet Configuration Manager | ||||||||
| sco-inetmgr | 615 | udp | Internet Configuration Manager | ||||||||
| dec-dlm | 625 | tcp | DEC DLM IANA assigned this well-formed service name as a replacement for "dec_dlm". |
Rudi Martin | Rudi Martin | ||||||
| dec_dlm | 625 | tcp | DEC DLM | Rudi Martin | Rudi Martin | This entry is an alias to "dec-dlm". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| dec-dlm | 625 | udp | DEC DLM IANA assigned this well-formed service name as a replacement for "dec_dlm". |
Rudi Martin | Rudi Martin | ||||||
| dec_dlm | 625 | udp | DEC DLM | Rudi Martin | Rudi Martin | This entry is an alias to "dec-dlm". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| rlzdbase | 635 | tcp | RLZ DBase | Michael Ginn | Michael Ginn | ||||||
| rlzdbase | 635 | udp | RLZ DBase | Michael Ginn | Michael Ginn | ||||||
| pssc | 645 | tcp | PSSC | Egon Meier-Engelen | Egon Meier-Engelen | ||||||
| pssc | 645 | udp | PSSC | Egon Meier-Engelen | Egon Meier-Engelen | ||||||
| dhcp-failover | 647 | tcp | DHCP Failover | IESG | IETF Chair | 2018-05-21 | RFC 8156 | ||||
| obex | 650 | tcp | OBEX | Jeff Garbers | Jeff Garbers | ||||||
| obex | 650 | udp | OBEX | Jeff Garbers | Jeff Garbers | ||||||
| ieee-mms | 651 | tcp | IEEE MMS | Curtis Anderson | Curtis Anderson | ||||||
| ieee-mms | 651 | udp | IEEE MMS | Curtis Anderson | Curtis Anderson | ||||||
| hello-port | 652 | tcp | HELLO_PORT | Patrick Cipiere | Patrick Cipiere | ||||||
| hello-port | 652 | udp | HELLO_PORT | Patrick Cipiere | Patrick Cipiere | ||||||
| repscmd | 653 | tcp | RepCmd | Scott Dale | Scott Dale | ||||||
| repscmd | 653 | udp | RepCmd | Scott Dale | Scott Dale | ||||||
| aodv | 654 | tcp | AODV | Charles Perkins | Charles Perkins | ||||||
| aodv | 654 | udp | AODV | Charles Perkins | Charles Perkins | ||||||
| tinc | 655 | tcp | TINC | Ivo Timmermans | Ivo Timmermans | ||||||
| tinc | 655 | udp | TINC | Ivo Timmermans | Ivo Timmermans | ||||||
| spmp | 656 | tcp | SPMP | Jakob Kaivo | Jakob Kaivo | ||||||
| spmp | 656 | udp | SPMP | Jakob Kaivo | Jakob Kaivo | ||||||
| rmc | 657 | tcp | RMC | Michael Schmidt | Michael Schmidt | ||||||
| rmc | 657 | udp | RMC | Michael Schmidt | Michael Schmidt | ||||||
| tenfold | 658 | tcp | TenFold | Louis Olszyk | Louis Olszyk | ||||||
| tenfold | 658 | udp | TenFold | Louis Olszyk | Louis Olszyk | ||||||
| 659 | Removed | 2001-06-06 | |||||||||
| sun-dr | 665 | tcp | Sun DR | Harinder Bhasin | Harinder Bhasin | ||||||
| sun-dr | 665 | udp | Sun DR | Harinder Bhasin | Harinder Bhasin | ||||||
| dctp | 675 | tcp | DCTP | Andre Kramer | Andre Kramer | ||||||
| dctp | 675 | udp | DCTP | Andre Kramer | Andre Kramer | ||||||
| mdc-portmapper | 685 | tcp | MDC Port Mapper | Noah Paul | Noah Paul | ||||||
| mdc-portmapper | 685 | udp | MDC Port Mapper | Noah Paul | Noah Paul | ||||||
| ieee-mms-ssl | 695 | tcp | IEEE-MMS-SSL | Curtis Anderson | Curtis Anderson | ||||||
| ieee-mms-ssl | 695 | udp | IEEE-MMS-SSL | Curtis Anderson | Curtis Anderson | ||||||
| epp | 700 | tcp | Extensible Provisioning Protocol | RFC 5734 | |||||||
| epp | 700 | udp | EPP running over QUIC | IESG | IETF Chair | 2026-07-23 | RFC 5734; RFC-ietf-regext-epp-quic-12 | ||||
| agentx | 705 | tcp | AgentX | Bob Natale | Bob Natale | ||||||
| agentx | 705 | udp | AgentX | Bob Natale | Bob Natale | ||||||
| iris-lwz | 715 | tcp | IRIS-LWZ | RFC 4993 | |||||||
| iris-lwz | 715 | udp | IRIS-LWZ | RFC 4993 | |||||||
| pana | 716 | udp | PANA Messages | RFC 5191 | |||||||
| 745-746 | Unassigned | ||||||||||
| rfile | 750 | tcp | |||||||||
| loadav | 750 | udp | |||||||||
| kerberos-iv | 750 | udp | kerberos version iv | Martin Hamilton | Martin Hamilton | ||||||
| pump | 751 | tcp | |||||||||
| pump | 751 | udp | |||||||||
| qrh | 752 | tcp | |||||||||
| qrh | 752 | udp | |||||||||
| rrh | 753 | tcp | |||||||||
| rrh | 753 | udp | |||||||||
| tell | 754 | tcp | send | Josyula R. Rao | Josyula R. Rao | ||||||
| tell | 754 | udp | send | Josyula R. Rao | Josyula R. Rao | ||||||
| 755-757 | Unassigned | ||||||||||
| nlogin | 758 | tcp | |||||||||
| nlogin | 758 | udp | |||||||||
| con | 759 | tcp | |||||||||
| con | 759 | udp | |||||||||
| webster | 765 | tcp | Josyula R. Rao | Josyula R. Rao | |||||||
| webster | 765 | udp | Josyula R. Rao | Josyula R. Rao | |||||||
| entomb | 775 | tcp | |||||||||
| acmaint-transd | 775 | udp | IANA assigned this well-formed service name as a replacement for "acmaint_transd". | ||||||||
| acmaint_transd | 775 | udp | This entry is an alias to "acmaint-transd". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||||||
| 781-785 | Unassigned | ||||||||||
| gdoi | 848 | tcp | GDOI | RFC 3547 | |||||||
| gdoi | 848 | udp | GDOI | RFC 3547 | |||||||
| 849-852 | Unassigned | ||||||||||
| domain-s | 853 | tcp | DNS query-response protocol run over TLS | IESG | IETF Chair | 2015-10-08 | 2022-04-11 | RFC 7858 | |||
| domain-s | 853 | udp | DNS query-response protocol run over DTLS or QUIC | IESG | IETF Chair | 2015-10-08 | 2022-04-01 | RFC 7858; RFC 8094; RFC 9250 | |||
| dlep | 854 | tcp | Dynamic Link Exchange Protocol (DLEP) | IESG | IETF Chair | 2017-04-03 | RFC 8175 | ||||
| dlep | 854 | udp | Dynamic Link Exchange Protocol (DLEP) | IESG | IETF Chair | 2017-04-03 | RFC 8175 | ||||
| 855-859 | Unassigned | ||||||||||
| owamp-control | 861 | tcp | OWAMP-Control | IESG | IETF Chair | RFC 4656 | |||||
| owamp-test | 861 | udp | OWAMP-Test | IESG | IETF Chair | 2018-12-21 | RFC 8545 | ||||
| twamp-control | 862 | tcp | TWAMP-Control | IESG | IETF Chair | RFC 5357 | |||||
| twamp-test | 862 | udp | TWAMP-Test Receiver Port | IESG | IETF Chair | 2018-12-21 | RFC 8545 | ||||
| 874-885 | Unassigned | ||||||||||
| 915 | tcp | Reserved | |||||||||
| rift-ties | 915 | udp | Routing in Fat Trees Topology Information Element | IESG | IETF Chair | 2023-02-17 | 2024-06-07 | RFC 9692 | |||
| 916-952 | Unassigned | ||||||||||
| rndc | 953 | tcp | BIND9 remote name daemon controller | Internet Systems Consortium, Inc. | Ray Bellis | 2017-06-08 | |||||
| 953 | udp | Reserved | |||||||||
| 954-988 | Unassigned | ||||||||||
| imaps | 993 | tcp | IMAP over TLS protocol | IESG | IETF Chair | 2021-02-22 | RFC 3501; RFC 8314; RFC 9051 |