Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
5550 udp Reserved
rscd 5750 tcp Bladelogic Agent Service Brian Trevor Brian Trevor 2008-10-24
rscd 5750 udp Bladelogic Agent Service Brian Trevor Brian Trevor 2008-10-24
x500ms 5757 tcp OpenMail X.500 Directory Server OpenMail Encyclopedia; Don Loughry OpenMail Encyclopedia; Don Loughry
x500ms 5757 udp OpenMail X.500 Directory Server OpenMail Encyclopedia; Don Loughry OpenMail Encyclopedia; Don Loughry
spramsca 5769 tcp x509solutions Internal CA Brendan Fay Brendan Fay 2006-02
spramsca 5769 udp x509solutions Internal CA Brendan Fay Brendan Fay 2006-02
spramsd 5770 tcp x509solutions Secure Data Brendan Fay Brendan Fay 2006-02
spramsd 5770 udp x509solutions Secure Data Brendan Fay Brendan Fay 2006-02
6150-6158 Unassigned
6245-6250 Unassigned
adap 6350 tcp App Discovery and Access Protocol Thomas Kjoernes Thomas Kjoernes 2010-06-22
adap 6350 udp App Discovery and Access Protocol Thomas Kjoernes Thomas Kjoernes 2010-06-22
boks 6500 tcp BoKS Master Magnus Nystrom Magnus Nystrom
boks 6500 udp BoKS Master Magnus Nystrom Magnus Nystrom
boks-servc 6501 tcp BoKS Servc

IANA assigned this well-formed service name as a replacement for "boks_servc".
Magnus Nystrom Magnus Nystrom Known Unauthorized Use on port 6501
boks_servc 6501 tcp BoKS Servc Magnus Nystrom Magnus Nystrom Known Unauthorized Use on port 6501 This entry is an alias to "boks-servc". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-servc 6501 udp BoKS Servc

IANA assigned this well-formed service name as a replacement for "boks_servc".
Magnus Nystrom Magnus Nystrom
boks_servc 6501 udp BoKS Servc Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servc". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-servm 6502 tcp BoKS Servm

IANA assigned this well-formed service name as a replacement for "boks_servm".
Magnus Nystrom Magnus Nystrom
boks_servm 6502 tcp BoKS Servm Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servm". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-servm 6502 udp BoKS Servm

IANA assigned this well-formed service name as a replacement for "boks_servm".
Magnus Nystrom Magnus Nystrom
boks_servm 6502 udp BoKS Servm Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servm". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-clntd 6503 tcp BoKS Clntd

IANA assigned this well-formed service name as a replacement for "boks_clntd".
Magnus Nystrom Magnus Nystrom
boks_clntd 6503 tcp BoKS Clntd Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-clntd". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-clntd 6503 udp BoKS Clntd

IANA assigned this well-formed service name as a replacement for "boks_clntd".
Magnus Nystrom Magnus Nystrom
boks_clntd 6503 udp BoKS Clntd Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-clntd". This entry is now historic, not usable for use with many common service discovery mechanisms.
6504 Unassigned
badm-priv 6505 tcp BoKS Admin Private Port

IANA assigned this well-formed service name as a replacement for "badm_priv".
Magnus Nystrom Magnus Nystrom
badm_priv 6505 tcp BoKS Admin Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
badm-priv 6505 udp BoKS Admin Private Port

IANA assigned this well-formed service name as a replacement for "badm_priv".
Magnus Nystrom Magnus Nystrom
badm_priv 6505 udp BoKS Admin Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
badm-pub 6506 tcp BoKS Admin Public Port

IANA assigned this well-formed service name as a replacement for "badm_pub".
Magnus Nystrom Magnus Nystrom
badm_pub 6506 tcp BoKS Admin Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
badm-pub 6506 udp BoKS Admin Public Port

IANA assigned this well-formed service name as a replacement for "badm_pub".
Magnus Nystrom Magnus Nystrom
badm_pub 6506 udp BoKS Admin Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-priv 6507 tcp BoKS Dir Server, Private Port

IANA assigned this well-formed service name as a replacement for "bdir_priv".
Magnus Nystrom Magnus Nystrom
bdir_priv 6507 tcp BoKS Dir Server, Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-priv 6507 udp BoKS Dir Server, Private Port

IANA assigned this well-formed service name as a replacement for "bdir_priv".
Magnus Nystrom Magnus Nystrom
bdir_priv 6507 udp BoKS Dir Server, Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-pub 6508 tcp BoKS Dir Server, Public Port

IANA assigned this well-formed service name as a replacement for "bdir_pub".
Magnus Nystrom Magnus Nystrom
bdir_pub 6508 tcp BoKS Dir Server, Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-pub 6508 udp BoKS Dir Server, Public Port

IANA assigned this well-formed service name as a replacement for "bdir_pub".
Magnus Nystrom Magnus Nystrom
bdir_pub 6508 udp BoKS Dir Server, Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
mgcs-mfp-port 6509 tcp MGCS-MFP Port Minoru Ozaki Minoru Ozaki
mgcs-mfp-port 6509 udp MGCS-MFP Port Minoru Ozaki Minoru Ozaki
fg-sysupdate 6550 tcp fg-sysupdate Mark Beyer Mark Beyer
fg-sysupdate 6550 udp fg-sysupdate Mark Beyer Mark Beyer
odette-ftps 6619 tcp ODETTE-FTP over TLS/SSL Ieuan Friend Ieuan Friend 2006-03 RFC 5024
odette-ftps 6619 udp ODETTE-FTP over TLS/SSL Ieuan Friend Ieuan Friend 2006-03 RFC 5024
iccrushmore 6850 tcp ICCRUSHMORE Dave Hubbard Dave Hubbard
iccrushmore 6850 udp ICCRUSHMORE Dave Hubbard Dave Hubbard
6947-6950 Unassigned
silhouette 7500 tcp Silhouette User Anthony Payne Anthony Payne 2004-02
silhouette 7500 udp Silhouette User Anthony Payne Anthony Payne 2004-02
ovbus 7501 tcp HP OpenView Bus Daemon David M. Rhodes David M. Rhodes Known Unauthorized Use on port 7501
ovbus 7501 udp HP OpenView Bus Daemon David M. Rhodes David M. Rhodes Known Unauthorized Use on port 7501
7502-7507 Unassigned
adcp 7508 tcp Automation Device Configuration Protocol Festo AG & Co. KG Joerg Ullmann 2011-05-27 2012-07-26
7508 udp Reserved
acplt 7509 tcp ACPLT - process automation service The Chair for Process Control Engineering Ulrich Epple 2010-12-07 2012-08-07
7509 udp Reserved
7550 tcp Reserved
cloudsignaling 7550 udp Cloud Signaling Service Scott Dawson Scott Dawson 2011-07-01
8045-8050 Unassigned
8150-8152 Unassigned
8323-8350 Unassigned
npmp 8450 tcp npmp Ian Chard Ian Chard
npmp 8450 udp npmp Ian Chard Ian Chard
fmtp 8500 tcp Flight Message Transfer Protocol Eivan Cerasi Eivan Cerasi 2003-12
fmtp 8500 udp Flight Message Transfer Protocol Eivan Cerasi Eivan Cerasi 2003-12
cmtp-mgt 8501 tcp CYTEL Message Transfer Management
cmtp-av 8501 udp CYTEL Message Transfer Audio and Video Frank Jäkel Frank Jäkel 2011-04-29
ftnmtp 8502 tcp FTN Message Transfer Protocol Yuri Myakotin Yuri Myakotin 2014-01-07
8502 udp Reserved
lsp-self-ping 8503 udp MPLS LSP Self-Ping IESG IETF Chair 2015-06-11 2016-02-01 RFC 7746
8503 tcp Reserved
8504-8553 Unassigned
dey-keyneg 8750 tcp DEY Storage Key Negotiation DEY Storage Systems, Inc. Garrett D'Amore 2013-03-01
8750 udp Reserved
versiera 9050 tcp Versiera Agent Listener Frank Pikelner Frank Pikelner 2010-01-15
9050 udp Reserved
sntlkeyssrvr 9450 tcp Sentinel Keys Server Martin Ziskind Martin Ziskind 2008-08-21
sntlkeyssrvr 9450 udp Sentinel Keys Server Martin Ziskind Martin Ziskind 2008-08-21
ismserver 9500 tcp ismserver Ian Gordon Ian Gordon
ismserver 9500 udp ismserver Ian Gordon Ian Gordon
9501-9521 Unassigned
board-voip 9750 tcp Board M.I.T. Synchronous Collaboration Francesco Rosi Francesco Rosi 2006-01
board-voip 9750 udp Board M.I.T. Synchronous Collaboration Francesco Rosi Francesco Rosi 2006-01
kca-service 9878 udp The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 IESG IETF Chair 2012-07-12 RFC 6717 Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements.
multicast-ping 9903 udp Multicast Ping Protocol 2011-12-09 RFC 6450
apc-9950 9950 tcp APC 9950 American Power Conversion American Power Conversion
apc-9950 9950 udp APC 9950 American Power Conversion American Power Conversion
zabbix-agent 10050 tcp Zabbix Agent Alexei Vladishev Alexei Vladishev 2006-02
zabbix-agent 10050 udp Zabbix Agent Alexei Vladishev Alexei Vladishev 2006-02
10500 tcp Reserved
hip-nat-t 10500 udp HIP NAT-Traversal IESG IETF Chair 2020-08-12 RFC 5770; RFC 9028
10501-10539 Unassigned
11724-11750 Unassigned
vcscmd 14150 tcp Veritas Cluster Server Command Server Anand Bhalerao Anand Bhalerao 2008-10-02
14150 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Alexei Vladishev alexei.vladishev&zabbix.com 2006-02
American Power Conversion ports&apcc.com 2002-02
Anand Bhalerao anand_bhalerao&symantec.com 2008-10-02
Anthony Payne opayne&pacbell.net 2004-02
Brendan Fay brendan.fay&x509solutions.com 2006-02
Brian Trevor btrevor&bmc.com 2008-10-24
The Chair for Process Control Engineering ks&plt.rwth-aachen.de 2012-08-07
Dave Hubbard dave&icc.net
David M. Rhodes davidrho&cnd.hp.com
DEY Storage Systems, Inc. garrett&dey-sys.com 2013-03-01
Don Loughry DON_LOUGHRY&hp-cupertino-om4.om.hp.com
Eivan Cerasi eivan.cerasi&eurocontrol.int 2022-08-08
Festo AG & Co. KG Software-Support&de.festo.com 2012-07-26
Francesco Rosi frosi&orenburg.com 2006-01
Frank Jäkel Frank.Jaekel&cytel.de 2011-04-29
Frank Pikelner frank.pikelner&netcraftcommunications.com 2010-01-15
Garrett D'Amore DEY Storage Systems, Inc. garrett&dey-sys.com 2013-03-01
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ian Chard ian&tanagra.demon.co.uk
Ian Gordon iang&micromuse.co.uk
Ieuan Friend ieuan.friend&dip.co.uk 2006-03
Joerg Ullmann Festo AG & Co. KG jgu&de.festo.com 2012-07-26
Magnus Nystrom magnus&dynas.se
Mark Beyer mbeyer&freegate.com
Martin Ziskind ziskind&us.ibm.com 2008-08-21
Minoru Ozaki Minoru.Ozaki&rdmg.mgcs.mei.co.jp
OpenMail Encyclopedia opencyc&hpopd.pwd.hp.com
Scott Dawson sdawson&arbor.net 2011-07-01
Thomas Kjoernes thomas&ipv.no 2010-06-22
Ulrich Epple ks&plt.rwth-aachen.de 2012-08-07
Yuri Myakotin yuri&ym-com.net 2014-01-07