Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
vacdsm-app 671 tcp VACDSM-APP
vacdsm-app 671 udp VACDSM-APP
vpps-qua 672 tcp VPPS-QUA
vpps-qua 672 udp VPPS-QUA
cimplex 673 tcp CIMPLEX Ulysses G. Smith Jr. Ulysses G. Smith Jr.
cimplex 673 udp CIMPLEX Ulysses G. Smith Jr. Ulysses G. Smith Jr.
acap 674 tcp ACAP Chris Newman Chris Newman 2010-10-15
acap 674 udp ACAP Chris Newman Chris Newman 2010-10-15
dctp 675 tcp DCTP Andre Kramer Andre Kramer
dctp 675 udp DCTP Andre Kramer Andre Kramer
vpps-via 676 tcp VPPS Via Ulysses G. Smith Jr. Ulysses G. Smith Jr.
vpps-via 676 udp VPPS Via Ulysses G. Smith Jr. Ulysses G. Smith Jr.
vpp 677 tcp Virtual Presence Protocol Klaus Wolf Klaus Wolf
vpp 677 udp Virtual Presence Protocol Klaus Wolf Klaus Wolf
ggf-ncp 678 tcp GNU Generation Foundation NCP Noah Paul Noah Paul
ggf-ncp 678 udp GNU Generation Foundation NCP Noah Paul Noah Paul
mrm 679 tcp MRM Liming Wei Liming Wei
mrm 679 udp MRM Liming Wei Liming Wei
entrust-aaas 680 tcp entrust-aaas
entrust-aaas 680 udp entrust-aaas
entrust-aams 681 tcp entrust-aams Adrian Mancini Adrian Mancini
entrust-aams 681 udp entrust-aams Adrian Mancini Adrian Mancini
xfr 682 tcp XFR Noah Paul Noah Paul
xfr 682 udp XFR Noah Paul Noah Paul
corba-iiop 683 tcp CORBA IIOP
corba-iiop 683 udp CORBA IIOP
corba-iiop-ssl 684 tcp CORBA IIOP SSL Andrew Watson Andrew Watson
corba-iiop-ssl 684 udp CORBA IIOP SSL Andrew Watson Andrew Watson
mdc-portmapper 685 tcp MDC Port Mapper Noah Paul Noah Paul
mdc-portmapper 685 udp MDC Port Mapper Noah Paul Noah Paul
hcp-wismar 686 tcp Hardware Control Protocol Wismar David Merchant David Merchant
hcp-wismar 686 udp Hardware Control Protocol Wismar David Merchant David Merchant
asipregistry 687 tcp asipregistry Erik Sea Erik Sea
asipregistry 687 udp asipregistry Erik Sea Erik Sea
realm-rusd 688 tcp ApplianceWare managment protocol Stacy Kenworthy Stacy Kenworthy
realm-rusd 688 udp ApplianceWare managment protocol Stacy Kenworthy Stacy Kenworthy
nmap 689 tcp NMAP Peter Dennis Bartok Peter Dennis Bartok
nmap 689 udp NMAP Peter Dennis Bartok Peter Dennis Bartok
vatp 690 tcp Velneo Application Transfer Protocol Velneo David Gutiérrez 2015-02-03
vatp 690 udp Velneo Application Transfer Protocol Velneo David Gutiérrez 2015-02-03
msexch-routing 691 tcp MS Exchange Routing David Lemson David Lemson
msexch-routing 691 udp MS Exchange Routing David Lemson David Lemson
hyperwave-isp 692 tcp Hyperwave-ISP Gerald Mesaric Gerald Mesaric
hyperwave-isp 692 udp Hyperwave-ISP Gerald Mesaric Gerald Mesaric
connendp 693 tcp almanid Connection Endpoint Ronny Bremer Ronny Bremer
connendp 693 udp almanid Connection Endpoint Ronny Bremer Ronny Bremer
ha-cluster 694 tcp ha-cluster Alan Robertson Alan Robertson
ha-cluster 694 udp ha-cluster Alan Robertson Alan Robertson
ieee-mms-ssl 695 tcp IEEE-MMS-SSL Curtis Anderson Curtis Anderson
ieee-mms-ssl 695 udp IEEE-MMS-SSL Curtis Anderson Curtis Anderson
rushd 696 tcp RUSHD Greg Ercolano Greg Ercolano
rushd 696 udp RUSHD Greg Ercolano Greg Ercolano
uuidgen 697 tcp UUIDGEN James Falkner James Falkner
uuidgen 697 udp UUIDGEN James Falkner James Falkner
olsr 698 tcp OLSR Thomas Clausen Thomas Clausen
olsr 698 udp OLSR Thomas Clausen Thomas Clausen
accessnetwork 699 tcp Access Network Yingchun Xu Yingchun Xu
accessnetwork 699 udp Access Network Yingchun Xu Yingchun Xu
silc 706 tcp SILC Pekka Riikonen Pekka Riikonen
silc 706 udp SILC Pekka Riikonen Pekka Riikonen
tbrpf 712 tcp TBRPF RFC 3684
tbrpf 712 udp TBRPF RFC 3684
pana 716 udp PANA Messages RFC 5191
netviewdm1 729 tcp IBM NetView DM/6000 Server/Client
netviewdm1 729 udp IBM NetView DM/6000 Server/Client
netviewdm2 730 tcp IBM NetView DM/6000 send/tcp
netviewdm2 730 udp IBM NetView DM/6000 send/tcp
netviewdm3 731 tcp IBM NetView DM/6000 receive/tcp Philippe Binet Philippe Binet
netviewdm3 731 udp IBM NetView DM/6000 receive/tcp Philippe Binet Philippe Binet
745-746 Unassigned
ns 760 tcp
ns 760 udp
rxe 761 tcp
rxe 761 udp
quotad 762 tcp
quotad 762 udp
cycleserv 763 tcp
cycleserv 763 udp
omserv 764 tcp
omserv 764 udp
webster 765 tcp Josyula R. Rao Josyula R. Rao
webster 765 udp Josyula R. Rao Josyula R. Rao
766 Unassigned
phonebook 767 tcp phone Josyula R. Rao Josyula R. Rao
phonebook 767 udp phone Josyula R. Rao Josyula R. Rao
768 Unassigned
vid 769 tcp
vid 769 udp
wpages 776 tcp Josyula R. Rao Josyula R. Rao
wpages 776 udp Josyula R. Rao Josyula R. Rao
786 Unassigned 2002-05-08
788-799 Unassigned Unauthorized Use Known on port 796
netconf-ssh 830 tcp NETCONF over SSH RFC 6242
netconf-ssh 830 udp NETCONF over SSH RFC 6242
834-846 Unassigned
iscsi 860 tcp iSCSI IESG IETF Chair 2013-08-27 RFC 7143
iscsi 860 udp iSCSI IESG IETF Chair 2013-08-27 RFC 7143
owamp-control 861 tcp OWAMP-Control IESG IETF Chair RFC 4656
owamp-test 861 udp OWAMP-Test IESG IETF Chair 2018-12-21 RFC 8545
twamp-control 862 tcp TWAMP-Control IESG IETF Chair RFC 5357
twamp-test 862 udp TWAMP-Test Receiver Port IESG IETF Chair 2018-12-21 RFC 8545

Contact Information

Name Organization Contact URI Last Updated
Adrian Mancini adrian.mancini&entrust.com
Alan Robertson alanr&unix.sh
Andre Kramer Andre.Kramer&ansa.co.uk
Andrew Watson andrew&omg.org
Chris Newman chris.newman&oracle.com 2017-01-26
Curtis Anderson ecanderson&turbolinux.com
David Gutiérrez Velneo velneo&velneo.com 2015-02-03
David Lemson dlemson&microsoft.com
David Merchant d.f.merchant&livjm.ac.uk
Erik Sea sea&apple.com
Gerald Mesaric gmesaric&hyperwave.com
Greg Ercolano erco&netcom.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
James Falkner james.falkner&sun.com
Josyula R. Rao jrrao&watson.ibm.com
Klaus Wolf wolf&cobrow.com
Liming Wei lwei&cisco.com
Noah Paul noahp&altavista.net
Noah Paul noahp&ultranet.com
Pekka Riikonen priikone&poseidon.pspt.fi
Peter Dennis Bartok peter&novonyx.com
Philippe Binet phbinet&vnet.ibm.com
Ronny Bremer rbremer&almanid.com
Stacy Kenworthy skenworthy&applianceware.com
Thomas Clausen thomas.clausen&polytechnique.edu 2023-02-28
Ulysses G. Smith Jr. ugsmith&cesi.com
Velneo velneo&velneo.com
Yingchun Xu Yingchun_Xu&3com.com