Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-11-10
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| DMExpress | 32636 | udp | DMExpress | Arnie Farrelly | Arnie Farrelly | ||||||
| 32637-32766 | Unassigned | ||||||||||
| profinet-rtm | 34963 | tcp | PROFInet RT Multicast | PNO – PROFIBUS Nutzerorganisation e.V. | Dietmar Bohn | 2004-11 | 2026-03-16 | ||||
| profinet-rtm | 34963 | udp | PROFInet RT Multicast | PNO – PROFIBUS Nutzerorganisation e.V. | Dietmar Bohn | 2004-11 | 2026-03-16 | ||||
| 36463-36523 | Unassigned | ||||||||||
| 38463-38471 | Unassigned | ||||||||||
| 38473-38637 | Unassigned | ||||||||||
| psqlmws | 38638 | tcp | Premier SQL Middleware Server | Brain Patchwork DX, LLC. | Ozz Nixon | 2022-02-15 | |||||
| 38638 | udp | Reserved | |||||||||
| 38639-38799 | Unassigned | ||||||||||
| vroa | 39063 | tcp | Children's hearing test/Telemedicine | Hearing Australia | Dan Zhou | 2021-12-23 | |||||
| 39063 | udp | Reserved | |||||||||
| 45967-46335 | Unassigned | ||||||||||
| inedo | 46336 | tcp | Listen port used for Inedo agent communication | Inedo | Steve Dennis | 2016-01-12 | |||||
| 46336 | udp | Reserved | |||||||||
| 46337-46997 | Unassigned | ||||||||||
| 49151 | Reserved | 2024-12-20 | RFC 6335 | ||||||||
| carddav | tcp | vCard Extensions to WebDAV (CardDAV) - non-TLS | IESG | IETF Chair | 2012-02-17 | RFC 6352 | This is an extension of the http service. Defined TXT keys: path=<context path> | ||||
| carddavs | tcp | vCard Extensions to WebDAV (CardDAV) - over TLS | IESG | IETF Chair | 2012-02-17 | RFC 6352 | This is an extension of the https service. Defined TXT keys: path=<context path> | ||||
| timezone | tcp | Time Zone Data Distribution Service - non-TLS | IESG | IETF Chair | 2015-08-03 | RFC 7808 | This is an extension of the http service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763). | ||||
| timezones | tcp | Time Zone Data Distribution Service - over TLS | IESG | IETF Chair | 2015-08-03 | RFC 7808 | This is an extension of the https service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763). |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Arnie Farrelly | afarrelly&syncsort.com | ||
| Brain Patchwork DX, LLC. | specifications&brainpatchworkdx.com | 2022-02-15 | |
| Dan Zhou | Hearing Australia | dan.zhou&hearing.com.au | 2021-12-23 |
| Dietmar Bohn | standards.central-office&profibus.com | 2026-03-10 | |
| Hearing Australia | dan.zhou&hearing.com.au | 2021-12-23 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Inedo | support&inedo.com | 2016-01-12 | |
| Ozz Nixon | Brain Patchwork DX, LLC. | specifications&bpdx.com | 2022-02-15 |
| PNO – PROFIBUS Nutzerorganisation e.V. | standards.central-office&profibus.com | 2026-03-10 | |
| Steve Dennis | sdennis&inedo.com | 2016-01-12 |