Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
maitrd 997 udp
1002-1007 Unassigned
exp1 1021 tcp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 udp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 sctp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 dccp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 tcp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 udp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 sctp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 dccp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
6a44 1027 udp IPv6 Behind NAT44 CPEs IESG IETF Chair 2012-08-02 RFC 6751
1027 tcp Reserved
ams 1037 tcp AMS Ronald R. Ohmer Ronald R. Ohmer 2004-02
ams 1037 udp AMS Ronald R. Ohmer Ronald R. Ohmer 2004-02
mtqp 1038 tcp Message Tracking Query Protocol RFC 3887
mtqp 1038 udp Message Tracking Query Protocol RFC 3887
neod1 1047 tcp Sun's NEO Object Request Broker
neod1 1047 udp Sun's NEO Object Request Broker
startron 1057 tcp STARTRON Markus Sabadello Markus Sabadello
startron 1057 udp STARTRON Markus Sabadello Markus Sabadello
instl-boots 1067 tcp Installation Bootstrap Proto. Serv.

IANA assigned this well-formed service name as a replacement for "instl_boots".
instl_boots 1067 tcp Installation Bootstrap Proto. Serv. This entry is an alias to "instl-boots". This entry is now historic, not usable for use with many common service discovery mechanisms.
instl-boots 1067 udp Installation Bootstrap Proto. Serv.

IANA assigned this well-formed service name as a replacement for "instl_boots".
instl_boots 1067 udp Installation Bootstrap Proto. Serv. This entry is an alias to "instl-boots". This entry is now historic, not usable for use with many common service discovery mechanisms.
gmrupdateserv 1070 tcp GMRUpdateSERV Steve Kellogg Steve Kellogg
gmrupdateserv 1070 udp GMRUpdateSERV Steve Kellogg Steve Kellogg
bsquare-voip 1071 tcp BSQUARE-VOIP Yen Lee Yen Lee
bsquare-voip 1071 udp BSQUARE-VOIP Yen Lee Yen Lee
cardax 1072 tcp CARDAX Charles Oram Charles Oram
cardax 1072 udp CARDAX Charles Oram Charles Oram
bridgecontrol 1073 tcp Bridge Control Andy Heron Andy Heron
bridgecontrol 1073 udp Bridge Control Andy Heron Andy Heron
warmspotMgmt 1074 tcp Warmspot Management Protocol Robert C. Henningsgard Robert C. Henningsgard
warmspotMgmt 1074 udp Warmspot Management Protocol Robert C. Henningsgard Robert C. Henningsgard
rdrmshc 1075 tcp RDRMSHC Ericko Shimada Ericko Shimada
rdrmshc 1075 udp RDRMSHC Ericko Shimada Ericko Shimada
dab-sti-c 1076 tcp DAB STI-C World DAB World DAB
dab-sti-c 1076 udp DAB STI-C World DAB World DAB
imgames 1077 tcp IMGames Jean A. Ames Jean A. Ames
imgames 1077 udp IMGames Jean A. Ames Jean A. Ames
avocent-proxy 1078 tcp Avocent Proxy Protocol Steven W. Clark Steven W. Clark
avocent-proxy 1078 udp Avocent Proxy Protocol Steven W. Clark Steven W. Clark
asprovatalk 1079 tcp ASPROVATalk Chiew Farn Chung Chiew Farn Chung
asprovatalk 1079 udp ASPROVATalk Chiew Farn Chung Chiew Farn Chung
cplscrambler-in 1087 tcp CPL Scrambler Internal
cplscrambler-in 1087 udp CPL Scrambler Internal
sunclustermgr 1097 tcp Sun Cluster Manager Ashit Patel Ashit Patel
sunclustermgr 1097 udp Sun Cluster Manager Ashit Patel Ashit Patel
isoipsigport-2 1107 tcp ISOIPSIGPORT-2 Peter Egli Peter Egli
isoipsigport-2 1107 udp ISOIPSIGPORT-2 Peter Egli Peter Egli
ltp-deepspace 1113 udp Licklider Transmission Protocol 2014-02-21 RFC 5326; RFC 7122
ltp-deepspace 1113 dccp Licklider Transmission Protocol 2013-11-12 2014-02-21 RFC 7122 7107696
ardus-mtrns 1117 tcp ARDUS Multicast Transfer Shinya Abe Shinya Abe
ardus-mtrns 1117 udp ARDUS Multicast Transfer Shinya Abe Shinya Abe
sacred 1118 tcp SACRED RFC 3767
sacred 1118 udp SACRED RFC 3767
kwdb-commn 1127 tcp KWDB Remote Communication Lal Samuel Varghese Lal Samuel Varghese 2005-08
kwdb-commn 1127 udp KWDB Remote Communication Lal Samuel Varghese Lal Samuel Varghese 2005-08
trim 1137 tcp TRIM Workgroup Service Siva Poobalasingam Siva Poobalasingam 2006-03
trim 1137 udp TRIM Workgroup Service Siva Poobalasingam Siva Poobalasingam 2006-03
capioverlan 1147 tcp CAPIoverLAN Diego Friedel Diego Friedel 2005-11
capioverlan 1147 udp CAPIoverLAN Diego Friedel Diego Friedel 2005-11
iascontrol 1157 tcp Oracle iASControl Todd Guay Todd Guay 2004-11
iascontrol 1157 udp Oracle iASControl Todd Guay Todd Guay 2004-11
cisco-ipsla 1167 tcp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
cisco-ipsla 1167 udp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
cisco-ipsla 1167 sctp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
atc-lm 1170 tcp AT+C License Manager Peter Schäfer Peter Schäfer 2004-02
atc-lm 1170 udp AT+C License Manager Peter Schäfer Peter Schäfer 2004-02
atc-appserver 1171 tcp AT+C FmiApplicationServer Peter Schäfer Peter Schäfer 2004-02
atc-appserver 1171 udp AT+C FmiApplicationServer Peter Schäfer Peter Schäfer 2004-02
dnap 1172 tcp DNA Protocol David McLaughlin David McLaughlin 2004-11
dnap 1172 udp DNA Protocol David McLaughlin David McLaughlin 2004-11
d-cinema-rrp 1173 tcp D-Cinema Request-Response Digital Cinema Initiatives, LLC Digital Cinema Initiatives, LLC 2004-11 2025-08-26
d-cinema-rrp 1173 udp D-Cinema Request-Response Digital Cinema Initiatives, LLC Digital Cinema Initiatives, LLC 2004-11 2025-08-26
fnet-remote-ui 1174 tcp FlashNet Remote Admin Terry Smyth Terry Smyth 2004-11
fnet-remote-ui 1174 udp FlashNet Remote Admin Terry Smyth Terry Smyth 2004-11
dossier 1175 tcp Dossier Server Rob Minerick Rob Minerick 2004-11
dossier 1175 udp Dossier Server Rob Minerick Rob Minerick 2004-11
indigo-server 1176 tcp Indigo Home Server Matt Bendiksen Matt Bendiksen 2004-11
indigo-server 1176 udp Indigo Home Server Matt Bendiksen Matt Bendiksen 2004-11
dkmessenger 1177 tcp DKMessenger Protocol Douglas Kadlecek Douglas Kadlecek 2004-11
dkmessenger 1177 udp DKMessenger Protocol Douglas Kadlecek Douglas Kadlecek 2004-11
sgi-storman 1178 tcp SGI Storage Manager Greg Banks Greg Banks 2004-11
sgi-storman 1178 udp SGI Storage Manager Greg Banks Greg Banks 2004-11
b2n 1179 tcp Backup To Neighbor Thomas Fok Thomas Fok 2004-11
b2n 1179 udp Backup To Neighbor Thomas Fok Thomas Fok 2004-11
alias 1187 tcp Alias Service Paul Tokarchuk Paul Tokarchuk 2004-11
alias 1187 udp Alias Service Paul Tokarchuk Paul Tokarchuk 2004-11
carrius-rshell 1197 tcp Carrius Remote Access Gerry Dubois Gerry Dubois 2005-08
carrius-rshell 1197 udp Carrius Remote Access Gerry Dubois Gerry Dubois 2005-08
metasage 1207 tcp MetaSage Peter Anvelt Peter Anvelt
metasage 1207 udp MetaSage Peter Anvelt Peter Anvelt
hpss-ndapi 1217 tcp HPSS NonDCE Gateway Michael Gleicher Michael Gleicher
hpss-ndapi 1217 udp HPSS NonDCE Gateway Michael Gleicher Michael Gleicher
dns2go 1227 tcp DNS2Go Deerfield Communications Inc. Mike Courterier 2015-07-15
dns2go 1227 udp DNS2Go Deerfield Communications Inc. Mike Courterier 2015-07-15
tsdos390 1237 tcp tsdos390 Ben Pracht Ben Pracht
tsdos390 1237 udp tsdos390 Ben Pracht Ben Pracht
visionpyramid 1247 tcp VisionPyramid Gavin Hutchinson Gavin Hutchinson
visionpyramid 1247 udp VisionPyramid Gavin Hutchinson Gavin Hutchinson

Contact Information

Name Organization Contact URI Last Updated
Andy Heron btexact.ports&bt.com
Ashit Patel Ashit.Patel&eng.sun.com
Ben Pracht ben.pracht&tivoli.com
Charles Oram charleso&cardax.com
Chiew Farn Chung cfchung&asprova.com
David McLaughlin davidmclaughlin&accessdata.com 2004-11
Deerfield Communications Inc. mikec&deerfield.net 2015-07-15
Diego Friedel d.friedel&avm.de 2006-03
Digital Cinema Initiatives, LLC dci.info&dcimovies.com 2025-08-26
Douglas Kadlecek doug&dkware.com 2004-11
Emmanuel Tychon etychon&cisco.com 2006-03
Ericko Shimada eriko&kel.fujitsu.co.jp
Gavin Hutchinson gavinh&visionlogistics.com
Gerry Dubois gdubois&carriustech.com 2005-08
Greg Banks gnb&sgi.com 2004-11
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jean A. Ames engr-admin&flipside.com
Lal Samuel Varghese lalsam&hp.com 2005-08
Markus Sabadello sabadello&startron.org
Matt Bendiksen matt&perceptiveautomation.com 2004-11
Michael Gleicher mgleicher&comcast.net
Mike Courterier Deerfield Communications Inc. mikec&deerfield.net 2015-07-15
Paul Tokarchuk ptokarch&alias.com 2004-11
Peter Anvelt panvelt&xnai.com
Peter Egli peter.egli&inalp.com
Peter Schäfer p.schaefer&nospam.atc-systeme.de 2004-02
Rob Minerick rob&vortimac.com 2004-11
Robert C. Henningsgard rhenningsgard&circuscontrols.com
Ronald R. Ohmer rohmer&aisconsulting.net 2004-02
Shinya Abe abeabe&pfu.co.jp
Siva Poobalasingam siva&towersoft.com.au 2006-03
Steve Kellogg stevekellogg&mezzogmr.com
Steven W. Clark steven.clark&avocent.com
Terry Smyth terry&sgluk.com 2004-11
Thomas Fok thomas&melody-soft.com 2004-11
Todd Guay todd.guay&oracle.com 2005-08
World DAB worlddab_irc&worlddab.org
Yen Lee YenL&bsquare.com