Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| proofd | 1093 | udp | PROOFD | ||||||||
| rootd | 1094 | tcp | ROOTD | Fons Rademakers | Fons Rademakers | ||||||
| rootd | 1094 | udp | ROOTD | Fons Rademakers | Fons Rademakers | ||||||
| nicelink | 1095 | tcp | NICELink | Jordi Lisbona | Jordi Lisbona | ||||||
| nicelink | 1095 | udp | NICELink | Jordi Lisbona | Jordi Lisbona | ||||||
| cnrprotocol | 1096 | tcp | Common Name Resolution Protocol | Michael Mealling | Michael Mealling | ||||||
| cnrprotocol | 1096 | udp | Common Name Resolution Protocol | Michael Mealling | Michael Mealling | ||||||
| sunclustermgr | 1097 | tcp | Sun Cluster Manager | Ashit Patel | Ashit Patel | ||||||
| sunclustermgr | 1097 | udp | Sun Cluster Manager | Ashit Patel | Ashit Patel | ||||||
| rmiactivation | 1098 | tcp | RMI Activation | ||||||||
| rmiactivation | 1098 | udp | RMI Activation | ||||||||
| rmiregistry | 1099 | tcp | RMI Registry | Mark Hodapp | Mark Hodapp | ||||||
| rmiregistry | 1099 | udp | RMI Registry | Mark Hodapp | Mark Hodapp | ||||||
| 1109 | Reserved - IANA | ||||||||||
| ltp-deepspace | 1113 | dccp | Licklider Transmission Protocol | 2013-11-12 | 2014-02-21 | RFC 7122 | 7107696 | ||||
| bnetgame | 1119 | tcp | Battle.net Chat/Game Protocol | ||||||||
| bnetgame | 1119 | udp | Battle.net Chat/Game Protocol | ||||||||
| saphostctrls | 1129 | tcp | SAPHostControl over SOAP/HTTPS | Muscarella Fabrizio | Muscarella Fabrizio | 2006-04 | |||||
| saphostctrls | 1129 | udp | SAPHostControl over SOAP/HTTPS | Muscarella Fabrizio | Muscarella Fabrizio | 2006-04 | |||||
| evm | 1139 | tcp | Enterprise Virtual Manager | Thomas Hennessy | Thomas Hennessy | 2007-10-04 | |||||
| evm | 1139 | udp | Enterprise Virtual Manager | Thomas Hennessy | Thomas Hennessy | 2007-10-04 | |||||
| x9-icue | 1145 | tcp | X9 iCue Show Control | Brandon Potter | Brandon Potter | 2006-01 | |||||
| x9-icue | 1145 | udp | X9 iCue Show Control | Brandon Potter | Brandon Potter | 2006-01 | |||||
| bvtsonar | 1149 | tcp | BlueView Sonar Service | Teledyne BlueView, Inc. | Cat Zimmermann | 2005-11 | 2012-09-19 | ||||
| bvtsonar | 1149 | udp | BlueView Sonar Service | Teledyne BlueView, Inc. | Cat Zimmermann | 2005-11 | 2012-09-19 | ||||
| oracle-oms | 1159 | tcp | Oracle OMS | Todd Guay | Todd Guay | 2004-11 | |||||
| oracle-oms | 1159 | udp | Oracle OMS | Todd Guay | Todd Guay | 2004-11 | |||||
| tripwire | 1169 | tcp | TRIPWIRE | Ed Metcalf; Albert Holt | Ed Metcalf; Albert Holt | ||||||
| tripwire | 1169 | udp | TRIPWIRE | Ed Metcalf; Albert Holt | Ed Metcalf; Albert Holt | ||||||
| b2n | 1179 | tcp | Backup To Neighbor | Thomas Fok | Thomas Fok | 2004-11 | |||||
| b2n | 1179 | udp | Backup To Neighbor | Thomas Fok | Thomas Fok | 2004-11 | |||||
| unet | 1189 | tcp | Unet Connection | Anthony Stahler | Anthony Stahler | 2004-11 | |||||
| unet | 1189 | udp | Unet Connection | Anthony Stahler | Anthony Stahler | 2004-11 | |||||
| commlinx-avl | 1190 | tcp | CommLinx GPS / AVL System | Peter Johnson | Peter Johnson | 2004-11 | |||||
| commlinx-avl | 1190 | udp | CommLinx GPS / AVL System | Peter Johnson | Peter Johnson | 2004-11 | |||||
| gpfs | 1191 | tcp | General Parallel File System | Dave Craft | Dave Craft | 2004-11 | |||||
| gpfs | 1191 | udp | General Parallel File System | Dave Craft | Dave Craft | 2004-11 | |||||
| caids-sensor | 1192 | tcp | caids sensors channel | Gregory Hostettler | Gregory Hostettler | 2004-11 | |||||
| caids-sensor | 1192 | udp | caids sensors channel | Gregory Hostettler | Gregory Hostettler | 2004-11 | |||||
| fiveacross | 1193 | tcp | Five Across Server | Glenn Reid | Glenn Reid | 2004-11 | |||||
| fiveacross | 1193 | udp | Five Across Server | Glenn Reid | Glenn Reid | 2004-11 | |||||
| openvpn | 1194 | tcp | OpenVPN | James Yonan | James Yonan | 2004-11 | |||||
| openvpn | 1194 | udp | OpenVPN | James Yonan | James Yonan | 2004-11 | |||||
| rsf-1 | 1195 | tcp | RSF-1 clustering | Dave Hines | Dave Hines | 2004-11 | |||||
| rsf-1 | 1195 | udp | RSF-1 clustering | Dave Hines | Dave Hines | 2004-11 | |||||
| netmagic | 1196 | tcp | Network Magic | Nick Holt | Nick Holt | 2005-08 | |||||
| netmagic | 1196 | udp | Network Magic | Nick Holt | Nick Holt | 2005-08 | |||||
| carrius-rshell | 1197 | tcp | Carrius Remote Access | Gerry Dubois | Gerry Dubois | 2005-08 | |||||
| carrius-rshell | 1197 | udp | Carrius Remote Access | Gerry Dubois | Gerry Dubois | 2005-08 | |||||
| cajo-discovery | 1198 | tcp | cajo reference discovery | John Catherino | John Catherino | 2005-08 | |||||
| cajo-discovery | 1198 | udp | cajo reference discovery | John Catherino | John Catherino | 2005-08 | |||||
| dmidi | 1199 | tcp | DMIDI | Phil Kerr | Phil Kerr | 2002-02 | |||||
| dmidi | 1199 | udp | DMIDI | Phil Kerr | Phil Kerr | 2002-02 | |||||
| ipcd3 | 1209 | tcp | IPCD3 | Mark Ciskey | Mark Ciskey | ||||||
| ipcd3 | 1209 | udp | IPCD3 | Mark Ciskey | Mark Ciskey | ||||||
| aeroflight-ret | 1219 | tcp | AeroFlight-Ret | Eric Johnson | Eric Johnson | ||||||
| aeroflight-ret | 1219 | udp | AeroFlight-Ret | Eric Johnson | Eric Johnson | ||||||
| zented | 1229 | tcp | ZENworks Tiered Electronic Distribution | Ty Ellis | Ty Ellis | ||||||
| zented | 1229 | udp | ZENworks Tiered Electronic Distribution | Ty Ellis | Ty Ellis | ||||||
| tsdos390 | 1237 | tcp | tsdos390 | Ben Pracht | Ben Pracht | ||||||
| tsdos390 | 1237 | udp | tsdos390 | Ben Pracht | Ben Pracht | ||||||
| nmsd | 1239 | tcp | NMSD | Yuri Machkasov | Yuri Machkasov | ||||||
| nmsd | 1239 | udp | NMSD | Yuri Machkasov | Yuri Machkasov | ||||||
| mesavistaco | 1249 | tcp | Mesa Vista Co | Rick LaBanca | Rick LaBanca | ||||||
| mesavistaco | 1249 | udp | Mesa Vista Co | Rick LaBanca | Rick LaBanca | ||||||
| opennl-voice | 1259 | tcp | Open Network Library Voice | Phil Frisbie | Phil Frisbie | ||||||
| opennl-voice | 1259 | udp | Open Network Library Voice | Phil Frisbie | Phil Frisbie | ||||||
| watilapp | 1269 | tcp | WATiLaPP | Frederic Weymann | Frederic Weymann | ||||||
| watilapp | 1269 | udp | WATiLaPP | Frederic Weymann | Frederic Weymann | ||||||
| dellwebadmin-2 | 1279 | tcp | Dell Web Admin 2 | Bridget Navoda | Bridget Navoda | ||||||
| dellwebadmin-2 | 1279 | udp | Dell Web Admin 2 | Bridget Navoda | Bridget Navoda | ||||||
| jwalkserver | 1289 | tcp | JWalkServer | ||||||||
| jwalkserver | 1289 | udp | JWalkServer | ||||||||
| winjaserver | 1290 | tcp | WinJaServer | ||||||||
| winjaserver | 1290 | udp | WinJaServer | ||||||||
| seagulllms | 1291 | tcp | SEAGULLLMS | Lee Breisacher | Lee Breisacher | ||||||
| seagulllms | 1291 | udp | SEAGULLLMS | Lee Breisacher | Lee Breisacher | ||||||
| dsdn | 1292 | tcp | dsdn | Stanislaw Skowronek | Stanislaw Skowronek | ||||||
| dsdn | 1292 | udp | dsdn | Stanislaw Skowronek | Stanislaw Skowronek | ||||||
| pkt-krb-ipsec | 1293 | tcp | PKT-KRB-IPSec | Nancy Davoust | Nancy Davoust | ||||||
| pkt-krb-ipsec | 1293 | udp | PKT-KRB-IPSec | Nancy Davoust | Nancy Davoust | ||||||
| cmmdriver | 1294 | tcp | CMMdriver | Lutz Karras | Lutz Karras | ||||||
| cmmdriver | 1294 | udp | CMMdriver | Lutz Karras | Lutz Karras | ||||||
| ehtp | 1295 | tcp | End-by-Hop Transmission Protocol | Alexander Bogdanov | Alexander Bogdanov | ||||||
| ehtp | 1295 | udp | End-by-Hop Transmission Protocol | Alexander Bogdanov | Alexander Bogdanov | ||||||
| dproxy | 1296 | tcp | dproxy | ||||||||
| dproxy | 1296 | udp | dproxy | ||||||||
| sdproxy | 1297 | tcp | sdproxy | Raimond Diederik | Raimond Diederik | ||||||
| sdproxy | 1297 | udp | sdproxy | Raimond Diederik | Raimond Diederik | ||||||
| lpcp | 1298 | tcp | lpcp | Christian Stredicke | Christian Stredicke | ||||||
| lpcp | 1298 | udp | lpcp | Christian Stredicke | Christian Stredicke | ||||||
| hp-sci | 1299 | tcp | hp-sci | Kim Scott | Kim Scott | ||||||
| hp-sci | 1299 | udp | hp-sci | Kim Scott | Kim Scott | ||||||
| 1301 | tcp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 | |||||||
| 1301 | udp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 | |||||||
| 1302 | tcp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 | |||||||
| 1302 | udp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 | |||||||
| jtag-server | 1309 | tcp | JTAG server | Altera Corporation | Kok Kuan Chang | 2026-04-09 | |||||
| jtag-server | 1309 | udp | JTAG server | Altera Corporation | Kok Kuan Chang | 2026-04-09 | |||||
| amx-icsp | 1319 | tcp | AMX-ICSP | Jeff Burch | Jeff Burch | ||||||
| amx-icsp | 1319 | udp | AMX-ICSP | Jeff Burch | Jeff Burch |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Albert Holt | alberth&triosoftware.com | ||
| Alexander Bogdanov | alexandr_bgd&softhome.net | ||
| Altera Corporation | kok.kuan.chang&altera.com | 2026-04-09 | |
| Anthony Stahler | imunfair&yahoo.com | 2004-11 | |
| Ashit Patel | Ashit.Patel&eng.sun.com | ||
| Ben Pracht | ben.pracht&tivoli.com | ||
| Brandon Potter | iana&brandonpotter.com | 2006-01 | |
| Bridget Navoda | Bridget_Navoda&dell.com | ||
| Cat Zimmermann | Teledyne BlueView, Inc. | czimmermann&teledyne.com | 2012-09-19 |
| Christian Stredicke | stredicke&snom.de | ||
| Dave Craft | gpfs&ibm.com | 2004-11 | |
| Dave Hines | d.hines&high-availability.com | 2004-11 | |
| Ed Metcalf | emetcalf&tripwiresecurity.com | ||
| Eric Johnson | eric&gruver.net | ||
| Fons Rademakers | Fons.Rademakers&cern.ch | ||
| Frederic Weymann | contact&fizzban.net | ||
| Gerry Dubois | gdubois&carriustech.com | 2005-08 | |
| Glenn Reid | port-reg&fiveacross.com | 2004-11 | |
| Gregory Hostettler | ghostettler&caracal.ch | 2004-11 | |
| James Yonan | jim&yonan.net | 2004-11 | |
| Jeff Burch | jeff.burch&amx.com | ||
| John Catherino | cajo&dev.java.net | 2005-08 | |
| Jordi Lisbona | jlisbona&tango04.net | ||
| Kim Scott | kims&cup.hp.com | ||
| Kok Kuan Chang | Altera Corporation | kok.kuan.chang&altera.com | 2026-04-09 |
| Lee Breisacher | lbreisacher&seagullsw.com | ||
| Lutz Karras | karras&zeiss.de | ||
| Mark Ciskey | mlciskey&plato.com | ||
| Mark Hodapp | mark.hodapp&sun.com | ||
| Michael Mealling | michaelm&netsol.com | ||
| Muscarella Fabrizio | fabrizio.muscarella&sap.com | 2006-04 | |
| Nancy Davoust | n.davoust&cablelabs.com | ||
| Nick Holt | nickh&purenetworks.com | 2005-08 | |
| Peter Johnson | peter&commlinx.com.au | 2004-11 | |
| Phil Frisbie | phil.frisbie&gmail.com | 2018-12-17 | |
| Phil Kerr | phil&plus24.com | 2002-02 | |
| Raimond Diederik | rdiederik&descartes.com | ||
| Rick LaBanca | rel&mesasys.com | ||
| Stanislaw Skowronek | thesis&elementary.pl | ||
| Teledyne BlueView, Inc. | czimmermann&teledyne.com | 2012-09-19 | |
| Thomas Fok | thomas&melody-soft.com | 2004-11 | |
| Thomas Hennessy | thennessy&manageiq.com | 2007-10-04 | |
| Todd Guay | todd.guay&oracle.com | 2005-08 | |
| Ty Ellis | tellis&novell.com | 2006-05 | |
| Yuri Machkasov | yuri&ptc.com |