Service Name and Transport Protocol Port Number Registry
- Last Updated
- 2026-10-09
- Expert(s)
-
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf SCTP: Michael Tuexen DCCP: Eddie Kohler and Yoshifumi Nishida
- Reference
- [RFC 6335]
- Note
-
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP. Service names are assigned on a first-come, first-served process, as documented in [RFC 6335]. Port numbers are assigned in various ways, based on three ranges: System Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private Ports (49152-65535); the different uses of these ranges are described in [RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are assigned by the "IETF Review" or "IESG Approval" procedures described in [RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, the "IESG Approval" process, or the "Expert Review" process, as per [RFC 6335]. Dynamic Ports are not assigned. The registration procedures for service names and port numbers are described in [RFC 6335]. Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration. ************************************************************************ * PLEASE NOTE THE FOLLOWING: * * * * ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN * * ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK * * TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT * * IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE * * ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD * * CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF * * THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER * * REGISTERED OR NOT. * ************************************************************************
- Request an Assignment
-
[https://www.iana.org/protocols/apply]
- Available Formats
-

CSV
XML
HTML
TXT
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 6490-6499 | Unassigned | ||||||||||
| boks-servc | 6501 | tcp | BoKS Servc IANA assigned this well-formed service name as a replacement for "boks_servc". |
[Magnus_Nystrom] | [Magnus_Nystrom] | Known Unauthorized Use on port 6501 | |||||
| boks_servc | 6501 | tcp | BoKS Servc | [Magnus_Nystrom] | [Magnus_Nystrom] | Known Unauthorized Use on port 6501 | This entry is an alias to "boks-servc". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| boks-servc | 6501 | udp | BoKS Servc IANA assigned this well-formed service name as a replacement for "boks_servc". |
[Magnus_Nystrom] | [Magnus_Nystrom] | ||||||
| boks_servc | 6501 | udp | BoKS Servc | [Magnus_Nystrom] | [Magnus_Nystrom] | This entry is an alias to "boks-servc". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| boks-servm | 6502 | tcp | BoKS Servm IANA assigned this well-formed service name as a replacement for "boks_servm". |
[Magnus_Nystrom] | [Magnus_Nystrom] | ||||||
| boks_servm | 6502 | tcp | BoKS Servm | [Magnus_Nystrom] | [Magnus_Nystrom] | This entry is an alias to "boks-servm". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| boks-servm | 6502 | udp | BoKS Servm IANA assigned this well-formed service name as a replacement for "boks_servm". |
[Magnus_Nystrom] | [Magnus_Nystrom] | ||||||
| boks_servm | 6502 | udp | BoKS Servm | [Magnus_Nystrom] | [Magnus_Nystrom] | This entry is an alias to "boks-servm". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| boks-clntd | 6503 | tcp | BoKS Clntd IANA assigned this well-formed service name as a replacement for "boks_clntd". |
[Magnus_Nystrom] | [Magnus_Nystrom] | ||||||
| boks_clntd | 6503 | tcp | BoKS Clntd | [Magnus_Nystrom] | [Magnus_Nystrom] | This entry is an alias to "boks-clntd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| boks-clntd | 6503 | udp | BoKS Clntd IANA assigned this well-formed service name as a replacement for "boks_clntd". |
[Magnus_Nystrom] | [Magnus_Nystrom] | ||||||
| boks_clntd | 6503 | udp | BoKS Clntd | [Magnus_Nystrom] | [Magnus_Nystrom] | This entry is an alias to "boks-clntd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| badm-priv | 6505 | tcp | BoKS Admin Private Port IANA assigned this well-formed service name as a replacement for "badm_priv". |
[Magnus_Nystrom] | [Magnus_Nystrom] | ||||||
| badm_priv | 6505 | tcp | BoKS Admin Private Port | [Magnus_Nystrom] | [Magnus_Nystrom] | This entry is an alias to "badm-priv". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| badm-priv | 6505 | udp | BoKS Admin Private Port IANA assigned this well-formed service name as a replacement for "badm_priv". |
[Magnus_Nystrom] | [Magnus_Nystrom] | ||||||
| badm_priv | 6505 | udp | BoKS Admin Private Port | [Magnus_Nystrom] | [Magnus_Nystrom] | This entry is an alias to "badm-priv". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| badm-pub | 6506 | tcp | BoKS Admin Public Port IANA assigned this well-formed service name as a replacement for "badm_pub". |
[Magnus_Nystrom] | [Magnus_Nystrom] | ||||||
| badm_pub | 6506 | tcp | BoKS Admin Public Port | [Magnus_Nystrom] | [Magnus_Nystrom] | This entry is an alias to "badm-pub". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| badm-pub | 6506 | udp | BoKS Admin Public Port IANA assigned this well-formed service name as a replacement for "badm_pub". |
[Magnus_Nystrom] | [Magnus_Nystrom] | ||||||
| badm_pub | 6506 | udp | BoKS Admin Public Port | [Magnus_Nystrom] | [Magnus_Nystrom] | This entry is an alias to "badm-pub". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| bdir-priv | 6507 | tcp | BoKS Dir Server, Private Port IANA assigned this well-formed service name as a replacement for "bdir_priv". |
[Magnus_Nystrom] | [Magnus_Nystrom] | ||||||
| bdir_priv | 6507 | tcp | BoKS Dir Server, Private Port | [Magnus_Nystrom] | [Magnus_Nystrom] | This entry is an alias to "bdir-priv". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| bdir-priv | 6507 | udp | BoKS Dir Server, Private Port IANA assigned this well-formed service name as a replacement for "bdir_priv". |
[Magnus_Nystrom] | [Magnus_Nystrom] | ||||||
| bdir_priv | 6507 | udp | BoKS Dir Server, Private Port | [Magnus_Nystrom] | [Magnus_Nystrom] | This entry is an alias to "bdir-priv". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| bdir-pub | 6508 | tcp | BoKS Dir Server, Public Port IANA assigned this well-formed service name as a replacement for "bdir_pub". |
[Magnus_Nystrom] | [Magnus_Nystrom] | ||||||
| bdir_pub | 6508 | tcp | BoKS Dir Server, Public Port | [Magnus_Nystrom] | [Magnus_Nystrom] | This entry is an alias to "bdir-pub". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| bdir-pub | 6508 | udp | BoKS Dir Server, Public Port IANA assigned this well-formed service name as a replacement for "bdir_pub". |
[Magnus_Nystrom] | [Magnus_Nystrom] | ||||||
| bdir_pub | 6508 | udp | BoKS Dir Server, Public Port | [Magnus_Nystrom] | [Magnus_Nystrom] | This entry is an alias to "bdir-pub". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| mgcs-mfp-port | 6509 | tcp | MGCS-MFP Port | [Minoru_Ozaki] | [Minoru_Ozaki] | ||||||
| mgcs-mfp-port | 6509 | udp | MGCS-MFP Port | [Minoru_Ozaki] | [Minoru_Ozaki] | ||||||
| mcer-port | 6510 | tcp | MCER Port | [Portnoy_Boxman] | [Portnoy_Boxman] | ||||||
| mcer-port | 6510 | udp | MCER Port | [Portnoy_Boxman] | [Portnoy_Boxman] | ||||||
| dccp-udp | 6511 | udp | Datagram Congestion Control Protocol Encapsulation for NAT Traversal | [IESG] | [IETF_Chair] | [RFC 6773] | |||||
| 6512-6512 | Unassigned | ||||||||||
| netconf-tls | 6513 | tcp | NETCONF over TLS | [IESG] | [IETF_Chair] | 2024-01-24 | [RFC 7589][RFC 9918] | ||||
| syslog-tls | 6514 | tcp | Syslog over TLS | [RFC 5425] | |||||||
| syslog-tls | 6514 | udp | syslog over DTLS | [RFC 6012] | |||||||
| syslog-tls | 6514 | dccp | syslog over DTLS | [RFC 6012] | |||||||
| elipse-rec | 6515 | tcp | Elipse RPC Protocol | [F_Englert] | [F_Englert] | 2007-09-17 | |||||
| elipse-rec | 6515 | udp | Elipse RPC Protocol | [F_Englert] | [F_Englert] | 2007-09-17 | |||||
| 6516-6542 | Unassigned | ||||||||||
| lds-distrib | 6543 | tcp | lds_distrib | [Jack_Baker] | [Jack_Baker] | 2003-06 | |||||
| lds-distrib | 6543 | udp | lds_distrib | [Jack_Baker] | [Jack_Baker] | 2003-06 | |||||
| lds-dump | 6544 | tcp | LDS Dump Service | [Jack_Baker] | [Jack_Baker] | 2006-02 | |||||
| lds-dump | 6544 | udp | LDS Dump Service | [Jack_Baker] | [Jack_Baker] | 2006-02 | |||||
| 6545-6546 | Unassigned | ||||||||||
| apc-6547 | 6547 | tcp | APC 6547 | [American_Power_Conve] | [American_Power_Conve] | ||||||
| apc-6547 | 6547 | udp | APC 6547 | [American_Power_Conve] | [American_Power_Conve] | ||||||
| apc-6548 | 6548 | tcp | APC 6548 | [American_Power_Conve] | [American_Power_Conve] | ||||||
| apc-6548 | 6548 | udp | APC 6548 | [American_Power_Conve] | [American_Power_Conve] | ||||||
| apc-6549 | 6549 | tcp | APC 6549 | [American_Power_Conve] | [American_Power_Conve] | ||||||
| apc-6549 | 6549 | udp | APC 6549 | [American_Power_Conve] | [American_Power_Conve] | ||||||
| fg-sysupdate | 6550 | tcp | fg-sysupdate | [Mark_Beyer] | [Mark_Beyer] | ||||||
| fg-sysupdate | 6550 | udp | fg-sysupdate | [Mark_Beyer] | [Mark_Beyer] | ||||||
| 6552-6555 | Unassigned | ||||||||||
| checkmk-agent | 6556 | tcp | Checkmk Monitoring Agent | [Checkmk_GmbH] | [Alexander_Wilms] | 2020-07-14 | 2024-08-06 | ||||
| 6559-6565 | Unassigned | ||||||||||
| sane-port | 6566 | tcp | SANE Control Port | [Henning_Meier_Geinit] | [Henning_Meier_Geinit] | 2002-10 | |||||
| sane-port | 6566 | udp | SANE Control Port | [Henning_Meier_Geinit] | [Henning_Meier_Geinit] | 2002-10 | |||||
| 6567 | Reserved | 2007-01 | 2011-08-26 | This entry has been removed on 2011-08-26. | |||||||
| canit-store | 6568 | tcp | CanIt Storage Manager IANA assigned this well-formed service name as a replacement for "canit_store". |
[Dianne_Skoll] | [Dianne_Skoll] | 2009-04-22 | 2017-05-25 | ||||
| canit_store | 6568 | tcp | CanIt Storage Manager | [Dianne_Skoll] | [Dianne_Skoll] | 2009-04-22 | 2017-05-25 | This entry is an alias to "canit-store". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||
| rp-reputation | 6568 | udp | Roaring Penguin IP Address Reputation Collection | [Dianne_Skoll] | [Dianne_Skoll] | 2010-02-05 | 2017-05-25 | ||||
| 6569-6578 | Unassigned | ||||||||||
| parsec-master | 6580 | tcp | Parsec Masterserver | [Andreas_Varga] | [Andreas_Varga] | ||||||
| parsec-master | 6580 | udp | Parsec Masterserver | [Andreas_Varga] | [Andreas_Varga] | ||||||
| parsec-peer | 6581 | tcp | Parsec Peer-to-Peer | [Andreas_Varga] | [Andreas_Varga] | ||||||
| parsec-peer | 6581 | udp | Parsec Peer-to-Peer | [Andreas_Varga] | [Andreas_Varga] | ||||||
| parsec-game | 6582 | tcp | Parsec Gameserver | [Andreas_Varga] | [Andreas_Varga] | ||||||
| parsec-game | 6582 | udp | Parsec Gameserver | [Andreas_Varga] | [Andreas_Varga] | ||||||
| 6584-6587 | Unassigned | ||||||||||
| 6589-6599 | Unassigned | ||||||||||
| mshvlm | 6600 | tcp | Microsoft Hyper-V Live Migration | [Rajesh_D] | [Rajesh_D] | 2009-02-03 | |||||
| mstmg-sstp | 6601 | tcp | Microsoft Threat Management Gateway SSTP | [Ori_Yosefi] | [Ori_Yosefi] | 2009-05-04 | |||||
| 6603-6609 | Unassigned | ||||||||||
| 6611-6618 | Unassigned | ||||||||||
| odette-ftps | 6619 | tcp | ODETTE-FTP over TLS/SSL | [Ieuan_Friend] | [Ieuan_Friend] | 2006-03 | [RFC 5024] | ||||
| odette-ftps | 6619 | udp | ODETTE-FTP over TLS/SSL | [Ieuan_Friend] | [Ieuan_Friend] | 2006-03 | [RFC 5024] | ||||
| kftp-data | 6620 | tcp | Kerberos V5 FTP Data | [Robert_J_Scott] | [Robert_J_Scott] | 2005-08 | |||||
| kftp-data | 6620 | udp | Kerberos V5 FTP Data | [Robert_J_Scott] | [Robert_J_Scott] | 2005-08 | |||||
| datascaler-db | 6624 | tcp | DataScaler database | [Vasu_Murthy] | [Vasu_Murthy] | 2010-02-08 | |||||
| datascaler-ctl | 6625 | tcp | DataScaler control | [Vasu_Murthy] | [Vasu_Murthy] | 2010-02-08 | |||||
| wago-service | 6626 | tcp | WAGO Service and Update | [Wolfgang_Adler] | [Wolfgang_Adler] | 2006-04 | |||||
| wago-service | 6626 | udp | WAGO Service and Update | [Wolfgang_Adler] | [Wolfgang_Adler] | 2006-04 | |||||
| afesc-mc | 6628 | tcp | AFE Stock Channel M/C | [K_K_Ho] | [K_K_Ho] | 2004-04 | |||||
| afesc-mc | 6628 | udp | AFE Stock Channel M/C | [K_K_Ho] | [K_K_Ho] | 2004-04 | |||||
| nexgen-aux | 6629 | tcp | Secondary, (non ANDI) multi-protocol multi-function interface to the Allied ANDI-based family of forecourt controllers | [Allied_Electronics] | [Robert_E_Tomenchok_Jr] | 2016-11-29 | |||||
| nexgen-aux | 6629 | udp | Secondary, (non ANDI) multi-protocol multi-function interface to the Allied ANDI-based family of forecourt controllers | [Allied_Electronics] | [Robert_E_Tomenchok_Jr] | 2016-11-29 | |||||
| mxodbc-connect | 6632 | tcp | eGenix mxODBC Connect | [Marc_Andre_Lemburg] | [Marc_Andre_Lemburg] | 2009-11-13 | Unauthorized Use Known on port 6632 | ||||
| cisco-vpath-tun | 6633 | udp | Cisco vPath Services Overlay | [Cisco2] | [Surendra_Kumar] | 2012-06-11 | |||||
| mpls-pm | 6634 | udp | MPLS Performance Measurement out-of-band response | [Cisco_Systems_2] | [Sagar_Soni] | 2014-02-20 | |||||
| mpls-udp | 6635 | udp | Encapsulate MPLS packets in UDP tunnels. | [IESG] | [IETF_Chair] | 2015-02-10 | [RFC 7510] | ||||
| mpls-udp-dtls | 6636 | udp | Encapsulate MPLS packets in UDP tunnels with DTLS. | [IESG] | [IETF_Chair] | 2015-02-10 | [RFC 7510] | ||||
| 6637-6639 | Unassigned | ||||||||||
| 6641-6652 | Unassigned | ||||||||||
| pcs-sf-ui-man | 6655 | tcp | PC SOFT - Software factory UI/manager | [Jerome_AERTS] | [Jerome_AERTS] | 2010-11-30 | |||||
| palcom-disc | 6657 | udp | PalCom Discovery | [Boris_Magnusson] | [Boris_Magnusson] | 2010-12-06 | |||||
| 6658-6664 | Unassigned | Unauthorized Use Known on Port 6659 | |||||||||
| ircu | 6665-6669 | tcp | IRCU | [Brian_Tackett] | [Brian_Tackett] | ||||||
| 6665-6669 | udp | Reserved |