Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
6665-6669 udp Reserved
vocaltec-gold 6670 tcp Vocaltec Global Online Directory [Scott_Petrack] [Scott_Petrack]
vocaltec-gold 6670 udp Vocaltec Global Online Directory [Scott_Petrack] [Scott_Petrack]
p4p-portal 6671 tcp P4P Portal Service [Chris_Griffiths] [Chris_Griffiths] 2008-07-28
p4p-portal 6671 udp P4P Portal Service [Chris_Griffiths] [Chris_Griffiths] 2008-07-28
vision-server 6672 tcp vision_server

IANA assigned this well-formed service name as a replacement for "vision_server".
[Chris_Kramer] [Chris_Kramer]
vision_server 6672 tcp vision_server [Chris_Kramer] [Chris_Kramer] This entry is an alias to "vision-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
vision-server 6672 udp vision_server

IANA assigned this well-formed service name as a replacement for "vision_server".
[Chris_Kramer] [Chris_Kramer]
vision_server 6672 udp vision_server [Chris_Kramer] [Chris_Kramer] This entry is an alias to "vision-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
vision-elmd 6673 tcp vision_elmd

IANA assigned this well-formed service name as a replacement for "vision_elmd".
[Chris_Kramer] [Chris_Kramer]
vision_elmd 6673 tcp vision_elmd [Chris_Kramer] [Chris_Kramer] This entry is an alias to "vision-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
vision-elmd 6673 udp vision_elmd

IANA assigned this well-formed service name as a replacement for "vision_elmd".
[Chris_Kramer] [Chris_Kramer]
vision_elmd 6673 udp vision_elmd [Chris_Kramer] [Chris_Kramer] This entry is an alias to "vision-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
6674-6677 Unassigned
vfbp-disc 6678 udp Viscount Freedom Bridge Discovery [Chris_MacDonald] [Chris_MacDonald] 2011-03-16
6680-6686 Unassigned
clever-ctrace 6687 tcp CleverView for cTrace Message Service [David_Cheng] [David_Cheng] 2010-02-01
clever-tcpip 6688 tcp CleverView for TCP/IP Message Service [David_Cheng] [David_Cheng] 2009-10-13
6691-6695 Unassigned
ircs-u 6697 tcp Internet Relay Chat via TLS/SSL 2014-02-11 [RFC 7194]
babel-dtls 6699 udp Babel Routing Protocol over DTLS [IESG] [IETF_Chair] 2020-09-04 [RFC 8968]
kti-icad-srvr 6701 tcp KTI/ICAD Nameserver [Stanley_Knutson] [Stanley_Knutson]
kti-icad-srvr 6701 udp KTI/ICAD Nameserver [Stanley_Knutson] [Stanley_Knutson]
e-design-net 6702 tcp e-Design network [Janos_Lerch] [Janos_Lerch] 2006-02
e-design-net 6702 udp e-Design network [Janos_Lerch] [Janos_Lerch] 2006-02
e-design-web 6703 tcp e-Design web [Janos_Lerch] [Janos_Lerch] 2006-02
e-design-web 6703 udp e-Design web [Janos_Lerch] [Janos_Lerch] 2006-02
frc-hp 6704 sctp ForCES HP (High Priority) channel [RFC 5811]
frc-mp 6705 sctp ForCES MP (Medium Priority) channel [RFC 5811]
frc-lp 6706 sctp ForCES LP (Low priority) channel [RFC 5811]
6707-6713 Unassigned
fibotrader-com 6715 tcp Fibotrader Communications [Robert_Wetzold] [Robert_Wetzold] 2006-01
fibotrader-com 6715 udp Fibotrader Communications [Robert_Wetzold] [Robert_Wetzold] 2006-01
princity-agent 6716 tcp Princity Agent [ENSTEAM_Sp_z.o.o.] [Tomasz_Krakowiak] 2014-07-07 2015-07-08
6717-6766 Unassigned
bmc-perf-agent 6767 tcp BMC PERFORM AGENT [Portnoy_Boxman] [Portnoy_Boxman]
bmc-perf-agent 6767 udp BMC PERFORM AGENT [Portnoy_Boxman] [Portnoy_Boxman]
bmc-perf-mgrd 6768 tcp BMC PERFORM MGRD [Portnoy_Boxman] [Portnoy_Boxman]
bmc-perf-mgrd 6768 udp BMC PERFORM MGRD [Portnoy_Boxman] [Portnoy_Boxman]
adi-gxp-srvprt 6769 tcp ADInstruments GxP Server [Mathew_Pitchforth] [Mathew_Pitchforth] 2005-08
adi-gxp-srvprt 6769 udp ADInstruments GxP Server [Mathew_Pitchforth] [Mathew_Pitchforth] 2005-08
plysrv-http 6770 tcp PolyServe http [Mike_Spitzer] [Mike_Spitzer] 2005-08
plysrv-http 6770 udp PolyServe http [Mike_Spitzer] [Mike_Spitzer] 2005-08
plysrv-https 6771 tcp PolyServe https [Mike_Spitzer] [Mike_Spitzer] 2005-08
plysrv-https 6771 udp PolyServe https [Mike_Spitzer] [Mike_Spitzer] 2005-08
6772-6776 Unassigned
ntz-tracker 6777 tcp netTsunami Tracker [Tomahawk_Holdings] [Sagara_Wijetunga] 2013-05-01
ntz-p2p-storage 6778 tcp netTsunami p2p storage system [Tomahawk_Holdings] [Sagara_Wijetunga] 2013-05-01
6779-6783 Unassigned
bfd-lag 6784 udp Bidirectional Forwarding Detection (BFD) on Link Aggregation Group (LAG) Interfaces [IESG] [BFD_Chairs] 2012-11-08 2014-01-09 [RFC 7130]
dgpf-exchg 6785 tcp DGPF Individual Exchange [Thomas_Weise] [Thomas_Weise] 2006-04
dgpf-exchg 6785 udp DGPF Individual Exchange [Thomas_Weise] [Thomas_Weise] 2006-04
smc-jmx 6786 tcp Sun Java Web Console JMX [Bill_Edwards] [Bill_Edwards] 2005-08
smc-jmx 6786 udp Sun Java Web Console JMX [Bill_Edwards] [Bill_Edwards] 2005-08
smc-admin 6787 tcp Sun Web Console Admin [Bill_Edwards] [Bill_Edwards] 2005-08
smc-admin 6787 udp Sun Web Console Admin [Bill_Edwards] [Bill_Edwards] 2005-08
smc-http 6788 tcp SMC-HTTP [Ratnadeep_Bhattachar] [Ratnadeep_Bhattachar] 2002-11
smc-http 6788 udp SMC-HTTP [Ratnadeep_Bhattachar] [Ratnadeep_Bhattachar] 2002-11
radg 6789 tcp GSS-API for the Oracle Remote Administration Daemon [Oracle_9] [Shawn_Emery] 2002-08 2016-09-15
6792-6800 Unassigned
6802-6816 Unassigned
pentbox-sim 6817 tcp PenTBox Secure IM Protocol [Alberto_Ortega_Llama] [Alberto_Ortega_Llama] 2009-11-04
6818-6830 Unassigned
ambit-lm 6831 tcp ambit-lm [Don_Hejna] [Don_Hejna]
ambit-lm 6831 udp ambit-lm [Don_Hejna] [Don_Hejna]
6832-6840 Unassigned
netmo-default 6841 tcp Netmo Default [Urs_Bertschinger] [Urs_Bertschinger]
netmo-default 6841 udp Netmo Default [Urs_Bertschinger] [Urs_Bertschinger]
netmo-http 6842 tcp Netmo HTTP [Urs_Bertschinger] [Urs_Bertschinger]
netmo-http 6842 udp Netmo HTTP [Urs_Bertschinger] [Urs_Bertschinger]
6843-6849 Unassigned
6851-6867 Unassigned
acctopus-cc 6868 tcp Acctopus Command Channel [Stefan_Auweiler] [Stefan_Auweiler] 2009-11-16
acctopus-st 6868 udp Acctopus Status [Stefan_Auweiler] [Stefan_Auweiler] 2009-11-16
6869-6887 Unassigned
6889-6899 Unassigned
rtimeviewer 6900 tcp R*TIME Viewer Data Interface [Curtiss-Wright_Corporation] [Robert_Ammon] 2016-12-14
6902-6923 Unassigned
split-ping 6924 tcp Ping with RX/TX latency/loss split [Ben_Cartwright_Cox] [Ben_Cartwright_Cox] 2020-02-12
split-ping 6924 udp Ping with RX/TX latency/loss split [Ben_Cartwright_Cox] [Ben_Cartwright_Cox] 2020-02-12
6925-6934 Unassigned
6937-6945 Unassigned
6947-6950 Unassigned
6952-6960 Unassigned
6967-6968 Unassigned
conductor 6970 tcp Conductor test coordination protocol [George_Neville-Neil] [George_Neville-Neil] 2014-09-18
conductor-mpx 6970 sctp conductor for multiplex [George_Neville-Neil] [George_Neville-Neil] 2014-07-29
6971-6979 Unassigned
qolyester 6980 udp QoS-extended OLSR protocol [Green_Communications_SAS] [Ignacy_Gawedzki] 2022-05-24
6981-6996 Unassigned
iatp-highpri 6998 tcp IATP-highPri [John_Murphy] [John_Murphy]
iatp-highpri 6998 udp IATP-highPri [John_Murphy] [John_Murphy]
iatp-normalpri 6999 tcp IATP-normalPri [John_Murphy] [John_Murphy]
iatp-normalpri 6999 udp IATP-normalPri [John_Murphy] [John_Murphy]
afs3-fileserver 7000 tcp file server itself
afs3-fileserver 7000 udp file server itself
afs3-callback 7001 tcp callbacks to cache managers Known Unauthorized Use on port 7001
afs3-callback 7001 udp callbacks to cache managers Known Unauthorized Use on port 7001
afs3-prserver 7002 tcp users & groups database Known Unauthorized Use on port 7002
afs3-prserver 7002 udp users & groups database Known Unauthorized Use on port 7002
afs3-vlserver 7003 tcp volume location database

Contact Information

ID Name Organization Contact URI Last Updated
[Alberto_Ortega_Llama] Alberto Ortega Llamas mailto:alberto.kun666&gmail.com 2009-11-04
[Ben_Cartwright_Cox] Ben Cartwright-Cox mailto:ben&benjojo.co.uk 2020-02-12
[BFD_Chairs] IETF BFD Working Group Chairs mailto:bfd-chairs&tools.ietf.org 2014-01-09
[Bill_Edwards] Bill Edwards mailto:bill.edwards&sun.com 2005-08
[Chris_Griffiths] Chris Griffiths mailto:chris_griffiths&cable.comcast.com 2008-07-28
[Chris_Kramer] Chris Kramer mailto:CKramer&gis.shl.com
[Chris_MacDonald] Chris MacDonald mailto:chris&viscount.com 2011-03-16
[Curtiss-Wright_Corporation] Curtiss-Wright Corporation mailto:rammon&curtisswright.com 2016-12-14
[David_Cheng] David Cheng mailto:davec&aesclever.com 2010-02-01
[Don_Hejna] Don Hejna mailto:djhejna&ambit.com
[ENSTEAM_Sp_z.o.o.] ENSTEAM Sp. z o.o. mailto:support&ensteam.com 2015-07-08
[George_Neville-Neil] George Neville-Neil mailto:gnn&neville-neil.com 2014-07-29
[Green_Communications_SAS] Green Communications SAS mailto:contact&green-communications.fr 2022-05-24
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Ignacy_Gawedzki] Ignacy Gawedzki Green Communications SAS mailto:ignacy.gawedzki&green-communications.fr 2022-05-24
[Janos_Lerch] Janos Lerch mailto:lerch&softic.hu 2006-02
[John_Murphy] John Murphy mailto:john.m.murphy&mci.com
[Mathew_Pitchforth] Mathew Pitchforth mailto:mathew&adinstruments.co.nz 2005-08
[Mike_Spitzer] Mike Spitzer mailto:mjs&polyserve.com 2005-08
[Oracle_9] Oracle mailto:shawn.emery&oracle.com 2016-09-15
[Portnoy_Boxman] Portnoy Boxman mailto:portnoy_boxman&bmc.com 2005-01
[Ratnadeep_Bhattachar] Ratnadeep Bhattacharjee mailto:ratnadeep.bhattacharjee&sun.com 2002-11
[Robert_Ammon] Robert Ammon mailto:rammon&curtisswright.com 2016-12-14
[Robert_Wetzold] Robert Wetzold mailto:robert.wetzold&fibotrader.com 2006-01
[Sagara_Wijetunga] Sagara Wijetunga Tomahawk Holdings Ltd mailto:sagara&tomahawk.lk 2013-05-01
[Scott_Petrack] Scott Petrack mailto:Scott_Petrack&vocaltec.com
[Shawn_Emery] Shawn Emery mailto:shawn.emery&oracle.com 2016-09-15
[Stanley_Knutson] Stanley Knutson mailto:Stanley.Knutson&ktiworld.com
[Stefan_Auweiler] Stefan Auweiler mailto:stefan.auweiler&saitc.de 2009-11-16
[Thomas_Weise] Thomas Weise mailto:weise&vs.uni-kassel.de 2006-04
[Tomahawk_Holdings] Tomahawk Holdings Ltd mailto:sagara&tomahawk.lk 2013-05-01
[Tomasz_Krakowiak] Tomasz Krakowiak ENSTEAM Sp. z o.o. mailto:tomasz.krakowiak&ensteam.com 2015-07-08
[Urs_Bertschinger] Urs Bertschinger mailto:urs&netmosphere.com