Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
trivnet2 8201 udp TRIVNET Saar Wilf Saar Wilf
8209-8210 Unassigned
8211 tcp Reserved
aruba-papi 8211 udp Aruba Networks AP management Aruba Networks Jon Green 2018-10-04
8212-8229 Unassigned
8231 tcp Reserved
hncp-udp-port 8231 udp HNCP IESG IETF Chair 2016-01-13 RFC 7788
8271-8275 Unassigned
8281 Unassigned
8283-8291 Unassigned
amberon 8301 tcp Amberon PPC/PPS Ronald Snyder Ronald Snyder 2006-03
amberon 8301 udp Amberon PPC/PPS Ronald Snyder Ronald Snyder 2006-03
8302-8312 Unassigned
hub-open-net 8313 tcp Hub Open Network Grexie Tim Behrsin 2012-06-13 Defined TXT keys: _hub._tcp.host.example.com
8313 udp Reserved
8314-8319 Unassigned
tnp 8321 tcp Thin(ium) Network Protocol Aly Orady Aly Orady 2007-08-07
tnp 8321 udp Thin(ium) Network Protocol Aly Orady Aly Orady 2007-08-07
server-find 8351 tcp Server Find Chris Brown Chris Brown
server-find 8351 udp Server Find Chris Brown Chris Brown
8381-8382 Unassigned
sabarsd 8401 tcp sabarsd Aaron Bilbrey Aaron Bilbrey
sabarsd 8401 udp sabarsd Aaron Bilbrey Aaron Bilbrey
8406-8414 Unassigned
dlpx-sp 8415 tcp Delphix Session Protocol Delphix Corp Peng Dai 2012-11-01
8415 udp Reserved
espeech 8416 tcp eSpeech Session Protocol Scott Tarone Scott Tarone 2002-11
espeech 8416 udp eSpeech Session Protocol Scott Tarone Scott Tarone 2002-11
espeech-rtp 8417 tcp eSpeech RTP Protocol Scott Tarone Scott Tarone 2003-04
espeech-rtp 8417 udp eSpeech RTP Protocol Scott Tarone Scott Tarone 2003-04
8418-8422 Unassigned
8424-8431 Unassigned
8434-8441 Unassigned
8451-8456 Unassigned
pim-port 8471 tcp PIM over Reliable Transport IESG IETF Chair 2008-08-21 RFC 6559
pim-port 8471 sctp PIM over Reliable Transport IESG IETF Chair 2008-08-21 RFC 6559
8471 udp Reserved
cmtp-mgt 8501 tcp CYTEL Message Transfer Management
cmtp-av 8501 udp CYTEL Message Transfer Audio and Video Frank Jäkel Frank Jäkel 2011-04-29
8601-8608 Unassigned
canon-mfnp 8610 tcp Canon MFNP Service Ritsuto Sako Ritsuto Sako 2009-05-04
canon-mfnp 8610 udp Canon MFNP Service Ritsuto Sako Ritsuto Sako 2009-05-04
canon-bjnp1 8611 tcp Canon BJNP Port 1 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp1 8611 udp Canon BJNP Port 1 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp2 8612 tcp Canon BJNP Port 2 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp2 8612 udp Canon BJNP Port 2 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp3 8613 tcp Canon BJNP Port 3 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp3 8613 udp Canon BJNP Port 3 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp4 8614 tcp Canon BJNP Port 4 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp4 8614 udp Canon BJNP Port 4 Atsushi Nakamura Atsushi Nakamura 2003-11
imink 8615 tcp Imink Service Control Canon Inc. Ken'ichi FUJII 2011-10-10
8615 udp Reserved
8616-8664 Unassigned Unauthorized Use Known on ports 8616 and 8617
8699 udp Reserved 2004-11 2013-05-24 This entry is being removed on 2013-05-24.
semi-grpc 8710 tcp gRPC for SEMI Standards implementations SEMI Albert Fuchigami 2020-01-10
8710 udp Reserved
nvc 8711 tcp Nuance Voice Control Nuance Communications Diego Negre 2012-10-05
8711 udp Reserved
8712-8731 Unassigned
8751-8762 Unassigned
8771-8777 Unassigned
8801-8803 Unassigned Known UNAUTHORIZED USE: Port 8801
3gpp-monp 8809 udp MCPTT Off-Network Protocol (MONP) 3GPP Dongwook Kim 2019-04-15 2026-01-23 3GPP TS 24.379 v13.5.0s
8810-8872 Unassigned
galaxy4d 8881 tcp Galaxy4D Online Game Engine Galaxy4D Online Game Engine Olivier St-Laurent 2012-06-18
8881 udp Reserved
ddi-tcp-1 8888 tcp NewsEDGE server TCP (TCP 1) Fred Yao Fred Yao Known Unauthorized Use on port 8888
ddi-udp-1 8888 udp NewsEDGE server UDP (UDP 1) Fred Yao Fred Yao Known Unauthorized Use on port 8888
ddi-tcp-2 8889 tcp Desktop Data TCP 1 Fred Yao Fred Yao Known Unauthorized Use on port 8889
ddi-tcp-4 8891 tcp Desktop Data TCP 3: NESS application Fred Yao Fred Yao
ddi-udp-4 8891 udp Desktop Data UDP 3: NESS application Fred Yao Fred Yao
jmb-cds1 8900 tcp JMB-CDS 1 Curtis Bray Curtis Bray
jmb-cds1 8900 udp JMB-CDS 1 Curtis Bray Curtis Bray
jmb-cds2 8901 tcp JMB-CDS 2 Curtis Bray Curtis Bray
jmb-cds2 8901 udp JMB-CDS 2 Curtis Bray Curtis Bray
manyone-http 8910 tcp manyone-http Matt King Matt King 2002-04
manyone-http 8910 udp manyone-http Matt King Matt King 2002-04
manyone-xml 8911 tcp manyone-xml Matt King Matt King 2002-04
manyone-xml 8911 udp manyone-xml Matt King Matt King 2002-04
wcbackup 8912 tcp Windows Client Backup Jim Lyon Jim Lyon 2005-11
wcbackup 8912 udp Windows Client Backup Jim Lyon Jim Lyon 2005-11
dragonfly 8913 tcp Dragonfly System Service Paul Hodara Paul Hodara 2005-11
dragonfly 8913 udp Dragonfly System Service Paul Hodara Paul Hodara 2005-11
8914-8936 Unassigned
nod-client 8981 udp Network of Devices Client David Müller David Müller 2015-02-22
8981 tcp Reserved
https-wmap 8991 tcp webmail HTTPS service Chris Newman Chris Newman 2007-12-03
https-wmap 8991 udp webmail HTTPS service Chris Newman Chris Newman 2007-12-03
etlservicemgr 9001 tcp ETL Service Manager Stephen McCrea Stephen McCrea 2002-03 Known Unauthorized Use on port 9001
etlservicemgr 9001 udp ETL Service Manager Stephen McCrea Stephen McCrea 2002-03 Known Unauthorized Use on port 9001
sdr 9010 tcp Secure Data Replicator Protocol Sufyan Almajali Sufyan Almajali 2008-06-27
9010 udp Reserved
9011 tcp Reserved
d-star 9011 udp D-Star Routing digital voice+data for amateur radio QuadNet2 USA IRC Network Thomas A Early 2018-03-16
9012-9019 Unassigned
panagolin-ident 9021 tcp Pangolin Identification William Benner William Benner 2002-03
panagolin-ident 9021 udp Pangolin Identification William Benner William Benner 2002-03
swa-1 9023 tcp Secure Web Access - 1 Tim McGranaghan Tim McGranaghan
swa-1 9023 udp Secure Web Access - 1 Tim McGranaghan Tim McGranaghan
fio-cmgmt 9051 tcp Fusion-io Central Manager Service Jim Sermersheim Jim Sermersheim 2010-01-15
9051 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
3GPP dongwook.kim&etsi.org 2026-01-23
Aaron Bilbrey abilbrey&commvault.com
Albert Fuchigami albert.fuchigami&peergroup.com 2020-01-10
Aly Orady Atto Devices Inc. aly.orady&attodevices.com 2007-08-07
Aruba Networks jon.green&hpe.com 2018-10-04
Atsushi Nakamura nakamura.atsushi318&canon.co.jp 2003-11
Canon Inc. fujii.ken-ichi149&canon.co.jp 2011-10-10
Chris Brown chrisb&chancery.com
Chris Newman chris.newman&oracle.com 2017-01-26
Curtis Bray CurtisB&creativedesign.com
David Müller david.muller.cz&gmail.com 2015-02-22
Delphix Corp peng.dai&delphix.com 2012-11-01
Diego Negre Nuance Communications Diego.Negre&nuance.com 2012-10-05
Dongwook Kim 3GPP dongwook.kim&etsi.org 2026-01-23
Frank Jäkel Frank.Jaekel&cytel.de 2011-04-29
Fred Yao Fred_Yao&ddigate2.desktopdata.com
Galaxy4D Online Game Engine admin&galaxy4d.com 2012-06-18
Grexie webmaster&grexie.com 2012-06-15
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jim Lyon JimLyon&microsoft.com 2005-11
Jim Sermersheim jims&fusionio.com 2010-01-15
Jon Green Aruba Networks jon.green&hpe.com 2018-10-04
Ken'ichi FUJII Canon Inc. fujii.ken-ichi149&canon.co.jp 2011-10-10
Matt King m&manyone.net 2002-04
Nuance Communications NOD_SolutionsArchitecture&nuance.com 2012-10-05
Olivier St-Laurent Galaxy4D Online Game Engine admin&galaxy4d.com 2012-06-18
Paul Hodara phodara&netwave.com 2005-11
Peng Dai Delphix Corp peng.dai&delphix.com 2012-11-01
QuadNet2 USA IRC Network admins&openquad.net 2018-03-16
Ritsuto Sako sakou.ritsuto&canon.co.jp 2009-05-04
Ronald Snyder pugaroni&sssnet.com 2006-03
Saar Wilf saar&trivnet.com
Scott Tarone starone&proactivethought.com 2003-04
SEMI jamano&semi.org 2020-01-10
Stephen McCrea smccrea&etlelectronique.com 2002-03
Sufyan Almajali sufyan.almajali&sdrlive.com 2008-06-27
Thomas A Early tom.n7tae&tearly.net 2018-03-16
Tim Behrsin tim&behrsin.com 2012-06-15
Tim McGranaghan tim_mcgranaghan&mech.disa.mil
William Benner wrb2&pangolin.com 2025-03-27