Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 9051 | udp | Reserved | |||||||||
| 9061-9079 | Unassigned | ||||||||||
| 9081 | tcp | Reserved | |||||||||
| cisco-aqos | 9081 | udp | Required for Adaptive Quality of Service | Manish Surolia | Manish Surolia | 2017-10-27 | |||||
| xmltec-xmlmail | 9091 | tcp | xmltec-xmlmail | Mitch Kaufman | Mitch Kaufman | ||||||
| xmltec-xmlmail | 9091 | udp | xmltec-xmlmail | Mitch Kaufman | Mitch Kaufman | ||||||
| hp-pdl-datastr | 9100 | tcp | PDL Data Streaming Port | Shivaun Albright | Shivaun Albright | 2002-04 | |||||
| hp-pdl-datastr | 9100 | udp | PDL Data Streaming Port | Shivaun Albright | Shivaun Albright | 2002-04 | |||||
| pdl-datastream | 9100 | tcp | Printer PDL Data Stream | Stuart Cheshire | Stuart Cheshire | 2002-09 | The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100. | ||||
| pdl-datastream | 9100 | udp | Printer PDL Data Stream | Stuart Cheshire | Stuart Cheshire | 2002-09 | The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100. | ||||
| bacula-dir | 9101 | tcp | Bacula Director | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-dir | 9101 | udp | Bacula Director | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-fd | 9102 | tcp | Bacula File Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-fd | 9102 | udp | Bacula File Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-sd | 9103 | tcp | Bacula Storage Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-sd | 9103 | udp | Bacula Storage Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| peerwire | 9104 | tcp | PeerWire | Steven Gerhardt | Steven Gerhardt | 2004-02 | |||||
| peerwire | 9104 | udp | PeerWire | Steven Gerhardt | Steven Gerhardt | 2004-02 | |||||
| xadmin | 9105 | tcp | Xadmin Control Service | Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009 | |||||||
| xadmin | 9105 | udp | Xadmin Control Service | Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009 | |||||||
| astergate | 9106 | tcp | Astergate Control Service | Ariën Huisken | Ariën Huisken | 2010-01-04 | |||||
| astergate-disc | 9106 | udp | Astergate Discovery Service | Ariën Huisken | Ariën Huisken | 2010-01-04 | |||||
| astergatefax | 9107 | tcp | AstergateFax Control Service | Gijs Middelkamp | Gijs Middelkamp | 2010-02-03 | |||||
| 9107 | udp | Reserved | |||||||||
| 9108-9110 | Unassigned | ||||||||||
| hexxorecore | 9111 | tcp | Multiple Purpose, Distributed Message Bus | Hexxore | Patrick Roozeboom | 2018-07-31 | |||||
| hexxorecore | 9111 | udp | Multiple Purpose, Distributed Message Bus | Hexxore | Patrick Roozeboom | 2018-07-31 | |||||
| 9112-9118 | Unassigned | ||||||||||
| mxit | 9119 | tcp | MXit Instant Messaging | Marnus Freeman | Marnus Freeman | 2006-02 | |||||
| mxit | 9119 | udp | MXit Instant Messaging | Marnus Freeman | Marnus Freeman | 2006-02 | |||||
| 9120-9121 | Unassigned | ||||||||||
| grcmp | 9122 | tcp | Global Relay compliant mobile instant messaging protocol | Global Relay Communications Inc | Lu Vo | 2012-11-28 | 2025-06-12 | ||||
| 9122 | udp | Reserved | |||||||||
| grcp | 9123 | tcp | Global Relay compliant instant messaging protocol | Global Relay Communications Inc | Lu Vo | 2012-11-28 | 2025-06-12 | ||||
| 9123 | udp | Reserved | |||||||||
| 9124-9130 | Unassigned | ||||||||||
| dddp | 9131 | tcp | Dynamic Device Discovery | Shane Dick | Shane Dick | 2005-08 | |||||
| dddp | 9131 | udp | Dynamic Device Discovery | Shane Dick | Shane Dick | 2005-08 | |||||
| 9132-9159 | Unassigned | ||||||||||
| apani1 | 9160 | tcp | apani1 | Neal Taylor | Neal Taylor | ||||||
| apani1 | 9160 | udp | apani1 | Neal Taylor | Neal Taylor | ||||||
| apani2 | 9161 | tcp | apani2 | Neal Taylor | Neal Taylor | ||||||
| apani2 | 9161 | udp | apani2 | Neal Taylor | Neal Taylor | ||||||
| apani3 | 9162 | tcp | apani3 | Neal Taylor | Neal Taylor | ||||||
| apani3 | 9162 | udp | apani3 | Neal Taylor | Neal Taylor | ||||||
| apani4 | 9163 | tcp | apani4 | Neal Taylor | Neal Taylor | ||||||
| apani4 | 9163 | udp | apani4 | Neal Taylor | Neal Taylor | ||||||
| apani5 | 9164 | tcp | apani5 | Neal Taylor | Neal Taylor | ||||||
| apani5 | 9164 | udp | apani5 | Neal Taylor | Neal Taylor | ||||||
| 9165-9182 | Unassigned | ||||||||||
| sirius-agent | 9183 | tcp | Sirius Configuration Agent | Sirius Computer, Inc | Jason Van der Schyff | 2026-03-09 | |||||
| sirius-agent | 9183 | udp | Sirius Configuration Agent | Sirius Computer, Inc | Jason Van der Schyff | 2026-03-09 | |||||
| 9184-9190 | Unassigned | ||||||||||
| sun-as-jpda | 9191 | tcp | Sun AppSvr JPDA | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| sun-as-jpda | 9191 | udp | Sun AppSvr JPDA | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| 9192-9199 | Unassigned | ||||||||||
| wap-wsp-wtp | 9201 | tcp | WAP session service | WAP Forum | WAP Forum | ||||||
| wap-wsp-wtp | 9201 | udp | WAP session service | WAP Forum | WAP Forum | ||||||
| oma-mlp | 9210 | tcp | OMA Mobile Location Protocol | Hans Rohnert | Hans Rohnert | 2002-04 | |||||
| oma-mlp | 9210 | udp | OMA Mobile Location Protocol | Hans Rohnert | Hans Rohnert | 2002-04 | |||||
| oma-mlp-s | 9211 | tcp | OMA Mobile Location Protocol Secure | Hans Rohnert | Hans Rohnert | 2002-04 | |||||
| oma-mlp-s | 9211 | udp | OMA Mobile Location Protocol Secure | Hans Rohnert | Hans Rohnert | 2002-04 | |||||
| serverviewdbms | 9212 | tcp | Server View dbms access | Detlef Rothe | Detlef Rothe | 2009-05-15 | |||||
| serverviewdbms | 9212 | udp | Server View dbms access | Detlef Rothe | Detlef Rothe | 2009-05-15 | |||||
| serverstart | 9213 | tcp | ServerStart RemoteControl | Detlef Rothe | Detlef Rothe | 2009-05-15 | |||||
| serverstart | 9213 | udp | ServerStart RemoteControl | Detlef Rothe | Detlef Rothe | 2009-05-15 | |||||
| ipdcesgbs | 9214 | tcp | IPDC ESG BootstrapService | Joerg Heuer | Joerg Heuer | 2006-02 | |||||
| ipdcesgbs | 9214 | udp | IPDC ESG BootstrapService | Joerg Heuer | Joerg Heuer | 2006-02 | |||||
| insis | 9215 | tcp | Integrated Setup and Install Service | Markus Treinen | Markus Treinen | 2006-02 | |||||
| insis | 9215 | udp | Integrated Setup and Install Service | Markus Treinen | Markus Treinen | 2006-02 | |||||
| acme | 9216 | tcp | Aionex Communication Management Engine | Mark Sapp | Mark Sapp | 2006-04 | |||||
| acme | 9216 | udp | Aionex Communication Management Engine | Mark Sapp | Mark Sapp | 2006-04 | |||||
| fsc-port | 9217 | tcp | FSC Communication Port | Teijo Mustonen | Teijo Mustonen | 2002-03 | |||||
| fsc-port | 9217 | udp | FSC Communication Port | Teijo Mustonen | Teijo Mustonen | 2002-03 | |||||
| 9218-9221 | Unassigned | ||||||||||
| swtp-port1 | 9281 | tcp | SofaWare transport port 1 | Amir Rapson | Amir Rapson | 2002-02 | |||||
| swtp-port1 | 9281 | udp | SofaWare transport port 1 | Amir Rapson | Amir Rapson | 2002-02 | |||||
| 9288-9291 | Unassigned | ||||||||||
| 9301-9305 | Unassigned | ||||||||||
| sapms | 9310 | tcp | SAP Message Server | SAP SE | Stefan Hagen | 2020-03-12 | |||||
| 9310 | udp | Reserved | |||||||||
| 9311 | Unassigned | ||||||||||
| sphinxapi | 9312 | tcp | Sphinx search server | Andrew Aksyonoff | Andrew Aksyonoff | 2009-10-20 | |||||
| 9312 | udp | Reserved | |||||||||
| 9313-9317 | Unassigned | ||||||||||
| secure-ts | 9318 | tcp | PKIX TimeStamp over TLS | Niklas Weiss | Niklas Weiss | 2004-11 | |||||
| secure-ts | 9318 | udp | PKIX TimeStamp over TLS | Niklas Weiss | Niklas Weiss | 2004-11 | |||||
| 9319-9320 | Unassigned | ||||||||||
| guibase | 9321 | tcp | guibase | Yutaka Ono | Yutaka Ono | ||||||
| guibase | 9321 | udp | guibase | Yutaka Ono | Yutaka Ono | ||||||
| 9341-9342 | Unassigned | ||||||||||
| 9381-9386 | Unassigned | ||||||||||
| 9391-9395 | Unassigned | ||||||||||
| sec-t4net-clt | 9401 | tcp | Samsung Twain for Network Client | Dongkeun Kim | Dongkeun Kim | 2007-02 | |||||
| sec-t4net-clt | 9401 | udp | Samsung Twain for Network Client | Dongkeun Kim | Dongkeun Kim | 2007-02 | |||||
| 9403-9417 | Unassigned | ||||||||||
| git | 9418 | tcp | git pack transfer service | Linus Torvalds | Linus Torvalds | 2005-09 | |||||
| git | 9418 | udp | git pack transfer service | Linus Torvalds | Linus Torvalds | 2005-09 | |||||
| 9419-9442 | Unassigned | ||||||||||
| 9451-9499 | Unassigned | ||||||||||
| 9501-9521 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Abhijit Kumar | as-iana-ports&sun.com | 2005-11 | |
| Amir Rapson | rapson&sofaware.com | 2002-02 | |
| Andrew Aksyonoff | shodan&sphinxsearch.com | 2009-10-20 | |
| Ariën Huisken | astergate&huisken-systems.nl | 2010-01-04 | |
| Detlef Rothe | detlef.rothe&ts.fujitsu.com | 2009-05-15 | |
| Dongkeun Kim | dongkeun70.kim&samsung.com | 2007-02 | |
| Gijs Middelkamp | astergate-fax&huisken-systems.nl | 2010-02-03 | |
| Global Relay Communications Inc | info&globalrelay.net | 2025-06-12 | |
| Hans Rohnert | hans.rohnert&siemens.com | 2002-04 | |
| Hexxore | info&hexxore.nl | 2018-07-31 | |
| Jason Van der Schyff | jason&sirius.computer | 2026-03-09 | |
| Joerg Heuer | Joerg.Heuer&siemens.com | 2006-02 | |
| Kern Sibbald | kern&sibbald.com | 2002-01 | |
| Linus Torvalds | torvalds&osdl.org | 2005-09 | |
| Lu Vo | Global Relay Communications Inc | lu.vo&globalrelay.net | 2025-06-12 |
| Manish Surolia | masurolia@cisco.com> | 2017-10-27 | |
| Mark Sapp | mark.sapp&aionex.com | 2006-04 | |
| Markus Treinen | markus.treinen&siemens.com | 2006-02 | |
| Marnus Freeman | marnus&swistgroup.com | 2006-02 | |
| Mitch Kaufman | mk&weconnectyou.com | ||
| Neal Taylor | ianareg&apani.com | ||
| Niklas Weiss | n.weiss&d-trust.net | 2004-11 | |
| Patrick Roozeboom | info&hexxore.nl | 2018-07-31 | |
| SAP SE | stefan.hagen&sap.com | 2020-03-12 | |
| Shane Dick | shane.dick&amx.com | 2005-08 | |
| Shivaun Albright | shivaun_albright&hp.com | 2002-04 | |
| Sirius Computer, Inc | jason&sirius.computer | 2026-03-09 | |
| Stefan Hagen | stefan.hagen&sap.com | 2020-03-12 | |
| Steven Gerhardt | sgerhardt&ixiononline.com | 2004-02 | |
| Stuart Cheshire | pdl-datastream&apple.com | 2002-09 | |
| Teijo Mustonen | Teijo.Mustonen&f-secure.com | 2002-03 | |
| WAP Forum | wap-feedback&mail.wapforum.org
pg&uplanet.com |
||
| Yutaka Ono | ono&saint.nm.fujitsu.co.jp |