Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 9501-9521 | Unassigned | ||||||||||
| 9560-9591 | Unassigned | ||||||||||
| 9601-9611 | Unassigned | ||||||||||
| streamcomm-ds | 9612 | tcp | StreamComm User Directory | Brian C. Wiles | Brian C. Wiles | ||||||
| streamcomm-ds | 9612 | udp | StreamComm User Directory | Brian C. Wiles | Brian C. Wiles | ||||||
| 9613 | Unassigned | ||||||||||
| iadt-tls | 9614 | tcp | iADT Protocol over TLS | Paul A. Suhler | Paul A. Suhler | 2009-02-05 | |||||
| 9614 | udp | Reserved | |||||||||
| 9615 | Unassigned | ||||||||||
| erunbook-agent | 9616 | tcp | eRunbook Agent IANA assigned this well-formed service name as a replacement for "erunbook_agent". |
Gerhard Wagner | Gerhard Wagner | 2009-03-10 | |||||
| erunbook_agent | 9616 | tcp | eRunbook Agent | Gerhard Wagner | Gerhard Wagner | 2009-03-10 | This entry is an alias to "erunbook-agent". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 9616 | udp | Reserved | |||||||||
| erunbook-server | 9617 | tcp | eRunbook Server IANA assigned this well-formed service name as a replacement for "erunbook_server". |
Gerhard Wagner | Gerhard Wagner | 2009-03-10 | |||||
| erunbook_server | 9617 | tcp | eRunbook Server | Gerhard Wagner | Gerhard Wagner | 2009-03-10 | This entry is an alias to "erunbook-server". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 9617 | udp | Reserved | |||||||||
| condor | 9618 | tcp | Condor Collector Service | Todd Tannenbaum | Todd Tannenbaum | 2008-04-03 | |||||
| condor | 9618 | udp | Condor Collector Service | Todd Tannenbaum | Todd Tannenbaum | 2008-04-03 | |||||
| 9619-9627 | Unassigned | ||||||||||
| peocoll | 9631 | tcp | Peovica Collector | Adrian Hungate | Adrian Hungate | 2009-09-14 | |||||
| 9631 | udp | Reserved | |||||||||
| 9641-9665 | Unassigned | ||||||||||
| 9701-9746 | Unassigned | ||||||||||
| 9751-9752 | Unassigned | ||||||||||
| 9754-9761 | Unassigned | ||||||||||
| sstp-2 | 9801 | tcp | Sakura Script Transfer Protocol-2 | Kouichi Takeda | Kouichi Takeda | ||||||
| sstp-2 | 9801 | udp | Sakura Script Transfer Protocol-2 | Kouichi Takeda | Kouichi Takeda | ||||||
| sapv1 | 9875 | tcp | Session Announcement v1 | RFC 2974 | |||||||
| sapv1 | 9875 | udp | Session Announcement v1 | RFC 2974 | |||||||
| x510 | 9877 | tcp | The X.510 wrapper protocol | ITU/TSB (ITU-T Study Group 17) | Erik Andersen | 2019-09-30 | ITU-T X.510 / ISO/IEC 9584-11 | ||||
| kca-service | 9878 | udp | The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 | IESG | IETF Chair | 2012-07-12 | RFC 6717 | Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements. | |||
| sctp-tunneling | 9899 | udp | SCTP TUNNELING | IESG | IETF Chair | 2013-04-10 | RFC 6951 | ||||
| enrp | 9901 | udp | enrp server channel | ||||||||
| enrp-sctp | 9901 | sctp | enrp server channel | RFC 5353 | |||||||
| 9910 | Unassigned | ||||||||||
| sype-transport | 9911 | tcp | SYPECom Transport Protocol | Sylvain Pedneault | Sylvain Pedneault | 2003-03 | |||||
| sype-transport | 9911 | udp | SYPECom Transport Protocol | Sylvain Pedneault | Sylvain Pedneault | 2003-03 | |||||
| 9912-9924 | Unassigned | ||||||||||
| apc-9951 | 9951 | tcp | APC 9951 | American Power Conversion | American Power Conversion | ||||||
| apc-9951 | 9951 | udp | APC 9951 | American Power Conversion | American Power Conversion | ||||||
| pumpkindb | 9981 | tcp | Event sourcing database engine with a built-in programming language | Eventsourcing, Inc. | Yurii Rashkovskii | 2017-04-18 | |||||
| 9981 | udp | Reserved | |||||||||
| osm-oev | 9991 | tcp | OSM Event Server | Vinay Gupta | Vinay Gupta | 2003-08 | |||||
| osm-oev | 9991 | udp | OSM Event Server | Vinay Gupta | Vinay Gupta | 2003-08 | |||||
| palace-1 | 9992 | tcp | OnLive-1 | Douglas Crockford | Douglas Crockford | ||||||
| palace-1 | 9992 | udp | OnLive-1 | Douglas Crockford | Douglas Crockford | ||||||
| ndmp | 10000 | tcp | Network Data Management Protocol | Brian Ehrmantraut | Brian Ehrmantraut | ||||||
| ndmp | 10000 | udp | Network Data Management Protocol | Brian Ehrmantraut | Brian Ehrmantraut | ||||||
| scp-config | 10001 | tcp | SCP Configuration | Michael Benz | Michael Benz | 2010-08-06 | |||||
| scp-config | 10001 | udp | SCP Configuration | Michael Benz | Michael Benz | 2010-08-06 | |||||
| documentum | 10002 | tcp | EMC-Documentum Content Server Product | Reza Bagherian | Reza Bagherian | 2007-07-19 | |||||
| documentum | 10002 | udp | EMC-Documentum Content Server Product | Reza Bagherian | Reza Bagherian | 2007-07-19 | |||||
| documentum-s | 10003 | tcp | EMC-Documentum Content Server Product IANA assigned this well-formed service name as a replacement for "documentum_s". |
Reza Bagherian | Reza Bagherian | 2007-07-19 | |||||
| documentum_s | 10003 | tcp | EMC-Documentum Content Server Product | Reza Bagherian | Reza Bagherian | 2007-07-19 | This entry is an alias to "documentum-s". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| documentum-s | 10003 | udp | EMC-Documentum Content Server Product IANA assigned this well-formed service name as a replacement for "documentum_s". |
Reza Bagherian | Reza Bagherian | 2007-07-19 | |||||
| documentum_s | 10003 | udp | EMC-Documentum Content Server Product | Reza Bagherian | Reza Bagherian | 2007-07-19 | This entry is an alias to "documentum-s". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| emcrmirccd | 10004 | tcp | EMC Replication Manager Client | Robert Boudrie | Robert Boudrie | 2008-06-09 | |||||
| 10004 | udp | Reserved | |||||||||
| emcrmird | 10005 | tcp | EMC Replication Manager Server | Robert Boudrie | Robert Boudrie | 2008-06-09 | |||||
| 10005 | udp | Reserved | |||||||||
| netapp-sync | 10006 | tcp | Sync replication protocol among different NetApp platforms | NetApp | Paul Mu | 2014-08-07 | |||||
| 10006 | udp | Reserved | |||||||||
| mvs-capacity | 10007 | tcp | MVS Capacity | Donna Dillenberger | Donna Dillenberger | ||||||
| mvs-capacity | 10007 | udp | MVS Capacity | Donna Dillenberger | Donna Dillenberger | ||||||
| octopus | 10008 | tcp | Octopus Multiplexer | Chris Koeritz | Chris Koeritz | 2002-10 | |||||
| octopus | 10008 | udp | Octopus Multiplexer | Chris Koeritz | Chris Koeritz | 2002-10 | |||||
| swdtp-sv | 10009 | tcp | Systemwalker Desktop Patrol | Akira Ide | Akira Ide | 2006-03 | |||||
| swdtp-sv | 10009 | udp | Systemwalker Desktop Patrol | Akira Ide | Akira Ide | 2006-03 | |||||
| rxapi | 10010 | tcp | ooRexx rxapi services | David Ashley | David Ashley | 2009-07-24 | |||||
| 10010 | udp | Reserved | |||||||||
| 10011-10019 | Unassigned | ||||||||||
| abb-hw | 10020 | tcp | Hardware configuration and maintenance | ABB | Adam Norén | 2017-03-28 | |||||
| 10020 | udp | Reserved | |||||||||
| 10021-10022 | Unassigned | ||||||||||
| cefd-vmp | 10023 | udp | Comtech EF-Data's Vipersat Management Protocol | Comtech | Nathan Jeffords | 2014-01-23 | |||||
| 10023 | tcp | Reserved | |||||||||
| 10024-10049 | Unassigned | ||||||||||
| zabbix-agent | 10050 | tcp | Zabbix Agent | Alexei Vladishev | Alexei Vladishev | 2006-02 | |||||
| zabbix-agent | 10050 | udp | Zabbix Agent | Alexei Vladishev | Alexei Vladishev | 2006-02 | |||||
| zabbix-trapper | 10051 | tcp | Zabbix Trapper | Alexei Vladishev | Alexei Vladishev | 2006-02 | |||||
| zabbix-trapper | 10051 | udp | Zabbix Trapper | Alexei Vladishev | Alexei Vladishev | 2006-02 | |||||
| 10052-10054 | Unassigned | ||||||||||
| qptlmd | 10055 | tcp | Quantapoint FLEXlm Licensing Service | Justin Vegso | Justin Vegso | 2010-07-01 | |||||
| 10055 | udp | Reserved | |||||||||
| 10056-10079 | Unassigned | ||||||||||
| amanda | 10080 | tcp | Amanda | John Jackson | John Jackson | ||||||
| amanda | 10080 | udp | Amanda | John Jackson | John Jackson | ||||||
| famdc | 10081 | tcp | FAM Archive Server | Frode Randers | Frode Randers | 2006-01 | |||||
| famdc | 10081 | udp | FAM Archive Server | Frode Randers | Frode Randers | 2006-01 | |||||
| 10082-10099 | Unassigned | ||||||||||
| itap-ddtp | 10100 | tcp | VERITAS ITAP DDTP | Saugata Guha | Saugata Guha | 2004-05 | |||||
| itap-ddtp | 10100 | udp | VERITAS ITAP DDTP | Saugata Guha | Saugata Guha | 2004-05 | |||||
| ezmeeting-2 | 10101 | tcp | eZmeeting | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezmeeting-2 | 10101 | udp | eZmeeting | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezproxy-2 | 10102 | tcp | eZproxy | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezproxy-2 | 10102 | udp | eZproxy | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezrelay | 10103 | tcp | eZrelay | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezrelay | 10103 | udp | eZrelay | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| swdtp | 10104 | tcp | Systemwalker Desktop Patrol | Akira Ide | Akira Ide | 2006-09 | |||||
| swdtp | 10104 | udp | Systemwalker Desktop Patrol | Akira Ide | Akira Ide | 2006-09 | |||||
| 10105-10106 | Unassigned | ||||||||||
| bctp-server | 10107 | tcp | VERITAS BCTP, server | Saugata Guha | Saugata Guha | 2004-05 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| ABB | adam.noren&se.abb.com | 2017-03-28 | |
| Adam Norén | ABB | adam.noren&se.abb.com | 2017-03-28 |
| Adrian Hungate | adrian&tlspu.com | 2014-07-11 | |
| Akira Ide | ide.akira&jp.fujitsu.com | 2006-09 | |
| Albert C. Yang | albert.yang&ezmeeting.com | 2002-03 | |
| Alexei Vladishev | alexei.vladishev&zabbix.com | 2006-02 | |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Brian C. Wiles | brian&streamcomm.com | ||
| Brian Ehrmantraut | bae&netapp.com | ||
| Chris Koeritz | fred&gruntose.com | 2002-10 | |
| Comtech | njeffords&comtechefdata.com | 2014-01-23 | |
| David Ashley | david.ashley.ibm&gmail.com | 2009-07-24 | |
| Donna Dillenberger | engd&us.ibm.com | ||
| Douglas Crockford | douglas&crockford.com | ||
| Erik Andersen | era&x500.eu | 2019-08-13 | |
| Eventsourcing, Inc. | accounts&eventsourcing.com | 2017-04-18 | |
| Frode Randers | Frode.Randers&tietoenator.com | 2006-01 | |
| Gerhard Wagner | gw&nova-ratio.de | 2009-03-10 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| ITU/TSB (ITU-T Study Group 17) | tsbsg17&itu.int | 2019-09-30 | |
| John Jackson | amanda.org | jrj&gandalf.cc.purdue.edu | |
| Justin Vegso | jvegso&quantapoint.com | 2010-07-01 | |
| Kouichi Takeda | KHB05271&nifty.com | ||
| Michael Benz | michael.benz&lsi.com | 2010-08-06 | |
| Nathan Jeffords | Comtech | njeffords&comtechefdata.com | 2014-01-23 |
| NetApp | pmu&netapp.com. | 2014-08-12 | |
| Paul A. Suhler | paul.suhler&quantum.com | 2009-02-06 | |
| Paul Mu | NetApp | pmu&netapp.com | 2014-08-07 |
| Reza Bagherian | bagherian_reza&emc.com | 2007-07-19 | |
| Robert Boudrie | boudrie_rob&emc.com | 2008-06-09 | |
| Saugata Guha | sguha&veritas.com | 2004-05 | |
| Sylvain Pedneault | sylvain&sypecom.qc.ca | 2003-03 | |
| Todd Tannenbaum | tannenba&cs.wisc.edu | 2008-04-03 | |
| Vinay Gupta | vinay.gupta&hp.com | 2003-08 | |
| Yurii Rashkovskii | yrashk&eventsourcing.com | 2017-04-18 |