Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
osvr 7728 udp Open-Source Virtual Reality [Open_Source_Virtual_Reality_OSVR.com] [Yuval_Boger_2] 2015-07-14
osvr 7728 sctp Open-Source Virtual Reality [Open_Source_Virtual_Reality_OSVR.com] [Yuval_Boger_2] 2015-07-14
7729-7733 Unassigned
7735-7737 Unassigned
7739-7740 Unassigned
sstp-1 7743 tcp Sakura Script Transfer Protocol [Kouichi_Takeda] [Kouichi_Takeda]
sstp-1 7743 udp Sakura Script Transfer Protocol [Kouichi_Takeda] [Kouichi_Takeda]
raqmon-pdu 7744 tcp RAQMON PDU [RFC 4712]
raqmon-pdu 7744 udp RAQMON PDU [RFC 4712]
7745-7746 Unassigned
7748-7776 Unassigned
accu-lmgr 7781 tcp accu-lmgr [Moises_E_Hernandez] [Moises_E_Hernandez]
accu-lmgr 7781 udp accu-lmgr [Moises_E_Hernandez] [Moises_E_Hernandez]
7782-7783 Unassigned
s-bfd 7784 udp Seamless Bidirectional Forwarding Detection (S-BFD) [IESG] [IETF_Chair] 2014-12-24 2016-07-14 [RFC 7881]
popup-reminders 7787 tcp Popup Reminders Receive [Robert_Harvey] [Robert_Harvey] 2006-01 Known Unauthorized Use on port 7787
popup-reminders 7787 udp Popup Reminders Receive [Robert_Harvey] [Robert_Harvey] 2006-01 Known Unauthorized Use on port 7787
office-tools 7789 tcp Office Tools Pro Receive [Robert_Harvey] [Robert_Harvey] 2006-01 Known Unauthorized Use on port 7789
office-tools 7789 udp Office Tools Pro Receive [Robert_Harvey] [Robert_Harvey] 2006-01 Known Unauthorized Use on port 7789
7790-7793 Unassigned
7795-7796 Unassigned
pnet-conn 7797 tcp Propel Connector port
pnet-conn 7797 udp Propel Connector port
pnet-enc 7798 tcp Propel Encoder port [Leif_Hedstrom] [Leif_Hedstrom] 2002-04
pnet-enc 7798 udp Propel Encoder port [Leif_Hedstrom] [Leif_Hedstrom] 2002-04
ssp-client 7801 tcp Secure Server Protocol - client [Rick_Macchio] [Rick_Macchio] 2006-11
ssp-client 7801 udp Secure Server Protocol - client [Rick_Macchio] [Rick_Macchio] 2006-11
vns-tp 7802 udp Virtualized Network Services Tunnel Protocol [Juniper_Networks] [Bruno_Rijsman] 2013-02-01
7803-7809 Unassigned
rbt-wanopt 7810 tcp Riverbed WAN Optimization Protocol [Vladimir_Legalov_2] [Vladimir_Legalov_2] 2007-09-04
rbt-wanopt 7810 udp Riverbed WAN Optimization Protocol [Vladimir_Legalov_2] [Vladimir_Legalov_2] 2007-09-04
7811-7844 Unassigned
apc-7845 7845 tcp APC 7845 [American_Power_Conve] [American_Power_Conve]
apc-7845 7845 udp APC 7845 [American_Power_Conve] [American_Power_Conve]
apc-7846 7846 tcp APC 7846 [American_Power_Conve] [American_Power_Conve]
apc-7846 7846 udp APC 7846 [American_Power_Conve] [American_Power_Conve]
7848-7868 Unassigned
rbt-smc 7870 tcp Riverbed Steelhead Mobile Service [Gabriel_Levy] [Gabriel_Levy] 2008-08-29
mipv6tls 7872 udp TLS-based Mobile IPv6 Security [IESG] [IETF_Chair] 2012-04-12 [RFC 6618]
7873-7877 Unassigned
7881-7886 Unassigned
7888-7899 Unassigned
tnos-sp 7901 tcp TNOS Service Protocol [Rene_Kurt] [Rene_Kurt] 2005-08
tnos-sp 7901 udp TNOS Service Protocol [Rene_Kurt] [Rene_Kurt] 2005-08
tnos-dp 7902 tcp TNOS shell Protocol [Rene_Kurt] [Rene_Kurt] 2005-08
tnos-dp 7902 udp TNOS shell Protocol [Rene_Kurt] [Rene_Kurt] 2005-08
tnos-dps 7903 tcp TNOS Secure DiaguardProtocol [Rene_Kurt] [Rene_Kurt] 2005-08
tnos-dps 7903 udp TNOS Secure DiaguardProtocol [Rene_Kurt] [Rene_Kurt] 2005-08
7904-7912 Unassigned
qo-secure 7913 tcp QuickObjects secure port [Jonas_Bovin] [Jonas_Bovin]
qo-secure 7913 udp QuickObjects secure port [Jonas_Bovin] [Jonas_Bovin]
7914-7931 Unassigned
t2-drm 7932 tcp Tier 2 Data Resource Manager [Peter_Carlson] [Peter_Carlson]
t2-drm 7932 udp Tier 2 Data Resource Manager [Peter_Carlson] [Peter_Carlson]
t2-brm 7933 tcp Tier 2 Business Rules Manager [Peter_Carlson] [Peter_Carlson]
t2-brm 7933 udp Tier 2 Business Rules Manager [Peter_Carlson] [Peter_Carlson]
7934-7961 Unassigned
generalsync 7962 tcp Encrypted, extendable, general-purpose synchronization protocol [Dirk_Steinmetz] [Dirk_Steinmetz] 2014-04-17
generalsync 7962 udp Encrypted, extendable, general-purpose synchronization protocol [Dirk_Steinmetz] [Dirk_Steinmetz] 2014-04-17
7963-7966 Unassigned
7968-7978 Unassigned
micromuse-ncps 7979 tcp Micromuse-ncps [Hing_Wing_To] [Hing_Wing_To]
micromuse-ncps 7979 udp Micromuse-ncps [Hing_Wing_To] [Hing_Wing_To]
quest-vista 7980 tcp Quest Vista [Preston_Bannister] [Preston_Bannister]
quest-vista 7980 udp Quest Vista [Preston_Bannister] [Preston_Bannister]
sossd-collect 7981 tcp Spotlight on SQL Server Desktop Collect [Rob_Griffin_2] [Rob_Griffin_2] 2010-08-30
sossd-agent 7982 tcp Spotlight on SQL Server Desktop Agent [Rob_Griffin_2] [Rob_Griffin_2] 2010-09-13
sossd-disc 7982 udp Spotlight on SQL Server Desktop Agent Discovery [Rob_Griffin_2] [Rob_Griffin_2] 2010-09-13
7983-7997 Unassigned
vcom-tunnel 8001 tcp VCOM Tunnel [Mark_Lewandowski] [Mark_Lewandowski] Known Unauthorized Use on port 8001
vcom-tunnel 8001 udp VCOM Tunnel [Mark_Lewandowski] [Mark_Lewandowski] Known Unauthorized Use on port 8001
wpl-analytics 8006 tcp World Programming analytics [World_Programming_Limited] [Thomas_Quarendon] 2017-04-04
wpl-disc 8006 udp World Programming analytics discovery [World_Programming_Limited] [Thomas_Quarendon] 2017-04-04
http-alt 8008 tcp HTTP Alternate [James_Gettys] [James_Gettys]
http-alt 8008 udp HTTP Alternate [James_Gettys] [James_Gettys]
nvme-disc 8009 tcp NVMe over Fabrics Discovery Service [NVM_Express_Inc] [Amber_Huffman] 2018-03-27
8011-8014 Unassigned
cfg-cloud 8015 tcp Configuration Cloud Service [admin_at_cfg_cloud] [Goksel_Darcan] 2019-01-09
ads-s 8016 tcp Beckhoff Automation Device Specification [Beckhoff_Automation_GmbH_Co_KG] [Henning_Mersch] 2019-02-28
cisco-cloudsec 8017 udp Cisco Cloudsec Dataplane Port Number [Cisco_Systems_Inc] [Govind_Sharma] 2021-03-18
intu-ec-svcdisc 8020 tcp Intuit Entitlement Service and Discovery [Daniel_C_McGloin] [Daniel_C_McGloin] 2005-05
intu-ec-svcdisc 8020 udp Intuit Entitlement Service and Discovery [Daniel_C_McGloin] [Daniel_C_McGloin] 2005-05
intu-ec-client 8021 tcp Intuit Entitlement Client [Daniel_C_McGloin] [Daniel_C_McGloin] 2005-05
intu-ec-client 8021 udp Intuit Entitlement Client [Daniel_C_McGloin] [Daniel_C_McGloin] 2005-05
oa-system 8022 tcp oa-system [Marie_France_Dubreui] [Marie_France_Dubreui]
oa-system 8022 udp oa-system [Marie_France_Dubreui] [Marie_France_Dubreui]
arca-api 8023 tcp ARCATrust vault API [ARCATrust_SA] [Yacince_Felk] 2018-07-05
arca-api 8023 udp ARCATrust vault API [ARCATrust_SA] [Yacince_Felk] 2018-07-05
ca-audit-da 8025 tcp CA Audit Distribution Agent [Henning_Smith] [Henning_Smith] 2006-07
ca-audit-da 8025 udp CA Audit Distribution Agent [Henning_Smith] [Henning_Smith] 2006-07
ca-audit-ds 8026 tcp CA Audit Distribution Server [Henning_Smith] [Henning_Smith] 2006-07
ca-audit-ds 8026 udp CA Audit Distribution Server [Henning_Smith] [Henning_Smith] 2006-07
papachi-p2p-srv 8027 tcp peer tracker and data relay service [Pavel_Csefalvay] [Pavel_Csefalvay] 2020-09-18
papachi-p2p-srv 8027 udp peer tracker and data relay service [Pavel_Csefalvay] [Pavel_Csefalvay] 2020-09-18
8028-8031 Unassigned
pro-ed 8032 tcp ProEd
pro-ed 8032 udp ProEd
vantronix-mgmt 8034 tcp .vantronix Management [Reyk_Floeter] [Reyk_Floeter] 2008-02-27
vantronix-mgmt 8034 udp .vantronix Management [Reyk_Floeter] [Reyk_Floeter] 2008-02-27
8035-8039 Unassigned
enguity-xccetp 8041 tcp Xcorpeon ASIC Carrier Ethernet Transport [Enguity_Technology_Corp] [Kraig_Beahn_Jr] 2017-06-28

Contact Information

ID Name Organization Contact URI Last Updated
[admin_at_cfg_cloud] admin_at_cfg_cloud mailto:gdarcan&gmail.com 2019-01-09
[Amber_Huffman] Amber Huffman mailto:amber.huffman&intel.com 2018-03-27
[American_Power_Conve] American Power Conversion mailto:ports&apcc.com 2002-02
[ARCATrust_SA] ARCATrust SA mailto:info&arcatrust.io 2018-07-05
[Beckhoff_Automation_GmbH_Co_KG] Beckhoff Automation GmbH & Co. KG mailto:legal&beckhoff.com 2019-02-28
[Bruno_Rijsman] Bruno Rijsman Juniper Networks mailto:brijsman&juniper.net 2013-02-01
[Cisco_Systems_Inc] Cisco Systems, Inc. mailto:gosharma&cisco.com 2021-03-18
[Daniel_C_McGloin] Daniel C. McGloin mailto:daniel_mcgloin&intuit.com 2005-05
[Dirk_Steinmetz] Dirk Steinmetz mailto:ds&generalsync.com 2014-04-17
[Enguity_Technology_Corp] Enguity Technology Corp. mailto:kraig.beahn&enguity.com 2017-06-28
[Gabriel_Levy] Gabriel Levy mailto:glevy&riverbed.com 2008-08-29
[Goksel_Darcan] Goksel Darcan mailto:gdarcan&gmail.com 2019-01-09
[Govind_Sharma] Govind Sharma Cisco Systems, Inc. mailto:gosharma&cisco.com 2021-03-18
[Henning_Mersch] Henning Mersch mailto:support&beckhoff.com 2019-02-28
[Henning_Smith] Henning Smith mailto:henning.smith&ca.com 2006-07
[Hing_Wing_To] Hing Wing To mailto:wing.to&mircromuse.com
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[James_Gettys] James Gettys mailto:jg&w3.org
[Jonas_Bovin] Jonas Bovin mailto:jonas.bovin&quickobjects.com
[Juniper_Networks] Juniper Networks mailto:brijsman&juniper.net 2013-02-01
[Kouichi_Takeda] Kouichi Takeda mailto:KHBO5271&nifty.com
[Kraig_Beahn_Jr] Kraig Beahn Jr. mailto:kraig&enguity.com 2017-06-28
[Leif_Hedstrom] Leif Hedstrom mailto:leif&propel.com 2002-04
[Marie_France_Dubreui] Marie-France Dubreuil mailto:Marie-France.Dubreuil&evidian.com 2002-11
[Mark_Lewandowski] Mark Lewandowski mailto:mlewan0&us.ibm.com
[Moises_E_Hernandez] Moises E. Hernandez mailto:moises&accugraph.com
[NVM_Express_Inc] NVM Express, Inc. mailto:admin&nvmexpress.org 2018-03-27
[Open_Source_Virtual_Reality_OSVR.com] Open Source Virtual Reality (OSVR.com) mailto:iana&sensics.com 2015-07-14
[Pavel_Csefalvay] Pavel Csefalvay mailto:csefalvay&gmail.com 2020-09-18
[Peter_Carlson] Peter Carlson mailto:pcarlson&tier2.com
[Preston_Bannister] Preston Bannister mailto:pbannister&quests.com
[Rene_Kurt] Rene Kurt mailto:rene.kurt&adasoft.ch 2005-08
[Reyk_Floeter] Reyk Floeter mailto:reyk&vantronix.net 2008-02-27
[Rick_Macchio] Rick Macchio mailto:rmacchio&juniper.net 2006-11
[Rob_Griffin_2] Rob Griffin mailto:rob.gri55in&gmail.com 2010-09-13
[Robert_Harvey] Robert Harvey mailto:robert&officetoolspro.com 2006-01
[Thomas_Quarendon] Thomas Quarendon World Programming Limited mailto:tom.quarendon&worldprogramming.com 2017-04-04
[Vladimir_Legalov_2] Vladimir Legalov mailto:vlegalov&riverbed.com 2007-09-04
[World_Programming_Limited] World Programming Limited mailto:support&worldprogramming.com 2017-04-04
[Yacince_Felk] Yacince Felk mailto:yacine&arcatrust.io 2018-07-05
[Yuval_Boger_2] Yuval Boger mailto:iana&sensics.com 2015-07-14