Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
enguity-xccetp 8041 tcp Xcorpeon ASIC Carrier Ethernet Transport [Enguity_Technology_Corp] [Kraig_Beahn_Jr] 2017-06-28
enguity-xccetp 8041 udp Xcorpeon ASIC Carrier Ethernet Transport [Enguity_Technology_Corp] [Kraig_Beahn_Jr] 2017-06-28
fs-agent 8042 tcp FireScope Agent [Matt_Rogers] [Matt_Rogers] 2008-10-16
fs-server 8043 tcp FireScope Server [Matt_Rogers] [Matt_Rogers] 2008-10-16
fs-mgmt 8044 tcp FireScope Management Interface [Matt_Rogers] [Matt_Rogers] 2008-10-16
8045-8050 Unassigned
nikatron-dev 8061 tcp Nikatron Device Protocol [Nikatron] [Marcel_Uhlir] 2023-09-07
8062-8065 Unassigned
toad-bi-appsrvr 8066 tcp Toad BI Application Server [Quest_Software_2] [Greg_Cottman_3] 2013-04-19
infi-async 8067 tcp Infinidat async replication [INFINIDAT] [Eldar_Kleiner] 2015-05-01
8068-8069 Unassigned
ucs-isc 8070 tcp Oracle Unified Communication Suite's Indexed Search Converter [Oracle_Corp] [Bharathi_Sivaramakrishnan] 2017-02-10
8071-8073 Unassigned
gadugadu 8074 tcp Gadu-Gadu [Marcin_Gozdalik] [Marcin_Gozdalik] 2006-05
gadugadu 8074 udp Gadu-Gadu [Marcin_Gozdalik] [Marcin_Gozdalik] 2006-05
8075-8076 Unassigned
8077 tcp Reserved 2024-01-05 De-Assigned on 2024-01-05.
8078-8079 Unassigned
http-alt 8080 tcp HTTP Alternate (see port 80) [Stephen_Casner] [Stephen_Casner]
http-alt 8080 udp HTTP Alternate (see port 80) [Stephen_Casner] [Stephen_Casner]
us-cli 8082 tcp Utilistor (Client) [Andy_Brewerton] [Andy_Brewerton] 2005-08
us-cli 8082 udp Utilistor (Client) [Andy_Brewerton] [Andy_Brewerton] 2005-08
us-srv 8083 tcp Utilistor (Server) [Andy_Brewerton] [Andy_Brewerton] 2005-08
us-srv 8083 udp Utilistor (Server) [Andy_Brewerton] [Andy_Brewerton] 2005-08
d-s-n 8086 tcp Distributed SCADA Networking Rendezvous Port [Gary_Hampton] [Gary_Hampton] 2008-02-27
d-s-n 8086 udp Distributed SCADA Networking Rendezvous Port [Gary_Hampton] [Gary_Hampton] 2008-02-27
radan-http 8088 tcp Radan HTTP [Steve_Hay] [Steve_Hay] 2008-06-13
radan-http 8088 udp Radan HTTP [Steve_Hay] [Steve_Hay] 2008-06-13
opsmessaging 8090 tcp Vehicle to station messaging [LAN-ACES_Inc] [Robert_Ripberger] 2017-02-08
8092-8096 Unassigned
8098-8099 Unassigned
xprint-server 8100 tcp Xprint Server [John_McKernan] [John_McKernan]
xprint-server 8100 udp Xprint Server [John_McKernan] [John_McKernan]
ldoms-migr 8101 tcp Logical Domains Migration [Liam_Merwick] [Liam_Merwick] 2009-01-16
kz-migr 8102 tcp Oracle Kernel zones migration server [Oracle_4] [John_Levon] 2013-12-24
8103-8110 Unassigned
8112-8114 Unassigned
mtl8000-matrix 8115 tcp MTL8000 Matrix [David_Pinch] [David_Pinch] 2002-04
mtl8000-matrix 8115 udp MTL8000 Matrix [David_Pinch] [David_Pinch] 2002-04
cp-cluster 8116 tcp Check Point Clustering [Roni_Moshitzky] [Roni_Moshitzky]
cp-cluster 8116 udp Check Point Clustering [Roni_Moshitzky] [Roni_Moshitzky]
8119-8120 Unassigned
apollo-data 8121 tcp Apollo Data Port [Anthony_Carrabino] [Anthony_Carrabino] 2003-08
apollo-data 8121 udp Apollo Data Port [Anthony_Carrabino] [Anthony_Carrabino] 2003-08
apollo-admin 8122 tcp Apollo Admin Port [Anthony_Carrabino] [Anthony_Carrabino] 2003-08
apollo-admin 8122 udp Apollo Admin Port [Anthony_Carrabino] [Anthony_Carrabino] 2003-08
8123-8127 Unassigned
paycash-online 8128 tcp PayCash Online Protocol [MegaZone] [MegaZone] 2005-08
paycash-online 8128 udp PayCash Online Protocol [MegaZone] [MegaZone] 2005-08
paycash-wbp 8129 tcp PayCash Wallet-Browser [MegaZone] [MegaZone] 2005-08
paycash-wbp 8129 udp PayCash Wallet-Browser [MegaZone] [MegaZone] 2005-08
indigo-vrmi 8130 tcp INDIGO-VRMI [Colin_Caughie] [Colin_Caughie]
indigo-vrmi 8130 udp INDIGO-VRMI [Colin_Caughie] [Colin_Caughie]
indigo-vbcp 8131 tcp INDIGO-VBCP [Colin_Caughie] [Colin_Caughie]
indigo-vbcp 8131 udp INDIGO-VBCP [Colin_Caughie] [Colin_Caughie]
8133-8139 Unassigned
8141-8147 Unassigned
isdd 8148 tcp i-SDD file transfer [Frank_Waarsenburg] [Frank_Waarsenburg] 2004-11
isdd 8148 udp i-SDD file transfer [Frank_Waarsenburg] [Frank_Waarsenburg] 2004-11
eor-game 8149 udp Edge of Reality game data [Sky_Schulz] [Sky_Schulz] 2011-05-09
8150-8152 Unassigned
8154-8159 Unassigned
patrol-snmp 8161 tcp Patrol SNMP [Portnoy_Boxman] [Portnoy_Boxman]
patrol-snmp 8161 udp Patrol SNMP [Portnoy_Boxman] [Portnoy_Boxman]
8163-8180 Unassigned
vmware-fdm 8182 tcp VMware Fault Domain Manager [Ron_Passerini] [Ron_Passerini] 2010-04-27
vmware-fdm 8182 udp VMware Fault Domain Manager [Ron_Passerini] [Ron_Passerini] 2010-04-27
8185-8189 Unassigned
gcp-rphy 8190 tcp Generic control plane for RPHY [CableLabs] [Karthik_Sundaresan] 2015-11-24
8196-8198 Unassigned
vvr-data 8199 tcp VVR DATA [Ming_Xu] [Ming_Xu]
vvr-data 8199 udp VVR DATA [Ming_Xu] [Ming_Xu]
8203-8203 Unassigned
lm-perfworks 8204 tcp LM Perfworks [Chris_Flynn] [Chris_Flynn]
lm-perfworks 8204 udp LM Perfworks [Chris_Flynn] [Chris_Flynn]
lm-instmgr 8205 tcp LM Instmgr [Chris_Flynn] [Chris_Flynn]
lm-instmgr 8205 udp LM Instmgr [Chris_Flynn] [Chris_Flynn]
lm-dta 8206 tcp LM Dta [Chris_Flynn] [Chris_Flynn]
lm-dta 8206 udp LM Dta [Chris_Flynn] [Chris_Flynn]
lm-sserver 8207 tcp LM SServer [Chris_Flynn] [Chris_Flynn]
lm-sserver 8207 udp LM SServer [Chris_Flynn] [Chris_Flynn]
lm-webwatcher 8208 tcp LM Webwatcher [Chris_Flynn] [Chris_Flynn]
lm-webwatcher 8208 udp LM Webwatcher [Chris_Flynn] [Chris_Flynn]
8209-8210 Unassigned
aruba-papi 8211 udp Aruba Networks AP management [Aruba_Networks] [Jon_Green] 2018-10-04
8212-8229 Unassigned
hncp-udp-port 8231 udp HNCP [IESG] [IETF_Chair] 2016-01-13 [RFC 7788]
hncp-dtls-port 8232 udp HNCP over DTLS [IESG] [IETF_Chair] 2016-01-13 [RFC 7788]
8233-8242 Unassigned
synapse-nhttps 8243 tcp Synapse Non Blocking HTTPS [Ruwan_Linton] [Ruwan_Linton] 2008-07-10
synapse-nhttps 8243 udp Synapse Non Blocking HTTPS [Ruwan_Linton] [Ruwan_Linton] 2008-07-10
8244-8265 Unassigned
espeasy-p2p 8266 udp ESPeasy peer-2-peer communication [ESPeasy] [Gijs_Noorlander] 2018-11-28
8267-8269 Unassigned
robot-remote 8270 tcp Robot Framework Remote Library Interface [Robot_Framework_Foundation] [Chris_Newman] 2017-01-26
8271-8275 Unassigned
ms-mcc 8276 tcp Microsoft Connected Cache [Microsoft_Corporation_6] [Narkis_Engler] 2008-02-27 2022-05-03
ms-mcc 8276 udp Microsoft Connected Cache [Microsoft_Corporation_6] [Narkis_Engler] 2008-02-27 2022-05-03
8277-8279 Unassigned
synapse-nhttp 8280 tcp Synapse Non Blocking HTTP [Ruwan_Linton] [Ruwan_Linton] 2008-06-05
synapse-nhttp 8280 udp Synapse Non Blocking HTTP [Ruwan_Linton] [Ruwan_Linton] 2008-06-05

Contact Information

ID Name Organization Contact URI Last Updated
[Andy_Brewerton] Andy Brewerton mailto:andy.brewerton&otium.co.uk 2005-08
[Anthony_Carrabino] Anthony Carrabino mailto:anthonyc&vistasoftware.com 2003-08
[Aruba_Networks] Aruba Networks mailto:jon.green&hpe.com 2018-10-04
[Bharathi_Sivaramakrishnan] Bharathi Sivaramakrishnan mailto:bharathi.sivaramakrishnan&oracle.com 2017-02-10
[CableLabs] CableLabs mailto:info&cablelabs.com 2015-11-24
[Chris_Flynn] Chris Flynn mailto:cflynn&landmark.com
[Chris_Newman] Chris Newman mailto:chris.newman&oracle.com 2017-01-26
[Colin_Caughie] Colin Caughie mailto:cfc&indigo-avs.com
[David_Pinch] David Pinch mailto:dpinch&mtl-inst.com 2002-04
[Eldar_Kleiner] Eldar Kleiner INFINIDAT mailto:eldark&infinidat.com 2015-05-01
[Enguity_Technology_Corp] Enguity Technology Corp. mailto:kraig.beahn&enguity.com 2017-06-28
[ESPeasy] ESPeasy mailto:gijs.noorlander&gmail.com 2018-11-28
[Frank_Waarsenburg] Frank Waarsenburg mailto:frank&eye-display.nl 2004-11
[Gary_Hampton] Gary Hampton mailto:GH&2hti.com 2008-02-27
[Gijs_Noorlander] Gijs Noorlander mailto:gijs.noorlander&gmail.com 2018-11-28
[Greg_Cottman_3] Greg Cottman Quest Software mailto:Greg.Cottman&quest.com 2013-04-19
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[INFINIDAT] INFINIDAT mailto:info&infinidat.com 2015-05-01
[John_Levon] John Levon Oracle mailto:john.levon&oracle.com 2013-12-24
[John_McKernan] John McKernan mailto:John.McKernan&sun.com
[Jon_Green] Jon Green Aruba Networks mailto:jon.green&hpe.com 2018-10-04
[Karthik_Sundaresan] Karthik Sundaresan mailto:k.sundaresan&cablelabs.com 2015-11-24
[Kraig_Beahn_Jr] Kraig Beahn Jr. mailto:kraig&enguity.com 2017-06-28
[LAN-ACES_Inc] LAN-ACES mailto:rip&lan-aces.com 2017-02-08
[Liam_Merwick] Liam Merwick mailto:ldoms-iana-ports&sun.com 2009-01-16
[Marcel_Uhlir] Marcel Uhlir Nikatron mailto:marcel.uhlir&nikatron.cz 2023-09-07
[Marcin_Gozdalik] Marcin Gozdalik mailto:gozdal&gadu-gadu.pl 2006-05
[Matt_Rogers] Matt Rogers mailto:mrogers&firescope.com 2008-10-16
[MegaZone] MegaZone mailto:megazone&paycash.us 2005-08
[Microsoft_Corporation_6] Microsoft Corporation mailto:naengler&microsoft.com 2022-05-03
[Ming_Xu] Ming Xu mailto:ming&veritas.com
[Narkis_Engler] Narkis Engler Microsoft Corporation mailto:naengler&microsoft.com 2022-05-03
[Nikatron] Nikatron mailto:marcel.uhlir&nikatron.cz 2023-09-07
[Oracle_4] Oracle mailto:john.levon&oracle.com 2013-12-24
[Oracle_Corp] Oracle Corp mailto:bharathi.sivaramakrishnan&oracle.com
mailto:chris.newman&oracle.com
2017-02-10
[Portnoy_Boxman] Portnoy Boxman mailto:portnoy_boxman&bmc.com 2005-01
[Quest_Software_2] Quest Software mailto:Greg.Cottman&quest.com 2013-04-19
[Robert_Ripberger] Robert Ripberger mailto:rip&lan-aces.com 2017-02-08
[Robot_Framework_Foundation] Robot Framework Foundation mailto:robotframework-foundation&googlegroups.com 2017-01-26
[Ron_Passerini] Ron Passerini mailto:rpasserini&vmware.com 2010-04-27
[Roni_Moshitzky] Roni Moshitzky mailto:rmosh&checkpoint.com
[Ruwan_Linton] Ruwan Linton mailto:ruwan&wso2.com 2008-08-20
[Sky_Schulz] Sky Schulz mailto:sky&edgeofreality.com 2011-05-09
[Stephen_Casner] Stephen Casner mailto:casner&precpt.com
[Steve_Hay] Steve Hay mailto:SteveHay&planit.com 2008-06-13