Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
synapse-nhttp 8280 udp Synapse Non Blocking HTTP [Ruwan_Linton] [Ruwan_Linton] 2008-06-05
libelle 8282 tcp Libelle EnterpriseBus [Libelle_AG] [Hans-Joachim_Krueger] 2016-02-17
libelle-disc 8282 udp Libelle EnterpriseBus discovery [Libelle_AG] [Hans-Joachim_Krueger] 2016-02-17
8283-8291 Unassigned
hiperscan-id 8293 tcp Hiperscan Identification Service [Thomas_Klose] [Thomas_Klose] 2009-12-15
8295-8299 Unassigned
8302-8312 Unassigned
hub-open-net 8313 tcp Hub Open Network [Grexie] [Tim_Behrsin] 2012-06-13 Defined TXT keys: _hub._tcp.host.example.com
8314-8319 Unassigned
tnp-discover 8320 tcp Thin(ium) Network Protocol [Aly_Orady] [Aly_Orady] 2007-08-07
tnp-discover 8320 udp Thin(ium) Network Protocol [Aly_Orady] [Aly_Orady] 2007-08-07
garmin-marine 8322 tcp Garmin Marine [Garmin_International_Inc] [Nathan_Karstens] 2015-07-23
garmin-marine 8322 udp Garmin Marine [Garmin_International_Inc] [Nathan_Karstens] 2015-07-23
8323-8350 Unassigned
server-find 8351 tcp Server Find [Chris_Brown] [Chris_Brown]
server-find 8351 udp Server Find [Chris_Brown] [Chris_Brown]
8352-8375 Unassigned
cruise-enum 8376 tcp Cruise ENUM [Steve_Husak] [Steve_Husak]
cruise-enum 8376 udp Cruise ENUM [Steve_Husak] [Steve_Husak]
cruise-swroute 8377 tcp Cruise SWROUTE [Steve_Husak] [Steve_Husak]
cruise-swroute 8377 udp Cruise SWROUTE [Steve_Husak] [Steve_Husak]
cruise-config 8378 tcp Cruise CONFIG [Steve_Husak] [Steve_Husak]
cruise-config 8378 udp Cruise CONFIG [Steve_Husak] [Steve_Husak]
cruise-diags 8379 tcp Cruise DIAGS [Steve_Husak] [Steve_Husak]
cruise-diags 8379 udp Cruise DIAGS [Steve_Husak] [Steve_Husak]
cruise-update 8380 tcp Cruise UPDATE [Steve_Husak] [Steve_Husak]
cruise-update 8380 udp Cruise UPDATE [Steve_Husak] [Steve_Husak]
8381-8382 Unassigned
8385-8399 Unassigned
8406-8414 Unassigned
dlpx-sp 8415 tcp Delphix Session Protocol [Delphix_Corp] [Peng_Dai] 2012-11-01
espeech-rtp 8417 tcp eSpeech RTP Protocol [Scott_Tarone] [Scott_Tarone] 2003-04
espeech-rtp 8417 udp eSpeech RTP Protocol [Scott_Tarone] [Scott_Tarone] 2003-04
8418-8422 Unassigned
aritts 8423 tcp Aristech text-to-speech server [Aristech_GmbH] [Martin_Mende] 2017-03-30 2022-02-22
8424-8431 Unassigned
aws-as2 8433 udp Non Persistent Desktop and Application Streaming [Amazon.com_Services_LLC] [Ivan_O_Mahony] 2022-11-07
8434-8441 Unassigned
cybro-a-bus 8442 tcp CyBro A-bus Protocol [Damir_Skrjanec] [Damir_Skrjanec] 2007-05
cybro-a-bus 8442 udp CyBro A-bus Protocol [Damir_Skrjanec] [Damir_Skrjanec] 2007-05
pcsync-https 8443 tcp PCsync HTTPS
pcsync-https 8443 udp PCsync HTTPS
pcsync-http 8444 tcp PCsync HTTP [Katy_Lynn_McCullough] [Katy_Lynn_McCullough]
pcsync-http 8444 udp PCsync HTTP [Katy_Lynn_McCullough] [Katy_Lynn_McCullough]
copy-disc 8445 udp Port for copy discovery [Copy] [Jason_Dictos] 2012-09-19
8446-8447 Unassigned
matrix-fed 8448 tcp Matrix Federation Protocol [The_Matrix.org_Foundation_C.I.C.] [Travis_Ralston] 2023-08-04
8451-8456 Unassigned
8458-8469 Unassigned
cisco-avp 8470 tcp Cisco Address Validation Protocol [Cullen_Jennings] [Cullen_Jennings] 2009-02-13
pim-port 8471 tcp PIM over Reliable Transport [IESG] [IETF_Chair] 2008-08-21 [RFC 6559]
pim-port 8471 sctp PIM over Reliable Transport [IESG] [IETF_Chair] 2008-08-21 [RFC 6559]
8475-8499 Unassigned
cmtp-mgt 8501 tcp CYTEL Message Transfer Management
cmtp-av 8501 udp CYTEL Message Transfer Audio and Video [Frank_Jakel] [Frank_Jakel] 2011-04-29
lsp-self-ping 8503 udp MPLS LSP Self-Ping [IESG] [IETF_Chair] 2015-06-11 2016-02-01 [RFC 7746]
8504-8553 Unassigned
rtsp-alt 8554 tcp RTSP Alternate (see port 554) [Stephen_Casner_2] [Stephen_Casner_2]
rtsp-alt 8554 udp RTSP Alternate (see port 554) [Stephen_Casner_2] [Stephen_Casner_2]
d-fence 8555 tcp SYMAX D-FENCE [Thomas_Geisel] [Thomas_Geisel] 2003-01
d-fence 8555 udp SYMAX D-FENCE [Thomas_Geisel] [Thomas_Geisel] 2003-01
8556-8566 Unassigned
dof-tunnel 8567 tcp DOF Tunneling Protocol [OpenDOF] [Bryant_Eastham] 2005-08 2015-04-23
dof-tunnel 8567 udp DOF Tunneling Protocol [OpenDOF] [Bryant_Eastham] 2005-08 2015-04-23
8568-8599 Unassigned
8601-8608 Unassigned
canon-cpp-disc 8609 udp Canon Compact Printer Protocol Discovery [Canon_Inc] [Ryusuke_Okuhara] 2012-06-08 2012-06-15
canon-mfnp 8610 tcp Canon MFNP Service [Ritsuto_Sako] [Ritsuto_Sako] 2009-05-04
canon-mfnp 8610 udp Canon MFNP Service [Ritsuto_Sako] [Ritsuto_Sako] 2009-05-04
canon-bjnp1 8611 tcp Canon BJNP Port 1 [Atsushi_Nakamura] [Atsushi_Nakamura] 2003-11
canon-bjnp1 8611 udp Canon BJNP Port 1 [Atsushi_Nakamura] [Atsushi_Nakamura] 2003-11
canon-bjnp2 8612 tcp Canon BJNP Port 2 [Atsushi_Nakamura] [Atsushi_Nakamura] 2003-11
canon-bjnp2 8612 udp Canon BJNP Port 2 [Atsushi_Nakamura] [Atsushi_Nakamura] 2003-11
canon-bjnp3 8613 tcp Canon BJNP Port 3 [Atsushi_Nakamura] [Atsushi_Nakamura] 2003-11
canon-bjnp3 8613 udp Canon BJNP Port 3 [Atsushi_Nakamura] [Atsushi_Nakamura] 2003-11
canon-bjnp4 8614 tcp Canon BJNP Port 4 [Atsushi_Nakamura] [Atsushi_Nakamura] 2003-11
canon-bjnp4 8614 udp Canon BJNP Port 4 [Atsushi_Nakamura] [Atsushi_Nakamura] 2003-11
8616-8664 Unassigned Unauthorized Use Known on ports 8616 and 8617
monetra-admin 8666 tcp Monetra Administrative Access [Main_Street_Softworks] [Brad_House] 2013-04-02
8669-8674 Unassigned
msi-cps-rm 8675 tcp Motorola Solutions Customer Programming Software for Radio Management [Motorola_Solutions_Inc] [Jenish_Amin] 2012-03-14
msi-cps-rm-disc 8675 udp Motorola Solutions Customer Programming Software for Radio Management Discovery [Motorola_Solutions_Inc] [Jenish_Amin] 2012-03-14
8676-8685 Unassigned
sun-as-jmxrmi 8686 tcp Sun App Server - JMX/RMI [Abhijit_Kumar] [Abhijit_Kumar] 2005-11
sun-as-jmxrmi 8686 udp Sun App Server - JMX/RMI [Abhijit_Kumar] [Abhijit_Kumar] 2005-11
openremote-ctrl 8688 tcp OpenRemote Controller HTTP/REST [OpenRemote_Inc] [Juha_Lindfors] 2012-12-18
8689-8698 Unassigned
8699 udp Reserved 2004-11 2013-05-24 This entry is being removed on 2013-05-24.
8700-8709 Unassigned
semi-grpc 8710 tcp gRPC for SEMI Standards implementations [SEMI] [Albert_Fuchigami] 2020-01-10
8712-8731 Unassigned
dtp-net 8732 udp DASGIP Net Services [Dr_Matthias_Arnold] [Dr_Matthias_Arnold] 2009-03-23
8734-8749 Unassigned
dey-keyneg 8750 tcp DEY Storage Key Negotiation [DEY_Storage_Systems_Inc] [Garrett_D_Amore] 2013-03-01
8751-8762 Unassigned
mc-appserver 8763 tcp MC-APPSERVER [Romeo_Kasanwidjojo] [Romeo_Kasanwidjojo]
mc-appserver 8763 udp MC-APPSERVER [Romeo_Kasanwidjojo] [Romeo_Kasanwidjojo]
ultraseek-http 8765 tcp Ultraseek HTTP [Walter_Underwood] [Walter_Underwood]
ultraseek-http 8765 udp Ultraseek HTTP [Walter_Underwood] [Walter_Underwood]
core-of-source 8767 tcp Online mobile multiplayer game [Alt_Solve_Sdn_Bhd] [Almaz_Hong] 2019-07-24
8771-8777 Unassigned

Contact Information

ID Name Organization Contact URI Last Updated
[Abhijit_Kumar] Abhijit Kumar mailto:as-iana-ports&sun.com 2005-11
[Albert_Fuchigami] Albert Fuchigami mailto:albert.fuchigami&peergroup.com 2020-01-10
[Almaz_Hong] Almaz Hong mailto:almaz.hong&altsolve.com 2019-07-24
[Alt_Solve_Sdn_Bhd] Alt Solve Sdn Bhd mailto:support&altsolve.com 2019-07-24
[Aly_Orady] Aly Orady Atto Devices Inc. mailto:aly.orady&attodevices.com 2007-08-07
[Amazon.com_Services_LLC] Amazon.com Services LLC mailto:aws-iana&amazon.com 2022-11-07
[Aristech_GmbH] Aristech GmbH mailto:aritts&aristech.de 2022-02-22
[Atsushi_Nakamura] Atsushi Nakamura mailto:nakamura.atsushi318&canon.co.jp 2003-11
[Brad_House] Brad House Main Street Softworks Inc mailto:brad&mainstreetsoftworks.com 2013-04-02
[Bryant_Eastham] Bryant Eastham OenDOF mailto:protocol&opendof.org 2015-04-23
[Canon_Inc] Canon Inc. mailto:fujii.ken-ichi149&canon.co.jp 2011-10-10
[Chris_Brown] Chris Brown mailto:chrisb&chancery.com
[Copy] Copy mailto:team&copy.com 2012-09-19
[Cullen_Jennings] Cullen Jennings mailto:fluffy&cisco.com 2010-02-03
[Damir_Skrjanec] Damir Skrjanec mailto:damir.skrjanec&cybrotech.co.uk 2007-05
[Delphix_Corp] Delphix Corp mailto:peng.dai&delphix.com 2012-11-01
[DEY_Storage_Systems_Inc] DEY Storage Systems, Inc. mailto:garrett&dey-sys.com 2013-03-01
[Dr_Matthias_Arnold] Dr. Matthias Arnold mailto:m.arnold&dasgip.de 2009-03-23
[Frank_Jakel] Frank Jäkel mailto:Frank.Jaekel&cytel.de 2011-04-29
[Garmin_International_Inc] Garmin International, Inc." mailto:nettel&garmin.com 2015-07-23
[Garrett_D_Amore] Garrett D'Amore DEY Storage Systems, Inc. mailto:garrett&dey-sys.com 2013-03-01
[Grexie] Grexie mailto:webmaster&grexie.com 2012-06-15
[Hans-Joachim_Krueger] Hans Joachim Krueger mailto:hkrueger&libelle.com 2016-02-17
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Ivan_O_Mahony] Ivan O'Mahony Amazon.com Services LLC mailto:iomahony&amazon.com 2022-11-07
[Jason_Dictos] Jason Dictos mailto:jdictos&barracuda.com 2012-09-19
[Jenish_Amin] Jenish Amin Motorola Solutions, Inc. mailto:jenish&motorolasolutions.com 2012-03-14
[Juha_Lindfors] Juha Lindfors OpenRemote, Inc. mailto:juha&openremote.org 2012-12-18
[Katy_Lynn_McCullough] Katy Lynn McCullough mailto:KatyM&laplink.com
[Libelle_AG] Libelle AG mailto:hkrueger&libelle.com 2016-02-17
[Main_Street_Softworks] Main Street Softworks Inc mailto:info&mainstreetsoftworks.com 2013-04-02
[Martin_Mende] Martin Mende Aristech GmbH mailto:martin.mende&aristech.de 2022-02-22
[Motorola_Solutions_Inc] Motorola Solutions, Inc. mailto:jenish&motorolasolutions.com 2012-03-14
[Nathan_Karstens] Nathan Karstens Garmin International, Inc. mailto:nettel&garmin.com 2015-07-23
[OpenDOF] OpenDOF mailto:protocol&opendof.org 2015-04-23
[OpenRemote_Inc] OpenRemote, Inc. mailto:juha&openremote.org 2012-12-18
[Peng_Dai] Peng Dai Delphix Corp mailto:peng.dai&delphix.com 2012-11-01
[Ritsuto_Sako] Ritsuto Sako mailto:sakou.ritsuto&canon.co.jp 2009-05-04
[Romeo_Kasanwidjojo] Romeo Kasanwidjojo mailto:romeo&microcomgroup.com
[Ruwan_Linton] Ruwan Linton mailto:ruwan&wso2.com 2008-08-20
[Ryusuke_Okuhara] Ryusuke Okuhara Canon Inc. mailto:okuhara.ryuusuke&canon.co.jp 2012-06-08
[Scott_Tarone] Scott Tarone mailto:starone&proactivethought.com 2003-04
[SEMI] SEMI mailto:jamano&semi.org 2020-01-10
[Stephen_Casner_2] Stephen Casner mailto:casner&precept.com
[Steve_Husak] Steve Husak mailto:portmaster&cruisetech.com
[The_Matrix.org_Foundation_C.I.C.] The Matrix.org Foundation C.I.C. mailto:matrix&matrix.org 2023-08-04
[Thomas_Geisel] Thomas Geisel mailto:tgeisel&symax.de 2003-01
[Thomas_Klose] Thomas Klose mailto:thomas.klose&hiperscan.com 2009-12-15
[Tim_Behrsin] Tim Behrsin mailto:tim&behrsin.com 2012-06-15
[Travis_Ralston] Travis Ralston The Matrix.org Foundation C.I.C. mailto:travisr&matrix.org 2023-08-04
[Walter_Underwood] Walter Underwood mailto:wunder&infoseek.com