Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
8771-8777 Unassigned
8779-8785 Unassigned
8788-8792 Unassigned
acd-pm 8793 tcp Accedian Performance Measurement [Marco_Mascitto] [Marco_Mascitto]
acd-pm 8793 udp Accedian Performance Measurement [Marco_Mascitto] [Marco_Mascitto]
8794-8799 Unassigned
8801-8803 Unassigned Known UNAUTHORIZED USE: Port 8801
hes-clip 8807 udp HES-CLIP Interoperability protocol [Tim_Schoechle] [Ludo_Bertsch] 2018-09-07
ssports-bcast 8808 udp STATSports Broadcast Service [Statsports_International] [Catalin_Caranfil] 2016-12-22
3gpp-monp 8809 udp MCPTT Off-Network Protocol (MONP) [_3GPP] [Dongwook_Kim] 2019-04-15 2026-01-23 [3GPP TS 24.379 v13.5.0s]
8810-8872 Unassigned
8874-8879 Unassigned
cddbp-alt 8880 tcp CDDBP [Steve_Scherf] [Steve_Scherf]
cddbp-alt 8880 udp CDDBP [Steve_Scherf] [Steve_Scherf]
galaxy4d 8881 tcp Galaxy4D Online Game Engine [Galaxy4D] [Olivier_St-Laurent] 2012-06-18
secure-mqtt 8883 tcp Secure MQTT [OASIS] [Robin_Cover] 2008-02-27 2015-03-06
secure-mqtt 8883 udp Secure MQTT [OASIS] [Robin_Cover] 2008-02-27 2015-03-06
8884-8887 Unassigned
ddi-tcp-1 8888 tcp NewsEDGE server TCP (TCP 1) [Fred_Yao] [Fred_Yao] Known Unauthorized Use on port 8888
ddi-udp-1 8888 udp NewsEDGE server UDP (UDP 1) [Fred_Yao] [Fred_Yao] Known Unauthorized Use on port 8888
ddi-tcp-2 8889 tcp Desktop Data TCP 1 [Fred_Yao] [Fred_Yao] Known Unauthorized Use on port 8889
ddi-udp-2 8889 udp NewsEDGE server broadcast [Fred_Yao] [Fred_Yao] Known Unauthorized Use on port 8889
ddi-tcp-3 8890 tcp Desktop Data TCP 2 [Fred_Yao] [Fred_Yao] Known Unauthorized Use on port 8890
ddi-udp-3 8890 udp NewsEDGE client broadcast [Fred_Yao] [Fred_Yao] Known Unauthorized Use on port 8890
ddi-tcp-4 8891 tcp Desktop Data TCP 3: NESS application [Fred_Yao] [Fred_Yao]
ddi-udp-4 8891 udp Desktop Data UDP 3: NESS application [Fred_Yao] [Fred_Yao]
ddi-tcp-5 8892 tcp Desktop Data TCP 4: FARM product [Fred_Yao] [Fred_Yao]
ddi-udp-5 8892 udp Desktop Data UDP 4: FARM product [Fred_Yao] [Fred_Yao]
ddi-tcp-6 8893 tcp Desktop Data TCP 5: NewsEDGE/Web application [Fred_Yao] [Fred_Yao]
ddi-udp-6 8893 udp Desktop Data UDP 5: NewsEDGE/Web application [Fred_Yao] [Fred_Yao]
ddi-tcp-7 8894 tcp Desktop Data TCP 6: COAL application [Fred_Yao] [Fred_Yao]
ddi-udp-7 8894 udp Desktop Data UDP 6: COAL application [Fred_Yao] [Fred_Yao]
8895-8898 Unassigned
ospf-lite 8899 tcp ospf-lite [Matthew_Thomas] [Matthew_Thomas] 2008-01-07
ospf-lite 8899 udp ospf-lite [Matthew_Thomas] [Matthew_Thomas] 2008-01-07
jmb-cds1 8900 tcp JMB-CDS 1 [Curtis_Bray] [Curtis_Bray]
jmb-cds1 8900 udp JMB-CDS 1 [Curtis_Bray] [Curtis_Bray]
jmb-cds2 8901 tcp JMB-CDS 2 [Curtis_Bray] [Curtis_Bray]
jmb-cds2 8901 udp JMB-CDS 2 [Curtis_Bray] [Curtis_Bray]
8902-8907 Unassigned
dpp 8908 tcp WFA Device Provisioning Protocol [Wi-Fi_Alliance_4] [Dr_Jun_Tian] 2020-10-19
manyone-http 8910 tcp manyone-http [Matt_King] [Matt_King] 2002-04
manyone-http 8910 udp manyone-http [Matt_King] [Matt_King] 2002-04
manyone-xml 8911 tcp manyone-xml [Matt_King] [Matt_King] 2002-04
manyone-xml 8911 udp manyone-xml [Matt_King] [Matt_King] 2002-04
8914-8936 Unassigned
8938-8952 Unassigned
ub-dns-control 8953 tcp unbound dns nameserver control [NLnet_Labs_Support] [NLnet_Labs_Support] 2011-05-10 2011-07-11
cumulus-admin 8954 tcp Cumulus Admin Port [Thomas_Schleu] [Thomas_Schleu]
cumulus-admin 8954 udp Cumulus Admin Port [Thomas_Schleu] [Thomas_Schleu]
8955-8979 Unassigned
nod-provider 8980 tcp Network of Devices Provider [David_Muller] [David_Muller] 2015-02-22
nod-provider 8980 udp Network of Devices Provider [David_Muller] [David_Muller] 2015-02-22
nod-client 8981 udp Network of Devices Client [David_Muller] [David_Muller] 2015-02-22
8982-8988 Unassigned
http-wmap 8990 tcp webmail HTTP service [Chris_Newman] [Chris_Newman] 2007-12-03
http-wmap 8990 udp webmail HTTP service [Chris_Newman] [Chris_Newman] 2007-12-03
https-wmap 8991 tcp webmail HTTPS service [Chris_Newman] [Chris_Newman] 2007-12-03
https-wmap 8991 udp webmail HTTPS service [Chris_Newman] [Chris_Newman] 2007-12-03
8992-8996 Unassigned
oracle-ms-ens 8997 tcp Oracle Messaging Server Event Notification Service [Oracle_6] [Hubert_Vijay_Arokiasamy] 2014-10-28
canto-roboflow 8998 tcp Canto RoboFlow Control [Canto] [Thomas_Schleu_2] 2014-02-26
9003-9004 Unassigned
golem 9005 tcp Golem Inter-System RPC [Jose_Luis_Tallon] [Jose_Luis_Tallon] 2015-03-09
9006 De-Commissioned Port 2000-02-24
ogs-client 9007 udp Open Grid Services Client [Gareth_Nelson_2] [Gareth_Nelson_2] 2008-08-22
ogs-server 9008 tcp Open Grid Services Server [Gareth_Nelson_2] [Gareth_Nelson_2] 2008-08-22
d-star 9011 udp D-Star Routing digital voice+data for amateur radio [QuadNet2_USA_IRC_Network] [Thomas_A_Early] 2018-03-16
9012-9019 Unassigned
panagolin-ident 9021 tcp Pangolin Identification [William_Benner] [William_Benner] 2002-03
panagolin-ident 9021 udp Pangolin Identification [William_Benner] [William_Benner] 2002-03
swa-1 9023 tcp Secure Web Access - 1 [Tim_McGranaghan] [Tim_McGranaghan]
swa-1 9023 udp Secure Web Access - 1 [Tim_McGranaghan] [Tim_McGranaghan]
swa-2 9024 tcp Secure Web Access - 2 [Tim_McGranaghan] [Tim_McGranaghan]
swa-2 9024 udp Secure Web Access - 2 [Tim_McGranaghan] [Tim_McGranaghan]
swa-3 9025 tcp Secure Web Access - 3 [Tim_McGranaghan] [Tim_McGranaghan]
swa-3 9025 udp Secure Web Access - 3 [Tim_McGranaghan] [Tim_McGranaghan]
swa-4 9026 tcp Secure Web Access - 4 [Tim_McGranaghan] [Tim_McGranaghan]
swa-4 9026 udp Secure Web Access - 4 [Tim_McGranaghan] [Tim_McGranaghan]
9027-9049 Unassigned
fio-cmgmt 9051 tcp Fusion-io Central Manager Service [Jim_Sermersheim] [Jim_Sermersheim] 2010-01-15
9052-9059 Unassigned
CardWeb-IO 9060 tcp CardWeb request-response I/O exchange [CardWare_Inc] [David_Wyatt] 2016-10-07 2025-07-17
CardWeb-RT 9060 udp CardWeb realtime device data [CardWare_Inc] [David_Wyatt] 2016-10-07 2025-07-17
9061-9079 Unassigned
cisco-aqos 9081 udp Required for Adaptive Quality of Service [Manish_Surolia] [Manish_Surolia] 2017-10-27
lcs-ap 9082 sctp LCS Application Protocol [Kimmo_Kymalainen] [Kimmo_Kymalainen] 2010-06-04
emc-pp-mgmtsvc 9083 tcp EMC PowerPath Mgmt Service [Jim_Perreault] [Jim_Perreault] 2010-06-04
ibm-rsyscon 9085 tcp IBM Remote System Console [William_LePera] [William_LePera] 2008-06-18
ibm-rsyscon 9085 udp IBM Remote System Console [William_LePera] [William_LePera] 2008-06-18
sqlexec-ssl 9089 tcp IBM Informix SQL Interface - Encrypted [Jonathan_Leffler] [Jonathan_Leffler] 2005-12
sqlexec-ssl 9089 udp IBM Informix SQL Interface - Encrypted [Jonathan_Leffler] [Jonathan_Leffler] 2005-12
xmltec-xmlmail 9091 tcp xmltec-xmlmail [Mitch_Kaufman] [Mitch_Kaufman]
xmltec-xmlmail 9091 udp xmltec-xmlmail [Mitch_Kaufman] [Mitch_Kaufman]
XmlIpcRegSvc 9092 tcp Xml-Ipc Server Reg [Casey_Harrington] [Casey_Harrington] 2006-01
XmlIpcRegSvc 9092 udp Xml-Ipc Server Reg [Casey_Harrington] [Casey_Harrington] 2006-01
9094-9099 Unassigned
hp-pdl-datastr 9100 tcp PDL Data Streaming Port [Shivaun_Albright] [Shivaun_Albright] 2002-04
hp-pdl-datastr 9100 udp PDL Data Streaming Port [Shivaun_Albright] [Shivaun_Albright] 2002-04
pdl-datastream 9100 tcp Printer PDL Data Stream [Stuart_Cheshire_4] [Stuart_Cheshire_4] 2002-09 The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100.
pdl-datastream 9100 udp Printer PDL Data Stream [Stuart_Cheshire_4] [Stuart_Cheshire_4] 2002-09 The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100.

Contact Information

ID Name Organization Contact URI Last Updated
[_3GPP] 3GPP mailto:dongwook.kim&etsi.org 2026-01-23
[Canto] Canto mailto:tschleu&canto.com 2014-02-26
[CardWare_Inc] CardWare, Inc mailto:dwyatt&cardware.com 2025-07-17
[Casey_Harrington] Casey Harrington mailto:charrington&isxinc.com 2006-01
[Catalin_Caranfil] Catalin Caranfil mailto:c.caranfil&statsports.com 2016-12-22
[Chris_Newman] Chris Newman mailto:chris.newman&oracle.com 2017-01-26
[Curtis_Bray] Curtis Bray mailto:CurtisB&creativedesign.com
[David_Muller] David Müller mailto:david.muller.cz&gmail.com 2015-02-22
[David_Wyatt] David Wyatt mailto:dwyatt&cardware.com 2025-07-17
[Dongwook_Kim] Dongwook Kim 3GPP mailto:dongwook.kim&etsi.org 2026-01-23
[Dr_Jun_Tian] Dr. Jun Tian mailto:jtian&wi-fi.org 2020-10-19
[Fred_Yao] Fred Yao mailto:Fred_Yao&ddigate2.desktopdata.com
[Galaxy4D] Galaxy4D Online Game Engine mailto:admin&galaxy4d.com 2012-06-18
[Gareth_Nelson_2] Gareth Nelson mailto:gareth&litesim.com 2008-08-22
[Hubert_Vijay_Arokiasamy] Hubert Vijay Arokiasamy Oracle Corp. mailto:hubert.vijay.arokiasamy&oracle.com 2014-10-28
[Jim_Perreault] Jim Perreault mailto:jim.perreault&emc.com 2010-06-04
[Jim_Sermersheim] Jim Sermersheim mailto:jims&fusionio.com 2010-01-15
[Jonathan_Leffler] Jonathan Leffler mailto:jleffler&us.ibm.com 2005-12
[Jose_Luis_Tallon] Jose Luis Tallon mailto:joseluis&talloncorp.com 2015-03-09
[Kimmo_Kymalainen] Kimmo Kymalainen mailto:kimmo.kymalainen&etsi.org 2017-05-08
[Ludo_Bertsch] Ludo Bertsch Horizon Technologies Inc. mailto:iana&horizontec.com 2018-09-07
[Manish_Surolia] Manish Surolia mailto:masurolia@cisco.com> 2017-10-27
[Marco_Mascitto] Marco Mascitto mailto:mmascitto&accedian.com 2011-06-28
[Matt_King] Matt King mailto:m&manyone.net 2002-04
[Matthew_Thomas] Matthew Thomas mailto:mrthom&essex.ac.uk 2008-01-07
[Mitch_Kaufman] Mitch Kaufman mailto:mk&weconnectyou.com
[NLnet_Labs_Support] NLnet Labs Support NLnet Labs mailto:support&nlnetlabs.nl 2011-07-11
[OASIS] OASIS mailto:robin&oasis-open.org 2015-02-10
[Olivier_St-Laurent] Olivier St-Laurent Galaxy4D Online Game Engine mailto:admin&galaxy4d.com 2012-06-18
[Oracle_6] Oracle Corp. mailto:hubert.vijay.arokiasamy&oracle.com 2014-10-28
[QuadNet2_USA_IRC_Network] QuadNet2 USA IRC Network mailto:admins&openquad.net 2018-03-16
[Robin_Cover] Robin Cover OASIS KMIP Technical Committee mailto:robin&oasis-open.org 2011-07-25
[Shivaun_Albright] Shivaun Albright mailto:shivaun_albright&hp.com 2002-04
[Statsports_International] Statsports_International mailto:iana_liaison&statsports.com 2016-12-22
[Steve_Scherf] Steve Scherf mailto:steve&moonsoft.com
[Stuart_Cheshire_4] Stuart Cheshire mailto:pdl-datastream&apple.com 2002-09
[Thomas_A_Early] Thomas A Early mailto:tom.n7tae&tearly.net 2018-03-16
[Thomas_Schleu] Thomas Schleu mailto:tschleu&canto.de
[Thomas_Schleu_2] Thomas Schleu Canto mailto:tschleu&canto.com 2014-02-26
[Tim_McGranaghan] Tim McGranaghan mailto:tim_mcgranaghan&mech.disa.mil
[Tim_Schoechle] Tim Schoechle ISO/IEC JTC1 SC25/WG1 mailto:timothy&schoechle.org 2018-09-07
[Wi-Fi_Alliance_4] Wi-Fi Alliance mailto:technical&wi-fi.org 2020-10-19
[William_Benner] William Benner mailto:wrb2&pangolin.com 2025-03-27
[William_LePera] William LePera mailto:lepera&us.ibm.com 2008-06-18