Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
pdl-datastream 9100 udp Printer PDL Data Stream [Stuart_Cheshire_4] [Stuart_Cheshire_4] 2002-09 The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100.
bacula-dir 9101 tcp Bacula Director [Kern_Sibbald] [Kern_Sibbald] 2002-01
bacula-dir 9101 udp Bacula Director [Kern_Sibbald] [Kern_Sibbald] 2002-01
bacula-fd 9102 tcp Bacula File Daemon [Kern_Sibbald] [Kern_Sibbald] 2002-01
bacula-fd 9102 udp Bacula File Daemon [Kern_Sibbald] [Kern_Sibbald] 2002-01
bacula-sd 9103 tcp Bacula Storage Daemon [Kern_Sibbald] [Kern_Sibbald] 2002-01
bacula-sd 9103 udp Bacula Storage Daemon [Kern_Sibbald] [Kern_Sibbald] 2002-01
xadmin 9105 tcp Xadmin Control Service [Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009]
xadmin 9105 udp Xadmin Control Service [Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009]
astergate-disc 9106 udp Astergate Discovery Service [Ari_Huisken] [Ari_Huisken] 2010-01-04
9108-9110 Unassigned
9112-9118 Unassigned
9120-9121 Unassigned
9124-9130 Unassigned
9132-9159 Unassigned
9165-9182 Unassigned
sirius-agent 9183 tcp Sirius Configuration Agent [Sirius_Computer_Inc] [Jason_Van_der_Schyff] 2026-03-09
sirius-agent 9183 udp Sirius Configuration Agent [Sirius_Computer_Inc] [Jason_Van_der_Schyff] 2026-03-09
9184-9190 Unassigned
sun-as-jpda 9191 tcp Sun AppSvr JPDA [Abhijit_Kumar] [Abhijit_Kumar] 2005-11
sun-as-jpda 9191 udp Sun AppSvr JPDA [Abhijit_Kumar] [Abhijit_Kumar] 2005-11
9192-9199 Unassigned
wap-wsp 9200 tcp WAP connectionless session service [WAP_Forum] [WAP_Forum]
wap-wsp 9200 udp WAP connectionless session service [WAP_Forum] [WAP_Forum]
wap-wsp-wtp 9201 tcp WAP session service [WAP_Forum] [WAP_Forum]
wap-wsp-wtp 9201 udp WAP session service [WAP_Forum] [WAP_Forum]
wap-wsp-s 9202 tcp WAP secure connectionless session service [WAP_Forum] [WAP_Forum]
wap-wsp-s 9202 udp WAP secure connectionless session service [WAP_Forum] [WAP_Forum]
wap-wsp-wtp-s 9203 tcp WAP secure session service [WAP_Forum] [WAP_Forum]
wap-wsp-wtp-s 9203 udp WAP secure session service [WAP_Forum] [WAP_Forum]
wap-vcard 9204 tcp WAP vCard [WAP_Forum] [WAP_Forum]
wap-vcard 9204 udp WAP vCard [WAP_Forum] [WAP_Forum]
wap-vcal 9205 tcp WAP vCal [WAP_Forum] [WAP_Forum]
wap-vcal 9205 udp WAP vCal [WAP_Forum] [WAP_Forum]
wap-vcard-s 9206 tcp WAP vCard Secure [WAP_Forum] [WAP_Forum]
wap-vcard-s 9206 udp WAP vCard Secure [WAP_Forum] [WAP_Forum]
wap-vcal-s 9207 tcp WAP vCal Secure [WAP_Forum] [WAP_Forum]
wap-vcal-s 9207 udp WAP vCal Secure [WAP_Forum] [WAP_Forum]
rjcdb-vcards 9208 tcp rjcdb vCard [Robert_John_Churchil] [Robert_John_Churchil] 2006-01
rjcdb-vcards 9208 udp rjcdb vCard [Robert_John_Churchil] [Robert_John_Churchil] 2006-01
almobile-system 9209 tcp ALMobile System Service [Rob_Graber] [Rob_Graber] 2006-01
almobile-system 9209 udp ALMobile System Service [Rob_Graber] [Rob_Graber] 2006-01
oma-mlp 9210 tcp OMA Mobile Location Protocol [Hans_Rohnert] [Hans_Rohnert] 2002-04
oma-mlp 9210 udp OMA Mobile Location Protocol [Hans_Rohnert] [Hans_Rohnert] 2002-04
oma-mlp-s 9211 tcp OMA Mobile Location Protocol Secure [Hans_Rohnert] [Hans_Rohnert] 2002-04
oma-mlp-s 9211 udp OMA Mobile Location Protocol Secure [Hans_Rohnert] [Hans_Rohnert] 2002-04
fsc-port 9217 tcp FSC Communication Port [Teijo_Mustonen] [Teijo_Mustonen] 2002-03
fsc-port 9217 udp FSC Communication Port [Teijo_Mustonen] [Teijo_Mustonen] 2002-03
9218-9221 Unassigned
9223-9254 Unassigned
9256-9276 Unassigned
pegasus-ctl 9279 tcp Pegaus GPS System Control Interface [Nestor_A_Diaz] [Nestor_A_Diaz] 2009-05-12
pegasus-ctl 9279 udp Pegaus GPS System Control Interface [Nestor_A_Diaz] [Nestor_A_Diaz] 2009-05-12
swtp-port1 9281 tcp SofaWare transport port 1 [Amir_Rapson] [Amir_Rapson] 2002-02
swtp-port1 9281 udp SofaWare transport port 1 [Amir_Rapson] [Amir_Rapson] 2002-02
swtp-port2 9282 tcp SofaWare transport port 2 [Amir_Rapson] [Amir_Rapson] 2002-02
swtp-port2 9282 udp SofaWare transport port 2 [Amir_Rapson] [Amir_Rapson] 2002-02
9288-9291 Unassigned
9296-9299 Unassigned
9301-9305 Unassigned
9307-9309 Unassigned
9313-9317 Unassigned
secure-ts 9318 tcp PKIX TimeStamp over TLS [Niklas_Weiss] [Niklas_Weiss] 2004-11
secure-ts 9318 udp PKIX TimeStamp over TLS [Niklas_Weiss] [Niklas_Weiss] 2004-11
9319-9320 Unassigned
9322-9338 Unassigned
gnmi-gnoi 9339 tcp gRPC Network Mgmt/Operations Interface [Google_Netops] [gNxi_Maintainers] 2019-05-09
9341-9342 Unassigned
9347-9373 Unassigned
9375-9379 Unassigned
9381-9386 Unassigned
9391-9395 Unassigned
9398-9399 Unassigned
sec-t4net-srv 9400 tcp Samsung Twain for Network Server [Dongkeun_Kim] [Dongkeun_Kim] 2007-02
sec-t4net-srv 9400 udp Samsung Twain for Network Server [Dongkeun_Kim] [Dongkeun_Kim] 2007-02
sec-t4net-clt 9401 tcp Samsung Twain for Network Client [Dongkeun_Kim] [Dongkeun_Kim] 2007-02
sec-t4net-clt 9401 udp Samsung Twain for Network Client [Dongkeun_Kim] [Dongkeun_Kim] 2007-02
sec-pc2fax-srv 9402 tcp Samsung PC2FAX for Network Server [HyeongBae_Yu] [HyeongBae_Yu] 2008-07-31
sec-pc2fax-srv 9402 udp Samsung PC2FAX for Network Server [HyeongBae_Yu] [HyeongBae_Yu] 2008-07-31
9403-9417 Unassigned
9419-9442 Unassigned
tungsten-https 9443 tcp WSO2 Tungsten HTTPS [Afkham_Azeez] [Afkham_Azeez] 2006-06
tungsten-https 9443 udp WSO2 Tungsten HTTPS [Afkham_Azeez] [Afkham_Azeez] 2006-06
wso2esb-console 9444 tcp WSO2 ESB Administration Console HTTPS [Ruwan_Linton] [Ruwan_Linton] 2008-08-20
wso2esb-console 9444 udp WSO2 ESB Administration Console HTTPS [Ruwan_Linton] [Ruwan_Linton] 2008-08-20
mindarray-ca 9445 tcp MindArray Systems Console Agent [MINDARRAY_SYSTEMS] [ALPESH_DHAMELIA] 2011-10-25
9446-9449 Unassigned
9451-9499 Unassigned
9501-9521 Unassigned
sma-spw 9522 udp SMA Speedwire [SMA_Solar_Techology] [SMA_Solar_Techology] 2011-03-08
9523-9534 Unassigned
laes-bf 9536 tcp Surveillance buffering function [Glen_Myers] [Glen_Myers] 2007-05
laes-bf 9536 udp Surveillance buffering function [Glen_Myers] [Glen_Myers] 2007-05
9537-9554 Unassigned
trispen-sra 9555 tcp Trispen Secure Remote Access [Jaco_Botha] [Jaco_Botha] 2004-11
trispen-sra 9555 udp Trispen Secure Remote Access [Jaco_Botha] [Jaco_Botha] 2004-11
9556-9558 Unassigned
9560-9591 Unassigned
mercury-disc 9596 tcp Mercury Discovery [Paul_Mclachlan] [Paul_Mclachlan] 2005-11
mercury-disc 9596 udp Mercury Discovery [Paul_Mclachlan] [Paul_Mclachlan] 2005-11
pd-admin 9597 tcp PD Administration [Duk_Loi] [Duk_Loi] 2005-11

Contact Information

ID Name Organization Contact URI Last Updated
[Abhijit_Kumar] Abhijit Kumar mailto:as-iana-ports&sun.com 2005-11
[Afkham_Azeez] Afkham Azeez mailto:azeez&wso2.com 2006-06
[ALPESH_DHAMELIA] ALPESH DHAMELIA MINDARRAY SYSTEMS (P) LTD. mailto:alpesh&mindarraysystems.com 2011-10-25
[Amir_Rapson] Amir Rapson mailto:rapson&sofaware.com 2002-02
[Ari_Huisken] Ariën Huisken mailto:astergate&huisken-systems.nl 2010-01-04
[Dongkeun_Kim] Dongkeun Kim mailto:dongkeun70.kim&samsung.com 2007-02
[Duk_Loi] Duk Loi mailto:dloi&peerdirect.com 2005-11
[Glen_Myers] Glen Myers mailto:glen.myers&ipfabrics.com 2007-05
[gNxi_Maintainers] gNxi Maintainers mailto:gnxi-maintainers&google.com 2019-05-09
[Google_Netops] Google Netops mailto:gnxi-maintainers&google.com 2019-05-09
[Hans_Rohnert] Hans Rohnert mailto:hans.rohnert&siemens.com 2002-04
[HyeongBae_Yu] HyeongBae Yu mailto:hyeongbae.yu&samsung.com 2008-07-31
[Jaco_Botha] Jaco Botha mailto:jaco.botha&trispen.com 2004-11
[Jason_Van_der_Schyff] Jason Van der Schyff mailto:jason&sirius.computer 2026-03-09
[Kern_Sibbald] Kern Sibbald mailto:kern&sibbald.com 2002-01
[MINDARRAY_SYSTEMS] MINDARRAY SYSTEMS (P) LTD. mailto:info&mindarraysystems.com 2011-10-25
[Nestor_A_Diaz] Nestor A. Diaz mailto:nestor&tiendalinux.com 2009-05-12
[Niklas_Weiss] Niklas Weiss mailto:n.weiss&d-trust.net 2004-11
[Paul_Mclachlan] Paul Mclachlan mailto:pmclachlan&mercury.com 2005-11
[Rob_Graber] Rob Graber mailto:r.graber&austinlane.com 2006-01
[Robert_John_Churchil] Robert John Churchill mailto:rjc&rjcdb.com 2006-01
[Ruwan_Linton] Ruwan Linton mailto:ruwan&wso2.com 2008-08-20
[SMA_Solar_Techology] SMA Solar Techology AG mailto:thomas.weber&sma.de 2011-03-08
[Sirius_Computer_Inc] Sirius Computer, Inc mailto:jason&sirius.computer 2026-03-09
[Stuart_Cheshire_4] Stuart Cheshire mailto:pdl-datastream&apple.com 2002-09
[Teijo_Mustonen] Teijo Mustonen mailto:Teijo.Mustonen&f-secure.com 2002-03
[WAP_Forum] WAP Forum mailto:wap-feedback&mail.wapforum.org
mailto:pg&uplanet.com