Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
pd-admin 9597 tcp PD Administration [Duk_Loi] [Duk_Loi] 2005-11
pd-admin 9597 udp PD Administration [Duk_Loi] [Duk_Loi] 2005-11
micromuse-ncpw 9600 tcp MICROMUSE-NCPW [Hing_Wing_To_2] [Hing_Wing_To_2]
micromuse-ncpw 9600 udp MICROMUSE-NCPW [Hing_Wing_To_2] [Hing_Wing_To_2]
9601-9611 Unassigned
streamcomm-ds 9612 tcp StreamComm User Directory [Brian_C_Wiles] [Brian_C_Wiles]
streamcomm-ds 9612 udp StreamComm User Directory [Brian_C_Wiles] [Brian_C_Wiles]
iadt-tls 9614 tcp iADT Protocol over TLS [Paul_A_Suhler] [Paul_A_Suhler] 2009-02-05
erunbook-agent 9616 tcp eRunbook Agent

IANA assigned this well-formed service name as a replacement for "erunbook_agent".
[Gerhard_Wagner] [Gerhard_Wagner] 2009-03-10
erunbook_agent 9616 tcp eRunbook Agent [Gerhard_Wagner] [Gerhard_Wagner] 2009-03-10 This entry is an alias to "erunbook-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
erunbook-server 9617 tcp eRunbook Server

IANA assigned this well-formed service name as a replacement for "erunbook_server".
[Gerhard_Wagner] [Gerhard_Wagner] 2009-03-10
erunbook_server 9617 tcp eRunbook Server [Gerhard_Wagner] [Gerhard_Wagner] 2009-03-10 This entry is an alias to "erunbook-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
9619-9627 Unassigned
mc-comm 9632 udp Mobile-C Communications [David_Ko_2] [David_Ko_2] 2009-09-14
9633-9639 Unassigned
9641-9665 Unassigned
xmms2 9667 tcp Cross-platform Music Multiplexing System [Juho_Herttua] [Juho_Herttua] 2009-04-14
xmms2 9667 udp Cross-platform Music Multiplexing System [Juho_Herttua] [Juho_Herttua]
tec5-sdctp 9668 tcp tec5 Spectral Device Control Protocol [Michael_Muth] [Michael_Muth] 2009-05-11
tec5-sdctp 9668 udp tec5 Spectral Device Control Protocol [Michael_Muth] [Michael_Muth] 2009-05-11
9669-9693 Unassigned
client-wakeup 9694 tcp T-Mobile Client Wakeup Message [Michael_Schonborn] [Michael_Schonborn] 2009-09-11
client-wakeup 9694 udp T-Mobile Client Wakeup Message [Michael_Schonborn] [Michael_Schonborn] 2009-09-11
9696-9699 Unassigned
board-roar 9700 tcp Board M.I.T. Service [Francesco_Rosi] [Francesco_Rosi] 2006-01
board-roar 9700 udp Board M.I.T. Service [Francesco_Rosi] [Francesco_Rosi] 2006-01
9701-9746 Unassigned
l5nas-parchan 9747 tcp L5NAS Parallel Channel [Lawrence_J_Dickson] [Lawrence_J_Dickson] 2002-03
l5nas-parchan 9747 udp L5NAS Parallel Channel [Lawrence_J_Dickson] [Lawrence_J_Dickson] 2002-03
9748-9749 Unassigned
board-voip 9750 tcp Board M.I.T. Synchronous Collaboration [Francesco_Rosi] [Francesco_Rosi] 2006-01
board-voip 9750 udp Board M.I.T. Synchronous Collaboration [Francesco_Rosi] [Francesco_Rosi] 2006-01
9751-9752 Unassigned
9754-9761 Unassigned
tungsten-http 9762 tcp WSO2 Tungsten HTTP [Afkham_Azeez] [Afkham_Azeez] 2006-06
tungsten-http 9762 udp WSO2 Tungsten HTTP [Afkham_Azeez] [Afkham_Azeez] 2006-06
9763-9799 Unassigned
sstp-2 9801 tcp Sakura Script Transfer Protocol-2 [Kouichi_Takeda_2] [Kouichi_Takeda_2]
sstp-2 9801 udp Sakura Script Transfer Protocol-2 [Kouichi_Takeda_2] [Kouichi_Takeda_2]
9803-9874 Unassigned
x510 9877 tcp The X.510 wrapper protocol [ITU_TSB_ITU-T_Study_Group_17] [Erik_Andersen] 2019-09-30 [ITU-T X.510 / ISO/IEC 9584-11]
kca-service 9878 udp The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 [IESG] [IETF_Chair] 2012-07-12 [RFC 6717] Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements.
9879-9887 Unassigned
cyborg-systems 9888 tcp CYBORG Systems [Malcolm_Graham] [Malcolm_Graham]
cyborg-systems 9888 udp CYBORG Systems [Malcolm_Graham] [Malcolm_Graham]
gt-proxy 9889 tcp Port for Cable network related data proxy or repeater [Dawei_Qi] [Dawei_Qi] 2010-07-07
gt-proxy 9889 udp Port for Cable network related data proxy or repeater [Dawei_Qi] [Dawei_Qi] 2010-07-07
9890-9897 Unassigned
sctp-tunneling 9899 udp SCTP TUNNELING [IESG] [IETF_Chair] 2013-04-10 [RFC 6951]
enrp-sctp 9901 sctp enrp server channel [RFC 5353]
enrp-sctp-tls 9902 sctp enrp/tls server channel [RFC 5353]
multicast-ping 9903 udp Multicast Ping Protocol 2011-12-09 [RFC 6450]
9904-9908 Unassigned
sype-transport 9911 tcp SYPECom Transport Protocol [Sylvain_Pedneault] [Sylvain_Pedneault] 2003-03
sype-transport 9911 udp SYPECom Transport Protocol [Sylvain_Pedneault] [Sylvain_Pedneault] 2003-03
9912-9924 Unassigned
xybrid-cloud 9925 tcp XYBRID Cloud [Rx_Networks_Inc_2] [Drew_Davies_2] 2013-04-25
9926-9949 Unassigned
apc-9950 9950 tcp APC 9950 [American_Power_Conve] [American_Power_Conve]
apc-9950 9950 udp APC 9950 [American_Power_Conve] [American_Power_Conve]
apc-9951 9951 tcp APC 9951 [American_Power_Conve] [American_Power_Conve]
apc-9951 9951 udp APC 9951 [American_Power_Conve] [American_Power_Conve]
apc-9952 9952 tcp APC 9952 [American_Power_Conve] [American_Power_Conve]
apc-9952 9952 udp APC 9952 [American_Power_Conve] [American_Power_Conve]
alljoyn-stm 9955 tcp Contact Port for AllJoyn standard messaging [Qualcomm_Innovation_Center] [Craig_Dowell] 2012-03-14
alljoyn-mcm 9955 udp Contact Port for AllJoyn multiplexed constrained messaging [Qualcomm_Innovation_Center] [Craig_Dowell] 2012-03-14
9957-9965 Unassigned
9967-9977 Unassigned
xybrid-rt 9978 tcp XYBRID RT Server [Rx_Networks_Inc] [Drew_Davies] 2013-01-24
pumpkindb 9981 tcp Event sourcing database engine with a built-in programming language [Eventsourcing_Inc] [Yurii_Rashkovskii] 2017-04-18
9982-9985 Unassigned
kaostransport 9986 tcp KAOS secure message transport protocol for safety-critical environments [KAOS_Management_Group_LLC] [Philip_Duvalsaint] 2025-10-30
dsm-scm-target 9987 tcp DSM/SCM Target Interface [Mike_Dyslin] [Mike_Dyslin] 2006-08
dsm-scm-target 9987 udp DSM/SCM Target Interface [Mike_Dyslin] [Mike_Dyslin] 2006-08
9989-9989 Unassigned
osm-appsrvr 9990 tcp OSM Applet Server [Vinay_Gupta] [Vinay_Gupta] 2003-08
osm-appsrvr 9990 udp OSM Applet Server [Vinay_Gupta] [Vinay_Gupta] 2003-08
osm-oev 9991 tcp OSM Event Server [Vinay_Gupta] [Vinay_Gupta] 2003-08
osm-oev 9991 udp OSM Event Server [Vinay_Gupta] [Vinay_Gupta] 2003-08
palace-1 9992 tcp OnLive-1 [Douglas_Crockford] [Douglas_Crockford]
palace-1 9992 udp OnLive-1 [Douglas_Crockford] [Douglas_Crockford]
palace-2 9993 tcp OnLive-2 [Douglas_Crockford] [Douglas_Crockford]
palace-2 9993 udp OnLive-2 [Douglas_Crockford] [Douglas_Crockford]
palace-3 9994 tcp OnLive-3 [Douglas_Crockford] [Douglas_Crockford]
palace-3 9994 udp OnLive-3 [Douglas_Crockford] [Douglas_Crockford]
palace-4 9995 tcp Palace-4 [Douglas_Crockford] [Douglas_Crockford]
palace-4 9995 udp Palace-4 [Douglas_Crockford] [Douglas_Crockford]
palace-5 9996 tcp Palace-5 [Douglas_Crockford] [Douglas_Crockford]
palace-5 9996 udp Palace-5 [Douglas_Crockford] [Douglas_Crockford]
palace-6 9997 tcp Palace-6 [Douglas_Crockford] [Douglas_Crockford]
palace-6 9997 udp Palace-6 [Douglas_Crockford] [Douglas_Crockford]
scp-config 10001 tcp SCP Configuration [Michael_Benz] [Michael_Benz] 2010-08-06
scp-config 10001 udp SCP Configuration [Michael_Benz] [Michael_Benz] 2010-08-06
documentum 10002 tcp EMC-Documentum Content Server Product [Reza_Bagherian] [Reza_Bagherian] 2007-07-19
documentum 10002 udp EMC-Documentum Content Server Product [Reza_Bagherian] [Reza_Bagherian] 2007-07-19
documentum-s 10003 tcp EMC-Documentum Content Server Product

IANA assigned this well-formed service name as a replacement for "documentum_s".
[Reza_Bagherian] [Reza_Bagherian] 2007-07-19
documentum_s 10003 tcp EMC-Documentum Content Server Product [Reza_Bagherian] [Reza_Bagherian] 2007-07-19 This entry is an alias to "documentum-s". This entry is now historic, not usable for use with many common service discovery mechanisms.
documentum-s 10003 udp EMC-Documentum Content Server Product

IANA assigned this well-formed service name as a replacement for "documentum_s".
[Reza_Bagherian] [Reza_Bagherian] 2007-07-19
documentum_s 10003 udp EMC-Documentum Content Server Product [Reza_Bagherian] [Reza_Bagherian] 2007-07-19 This entry is an alias to "documentum-s". This entry is now historic, not usable for use with many common service discovery mechanisms.
netapp-sync 10006 tcp Sync replication protocol among different NetApp platforms [NetApp_2] [Paul_Mu] 2014-08-07
mvs-capacity 10007 tcp MVS Capacity [Donna_Dillenberger] [Donna_Dillenberger]

Contact Information

ID Name Organization Contact URI Last Updated
[Afkham_Azeez] Afkham Azeez mailto:azeez&wso2.com 2006-06
[American_Power_Conve] American Power Conversion mailto:ports&apcc.com 2002-02
[Brian_C_Wiles] Brian C. Wiles mailto:brian&streamcomm.com
[Craig_Dowell] Craig Dowell Qualcomm Innovation Center, Inc. mailto:cdowell&quicinc.com 2011-12-21
[David_Ko_2] David Ko mailto:david.dk.ko&gmail.com 2009-09-14
[Dawei_Qi] Dawei Qi mailto:dqi&galaxytelecomms.com 2010-07-07
[Donna_Dillenberger] Donna Dillenberger mailto:engd&us.ibm.com
[Douglas_Crockford] Douglas Crockford mailto:douglas&crockford.com
[Drew_Davies] Drew Davies Rx Networks Inc. mailto:ddavies&rxnetworks.com 2013-01-24
[Drew_Davies_2] Drew Davies Rx Networks Inc. mailto:ddavies&rxnetworks.com 2013-04-25
[Duk_Loi] Duk Loi mailto:dloi&peerdirect.com 2005-11
[Erik_Andersen] Erik Andersen mailto:era&x500.eu 2019-08-13
[Eventsourcing_Inc] Eventsourcing, Inc. mailto:accounts&eventsourcing.com 2017-04-18
[Francesco_Rosi] Francesco Rosi mailto:frosi&orenburg.com 2006-01
[Gerhard_Wagner] Gerhard Wagner mailto:gw&nova-ratio.de 2009-03-10
[Hing_Wing_To_2] Hing Wing To mailto:wing.to&micromuse.com
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[ITU_TSB_ITU-T_Study_Group_17] ITU/TSB (ITU-T Study Group 17) mailto:tsbsg17&itu.int 2019-09-30
[Juho_Herttua] Juho Vähä-Herttua mailto:juhovh&iki.fi 2009-04-14
[KAOS_Management_Group_LLC] KAOS Management Group, LLC mailto:phil&GotKAOS.com 2025-10-30
[Kouichi_Takeda_2] Kouichi Takeda mailto:KHB05271&nifty.com
[Lawrence_J_Dickson] Lawrence J. Dickson Land-5 Corporation mailto:ldickson&land-5.com 2002-03
[Malcolm_Graham] Malcolm Graham mailto:Malcolm_Graham&cyborg.com
[Michael_Benz] Michael Benz mailto:michael.benz&lsi.com 2010-08-06
[Michael_Muth] Michael Muth mailto:m.muth&tec5.com 2009-05-11
[Michael_Schonborn] Michael Schönborn T-Mobile International AG mailto:michael.schoenborn&t-mobile.net 2009-09-11
[Mike_Dyslin] Mike Dyslin mailto:mike.dyslin&hp.com 2006-08
[NetApp_2] NetApp mailto:pmu&netapp.com. 2014-08-12
[Paul_A_Suhler] Paul A. Suhler mailto:paul.suhler&quantum.com 2009-02-06
[Paul_Mu] Paul Mu NetApp mailto:pmu&netapp.com 2014-08-07
[Philip_Duvalsaint] Philip Duvalsaint mailto:phil&GotKAOS.com 2025-10-30
[Qualcomm_Innovation_Center] Qualcomm Innovation Center, Inc. mailto:cdowell&quicinc.com 2011-12-21
[Reza_Bagherian] Reza Bagherian mailto:bagherian_reza&emc.com 2007-07-19
[Rx_Networks_Inc] Rx Networks Inc. mailto:ddavies&rxnetworks.com 2013-01-24
[Rx_Networks_Inc_2] Rx Networks Inc. mailto:ddavies&rxnetworks.com 2013-04-25
[Sylvain_Pedneault] Sylvain Pedneault mailto:sylvain&sypecom.qc.ca 2003-03
[Vinay_Gupta] Vinay Gupta mailto:vinay.gupta&hp.com 2003-08
[Yurii_Rashkovskii] Yurii Rashkovskii mailto:yrashk&eventsourcing.com 2017-04-18