Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
corba-iiop 683 tcp CORBA IIOP
corba-iiop 683 udp CORBA IIOP
corba-iiop-ssl 684 tcp CORBA IIOP SSL [Andrew_Watson] [Andrew_Watson]
corba-iiop-ssl 684 udp CORBA IIOP SSL [Andrew_Watson] [Andrew_Watson]
mdc-portmapper 685 tcp MDC Port Mapper [Noah_Paul] [Noah_Paul]
mdc-portmapper 685 udp MDC Port Mapper [Noah_Paul] [Noah_Paul]
hcp-wismar 686 tcp Hardware Control Protocol Wismar [David_Merchant] [David_Merchant]
hcp-wismar 686 udp Hardware Control Protocol Wismar [David_Merchant] [David_Merchant]
realm-rusd 688 tcp ApplianceWare managment protocol [Stacy_Kenworthy] [Stacy_Kenworthy]
realm-rusd 688 udp ApplianceWare managment protocol [Stacy_Kenworthy] [Stacy_Kenworthy]
msexch-routing 691 tcp MS Exchange Routing [David_Lemson] [David_Lemson]
msexch-routing 691 udp MS Exchange Routing [David_Lemson] [David_Lemson]
hyperwave-isp 692 tcp Hyperwave-ISP [Gerald_Mesaric] [Gerald_Mesaric]
hyperwave-isp 692 udp Hyperwave-ISP [Gerald_Mesaric] [Gerald_Mesaric]
ha-cluster 694 tcp ha-cluster [Alan_Robertson] [Alan_Robertson]
ha-cluster 694 udp ha-cluster [Alan_Robertson] [Alan_Robertson]
ieee-mms-ssl 695 tcp IEEE-MMS-SSL [Curtis_Anderson_2] [Curtis_Anderson_2]
ieee-mms-ssl 695 udp IEEE-MMS-SSL [Curtis_Anderson_2] [Curtis_Anderson_2]
epp 700 udp EPP running over QUIC [IESG] [IETF_Chair] 2026-07-23 [RFC 5734][RFC-ietf-regext-epp-quic-12]
iris-beep 702 tcp IRIS over BEEP [RFC 3983]
iris-beep 702 udp IRIS over BEEP [RFC 3983]
borland-dsj 707 tcp Borland DSJ [Gerg_Cole] [Gerg_Cole]
borland-dsj 707 udp Borland DSJ [Gerg_Cole] [Gerg_Cole]
entrust-kmsh 709 tcp Entrust Key Management Service Handler
entrust-kmsh 709 udp Entrust Key Management Service Handler
entrust-ash 710 tcp Entrust Administration Service Handler [Peter_Whittaker] [Peter_Whittaker]
entrust-ash 710 udp Entrust Administration Service Handler [Peter_Whittaker] [Peter_Whittaker]
cisco-tdp 711 tcp Cisco TDP [Bruce_Davie] [Bruce_Davie]
cisco-tdp 711 udp Cisco TDP [Bruce_Davie] [Bruce_Davie]
iris-xpc 713 tcp IRIS over XPC
iris-xpc 713 udp IRIS over XPC
iris-xpcs 714 tcp IRIS over XPCS [RFC 4992]
iris-xpcs 714 udp IRIS over XPCS [RFC 4992]
iris-lwz 715 tcp IRIS-LWZ [RFC 4993]
iris-lwz 715 udp IRIS-LWZ [RFC 4993]
717-728 Unassigned
732-740 Unassigned
745-746 Unassigned
fujitsu-dev 747 tcp Fujitsu Device Control
fujitsu-dev 747 udp Fujitsu Device Control
ris-cm 748 tcp Russell Info Sci Calendar Manager
ris-cm 748 udp Russell Info Sci Calendar Manager
kerberos-adm 749 tcp kerberos administration
kerberos-adm 749 udp kerberos administration
kerberos-iv 750 udp kerberos version iv [Martin_Hamilton] [Martin_Hamilton]
755-757 Unassigned
acmaint-dbd 774 udp

IANA assigned this well-formed service name as a replacement for "acmaint_dbd".
acmaint_dbd 774 udp This entry is an alias to "acmaint-dbd". This entry is now historic, not usable for use with many common service discovery mechanisms.
acmaint-transd 775 udp

IANA assigned this well-formed service name as a replacement for "acmaint_transd".
acmaint_transd 775 udp This entry is an alias to "acmaint-transd". This entry is now historic, not usable for use with many common service discovery mechanisms.
multiling-http 777 tcp Multiling HTTP [Alejandro_Bonet] [Alejandro_Bonet]
multiling-http 777 udp Multiling HTTP [Alejandro_Bonet] [Alejandro_Bonet]
778-779 Unassigned
781-785 Unassigned
788-799 Unassigned Unauthorized Use Known on port 796
mdbs-daemon 800 tcp

IANA assigned this well-formed service name as a replacement for "mdbs_daemon".
mdbs_daemon 800 tcp This entry is an alias to "mdbs-daemon". This entry is now historic, not usable for use with many common service discovery mechanisms.
mdbs-daemon 800 udp

IANA assigned this well-formed service name as a replacement for "mdbs_daemon".
mdbs_daemon 800 udp This entry is an alias to "mdbs-daemon". This entry is now historic, not usable for use with many common service discovery mechanisms.
mbap-s 802 tcp Modbus Application Protocol Secure [modbus.org] [Dennis_Dube] 2014-06-10
mbap-s 802 udp Modbus Application Protocol Secure [modbus.org] [Dennis_Dube] 2014-06-10
803-809 Unassigned
fcp-udp 810 tcp FCP [Paul_Whittemore] [Paul_Whittemore]
fcp-udp 810 udp FCP Datagram [Paul_Whittemore] [Paul_Whittemore]
811-827 Unassigned
itm-mcell-s 828 tcp itm-mcell-s [Portnoy_Boxman] [Portnoy_Boxman]
itm-mcell-s 828 udp itm-mcell-s [Portnoy_Boxman] [Portnoy_Boxman]
pkix-3-ca-ra 829 tcp PKIX-3 CA/RA [Carlisle_Adams] [Carlisle_Adams]
pkix-3-ca-ra 829 udp PKIX-3 CA/RA [Carlisle_Adams] [Carlisle_Adams]
netconf-ssh 830 tcp NETCONF over SSH [RFC 6242]
netconf-ssh 830 udp NETCONF over SSH [RFC 6242]
834-846 Unassigned
dhcp-failover2 847 tcp dhcp-failover 2 [Bernard_Volz] [Bernard_Volz]
dhcp-failover2 847 udp dhcp-failover 2 [Bernard_Volz] [Bernard_Volz]
849-852 Unassigned
domain-s 853 tcp DNS query-response protocol run over TLS [IESG] [IETF_Chair] 2015-10-08 2022-04-11 [RFC 7858]
domain-s 853 udp DNS query-response protocol run over DTLS or QUIC [IESG] [IETF_Chair] 2015-10-08 2022-04-01 [RFC 7858][RFC 8094][RFC 9250]
855-859 Unassigned
owamp-control 861 tcp OWAMP-Control [IESG] [IETF_Chair] [RFC 4656]
owamp-test 861 udp OWAMP-Test [IESG] [IETF_Chair] 2018-12-21 [RFC 8545]
twamp-control 862 tcp TWAMP-Control [IESG] [IETF_Chair] [RFC 5357]
twamp-test 862 udp TWAMP-Test Receiver Port [IESG] [IETF_Chair] 2018-12-21 [RFC 8545]
863-872 Unassigned
874-885 Unassigned
iclcnet-locate 886 tcp ICL coNETion locate server [Bob_Lyon] [Bob_Lyon]
iclcnet-locate 886 udp ICL coNETion locate server [Bob_Lyon] [Bob_Lyon]
iclcnet-svinfo 887 tcp ICL coNETion server info

IANA assigned this well-formed service name as a replacement for "iclcnet_svinfo".
[Bob_Lyon] [Bob_Lyon]
iclcnet_svinfo 887 tcp ICL coNETion server info [Bob_Lyon] [Bob_Lyon] This entry is an alias to "iclcnet-svinfo". This entry is now historic, not usable for use with many common service discovery mechanisms.
iclcnet-svinfo 887 udp ICL coNETion server info

IANA assigned this well-formed service name as a replacement for "iclcnet_svinfo".
[Bob_Lyon] [Bob_Lyon]
iclcnet_svinfo 887 udp ICL coNETion server info [Bob_Lyon] [Bob_Lyon] This entry is an alias to "iclcnet-svinfo". This entry is now historic, not usable for use with many common service discovery mechanisms.
889-899 Unassigned
ideafarm-door 902 tcp self documenting Telnet Door
ideafarm-door 902 udp self documenting Door: send 0x00 for info
ideafarm-panic 903 tcp self documenting Telnet Panic Door [Wo_o_Ideafarm] [Wo_o_Ideafarm]
ideafarm-panic 903 udp self documenting Panic Door: send 0x00 for info [Wo_o_Ideafarm] [Wo_o_Ideafarm]
904-909 Unassigned
xact-backup 911 tcp xact-backup [Bill_Carroll] [Bill_Carroll]
xact-backup 911 udp xact-backup [Bill_Carroll] [Bill_Carroll]
apex-mesh 912 tcp APEX relay-relay service
apex-mesh 912 udp APEX relay-relay service
apex-edge 913 tcp APEX endpoint-relay service [RFC 3340]

Contact Information

ID Name Organization Contact URI Last Updated
[Alan_Robertson] Alan Robertson mailto:alanr&unix.sh
[Alejandro_Bonet] Alejandro Bonet mailto:babel&ctv.es
[Andrew_Watson] Andrew Watson mailto:andrew&omg.org
[Bernard_Volz] Bernard Volz mailto:bevolz&gmail.com 2022-08-03
[Bill_Carroll] Bill Carroll mailto:billc&xactlabs.com
[Bob_Lyon] Bob Lyon mailto:bl&oasis.icl.co.uk
[Bruce_Davie] Bruce Davie mailto:bsd&cisco.com
[Carlisle_Adams] Carlisle Adams mailto:Cadams&entrust.com
[Curtis_Anderson_2] Curtis Anderson mailto:ecanderson&turbolinux.com
[David_Lemson] David Lemson mailto:dlemson&microsoft.com
[David_Merchant] David Merchant mailto:d.f.merchant&livjm.ac.uk
[Dennis_Dube] Dennis Dube mailto:dennis.dube&schneider-electric.com 2014-06-10
[Gerald_Mesaric] Gerald Mesaric mailto:gmesaric&hyperwave.com
[Gerg_Cole] Gerg Cole mailto:gcole&corp.borland.com
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Martin_Hamilton] Martin Hamilton mailto:martin&mrrl.lut.as.uk
[modbus.org] modbus.org mailto:rbelliardi&modbus.org 2014-06-10
[Noah_Paul] Noah Paul mailto:noahp&altavista.net
[Paul_Whittemore] Paul Whittemore mailto:paul&softarc.com
[Peter_Whittaker] Peter Whittaker mailto:pww&entrust.com
[Portnoy_Boxman] Portnoy Boxman mailto:portnoy_boxman&bmc.com 2005-01
[Stacy_Kenworthy] Stacy Kenworthy mailto:skenworthy&applianceware.com
[Wo_o_Ideafarm] Wo'o Ideafarm mailto:b85f3c23.9ad6f42c&ideafarm.com